跳到主内容

Offset in STP / STEP import

评论

5 条评论

  • tab...

    Dirk,

    Do i understand corretly.

    You have a step file / files and which import into DSM v5 with some components coming in slightly in the wrong position - you believe the problem is with DSM because  a) the part is slightly offset , b) FreeCad  puts in in the correct place.

    Lets check the parts that are displaced. Go to the Measure Tab and, a) Integrity - do a 'Geometry Check, b) check the face normals etc.

    Have you tried correcting the position in DSM, then step export / Import - what happens?

    Looking at DSM Step Import options 'Facewise Connections' or Faces Independently' , i wonder exactly what happens if Facewise connections get mixed up ?

    Perhaps try importing by Faces Independently - might help.

    0
  • Dirk Schnabel

    Thank's for the reply. The facewise option makes no difference to the offset. The component is on the exact place in:

    • the original drawing tool (don't know which one was used)
    • a PDF-3D export
    • FreeCad

    but not in DSM v4 or DSM v5. I can move the component but cannot export as STP (this option is greyed for my free DSM). I can save it as a rsdoc format and when I open it again, the position is the same as before the saving.

    0
  • tab...

    Hmm, have you checked the geometry and it's face normals? - is it a good part?

     

    0
  • Dirk Schnabel

    I have installed the newest FreeCad 0.19 Version, opened the original STP file and exported it as STP again. Now DSM v5 opens it with correct position data. Seems, that FreeCad is more fault tolerant.

    0
  • tab...

    Hmm,

    Perhaps some ambiguity in the original source STP that DSM was intolerant of. FreeCad v0.18 didn't care but v0.19 now cares more when exporting to STP.

    The translators for DSM V5 come from Ansys R2020 R2 - so they are fairly current.

    So all is now Ok - it appears the original source STP might not be outputting with enough quality or latest requirements .

    0

请先登录再写评论。