欢迎使用

欢迎使用 DesignSpark Electrical 帮助

DesignSpark Electrical 是一款用于制备电气原理图的开放、直观、完整的软件包。它提供了原理图设计、布线方框图以及完整的报表管理。工程数据存储在 (SQLite) 数据库中，并且实时更新。

要使用 DesignSpark Electrical，必须要有带登录名和密码的帐户。如果没有，您必须创建一个帐户。

本帮助系统将指导您完成创建原理图和管理软件（从安装、文档设置到流程维护）的流程。

说明

XXXX | 章节中的重要界面术语采用加粗字体突出显示。
链接 | 标注相关页面和资源链接。要查看相关信息，请单击链接。
绿色文字 | 标注隐藏注释。要显示或隐藏注释，请单击以绿色斜体字显示的文本。
1.斜体文字 | 指示使用功能应遵循的步骤。
 | 显示视频（要求互联网连接）。
 | 表示可下载的文件（要求互联网连接）。
 | 显示注释或提示。
 | 表示存在风险或潜在危险的操作。

相关章节：


帮助菜单

菜单：帮助

帮助/F1：打开 DesignSpark Electrical 在线帮助。此帮助是右键菜单且可通过按下键盘上的 F1 键访问。这将打开介绍当前功能的章节。

教程面板：在弹出的窗口中打开软件界面中的教程。还可在线访问教程。

文档：打开 Windows 资源管理器，您可在其中查找所有软件文档文件。

收集信息：收集关于计算环境的信息，以解决潜在问题。

在线内容：用于从互联网访问可下载的设备型号压缩文件。这些文件包含最新的设备型号。

DesignSpark Electrical 主页：显示 DesignSpark Electrical 网站。

关于：显示软件版本信息。


教程 - 2D

教程 - DesignSpark Electrical

本练习的目的在于通过一系列简单的练习向您介绍 DesignSpark Electrical，从而使您可以创建工程。这样，您将可以使用该软件的大部分功能。

可以单独完成所有练习，但是最好按顺序来完成。大多数练习都是基于之前的练习。如果您尚未完成相应练习，您可以通过单击特定链接来进行下载。

附录

请务必打印各种不同的附录，它们可以帮助您更容易地完成练习。

视频

为了帮助您理解，每个练习的结尾都将提供一个视频。我们建议您以全屏模式在高分辨率之下观看这些视频。

练习 #1 | 环境解压缩
练习 #2 | 创建工程
练习 #3 | 管理位置 创建布线方框图 电缆清单
练习 #4 | 插入电线 插入符号 分配设备型号
练习 #5 | 处理对象 插入黑盒 创建宏 复制/粘贴 替换设备端子
练习 #6 | 多语言文本 线路中断转移 电位编号 布线
练习 #7 | 设备型号
练习 #8 | 不适用于 DesignSpark Electrical
练习 #9 | 不适用于 DesignSpark Electrical
练习 #10 | 不适用于 DesignSpark Electrical
练习 #11 | 管理校对


练习 #01

DesignSpark Electrical - 练习 #01

该第一项练习让您了解 DesignSpark Electrical 软件的基本原理；如何使用特定环境、简单文件与原理图图纸之间的差异以及如何使用界面工具。

  • 环境解压缩

  • 开始之前的一些建议

环境解压缩

通过此链接下载环境压缩文件并将其解压缩。

环境压缩文件包含您在 DesignSpark Electrical 中所需的所有数据，例如符号、设备型号、配置或工程。它用于将数据转发到其他公司或其他工作台。您也可以使用它来在重新安装软件之前保存数据。

1.下载压缩文件后，使用解压缩命令将其打开。

菜单：文件 > 环境解压缩

2.选择 EnvironmentForTraining.tewzip 文件。

3.在选择选项卡中，您可以选择要恢复的对象（全选）。

4.单击完成按钮。 DesignSpark Electrical 列示将恢复/导入的所有对象。

开始之前的一些建议

文件/图纸

文件和图纸是您可在其中进行绘制操作的文档，但是您必须了解这两种类型文档的区别。允许自动流程的图纸或电气图纸将被自动保存到数据库中，例如报表。文件是简单的非智能 DWG 文件。您的电气原理图必须转为图纸，而非 DWG 文件。

缩放

要缩放图纸，您可以使用视图菜单的命令或使用鼠标滚轮。转动滚轮以放大或缩小。单击并保持单击滚轮以进行实时平移。双击滚轮以对所有图纸实体进行一定程度的缩放。

选择模式

在设计原理图时，您将需要选择对象。以下是一些提示。

当您想要选择一个对象时，很简单，单击即可。如果您想要选择多个对象，请在按住 [Ctrl] 键的同时单击对象进行选择即可。要选择多个对象，您也可以使用矩形框选。绘制一个矩形（由其对角线定义）从左到右框选对象。矩形轮廓线中包括的所有对象都将被选定。还可以使用捕获选择。它与矩形框选的方法相同，但是是从右到左绘制。矩形轮廓线中包括其一部分的所有对象都将被选定。

相关章节：

下一练习

目录


练习 #02

DesignSpark Electrical - 练习 #02

首先，此练习的目的是从工程模板创建一个新的工程并打开其属性以输入个人数据。然后，您必须选择该工程的语言。您将操作各工程元素，例如文件集或图纸。最后，您将从您的新工程创建一个新的工程模板。

  • 创建工程

  • 编辑工程属性

  • 配置工程语言

  • 管理工程元素

  • 创建工程模板

创建工程

1.打开工程管理器。

菜单：文件 > 工程管理器

2.单击新建图标。

工程管理器 > 新建

3.在模板列表中，选择 IEC 模板。

4.在工程语言对话框中，选择英语语言。

5.输入工程名称。

新工程将自动添加到工程管理器中。

编辑工程属性

1.打开工程属性。

工程管理器 > 属性

2.输入工程属性。

合约号 | 123456
客户名称 | Trace Software
地址 1 | 76430
地址 2 | St Romain
地址 3 | France
设计院名称 | Your company
地址 1 | 邮政编码
地址 2 | 城市
地址 3 | 电话号码
说明行 1 | 培训工程

配置工程语言

要打开工程配置，必须在文档选项卡的可停靠面板中打开并显示该工程。要打开它，在工程管理器中选择它并单击打开按钮。

仅使用英语语言并移除第二语言。

1.打开工程配置。

可停靠面板 > 文档选项卡 > 工程的右键菜单：配置 > 工程...

2.在基本信息选项卡中选择英语作为主要语言，并将“您的语言”选作第二语言。

完成配置以后，工程会自动更新。

管理工程元素

编辑文件集

1.打开文件集属性。

可停靠面板 > 文档选项卡 > 文件集的右键菜单：属性

2.输入以下文件集属性。

说明 | 我的文件集
用户数据 1（绘制者） | A.B.
用户数据 2（日期） | 07/09/2016

要更改用户数据标注，单击自定义...按钮。在对话框的左侧选择用户数据 1，然后在右侧以您所需的语言输入正确的标注（绘制者）。对用户数据 2 重复操作。

创建/移动/删除图纸。

1.创建新图纸。

可停靠面板 > 文档选项卡 > 文件集的右键菜单：新建 > 原理图

菜单：工程 > 新建 > 新建原理图

新图纸将自动添加到工程元素列表的末尾。

2.要在列表中移动此图纸，将其拖放到正确位置即可。

3.要删除此图纸，按住 [Del] 键的同时将其选中；或者在其右键菜单中选择删除选项。

可停靠面板 > 图纸的右键菜单：删除

添加附件。

要将外部文件添加到工程，有两种可能的方法。

1.添加附件。

可停靠面板 > 文档选项卡 > 文件集的右键菜单：新建 > 附件

2.选择存储于软件目录 C:\Program Files\...\Documentation 中的“ExcelAutomation_EN.pdf”。

文件将被复制到工程。如果您修改原始文件，此副本将不受影响。

另一种可能的方法是创建原始文件的链接，这样如果您修改原始文件，将始终更新工程中的文档。

1.添加附件快捷方式。

可停靠面板 > 文档选项卡 > 文件集的右键菜单：新建 > 附件快捷方式

2.选择存储于软件目录 C:\Program Files\...\Documentation 中的“ExcelAutomation_EN.pdf”。

创建工程模板

工程模板用于创建新的工程。当您创建新的工程模板时，必须清除工程并删除不需要集成在项目模板中的元素。在此练习中，您将必须删除“图纸列表”并对其他图纸进行重新编号。然后，您将可以创建工程模板。

删除图纸

1.通过选择右键菜单中的删除命令来删除图纸 02。

您还可以通过选择一张图纸并按 [Del] 键删除图纸。

2.删除您所添加的附件或快捷方式。

对图纸进行重新编号

1.要在文件集中对图纸进行重新编号，请打开文件集的右键菜单，然后选择文档重新编号命令。

可停靠面板 > 文档选项卡 > 文件集的右键菜单：重新编号文档

2.选择重新计算序号选项并验证。

创建工程模板

1.打开工程管理器。

菜单：文件 > 工程管理器

注意：另存为模板图标已禁用。必须首先关闭工程。

2.从列表选择工程，然后单击关闭图标以将其关闭。

工程管理器 > 关闭

3.选择工程并单击另存为模板按钮

工程管理器 > 另存为模板

4.输入新工程模板的名称。现在，您的工程可以用于创建新的工程。

相关章节：

下一练习

目录


练习 #03

DesignSpark Electrical - 练习 #03

此练习让您可以学习如何管理电气安装的工程位置以及设计布线方框图。它基于您在练习 #02 中所创建的工程。如果您没有完成此操作，您可以在 DesignSpark Electrical 中下载工程文件并将其解压缩。

下载工程

要完成此练习，您需要下载练习的 PDF 文件。建议将此文件打印出来。

下载 PDF 文件

  • 管理位置

  • 布线方框图

  • 预设电缆

  • 电缆列表

管理位置

编辑现有 L1 位置以完成它。

1.打开 L1 位置属性。

可停靠面板 > 设备选项卡 > 位置的右键菜单：属性

2.输入 TGBT 作为 L1 位置的说明。

创建其他工程位置

添加以下位置：

L2：电机室

L3：控制面板

BJ：接线盒

1.打开位置管理器。

菜单：工程 > 位置

2.单击新位置图标。

位置管理器：新位置

3.在“位置属性”对话框中输入 L2，然后输入说明电机室。

4.对位置 L3 和 BJ 重复此操作。必须在手动模式中输入 BJ 标注。

布线方框图

使用之前下载的 PDF 文档（附录 3a）在布线方框图纸上创建布线方框图，遵循以下说明。

1.通过双击打开图纸 02 - 布线方框图。

插入符号

使用插入符号命令插入电机 M1 和 M2，不需要绘制位置轮廓线。稍后会插入。

2.单击布线方框图菜单中的插入符号图标。

菜单：布线方框图 > 插入符号

3. DesignSpark Electrical 会自动记住上次插入的符号。首次执行插入符号命令时，符号库可能会直接打开。如果未打开，可以单击可停靠面板中的其他符号按钮。

4.单击数据库中的分类选项卡。选择电机分类。在右侧选择对应的符号。

5.单击选择以确认。您也可以双击符号的缩略图。

6.用指针拖着符号。只需在图形区域中单击插入点。插入符号时，请确保捕捉锁定已启用。

7.如果是在电机分类中插入首个符号，则建议在“属性”对话框中使用标注 M1。

8.您必须更改分配到符号的位置。单击 +L1-TGBT 单元格上的 [...] 按钮。

9.在“位置”对话框中，选择 L2 电机室。

10.验证符号属性。

11.对电机 M2 执行相同操作。

请注意，标注将显示位置标注。设备的位置和图纸的位置不相同。

位置轮廓线

放置 L3-控制面板位置轮廓线，然后使用侧面板插入 H1 和 H2 指示灯。

（注意对标注的影响。）

1.选择布线方框图菜单中的位置轮廓线命令。

菜单：布线方框图 > 位置轮廓线

注意：位置轮廓线命令包含选项（图标中显示的箭头）。如果单击图标上部，您将触发该命令，而无需使用选项。如果单击图标的下半部分，将会显示选项。

2.对于矩形位置轮廓线，单击图形区域中的第一个点和矩形对角线中的第二个点。

3.对于多边轮廓线，请单击轮廓线上的第一个点，然后单击第二个点...要完成操作，您必须关闭轮廓线。

符号控制面板

通过使用符号控制面板插入指示器。

1.打开可停靠面板中的符号选项卡。

2.打开查找群组。在搜索字段中输入指示灯，然后单击查找。

3.将符号拖拽至图形区域或者双击符号，以将其插入。与电机不同，指示灯插入到位置轮廓线里。 DesignSpark Electrical 将自动推荐“标注”对话框中的位置 L3 控制面板。

4.根据附录插入其他符号和位置轮廓线。

绘制电缆

1.使用布线方框图菜单中的绘制电缆来绘制电缆。

菜单：布线方框图 > 绘制电缆

2.单击符号轮廓线上的第一个点。绿点指示连接。

3.单击第二个符号轮廓线上的第二个点。

在命令可停靠面板中，您可以选择线型和电缆类型以区分电缆类型。

预设电缆

必须给电机 M1 和 M2 选择一根 4 芯的电缆连接。

使用一根至少 7 芯的电缆连接 XA2 端子排和指示灯。

1.打开电线的右键菜单（右键单击电线），然后选择预设电缆和缆芯命令。

布线方框图电缆的右键菜单：预设电缆和缆芯

2.在“电缆预设”对话框中单击新电缆图标。

预设电缆和电缆芯 > 新建电缆

3.在“电缆型号搜索”对话框中，使用筛选器选项卡，然后在系列和导线数中输入筛选条件。

4.新电缆出现在列表中。勾选电缆的框。

电缆的标注和型号显示在布线方框图上。您可以使用电缆右键菜单中的显示/隐藏电缆文本来显示或隐藏电缆文本。

电缆列表

查看电缆列表。

1.单击工程菜单中的报表图标。

菜单：工程 > 报表

2.选择电缆列表报表。

报表管理器对话框的右侧将实时显示您在工程中所做的所有操作。

相关章节：

下一练习

目录


练习 #04

DesignSpark Electrical - 练习 #04

此练习让您能够了解用于管理电气原理图的基本命令。它基于您在练习 #03 中所创建的工程。如果您没有完成此操作，您可以在 DesignSpark Electrical 中下载工程文件并将其解压缩。

下载工程

要完成此练习，您需要下载练习的 PDF 文件。建议将此文件打印出来。

下载文件

  • 插入电线

  • 插入符号

  • 分配设备型号

插入电线

创建原理图 03。（附录 4a）

插入电源线

一开始是使用放置选项来管理折弯，以便放置电线。

菜单：原理图 > 绘制多线

1.如果当前电线不是 N L1 L2 L3，请单击 [?] 按钮打开电线选择器并将其选中。

2.取消选中保护导线框。

3.单击电线水平方向的两点代表母线。

4.要绘制电机回路线，请采用跟前面一样的操作，同时取消选中中性线框。第一次单击时，光标放置在 L3 上。使用 [C] 键插入折弯，使用 [Space] 键使导线交叉或不交叉。

5.要绘制变压器上游线，请不要尝试直接断开 L2 上相位的连接。首先连接到 L1，然后使用手柄（蓝色方形）将其选中并断开与 L1 的连接。最后重新连接至 L2。

插入控制命令线

变压器的出线端类型是一根 48VDC 电线。

菜单：原理图 > 绘制单线样式

请记住单击可停靠面板中的 [?] 按钮，以打开电线选择器并选择电线 =48V。

插入符号

图形模式的生成，请参阅附录 4A。

可以通过符号库或者控制面板放置符号。

最快和最好的插入符号的方法是使用控制面板。似乎刚开始时这样做看起来比较耗时，但是一旦创建了自己的控制面板，绘图尤其是搜索将会更快。

1.打开可停靠面板中的符号选项卡。

2.单击标题为保护的这一组。如果三极断路器的符号不在这个组中，您可以打开这个组的右键菜单添加符号。如果在这个控制面板中，双击将其插入。

3.您也可以使用控制面板中的搜索组。在输入框中输入断路器，单击搜索按钮。 DesignSpark Electrical 将显示数据库中所有符合条件的符号的缩略图，不仅仅是控制面板中的符号。

您同样可以使用原理图菜单中的插入符号命令。

菜单：原理图 > 插入符号

1.如果可停靠面板中未显示所需符号，请单击其他符号按钮。

2.符号选择器将打开。使用两个选项卡中的一个（筛选或分类）来查找所需符号。

将 M1 电机关联到布线方框图符号上。添加泵电机文本。

要将 M1 电机与布线方框图中的符号关联，只需使用相同标注。

1.在“标注”对话框中，在右侧设备列表中选择 M1 标注，然后单击确定。

制造商数据存在于设备型号中。用户数据是由用户自己输入的。

此数据可以传输至整个符号，只要关联的标注位于符号定义中。

保险丝 F3 是 F2 的副本。

1.复制命令在原理图菜单中可用。

菜单：原理图 > 多项复制

当复制已有符号时，标注会自动增加。与原来被复制的符号关联的设备型号也一起被复制。

使用放置选项插入 F4 和 K1 接触器。

当一个符号插入到电线上时，会自动根据电线的方向定向。当符号插入到电线外时，对方向的管理将取决于用户。

注意交叉引用的自动生成。

完成 K1 的 F4 电线和自动电源线。

图形模式的生成，请参阅附录 4B。

分配设备型号

使用设备报表帮助您分配设备型号（附录 4C）。

1.打开设备属性。

符号上下文菜单：设备属性

2.转至设备型号与回路选项卡。

3.单击搜索按钮，以搜索制造商目录中的设备型号。

- 选择分类。

- 选择制造商。

- 如果您知道型号，可以在型号字段中直接输入该型号。

- 如果未选择自动刷新框，请单击搜索按钮。

- 在结果中选择设备型号。

- 单击 [+] 按钮添加该设备型号。

要添加辅助型号（如接触块），请重复相同的操作，在类型字段中选择辅助。

有时，必须取消选中分类条件以查找附件或配件。它们可能存储于另一分类中（多个型号的共同项）。

相关章节：

下一练习

目录


练习 #05

DesignSpark Electrical - 练习 #05

此练习让您能够操作现有对象。它基于您在练习 #04 中所创建的工程。如果您没有完成此操作，您可以在 DesignSpark Electrical 中下载工程文件并将其解压缩。

下载工程

如果是首次操作，请打开练习的 PDF 文件并阅读全文。建议将此文件打印出来。

下载文件

  • 处理对象

  • 插入一个黑盒

  • 复制现有元素

  • 回路管理

  • 插入端子

处理对象

修改 M1 电机回路，以使其符合模板（附录 4a）。

1.使用“捕捉”模式选择马达符号及其正上方的电线。移动接触器符号下面的设置。删除多余的电线。

菜单：原理图 > 移动

使用复制命令复制 M1 电机回路。

1.选择整个电机回路。单击原理图菜单中的多项复制。单击起始点和目标点。

菜单：原理图 > 多项复制

设备标注自动累加。保留设备型号。

插入一个黑盒

插入 EV1 变速器（黑盒），将其与其他类别关联，并修改引脚号。

1.单击原理图菜单中的插入黑盒图标。

菜单：原理图 > 插入黑盒

2.分配其他分类。

3.将根更改为 EV。

4.要修改设备端子数量，请使用黑盒右键菜单中的编辑符号端子命令。

黑盒右键菜单：编辑符号端子

5.在标注列中更改设备端子编号。

复制现有元素

如果要移动或复制原理图的一部分，您可以使用复制/粘贴 ([Ctrl]+[C] - [Ctrl]+[V]) 或将其保存为宏。宏应该用于重复性元器件。

复制/粘贴。在新原理图上移动 K1 命令回路（标注：04 - 说明：命令）。

1.使用捕获或选择模式选择实体。

2.使用 [Ctrl]+[C] 键复制选定实体。

3.创建并打开图纸 04。

4.绘制在列 6 中具有换向开关触点的高极性和低极性电线 (48VDC) 和回路（附录 5b）。

5.使用 [Ctrl]+[V] 键在图纸 04 中粘贴复制的实体。

6.在图纸 03 中，删除 K1 命令回路。

6.在图纸 04 中，使用符号属性审查和修改符号标注。

符号上下文菜单：符号属性

7.放大装配体以查看模型的特写视图（附录 5b）。

复制/粘贴命令不是在图纸之间移动实体的最佳方式。使用此命令时，您必须删除现有实体并管理设备标注。建议使用剪切/粘贴命令。

特定复制/粘贴。在图纸 04 中，复制列 04 中的 K1 命令回路并重新适应标注。

1.使用 [Ctrl]+[C] 键复制实体。

2.使用 [Ctrl]+[Shift]+[V] 键粘贴选定对象。

3.管理对象标注使其符合附录 5b。将 Q2 和 K2 触点与图纸 03 的 Q2 和 K2 设备关联。

使用宏。在图纸 04 中，删除 K2 命令回路并创建由 K1 命令回路组成的宏并将其插入到列 04 中。

1.删除实体后，选择 K1 命令回路的实体并将其拖放到可停靠面板中宏选项卡中的命令组。

2.要插入此宏，将其从可停靠面板拖放到图形区域。

3.使用特定粘贴命令管理设备标注。

宏类似于特定复制/粘贴，其中图形对象保存在宏管理器中以便重复使用。

回路管理

两个符号和制造商零件都具有回路。设备的各极都与回路关联，管理他们对获得良好的交叉引用和材料端子显示等结果非常重要...

修改设备端子号。修改图纸 04，以 K1 常开触点的端子号从 83/84 替换为 53/54。

1.编辑 K1 设备，然后转至设备型号与回路选项卡。

符号上下文菜单：符号属性

2.在回路列表中，将触点 (53-54) 拖动至触点 (83-84)。

相关章节：

下一练习

目录


练习 #06

DesignSpark Electrical - 练习 #06

此练习让您能够学习如何管理电位编号。它基于您在练习 #05 中所创建的工程。如果您没有完成此操作，您可以在 DesignSpark Electrical 中下载工程文件并将其解压缩。

下载工程

如果是首次操作，请打开练习的 PDF 文件并阅读全文。建议将此文件打印出来。

下载文件

  • 从可停靠面板插入符号

  • 多语言文本

  • 线路中断转移

  • 电位编号

  • 布线

从可停靠面板插入符号

删除布线方框图图纸 (02)。

创建新的图纸 (05)，信号。

绘制电线并使用可停靠面板中的设备列表放置指示灯。

1.打开可停靠面板中的设备选项卡。

2.打开 L3 位置。

3.在 H1 右键菜单中选择插入符号命令。

4.符号选择器将打开，可让您选择指示灯符号。

多语言文本

在图纸 05 上，放置可译文本：Motor 1 On 和 Motor 2 On。该文本显示为蓝色，使用 Arial 字体，高度为 6mm。

使用多语言文本比使用基本文本效果更好。它们都存储在工程数据库中。

1.多语言文本插入命令在绘制菜单中可用。

菜单：绘制 > 多语言文本

可停靠面板中将显示绘图选项。在图形区域内单击文本的插入点（您也可以自己输入 X 和 Y 的坐标）。

2.输入文本的旋转角度或在图形区域内指出绘图方向。

3.以工程内管理的主要语言输入文本。

可停靠面板的下半部分将显示每个文本的格式和对齐方式。

4.要插入多行文本，请插入回车符来换行。

例如

输入文本：Motor 1 \P ON

将给出以下结果：

线路中断转移

在图纸 03 和图纸 04 之间放置线路中断转移。

首先，为避免起点-终点界面中的复杂导航，建议转至将会接入起点箭头的图纸，然后再启动命令。

1.起点-终点命令在原理图菜单中可用。

菜单：原理图 > 跳转

2.确认起点和终点图纸的加载。如有必要，可以使用导航图标（前一张图纸、后一张图纸或选择器）来创建第一个起点-终点。

跳转 > 单项插入

3.单击左手边图纸上的电线末端（输出箭头 > 开始箭头）。

4.单击右手边图纸上的电线末端（输入箭头 > 到达箭头）。

电位编号

执行电线编号操作。

1.由于这是第一次编号，请使用处理菜单中的新电线编号命令。

菜单：处理 > 新电线编号

修改图纸 03 第 1 列中 F1 的上游电线 (N.R.S.T)。

1.打开图纸 03，然后放大第一列保险丝断路器的电线上游。

2.在电线右键菜单中，选择编辑电线标注命令来修改线号。执行此操作时可以同时选择 4 根导线。

电线的右键菜单：编辑电线标注

修改 48VDC 电线的编号格式，包含页码。

1.打开电线样式配置选项卡。

菜单：工程 > 配置 > 电线样式...

可停靠面板 > 工程的右键菜单： 配置 > 电线样式...

2.选择 =48V 电线，然后单击属性图标。

电线样式管理器 > 属性

3.单击与电位编号格式相对应的框。

4.在编号格式管理器中，双击行文件标注/电位计数器。

再次执行编号操作来更新图纸，但不会丢失手动编号。

1.要更新图纸中的电位编号，请在处理菜单中选择重新编号电线。

菜单：处理 > 对电线进行重新编号

2.在“电线重新编号”对话框中，选择重新计算线号选项，不选择重新计算手动编号框。

管理文本位置

1.使用对齐文本命令来在轴线上对齐文本。

菜单：原理图 > 对齐文本

2.选择要对齐的文本。

3.绘制与电线垂直的轴线，然后选择对应于文本对齐的一侧。

对齐文本命令还允许沿电线移动文本。

4.使用显示/隐藏电线标注命令来显示或隐藏文本。

菜单：原理图 > 显示文本 > 显示/隐藏电线标注

5.选择要显示或隐藏文本的电线。

从电位编号自动中断转移。

1.打开图纸 05 并编辑极电线编号。电线上部的编号是 03/5，电线下部的编号是 03/6。

2.要自动生成跳转，选择跳转命令的自动插入。

菜单：原理图 > 跳转/自动插入

3.在对话框中，选中连接所有带有相同标注的电位选项。

由于电线具有相同编号，将自动连接它们。

重新启动电线编号以校正图纸 05 的电位编号。

布线

在图纸 05 上，添加端子并连线（使用布线方框图中预设的电缆），在原理图中使用所有电缆。

1.打开图纸 05。

2.打开电线的右键菜单，以接收电缆芯并选择关联电缆芯命令。

电线的右键菜单：关联电缆芯

- 选择对话框上部列表中的 W4 缆芯。

- 选择对话框下部列出的电线。

- 单击关联电缆芯图标。

- 对所有电缆重复此操作。

此操作可以在选择几根电缆芯导体和启动命令之后执行。这允许您为所有选定的电线接线。

相关章节：

下一练习

目录


练习 #07

DesignSpark Electrical - 练习 #07

本练习的目的是让您能够操作设备型号、将其分配给设备、创建设备型号以及使用 electrical Content Portal。本练习基于您在练习 #06 中所创建的工程。如果您没有完成此操作，您可以在 DesignSpark Electrical 中下载工程文件并将其解压缩。要完成此练习，您需要解压缩练习 #01 中提供的环境。

下载工程

如果是首次操作，请打开练习的 PDF 文件并阅读全文。建议将此文件打印出来。

下载文件

  • 分配设备型号

  • 手动设备型号

  • 创建设备型号

分配设备型号

使用可停靠面板为没有选型的设备分配设备型号。（参见附录 7a）

1.转至可停靠面板中的设备选项卡，然后选择需要添加型号的元素。

2.该命令在右键菜单中。

设备右键菜单：设备 > 分配设备型号

注意：如果设备已被分配到设备型号，您选择的设备型号将会删除和替换原来的型号。

3.转至筛选器选项卡。取消选中自动刷新框并输入多个条件。

4.单击搜索按钮。

5.相同的规则将会应用于位置和设备的引用。

手动设备型号

为 EV1 设备手动输入一个型号。

型号：56356

制造商：Siemens

说明：变速器

修改转换开关的端子号（11、12、14）。

此设备型号不会被添加到目录中。

1.打开设备 EV1的右键菜单，然后选择设备属性命令。

符号上下文菜单：设备属性

2.在属性对话框中，转至设备型号与回路选项卡。

3.单击手动添加按钮并输入必要数据。

4.单击确定。将会弹出一条信息，询问您是否要把型号存储至目录中。

5.所选设备型号只应用于此设备。

创建设备型号

打开制造商目录并创建以下设备型号：

型号：123456

制造商：培训

分类：启动器\转换开关

数据库：用户

类型：基础

说明：接触器断路器逆变器

原理图符号：TR-TELE006

高度105

宽度：203

深：104

此设备带有 3 个常开电源触点回路。

设备端子号为 1, 2, 3 ? 4, 5, 6

1.设备型号管理器在数据库菜单中可用。

菜单：数据库 > 设备型号管理器

2.选择启动器分类。

3.单击添加零件图标。

设备型号管理器 > 添加型号

4.输入必要数据。

压缩此新设备（如同传给其他公司一样）。

5.要压缩之前创建的设备型号，请搜索并选择。单击设备型号管理器中的压缩图标。

设备型号管理器 > 压缩

在工程（可停靠面板）中添加此设备，然后将与其关联的符号插入到其中一张图纸。然后删掉所插入的符号。

1.转至可停靠面板中的设备选项卡。在位置右键菜单中选择新建 > 设备制造商零件命令。

侧面板：设备 > 位置右键菜单 > 新建 > 设备制造商零件

2.选择启动器/反向开关分类（将会提供标注源）。

3.在培训制造商的设备型号 123456 上执行搜索。

4.新标注将会添加到列表末尾。

5.打开新设备的右键菜单，然后选择插入符号命令。

可停靠面板：设备 > 插入符号

6.将自动选择与设备型号关联的符号。插入该符号并检查设备型号关联。

相关章节：

下一练习

目录


练习 #11

DesignSpark Electrical - 练习 #11

为了帮助您完成教程工程，本练习将用于管理校对以及打印和压缩工程的命令分组到一起。如果没有完成练习 #10，您可以下载上一练习的工程文件。在 DesignSpark Electrical 中将其解压缩。

下载工程

  • 管理校对

  • 打印

  • 压缩

管理校对

更新图纸列表报表之后，将校对 A 添加到所有图纸。

1.您可以使用报表管理器中的命令手动更新图纸列表报表。可在校对流程中完成图纸报表更新。

报表管理器：生成图纸

2.首先修改配置设置（工程 > 配置 > 基本信息 > 校对编号）。

菜单：工程 > 配置 > 工程...> 基本信息 > 校对编号

设置所需的格式。

校对编号。0AB

3.在文件集右键菜单中选择校对命令。

文件集右键菜单：校对

4.在“校对索引管理”对话框中，输入索引 0 的说明。

5.单击确认按钮，然后单击核实按钮。 DesignSpark Electrical 将询问您是否将文件集中的所有图纸添加到此索引。

6.单击确定按钮以结束。

7.取消 DesignSpark Electrical 建议的其他操作。

8.重复此操作以增加至索引 A。

打印

生成包含所有工程图纸的 PDF 文件。

有两种方法可以生成 PDF 文件：使用打印命令或使用导出 PDF 文件。

1.在导入/导出菜单中（推荐）。

菜单：导入/导出 > 导出 PDF 文件

2.指示将保存 PDF 文件的目录。

3.保留默认参数。

4.单击打印按钮以生成 PDF 文件。

压缩

压缩工程。

1.打开工程管理器。

2.在列表中选择工程，然后单击关闭按钮。要压缩图纸和工程，图纸和工程必须处于关闭状态。

3.单击压缩图标。

工程管理器 > 压缩

4.选择更新图纸选项以确保所有工程图纸均已更新。

5.文件备份对话框打开，允许您选择目录和修改文件名。

相关章节：

下一练习

目录


设置

DesignSpark Electrical 具有多种配置等级，可分为应用等级（如应用语言、图形选项、数据库）和工程等级参数。

工程等级配置参数存储在工程等级（设置仅适用于特定工程）。应用等级配置参数适用于使用该配置的所有工程。

  • 应用程序设置

  • 界面配置

  • 工程配置

  • 格式管理器


应用程序设置

菜单：工具 > 应用程序设置

这些参数允许您配置数据库访问设置。

  • 数据库

相关章节：

界面配置


数据库

菜单：工具 > 应用程序设置 > 数据库

应用程序数据文件夹：显示数据库存储位置。

包含工程的文件夹：显示存储工程文件的文件夹。

连接类型：显示所用数据库的类型：SQL 服务器或 SQLite。

服务器名称：显示 SQL Server 数据库的服务器名称。

用户名：显示连接 SQL 服务器数据库的用户名。

密码：显示要连接至 SQL Server 数据库所需密码。

数据库名称：显示所用数据库的名称和版本。

显示查询执行错误日志按钮用于打开包含软件使用过程中查询失败的文件。


界面配置

菜单：工具 > 界面配置

这些参数允许您配置软件的用户界面语言和图形外观。

  • 图形选项

  • 应用语言

相关章节：

应用程序设置

工程配置


图形选项

菜单：工具 > 界面配置 > 图形选项

选择光标

拾取框大小（像素）：以像素为单位。允许您设置光标大小。

十字光标大小（%/屏幕大小）：以屏幕大小百分比表示。允许您设置十字光标大小。

鼠标滚轮缩放

反向缩放：滚动鼠标滚轮时反转缩放方向。

缩放速度 (%)：允许设置滚动鼠标滚轮时的缩放比例参数。

颜色

图纸底色：允许您定义图纸底色。

标记颜色：可以设置所需标记颜色。

位置与样式

工具栏字体高度：允许您修改工具栏中使用的字体大小。

选项

允许的已打开文档数量：键入在软件部分可打开的文档数量。每个文档都会耗用内存，如果打开太多文档，可能导致工作台运行速度减慢。超出此限制时，系统将显示一条消息。

选择模式：默认情况下，当您选择多个实体时，在您选择第一个实体之后，您必须按住 [Ctrl] 键才能选择第二个实体。借助此选项，您可以在选择多个实体时不必按住 [Ctrl] 键。

单位系统：设置工程外所生成的所有文件在软件中使用的单位模式（英制或公制）。

文本显示模式：管理文本显示的质量。一些语言，如中文，必须在矢量模式中设置。

文本打印模式：管理文本的打印质量。一些语言，如中文，必须在矢量模式中设置。

图形加速：如果您的显卡兼容，请在编辑图形实体时启用加速以提高性能。如果遇到问题，请将其禁用或尝试其他选项。如果您更改此值，您必须关闭再重新打开已打开的文档，才能激活此新渲染模式。

帮助：您可以选择默认帮助文件：您工作台上安装的文件（CHM 文件）或在线帮助功能（需要互联网连接）。

在打开工程时将打开最近的文件： DesignSpark Electrical 保存最近在工程中使用的图纸。当您重新打开工程时，此图纸会自动重新打开。在列表中选择所需的选项。

要求移除已翻译文本：如果选择此选项，当您以主语言更改某个说明（例如设备属性或符号属性中提供的说明）时，DesignSpark Electrical 将打开一个选项对话框，询问您是否要删除此文本的现有翻译。

在启动时显示欢迎页：如果选中，将在软件启动时打开一个信息对话框。即使您取消选定此选项，每次安装新版本后，也会打开欢迎页。

单击重置所有界面按钮将清除该软件所有对话框中的位置和尺寸更改。


应用语言

菜单：工具 > 界面配置 > 应用语言

此选项卡允许您定义应用语言。您还可以在数据库和目录中设置所需的默认语言。

界面语言

设置所需软件语言。更改此设置时必须重新启动应用程序。

管理器中应用的语言

选择复选框以定义要在管理器中使用的语言。


工程配置

菜单：工程 > 配置

可停靠面板 > 工程的右键菜单：配置

  • 工程...

  • 电线样式...

  • 布线方框图线样式...

  • 报表...

  • 用户数据...

  • 控制面板...

工程配置参数使您可以个性化绘图且使结果和流程有效。

创建新工程时，配置参数来自工程模板。考虑到大量参数，很难创建空的工程，在其中需要设置所有配置参数。

应用/工程参数

特定参数仅在工程等级（工程、电线样式、交叉引用图纸）进行管理，而其他参数可在工程等级或应用等级进行管理，如 端子图纸或用户数据。

配置显示在分为两个部分的对话框中。对话框的左侧表示在应用程序等级保存的配置，对话框的右侧显示在工程等级保存的配置。

对于不使用此对话框的配置类型，参数仅对工程有效。

如果在应用程序等级修改配置参数，则这些参数将应用于使用此配置的所有工程。因此，您修改在工程等级存储的配置参数时，仅对该工程有效。

特殊图标（添加至工程和添加至应用程序）允许您将工程配置传至应用程序，反之，也可从应用程序等级传至工程。


工程设置

菜单：工程 > 配置 > 工程...

可停靠面板 > 工程的右键菜单：配置 > 工程...

该对话框具有很多选项卡，打开可使您访问配置参数。这些参数特定于当前工程。参数可用于其他目的：帮助定义标注、构成工程的元素图形选项。这些参数特定于工程。

  • 基本信息

  • 图形

  • 文本

  • 标注

  • 图框

  • 数据库及控制面板

相关章节：

工程配置


基本信息

菜单：工程 > 配置 > 工程...> 基本信息

可停靠面板 > 工程的右键菜单：配置 > 工程...> 基本信息

工程语言

选择要在工程中使用的语言。选择最多三种语言。如果您无需使用第二种或第三种语言，请从列表中选择 <空>。

如果您使用多种语言，则在您更改工程语言时文本将自动显示。

标准

单位系统：定义工程单位（公制或英制）。此选项用于原理图单位。

尺寸单位：选择要用于工程元素的单位类型（制造商零件的尺寸）。

默认电缆尺寸标准：定义用于电缆测量的标准（截面积、规格或圆密耳-千圆密耳）。

日期显示格式

显示格式：从列表中选择您要使用的日期格式。您也可以输入自己的格式。

系统日期：使用 Windows 日期格式。

dd/mm/yyyy：使用日/月/年格式。

mm/dd/yyyy：使用月/日/年格式。

%d-%m-%y：允许您创建自己的日期格式（%d = 日、%m = 月、%y = 年（2 位数）、%Y = 年（4 位数））。

可用变量：

%a：星期几缩写（例如 Mon）

%A：星期几全拼（例如 Monday）

%b：月份缩写（例如 Jan）

%B：月份全拼（例如 January）

%c：本地日期时间

%d：十进制格式某月某日 (01 - 31)

%H：当前 24 小时制时间 (00 - 23)

%I：当前 12 小时制时间 (00 - 12)

%j：十进制格式某年某日 (001 – 366)

%m：年月数 (01 – 12)

%M：当前十进制格式某时某分 (00 – 59)

%p：12 小时制 AM / PM 指示灯

%S：当前十进制格式某分某秒 (00 – 59)

%U：十进制格式年星期数（星期天是一周的第一天）(00 - 53)

%w：十进制格式星期几 (0 – 6 ; Sunday = 0 )

%W：十进制格式年周数（星期一是一周的第一天）(00 - 53)

%x：本地日期

%X：本地时间

%y：两位数年份

%Y：四位数年份

%z、%Z：时区

预览：显示当前显示格式设置的结果。

校对编号

格式：在列表中选择所需校对模式，即数字或字母、是否从 0 开始。选择自定义以使用以下自定义设置。

自定义格式：仅在之前设置中选定自定义项目的情况下使用。访问格式管理器以创建特定格式。

最新修订版的填充标注：此选项允许您在使用相对模式时管理修订版标注的显示。

始终填充低索引标注：此选项强制在修订版网格的底部显示修订版索引，而不考虑标注的索引号。

从索引填充标注：此选项允许您将修订版索引插入相应的标注中。例如，如果具有索引号 -0（当前修订版）的标注被插入到修订版网格的顶部，则当前修订版索引将被插入到修订版网格的顶部。

<Default>

文件集：在自动生成图纸（如材料明细表）时作为默认文件集。

默认配置

交叉引用：为工程中的所有交叉引用选择默认交叉引用配置文件。

选项

通常使用位置标注填充：假设标注位于符号定义中，勾选此项可将位置标注到对应的标注中 (#LOC_TAG)。

通常使用功能标注填充：假设标注位于符号定义中，勾选此项可将功能标注到对应的标注中 (#FUN_TAG)。

相关章节：

格式管理器


图形

菜单：工程 > 配置 > 工程...> 图形

可停靠面板 > 工程的右键菜单：配置 > 工程...> 图形

设备连接点

符号：在列表中为显示放置在电线连接到符号位置的点选择您想要的值（从不、总是或仅在符号连接到电线时）。您还可以设置点的大小和颜色。

电线：显示复选框可使您控制是否显示两根电线连接交点处的点。您还可以设置点的大小和颜色。

线型

位置：定义位置轮廓线的线型和颜色。

功能：定义功能轮廓线的线型和颜色。

电缆芯：定义将在图纸中为表示电缆芯而使用的线型和颜色。

跳线：设置原理图页面（电线/跳线）中跳线的显示参数（颜色和线样式）。

电位冲突：当连接两个不同电位（电位有不同编号）时会出现电位冲突。此复选框可更新控制。您也可以为线符号选择线类型和颜色。

电缆标签：定义将电缆接合至电缆标注的线型和颜色。


文本

菜单：工程 > 配置 > 工程...> 文本

可停靠面板 > 工程的右键菜单：配置 > 工程...> 文本

多语言文本

指定多语言文本中使用的每种语言的字体、高度、样式和颜色。

其他文字

此界面可使您访问显示在图形图纸中的文本的不同参数。您可以编辑文本的字体、高度、样式和颜色，以及相对所属元素的 X 和 Y 偏移。

其中某些文本包含公式来管理其标注。单击 [...] 按钮以访问公式管理器。

其他文本部分中所做的所有修改将更新现有文本。

为黑盒连接点使用符号

如果激活，此部分允许您选择和编辑用于具体化黑盒中的连接点（端子）的符号。使用符号允许您将特定数据延伸到符号的标注。

打开符号选择器以选择所需符号。

删除符号。

打开符号编辑器以进行修改。

代表黑盒的连接点（端子）的符号必须拥有定向的连接点（以连接电线）和标注。


标注

菜单：工程 > 配置 > 工程...> 标注

可停靠面板 > 工程的右键菜单：配置 > 工程...> 标注

让您可以访问格式生成器。也可通过双击单元格访问格式管理器。

生成文档标注的格式

在此部分，您可以输入标注文件集、文件夹和图纸的格式。这些格式包含带有 + 分隔符的变量和文本字符串。

例如：公式“Bundle”+ BOOK_ORDERNO 返回：Bundle 1

行和列字段让您可以选择在行和列标注时采用的格式（用于交叉引用和起点-终点）。

起点-终点和交叉引用

让您可以输入线路中断转移文本和交叉引用文本的格式。

标注唯一

用于管理标注的唯一性。

设备：可从下拉列表中选择设备标注的唯一性级别。例如，如果您选择标注的唯一性取决于位置，则同一位置不可有两个相同的设备标注。但不同位置可以有两个相同标注。

电缆：让您可以管理电缆标注的唯一性级别。

电线与设备编号

方向：此参数用于定义优先权，水平方向优先或垂直方向优先。如果选择 [image] 图标，在垂直方向上对齐的元素标注比在水平方向上对齐的元素标注优先级高。

顺序号唯一：勾选此框时，从标注格式中使用的顺序号变量获取的值在整个工程中不连续。如果未勾选此框，在标注唯一管理器中选定的元素已修改时，顺序号再次从 1 开始。

例如，如果设备标注唯一性级别设置为位置，且您在位置 L1 放置标注为 Q1 的符号，如果已取消勾选唯一顺序号框，则无论在任何位置插入符号，第二个符号标注都将从 Q2 开始。但是，如果选中此框，若在不同位置添加标注，标注将从 Q1 开始，若在位置 L1 添加标注，则标注从 Q2 开始。

电线样式管理器：有一个按钮允许访问电线样式管理器，以设置连接参数编号。根据标注在图纸中的位置计算标注，从图纸的左上角到右下角进行计算。

分配未使用标注：如果选中此选项，则分配给电线或电位编号或分配给新设备标注或新电缆标注的序号只能是新的编号。不会再重复使用被移除的编号。

设备标注的优先级：此选项在重新编号标注功能中使用，选择要开始编号的符号类型。例如，如果您选择多线符号选项，数字“1”将用作找到的第一个原理图符号，即使在它之前找到布线方框图符号也是如此。

标注

您可以使用 IEC61346 编号标准 (=F1+A1-KA1) 或自定义的标注。

如果选择自定义标注，您必须为各种不同标注系统输入格式，如“位置”或“功能”。这些格式包含带有 + 分隔符的变量和文本字符串。

您也可以选择标注路径的分隔符，当您具有级联设备要分隔设备标注与主设备标注时，可以使用此选项。在列表中选择建议值或者输入所需的特定字符。

按标注排序

可以使用几个选项来对所有标注元素的标注进行排序。可以从可停靠面板、电线接线方向、电缆、PLC 和搜索管理器的“设备”选项卡来使用标注排序选项。

自动标注，按源/序号排序后手动标注：首先显示按根排序的自动编号（如在格式中使用），然后显示序号编号（编号在根中唯一），最后显示按字母顺序排序的手动标注。这是默认模式。

自然排序，自动和手动混合标注：与 Windows 资源管理器一样，按字母顺序排序所有标注（手动和自动），例如：A1、A2、A3、A10、A11、A20...

相关章节：

格式管理器


图框

菜单：工程 > 配置 > 工程...> 图框

可停靠面板 > 工程的右键菜单：配置 > 工程...> 图框

此选项卡可使您选择要与各种工程图纸类型关联的默认图框。要修改关联，请单击 [...] 按钮。图框选择器将打开，使您可选择要应用的默认图框。

相关章节：

图框选择器


数据库及控制面板

菜单：工程 > 配置 > 工程...> 库及控制面板

可停靠面板 > 工程的右键菜单：配置 > 工程...> 库及控制面板

显示的数据库

可使您设置数据库的筛选条件。勾选任意所列数据库，使数据库中包含的所有元素（例如在 IEC 情况下为 IEC 标准符号）可在工程设计期间使用。

使用的控制面板

设置要使用的控制面板。有 6 种可用的控制面板，您可从弹出下拉菜单中为每种分别选择一种特定格式。


电线样式

菜单：工程 > 配置 > 电线样式...

可停靠面板 > 工程的右键菜单：配置 > 电线样式...

插入电线时，通过从可停靠面板单击 [...] 按钮并选择管理器按钮，也可打开管理器。

电线样式管理器重新组合可用于工程原理图图纸中的所有电线。它用于设置电位或线号。

这些参数特定于工程。

  • 管理电线样式

  • 电线属性

  • 配置编号

  • 群属性编号

相关章节：

工程配置


管理电线样式

菜单：工程 > 配置 > 电线样式...

可停靠面板 > 工程的右键菜单：配置 > 电线样式...

绘制电线 > [...]> [管理器]

在管理器中，您可以添加新类型电线或修改现有电线的类型。

对话框左侧显示电线组列表，右侧显示不同电线的参数。

电线属于编号群。这在电线编号时使用，它们将共享同一计数器。

有两种电线类型：

  • 电线命令通常用于绘制单线。

  • 电源线用于同时绘制多线。

配置

配置图标允许您选择对话框右侧显示的列。

管理组

关闭编号群

您可以关闭编号群。在电线编号时，这不会排除在外。组名称前的复选框指示其状态（复选框 = 激活的群）。

使用编号群右键菜单选择您喜欢的选项。

添加编号群

要添加新的编号群，请在主菜单中单击添加编号群图标。该群会自动添加到其他群后面。请注意，此新群已具有新类型的连接（如果不包含连接，则群不存在）。

删除编号群

要删除编号群，请将其选中并单击删除图标。删除命令还可在编号群的右键菜单中使用。删除编号群后，包含在此群中的所有电线会自动删除，除非它们用于原理图图纸中。

管理电线和导线

添加电线

有两种添加电线的方法：一种是使用添加和/或添加多个图标（取决于您想要创建/添加的电线类型），另一种是从编号群使用右键下拉菜单。

新电线将自动添加到选定编号群的列表末端。

您可以使用复制、粘贴和特殊粘贴命令来复制现有电线样式以创建新的电线样式。在工程级别粘贴电线样式时，将在新组中自动创建一个新的电线样式。

复制/粘贴/特殊粘贴功能可用于在工程之间复制电线定义。

为电线类型添加导线

您可以通过电线右键菜单为现有电线类型添加导线，然后选择‘向电线样式添加电线’选项。

下/上

箭头形式的两个图标允许您管理导线，以使其上下移动。

删除线样式

要删除线样式，请将其选中并单击删除图标，或者右键单击要移除的电线样式，然后从右键菜单中选择删除选项。线样式仅在当前未用于原理图时可删除。

删除导线

要删除导线，请将其选中并单击删除图标，或者从导线的下拉菜单中选择删除选项。导线仅在电线样式未用于图纸或原理图时可删除。

相关章节：

群属性编号

电线属性

配置编号

线号

绘制电线


电线属性

菜单：工程 > 配置 > 电线样式...> 属性

可停靠面板 > 工程的右键菜单：配置 > 电线样式...> 属性

绘制电线 > [...]> [管理器] > 属性

此对话框显示使用所选电线样式的所有电线的共同属性。

当选择多个电线样式并更改所有选定样式的共同属性值时，新的属性值将应用至所有由所选样式定义的导线。例如，您选择了具有“线颜色”属性的多个电线样式，并将其属性值更改为红色，那么活动文档中由所选电线样式定义的全部导线将变为红色。

选择一种电线或导线类型，然后单击属性图标，或者在右键菜单中选择属性选项。

电线属性

电线样式

名称：电线名称。

编号群：电线所属的群。

基本信息

导线：导线类型。可以是非电导线。

线颜色：单击 [...] 按钮，以选择表示电线的线颜色。

线型：表示电线的线类型。

线宽：设置指定电线的宽度。此宽度自动应用于原理图中的电线。

电位格式：单击 [...] 按钮，以访问格式管理器并为电位编号定义一个格式。

电线格式：单击 [...] 按钮，以访问格式管理器并为电线编号定义格式。

延伸：如果您接受可通过延伸数据功能更新此电线格式的电线，请勾选此框。

布线

此部分用于电线布线中使用的参数。如果您关联一个电缆型号，这些字段将根据型号自动更新。这些设置将应用于原理图图纸中绘制的所有电线类型。

直径：电线直径。

截面积或规格：电线截面积。

电线尺寸标准：工程中使用的标准。

电线颜色：单击 [...] 按钮以选择电线的真实颜色。

弯曲半径（x 直径）：需要参数来计算弯曲半径（参数 x 直径 = 弯曲半径）。

电缆型号：单击 [...] 按钮，以关联电缆型号。

技术数据

电压：尚未实施电气数据。

频率：尚未实施电气数据。

说明

使用工程中所用的各种不同语言输入说明。

用户数据

将此属性应用于您工程的列表数据。

可译数据

将此属性应用于您需要翻译的列表数据。

导线属性

对话框与“电线属性”对话框相似。但是此对话框显示组成此电线样式的所有导线的共同属性。

有时需要在电线或电线样式内编辑导线的属性以更改其颜色，或者修改其电位和电线格式。

相关章节：

电线样式管理器

编号规则


配置编号

菜单：工程 > 配置 > 电线样式...

可停靠面板 > 工程的右键菜单：配置 > 电线样式...

电线插入 > [...]> [管理器]

所有线号设置可用于三个等级：

  • 工程配置

  • 电线样式管理器

  • 电线特殊设置

项目设置中的编号选项

您可以通过项目设置对话框中的标注选项卡访问项目级别编号设置。

可用设置如下：

方向：定义线号的方向。可用设置将配置水平排序、垂直排序和水平或垂直优先。

电线样式：可供直接访问“电线样式管理器”对话框中的编号管理器选项。

“电线样式管理器”中的编号选项

电线样式管理器中可用的一些编号选项。

DesignSpark Electrical 允许您以两种方式对电线进行编号：

- 电位编号，即所有连接至同一网格（连接在一起）的电线使用同一编号。

- 线号，每根物理电线应该单独进行编号。

编号（电线/电位）：选择编号模式：电位或电线。

显示：用于选择显示编号所用的模式，编号置于段的中间或编号置于网状的首段和末段上。在电线编号过程中，每根电线单号模式不可用。

“电线样式”中的编号选项

    • 群属性编号

电线在编号群中分组，因此属于组中一部分的所有电线使用相同计数器。这可确保即使电线类型不同，电线编号也连续。

可通过右键菜单属性选项访问编号群参数。

编号群

首先要设置群编号。此编号不可更改。每个组与一个“计数器”关联，即自动增量计数器。它还可确保同一编号组中的两根电线不会意外应用同一编号。

线号选项

激活编号：允许您激活或关闭组中的电线编号。

如果禁用该选项，则不会对组中的任何电线进行编号。

开始编号自：允许您定义应用到组的第一个电线编号。

例如，如果您输入值 100，则第一根电线将编号为 100，第二根编号为 101，以此类推。

标注唯一：管理线号的唯一性。例如，如果将唯一性级别设置为工程，则计数器将在整个工程内连续。如果将其设置为文件集，每次更改文件集时，计数器将在开始编号自参数值重新开始。

计算多线制线号

允许您定义该组电线的电线编号模式。

第一种模式将为每根电线导线分配不同编号；第二种模式为所有电线导线分配同一编号。

在此模式下，建议为编号格式添加前缀；否则，所有电线导线具有相同值。

    • 电线属性

电线编号参数可用于电线样式属性。

电位格式和电线格式字段允许您输入包含变量和字符串的格式。

电位编号和电线编号不同，可用变量的列表不同。

有关格式生成器可能性的更多信息，请参阅章节：格式管理器。

相关章节：

管理电线样式

电线编号

格式管理器


群属性编号

菜单：工程 > 配置 > 电线样式...> 属性

可停靠面板 > 工程的右键菜单：配置 > 电线样式...> 属性

绘制电线 > [...]> [管理器] > 属性

在电线样式管理器中，可通过群右键菜单访问群属性。您也可以选择群并单击属性图标。

电线在编号群中分组，因此属于组中一部分的所有电线使用相同计数器。这可确保即使电线类型不同，电线编号也能保持连续性。

基本信息

首先要设置群编号。此编号不可更改。每个群关联一个自动递增计数器。这可确保同一编号组中的两根电线不会意外应用同一编号。

说明

您可以使用由软件管理的所有语言为组输入名称。

线号选项

激活编号：激活或禁用组中的电线编号。

禁用该选项将不会对群中的任何电线进行编号。

开始编号自：定义组的起始线号。

如果您输入值 100，第一根电线将编号为 100，第二根编号为 101，以此类推。

标注唯一：管理线号的唯一性级别。如果将唯一性级别设置为工程，计数器将在整个工程内生效。如果将其设置为文件集，每次更改文件集时，计数器将在开始编号自参数值重新开始。电位位置由其第一线段提供，其他信息则与源设备相同。如果存在源设备，则电位位置是该设备的位置；否则，该位置是绘制此线段所在的文件的位置（或者如果其开始于位置轮廓线，则为该位置轮廓线）。

计算多线序号

定义该组电线的电线编号模式。

每条线不同选项将为每个电线导线分配不同编号；

不同线可以相同选项将为所有电线导线分配同一编号。在此模式中，我们建议为编号格式添加前缀。否则，所有电线导线将具有相同值。

相关章节：

电线样式

配置编号


布线方框图线样式

菜单：工程 > 配置 > 布线方框图线样式...

可停靠面板 > 工程的右键菜单：配置 > 布线方框图线样式...

在布线方框图中插入电缆时，通过从可停靠面板单击 [...] 按钮并选择管理器按钮，也可打开管理器。

这将打开电缆样式管理器对话框，可在其中创建/修改电缆样式。

添加：允许您创建新电缆类型。

删除：删除选定的电缆类型。

复制：将选定样式的副本放置在软件剪切板中。

粘贴：插入软件剪切板上的样式。

特定粘贴：插入软件剪切板上的样式，但允许您管理其标注。

复制/粘贴/特殊粘贴功能可用于在工程之间复制布线方框图线型的定义。

要编辑电缆类型，请单击要修改的电缆列（说明、颜色、线型）。

相关章节：

绘制电缆


报表

菜单：工程 > 配置 > 报表...

可停靠面板 > 工程的右键菜单：配置 > 报表...

报表配置管理器允许您区分和定义附加到应用程序和工程的配置。

附加到应用程序的配置通用于使用它的所有工程。附加到工程的配置仅在当前工程中可见。

DesignSpark Electrical 将工程配置视为优先；如果这些不可用，将使用应用程序配置。

删除：删除选定的配置文件。

属性：编辑选定的配置文件。

复制：复制配置文件。消息询问您是否想要打开文件以进行修改。

添加到工程/应用程序：将在应用程序等级可用的配置添加到您的工程，同样，还可使您为工程所创建配置在应用程序等级可用。

压缩：创建配置压缩文件。此功能用于交换配置文件。

解压缩：恢复初始压缩的配置文件。

用于工程中/从工程中移除：用于在工程中使用的配置列表中添加或删除文件。

重命名：重命名选定的配置文件。一个对话框打开，询问您是否定义文件的新名称。

修改绘图规则：将报表配置更改为绘图规则配置。

相关章节：

报表管理器

编辑报表设置

添加报表

计划报表

生成图纸报表

导出 Excel

导出 Txt

导出 XML


编辑报表配置

菜单：工程 > 配置 > 报表 > 属性

菜单：报表管理器 > 属性

工程右键菜单：配置 > 报表 >

报表图纸右键菜单：编辑报表配置

此命令允许您编辑选定的报表配置。

显示所有报表配置参数的对话框打开。

打开预览窗口以检查设置。

调整预览以配合图形区域。

基本信息

名称：允许您命名配置文件。

类型：在列表中，选择报表配置类型。

说明：允许您使用软件支持的所有语言输入说明。

样式

对于表中显示的所有文本类型，您可以管理字体、高度、颜色和样式。

列

允许您定义表的列及其列内容。

更改预览。激活此选项时，预览在图纸空间显示此表。

显示有关列排序的提示。

允许您选择要在报表配置中管理的列。勾选所需字段对应的框。您可以使用图标（箭头）来管理列。

允许您添加新的列。此图标仅在激活专家模式时可用。

允许您删除一列。此图标仅在激活专家模式时可用。

标题：表的第一行。标题包含表示数据类型的文本。您可以使用工程支持的所有语言输入文本。

内容：存储在工程数据库中的数据字段。单击单元格以访问列属性。

转至：允许您生成带数据的链接，例如设备的标注 ID 和工程（设备）中的元素。

宽度：输入列的宽度。

计算总和：此数据可选。您仅可使用总数字数据。

打印垂直分离：取消选中此选项时，将移除两列之间的垂直行。

多线：当文本长度超过单元格长度时，如果激活此选项，则剩余文本将放置在第二行。

标题对齐：允许您管理标题文本的对齐。

内容对齐：允许您管理内容文本的对齐。

合并行：如果数据具有相同值，则为其分组。

列表中重复显示：合并行时，后续列会在相同单元格中显示所有数据。如果激活此选项，则意味着您接受多次重复显示数据。

分隔符：此字符用于在出现重复时分隔数据。

布局

允许您配置表在图纸中的位置。

图纸空间

高度：输入可以在其中绘制表的区域的高度。

宽度：输入可以在其中绘制表的区域的宽度。

图纸空间插入

X 和 Y 坐标：输入边界所对应区域的坐标（无法在图框网格中绘制表）。

表间空隙

水平和垂直：输入每个表之间的所需间隙。

标题与表之间的间距：输入显示表标题的文本与表之间的距离。

选项

使用‘|’字符作为换行符：当您管理报表中的换行符时选择此选项。对于每种类型的报表（例如图纸或 Excel 文件），‘|’ (Alt 124) 字符将替换为特定换行符。

不切断表：使用切断时，表可能不会占用整个图纸。因此，可能在同一张图纸上绘制第二个表。选择此选项时，如果第二个表无法完全绘制到图纸中，则将在新图纸中绘制。

每页一个表：使用切断时，如果勾选此选项，您无法在一页上放置两个或更多表。

图纸列表：图纸列表的特殊选项。启动图纸列表时允许创建一个或更多新图纸。将多次启动报表以集成这些新图纸。

每个文件集一个报表：在文件集上使用切断时，您可以选择在一个文件集中为所有报表图纸分组，也可以将其分配给不同文件集。

与此报表关联的图框显示在此选项卡中。它可能不同于项目配置中设置的图框。

您可以通过单击图标 [image] 对其进行修改。

排序和中断

允许您配置数据排序。中断允许您将报表分为不同表，值相同的数据将分为一组（中断 = 每页一张表）。

此表的左上方可以插入标题。还允许您自动或者使用格式配置表的标题。

标题格式：允许您访问格式管理器以创建表的标题格式。

自动中断格式：此选项会自动设置要设置的中断的标题。

排序和中断条件：添加用于排序的字段。您可以使用向上/向下箭头管理排序。顺序基于第一个字段创建，然后第二个字段，以此类推。如果想要创建中断，请勾选此框。

筛选器

筛选器允许您在报表数据中进行提取，例如用于显示特定制造商的设备型号，或者显示特定文件集的图纸列表。

允许您添加新筛选器。

复制选定筛选器。

删除选定筛选器。

打开选定筛选器定义。

筛选器名称：显示报表中所用不同筛选器的名称。

筛选器说明：以工程中所用主语言显示筛选器说明。

筛选器：显示筛选条件。

文件数据

您可通过此选项卡为自动生成要传输到报表图纸属性中的信息定义参数。在右侧列中单击鼠标可以打开格式管理器。

名称：此格式允许您定义图纸标注。如果将此格式留空，则将使用配置参数。

说明：允许您为自动生成要传输到报表图纸属性中的信息定义参数。

用户数据/可译数据：允许您为自动生成要传输到报表图纸用户数据中的数据设置参数。

激活专家模式

专家模式让您可以直接干涉用于生成报表的 SQL 查询。这种模式只对能够使用 SQL 和拥有数据库结构知识的用户可用。

警告：变更执行不正确或未经过深思熟虑的操作可能产生不想要的结果或完全丢失报表配置。

激活‘专家’模式时，会显示新的‘SQL 查询’选项卡。左侧用 SQL 格式显示。右侧采用表格和字段方式显示。

添加/删除一列：允许您添加或删除一列。请不要将此功能与添加/删除列选项卡混淆。在专家模式下添加/删除列将会添加/删除查询中的字段。

打开文件：允许在文件编辑器中打开 XML 文件（保存报表配置和语句的参数）。

编辑：让您可以编辑语句。

测试：让您可以测试语句结果。如果结果有效，显示结果的对话框将打开。如果语句不正确，将出现一则提示消息。

导出查询：允许您导出文本文件中报表所用的查询。此文件将自动打开。

相关章节：

报表管理器

添加报表

计划报表

生成报表图纸

导出 Excel

导出 Txt

导出 XML


用户数据

菜单：工程 > 配置 > 用户数据...

可停靠面板 > 工程的右键菜单：配置 > 用户数据...

用户数据存在于工程的各个位置。它用于存储可显示在原理图或报表中的个人信息。有两种类型的用户数据：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

对话框的左侧显示应用程序等级可用的配置，即通用于所有工程。对话框的右侧列出仅在当前工程中可用的所有配置。

新建：用于创建新的配置文件。

删除：用于删除选定的配置文件。

属性：用于编辑选定的配置文件。

复制：复制配置文件。消息询问您是否想要打开文件以进行修改。

添加到工程/应用程序：用于将在应用程序等级可用的配置添加到您的工程，同样，使您创建用于工程的配置在应用程序等级可用。

压缩：用于创建配置压缩文件。此功能用于交换配置文件。

解压缩：用于恢复初始压缩的配置文件。

相关章节：

用户数据自定义


用户数据自定义

菜单：工程 > 配置 > 用户数据...> 属性

菜单：工程 > 配置 > 用户数据...> 新建

可停靠面板 > 工程的右键菜单：配置 > 用户数据...> 属性

可停靠面板 > 工程的右键菜单：配置 > 用户数据...> 新建

对话框分为两个选项卡。常规选项卡允许您设置用户数据配置文件的说明。第二个选项卡编辑允许您管理用户数据

在编辑选项卡中，对话框的左侧显示用户数据，右侧显示用户数据或选定组的名称。

用户数据已重新划分在不同组中（组名称为用户数据和可译数据可以重命名，并且只用来区分数据类型）。您可以创建多个组，但是某些元素的用户数据量有限（例如电缆的可译用户数据量最多为三个）。

为方便用户数据的管理，每一项用户数据都带有顺序号。此编号会在电气对象属性对话框中显示。

插入组：让您可以插入新用户数据组。

插入用户数据：让您可以创建新用户数据（不可译）。在选定组中创建用户数据。

插入可译数据：允许您创建新的可译数据。在选定组中创建可译数据。

下移/上移：用于管理用户数据的顺序。

删除：让您可以删除选定的用户数据。

保存：让您可以保存配置文件。对话框关闭时也可以保存。

剪切/复制/粘贴：允许您复制现有用户数据。


控制面板

菜单：工程 > 配置 > 控制面板...

可停靠面板 > 工程的右键菜单：配置 > 控制面板...

控制面板用于存储原理图或布线方框图符号、原理图宏 的输入/输出。

对话框的左侧显示应用程序等级可用的配置，即通用于所有工程。对话框的右侧列出在当前工程中唯一可用的所有配置。

删除：删除选定的配置文件。

属性：编辑选定的配置文件。

复制：复制配置文件。消息询问您是否想要打开文件以进行修改。

添加到工程/应用程序：将在应用程序等级可用的配置添加到您的工程，同样，还可使您为工程所创建配置在应用程序等级可用。

压缩：创建配置压缩文件。此功能用于交换配置文件。

解压缩：恢复初始压缩的配置文件。

重命名：重命名选定的配置文件。一个对话框打开，询问您是否定义文件的新名称。

您无法在此界面中修改配置文件。使用控制面板时，它们将自动进行修改。

相关章节：

工程配置 > 库和控制面板

符号控制面板

宏控制面板


格式管理器

工程设置 > 基本信息

工程设置 > 标注

线样式管理器 > 线属性

DesignSpark Electrical 使用可发送数据库中信息的变量（设备标注、电线编号...）。这些信息都可以通过格式管理器修改，以获得自己想要的格式。

例如：

从数据库中读取等电位编号：5

此值存储在变量 EQU_NO 中。

如果要在图纸上将此信息显示为 005（显示为三个字符），您需要使用以下格式：STRZ(VAL(EQU_NO), 3, 0)

使用格式管理器

DesignSpark Electrical 随附多个预定义的格式，我们建议使用这些格式。但是，如果您需要创建自己的格式，我们将简单地讨论某些用来创建格式所需的元素。

- 每个格式都包含变量（在第三个选项卡中）和文本。需要将文本字符串置于引号内，而且每个变量或文本字符串之间必须用 + 符号分隔。例如：CHAN_TYP + ":"+ COM_VAL1 + "."+ CHAN_ADDR

- 变量通常是文本类型，即使它们看起来是数字样式（例如：EQU_NO 变量用来显示电位编号）。

- 变量可以实现某些功能。

STRZ (VAL(FIL_NO),2,0) 可以发送由两个字符表示的图纸编号。此处缺失的字符将替换为 0（例如：01、02...）。

VAL：将一串字符转换为数字。由于 FIL_NO 是一串字符，因此需要转换为数字，因为 STRZ 函数只能处理数值。

STRZ：通过强制使用某些数值（示例中为 2）和十进制数（示例中为 0）来转换数值。

- 可以使用数学运算函数 (+ - * /) 来修改变量的结果。

STRZ(VAL(EQU_NO)*2,3,0) 可以发送由三个字符表示的电位号，但仅能使用偶数。

STRZ((VAL(EQU_NO)*2)-1,3,0) 显示与之前格式相同的结果，但仅能使用奇数。

如果输入的格式错误，对话框底部会显示一条消息。

对话框提供四个选项卡来帮您创建自己的格式。

预定义格式

该选项卡根据您要关联至格式的元素为所有预定义格式分组。在列表中，选择格式并单击替换格式按钮以替换现有格式。

如果愿意，您可以手动修改此格式。当此格式生效时，会出现一条通知消息。

最近格式

该选项卡显示您使用的旧格式。和在第一个选项卡中一样，您可以通过选择现有格式并单击替换格式按钮来替换活动格式。

变量和简单格式

此选项卡允许您创建自己的格式。

简单格式：此列显示可用变量的列表以及使用这些变量的简单格式。

说明：此列针对所选变量进行说明。

类型：显示变量类型以帮助您使用特定函数，如 VAL 或 STRZ。

添加简单格式：要创建此格式，请选择变量并单击添加简单格式按钮。

您可以添加文本，但文本必须使用引号（“文本”），而且每个文本和变量之间必须使用符号 + 分隔。当此格式生效时，会出现一条通知消息。

功能

此选项卡列出了您可在格式中使用的所有函数和操作符。

功能：显示函数名称。函数按类型、数学运算、文本和各种功能排序。

说明：显示函数说明（定义）。

示例：显示函数使用及其句法的示例。您可在示例结尾处看到函数的结果。

如之前选项卡一样，单击添加函数按钮可以向格式添加函数。


可停靠面板

DesignSpark Electrical 使用特定面板来帮助您进行原理图设计。这些可停靠面板可置于屏幕右侧或左侧。

可停靠面板包含不同选项卡，每个选项卡关联一个特定图标。可以使用拖放方法将这些选项卡从一个可停靠面板移至另一个可停靠面板。

多数选项卡显示通过手动管理，方法是使用视图菜单（可停靠面板部分）命令。某些可停靠面板自动打开，如命令选项卡。

文档：显示工程文档列表。

设备：显示设备列表。

命令：显示当前命令的选项。

宏：显示红控制面板。

符号：显示符号控制面板。

属性：显示选定元素的属性。

资源：显示软件相关快捷方式。

您可以保存可停靠面板布局（选项卡和可停靠面板位置）、恢复已保存的布局或者重置为加载默认面板布局。


‘命令’选项卡

可停靠面板：命令

当命令运行并需要选项时，命令选项卡将显示。


属性选项卡

可停靠面板：属性

菜单：修改 > 属性

可停靠面板包含一个特定选项卡，它允许您显示选定元素的属性。属性可以是（存储在图形实体中的）图形属性，也可以是存储在工程数据库或软件数据库中的数据。

此元素可以是：

  • 工程文档（在文档选项卡中）。

  • 设备（在设备选项卡中）。

  • 任何图形电气对象（图形区域中的电线、符号、位置和功能轮廓线）。

  • 任何基本实体（图形区域中线、圆、弧或文本）。

  • 符号（图形编辑模式）。

  • 2D 布局图（图形编辑模式）。

  • 图框（图形编辑模式）。

对象属性可以显示在特定对话框中。

工程元素

工程元素根据工程（例如工程文档、设备或电气实体）对所有元素进行分组。

当您选择一个工程元素时，将出现特定图标以编辑其属性。

单击此按钮编辑选定元素的电气属性。

确认在“属性”选项卡中完成的修改。

取消在“属性”选项卡中完成的修改。

在编辑模式中，有些数据无法修改，因为这些数据由软件或工程配置进行管理。

此功能允许多项选择，但您必须选择相同类型的元素（例如，您不能选择一个符号和一个图纸）。当您选择多个元素（例如不同类型的电线）时，仅显示通用属性。

在多项选择模式中，灰色单元格表示所选元素的数据不同。在编辑模式中，灰色将替换为紫色。

文档元素

属性选项卡显示在文档选项卡中选定的每个工程元素（工程、文件集、文件夹、图纸、附件）的属性如果选择不同类型的元素（如文件夹和图纸），将出现新选项卡以对元素排序。

例如，如果选择一个文件夹和一张图纸，则会显示两个选项卡。您可以访问文件夹选项卡中的文件夹属性和图纸选项卡中的图纸属性。

设备元素

对于文档元素，如果您在设备选项卡中选择多个不同类型的元素，则属性选项卡中会显示对应于每种类型设备的新选项卡（位置、设备、端子排）。

图形实体

要在图形区域中编辑选定元素的属性，您必须选择一个元素或仅选择相同类型的元素（多项选择）。如果您选择多种类型的实体，则仅显示图形属性选项卡，而且您无法更改电气属性。

延迟模式被激活后，电线属性不可用。

对应所选实体类型显示特定选项卡。例如，当您选择电线时，将显示与您能在此电线上找到的所有设置相对应的几个选项卡（电位、电缆、电缆芯、电线样式）。

图形属性选项卡显示选定元素的图形设置。由于部分设置由配置进行管理，因此这部分设置无法更改。在此选项卡顶部，您可以找到按类型分组选定实体的列表。在多项选择中，该选项卡显示通用数据。

软件元素

属性选项卡显示线、圆或文本等基本图形实体的设置。它还显示存储在管理器中元素的数据（符号、图框和 2D 布局图）。

基本实体

在基本实体选择中，仅图形属性选项卡可用。如果您选择不同类型的实体，这些实体将在选项卡顶部的列表中分组。显示的设置为选定分组或整个选择的设置。当您更改元素属性时，它们将在图形区域中自动更新。

管理器元素

在图形管理器中，当您编辑符号、2D 布局图或图框等元素时，属性选项卡将显示选定层次的数据。

对于符号，您可以访问符号、回路、连接点和标注的属性。对于 2D 布局图和图框，您也可访问其属性和标注的属性。

当所选元素具有图形展示（基本图形实体、标注和连接点）时，图形属性选项卡可用。


‘资源’选项卡

可停靠面板：资源

显示软件相关快捷方式。


工程和文件

工程由文件组成：这些文件可以是由用户创建的图纸（如原理图或布线方框图）或由软件自动生成的图纸（如报表）或其他文件（如 PDF 文件或 DWG 文件）。工程文档组织到文件夹和文件集中。

DesignSpark Electrical 不会将 DesignSpark Electrical 之外创建的所有图纸考虑在内，而且这些图纸将不包含在不同流程中。

  • 工程管理器

  • 管理文件集

  • 管理文件夹

  • 文档的不同类型

  • 管理工程图纸

  • 图框管理

  • 添加附件


工程管理器

菜单：文件 > 工程管理器

快速工具栏

两个选项卡可用。一个显示所有工程（所有工程），另一个显示最近访问的工程（最近工程）。

工程显示为蓝色和粗体时，它在可停靠面板的文档选项卡中存在，且至少已打开一张图纸。它是当前工程。

当工程显示为蓝色时，这意味着它在可停靠面板的文档选项卡中存在，但无图纸打开。

当工程显示为黑色时，它不在可停靠面板的文档选项卡中存在，且无图纸打开。

默认情况下，工程说明以软件语言显示。如果您想以其他语言显示，请在功能区的可用列表中进行选择。

新建：允许您创建新工程。

解压缩：允许您恢复现有压缩工程。

打开：允许您打开工程资源管理器（可停靠面板）中选定的工程。

设置为当前：允许将选定工程设置为当前。工程必须在可停靠面板的文档选项卡中。

关闭：关闭所选工程。

压缩：允许压缩选定的工程。必须关闭工程。

复制：复制所选工程。

另存为模板：允许您创建新工程模板。

删除：删除所选工程。

属性：打开选定工程的属性。

配置：允许您配置工程管理器中显示的列。

筛选器：激活过滤器以帮助您查找工程。

这些命令还可在工程的右键菜单中使用。

  • 解压已有工程

  • 新建工程

  • 创建工程模板

  • 工程属性

  • 打开一个工程

  • 设为当前选项

  • 关闭一个工程

  • 压缩一个工程

  • 复制一个工程

  • 删除一个工程

  • 筛选工程


解压已有工程

工程管理器 > 解压缩

解压缩工程使您可修复之前压缩的工程。这包含打开先前已压缩的工程。 DesignSpark Electrical 将提示您选择已压缩的 TEWZIP 文件。

解压缩命令有 2 个选项。第一个解压缩选项允许您使用选项解压缩工程。第二个解压并打开选项允许您解压缩工程并将其自动打开，无需选择选项。将自动验证工程的属性，且不更新数据。

工程属性对话框将打开，允许您修改工程数据。确认后，将打开一个新对话框，您可以在该对话框中定义要导入的数据和处理方法。

如果选定更新选项，将自动打开更新向导，您可以在此处管理要解压缩的数据。

弹出窗口将询问是否立即打开工程或您是否保留在工程管理器中。

相关章节：

工程管理器

压缩一个工程


新建工程

工程管理器 > 新建

创建新工程时，您必须选择模板或创建空工程。如果您选择 <空工程>，您需要为此工程输入所有配置参数。

一些工程模板允许您选择要用于工程的主语言。

将显示“工程属性”对话框，您可以在该对话框中输入工程特殊数据。

请注意，在此阶段，您无法修改工程配置参数。需要确认您的设置（这将创建新工程），然后您可以编辑配置参数。

新建工程将自动添加至可停靠面板。使用模板后，工程将由模板工程中的元素（如原理图或封面）自动填充。

相关章节：

工程管理器

工程属性

创建工程模板


创建工程模板

工程管理器 > 另存为模板

选择列表中的工程，然后单击另存为模板图标。对话框打开，让您可以输入工程模板的名称。

工程模板中包含可用于创建工程的所有工程元素（如图纸或配置）。使用此工程模板创建新工程时，新工程会包含工程模板中的所有内容。

相关章节：

工程配置

创建新工程


工程属性

工程管理器 > 属性

可停靠面板 > 工程的右键菜单：工程属性

菜单：工程 > 属性

允许您访问所选工程的属性。

输入数据可显示在图框中。

名称：工程名称。当您压缩工程时，此名称可用作文件名。工程名称不能为空。

基本信息

合约号：识别合约的合约号或代码。此数据可选，但不可自定义。

客户

这些数据可选，但不可自定义。

名称：客户名称。

地址 1/2/3：客户地址。可使用三行。

设计院

这些数据可选，但不可自定义。

名称：设计院名称。

地址 1/2/3：设计院地址。可使用三行。

系统

显示关于工程创建和修改的信息。这些数据为自动数据且不可修改。

创建者：创建工程的用户名称。

创建日期：工程的创建日期。

修改日期：最后修改工程的日期。

信息

显示有关工程的信息。

说明

工程的第一个可译数据。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据在整个工程中可用。用于存储可在图纸中显示的个人信息。用户数据有两种类型：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

统计数据：打开工程后您即可访问工程的统计数据。单击统计数据按钮可打开一个对话框，其中显示工程中可找到的元素数量（如图纸、制造商零件或电缆）。

自定义：允许访问工程的用户数据。

工程配置：允许访问 工程配置。

相关章节：

工程设置

用户数据


打开一个工程

工程管理器 > 打开

在列表中选择该工程，然后单击打开图标。

工程将自动添加到可停靠面板中的文档选项卡中，并且成为当前工程。

工程处于可停靠面板中时，打开图标呈灰色。

工程管理中有一个复选框保持对话框开启，它可在打开工程后让工程管理器保持开启状态。

如果您（从 DesignSpark Electrical 数据的工程文件夹）将‘.ewg’文件放到 DesignSpark Electrical 界面中，也可以打开工程。文件将在图形界面中打开，并且工程将添加到可停靠面板的文档选项卡中。

相关章节：

工程管理器


设为当前选项

当前工程即您正在使用的工程。为区分可停靠面板和工程管理器中的当前工程，将其加粗显示。

工程管理器 > 设为当前工程

可停靠面板 > 工程的右键菜单：设为当前选项

当您打开或激活其中一张工程图纸（当前图纸）时，工程将自动设置为当前工程。


关闭工程

工程管理器 > 关闭

可停靠面板 > 工程的右键菜单：关闭工程

从列表中选择工程，然后单击关闭图标。

打开的页面将自动保存并关闭。工程将从可停靠面板的文档选项卡中移除，但仍保留在工程管理器中。

工程在压缩前、保存为模版前、删除或复制前都必须处于关闭状态。

相关章节：

工程管理器


压缩工程

工程管理器 > 压缩

压缩命令可以保存该工程及其设计中使用的所有文档和所有数据（如符号、图框或配置）。

压缩工程文件的扩展名为 .PROJ.TEWZIP。已压缩的工程在工程管理器中仍然可用。

1. 从列表中选择工程。

2. 单击压缩图标。

3. 将会打开一个消息框，要求您允许用户在解压缩时更改工程语言。

4. 如果您在工程中有快捷方式，则将开打一个选项对话框，询问您是否包含该快捷方式所管理的文件。

5. 在另存为窗口中，选择文件夹和压缩文件的名称。

相关章节：

工程管理器

关闭工程

解压缩工程


复制一个工程

工程管理器 > 复制

创建某现有工程的副本。所有工程数据都将保留。

选择列表中的工程，然后单击复制图标。

属性对话框将打开，您可以修改新工程的名称和属性。工程将添加到工程列表中。

工程在复制前必须处于关闭状态。

相关章节：

工程管理器

关闭工程

工程属性


删除一个工程

工程管理器 > 删除

删除一个工程及构成该工程的所有元素。

从列表中选择一个或多个工程，然后单击删除图标。

将打开一个对话框，显示以下选项：

存档并删除：将在删除之前创建一个包含选定工程的存档文件。如果您不确定最终删除，请使用此选项。此工程可以通过解压缩功能进行恢复。

删除且不备份：将删除此工程而不创建存档文件。

删除工程操作不可撤消，因此一旦删除，无法恢复。在删除工程前，最好先压缩工程。

工程在删除前必须处于关闭状态。

相关章节：

工程管理器

关闭工程

压缩工程


筛选工程

工程管理器 > 筛选

通过输入筛选条件，此命令使您可以减少工程列表。

对话框的左边显示筛选条件列表。输入筛选条件后，工程列表将减少为与这些条件相应的工程。

相关章节：

工程管理器


管理文件集

文件集包含构成工程的所有文档。文件集可包含文件夹、图纸和所有关联的文档。如果需要，您可以在单个工程中创建多个文件集。

通过可停靠面板中的标注和说明，可以识别文件集。

创建一个新文件集

菜单：工程 > 新建 > 新建文件集

可停靠面板 > 工程的右键菜单：新建文件集

打开文件集的‘属性’对话框，它允许您为文件集分配一个标注并输入内容或管理校对。

移动文件集

您可以使用拖放功能移动文件集。移动后的文件集必须处于同一工程中。将显示一条黑线，可用于定义新位置。

文件集属性

文件集右键菜单：属性

标注

将根据工程设置自动计算文件集标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

数量：显示分配至文件集的序号。您可以更改此序号，但不可使用现有序号。

层级结构

文件集默认关联一个位置和功能。此文件集下的所有项目（图纸和设备）都会自动默认关联此位置和功能。

位置/功能：单击 [...] 按钮打开位置（功能）选择器，您便可选择要关联文件集的位置（功能）。

信息

文档数：显示文件集中包含的文档数。此信息提供给使用原理图页数限制版本的用户。

校对

当前校对：显示分配至文件集的校对系数。您可以通过单击 [...] 按钮来管理校对。

说明

文件集可译数据的第一个字段。您可以为工程中管理的所有语言输入说明。

用户数据/可译数据

用户数据存在于整个工程。用于存储可在图纸中显示的个人信息。用户数据有两种类型：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

自定义...按钮可让您访问文件集的用户数据。

删除一个文件集

文件集右键菜单：删除

删除一个文件集会删除文件集中包含的所有元素（文件夹、图纸或附件）。

相关章节：

管理文件夹

文档的不同类型


管理文件夹

文件夹可以视为存储图纸或其他文件夹的目录。此系统可提供用于对一个工程内的多个图纸进行分类或分组的工具。

文件夹按其在可停靠面板中的标注和说明来标识。

新建一个文件夹

菜单：工程 > 新建 > 新建文件夹

文件集右键菜单：新建 > 文件夹

打开文件夹的属性对话框可使您向其分配标注和输入与其数据集相关的信息。

文件夹属性

文件夹右键菜单：属性

标注

将根据工程设置自动计算文件夹标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

数量：显示分配至文件夹的序号。您可以更改此序号，但不可使用现有序号。

基本信息

定义第一个图纸编号：如果选择此选项，您将能够指示此文件夹中第一个图纸的编号。否则，第一个图纸的编号将根据上一个图纸得出（无论哪个文件夹）。

第一个图纸编号：仅激活上一个设置时可使用此设置。输入文件夹第一个图纸的编号。

路径：表示文件夹所依赖的文件集的路径。

说明

文件夹的第一个可译数据。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据在整个工程中可用。用于存储可在图纸中显示的个人信息。用户数据有两种类型：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

自定义...按钮可让您访问文件夹用户数据。

删除文件夹

文件夹右键菜单：删除

删除一个文件夹将删除该文件夹中包含的所有图纸。

相关章节：

管理文件集

文档类型


文档的不同类型

提供多种文档。DesignSpark Electrical 中可编辑的所有文档称为图纸。

由用户创建的文档：

封面 | 首页或封面，不含图形。
布线方框图 | 使用方框图绘制用于描述布线的布线方框图。
原理图 | 原理图、电气原理图或其他类型的图纸（文档默认类型）。

由 DesignSpark Electrical 生成的文档（无法由用户生成）：

报表

基于数据库提取的清单。图纸清单、BOM、电缆报表、接线清单等

附件：

附件是复制到工程的外部文件。它可以是任何格式的文件。

DWG 和 DXF 文件可作为 DesignSpark Electrical 文档进行管理。显示预览。它们可在 DesignSpark Electrical 中修改和打印。

所有其他文件格式均可添加至工程，但无法在 DesignSpark Electrical 界面中预览或编辑。如果要打开它们，与文件类型关联的应用程序会将其打开。

文件快捷方式

此文件类型并非真正的工程文档，仅是到外部文件的链接。其名称以类似工程文档的形式显示，但带有特殊图标。

可使用 Windows 关联应用程序打开这些文件。

  • 封面

  • 布线方框图

  • 原理图图纸

  • 报表图纸

  • 附件

  • 文件快捷方式


封面

封面是特殊的图纸，不包含在原理图中。

既然可以用多种方式实现图纸的管理（文件集、文件夹），您可以管理尽可能多且位于工程中任意位置的封面。

相关章节：

文档的不同类型

创建封面


布线方框图

布线方框图允许您绘制安装的电缆图纸。打开布线方框图后，布线方框图菜单将激活并显示创建布线原理图所需的命令。

用于此类型图纸、由布线方框图菜单中命令插入的图形元素保存在工程数据库中。

相关章节：

文档的不同类型

创建图纸


原理图图纸

在图纸类型原理图上安装详细的原理图。打开原理图图纸时，原理图菜单将激活并显示创建原理图所需的特殊命令。

用于此类型图纸、由原理图菜单中命令插入的图形元素保存在工程数据库中。

相关章节：

文档的不同类型

创建图纸


报表图纸

报表图纸由 DesignSpark Electrical 自动创建。将根据工程数据库中存储的信息和配置参数自动生成报表图纸。

无法添加原理图或布线方框图元素，仅绘制或修改菜单可用于完成图形详细信息。如果已添加图形元素，请在报表更新后检查图纸。

相关章节：

文档的不同类型

绘制报表


数据文件

DesignSpark Electrical 允许您向工程添加不同文档类型，例如：DWG/DXF、Word 或 Excel 文件。可以在工程中复制这些文件，但无法在图形界面中打开。这些文件以在 Windows 中与文件类型相关的应用程序打开。

相关章节：

文档类型

添加数据文件


管理工程图纸

每页图纸都有一个标注（号码）。此标注在文件集中具有唯一属性，两页图纸不能有相同的标注。

在可停靠面板的文档选项卡中，用户可以定义这些图纸的显示顺序，只需根据需要拖放图纸使其移动，还可以添加文件集或文件夹。图纸可以移动，复制或者重新编号。

要打开图纸，请双击图纸或使用其右键菜单中的打开命令。当图纸在您的会话中打开时，它显示为蓝色。如果图纸在其他工作台中打开，则将显示为红色。当前图纸显示为蓝色并加粗。

  • 创建封面

  • 创建图纸

  • 打开图纸

  • 图纸属性

  • 预览

  • 重建图纸

  • 修改位置

  • 修改功能

  • 获取图纸

  • 移动图纸

  • 图纸重新编号

  • 复制/粘贴图纸

  • 浏览图纸

  • 删除一张图纸


创建封面

菜单：工程 > 新建 > 封面

文件集右键菜单：新建 > 封面

文件夹右键菜单：新建 > 封面

封面自动添加至文件集或文件夹图纸列表。然后，将在图形区域自动打开封面；其图框将根据您已在工程、文件集或文件夹属性中输入的信息更新。

相关章节：

管理工程图纸


创建图纸

菜单：工程 > 新建 > 原理图（布线方框图 - 混合图）

文件集右键菜单：新建 > 原理图（布线方框图 - 混合图）

文件夹右键菜单：新建 > 原理图（布线方框图 - 混合图）

图纸右键菜单：新建 > 原理图（布线方框图 - 混合图）

创建时，图纸将会添加到文件集或文件夹，具体取决于运行命令的位置。

图纸将在图形区域自动打开。可以通过打开图纸的属性修改与之相关的编号及数据。

也可单击快速工具栏的下一页图标，在列表上的最后一页图纸中创建图纸。

相关章节：

管理工程图纸


图纸属性

图纸右键菜单：属性

标注

将根据工程设置自动计算图纸标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

数量：显示分配至图纸的序号。您可以更改此序号，但不可使用现有序号。

层级结构

图纸默认关联了一个位置和一个功能。默认情况下，此图纸中包含的所有设备将自动关联此位置和功能。当您更改图纸位置（或功能）时，将打开一个信息框，允许您更改插入到此图纸中的设备的位置（或功能）。

位置：单击 [...] 按钮打开位置选择器，这让您可以选择要与图纸关联的位置。

功能：单击 [...] 按钮打开功能选择器，这可让您选择要与图纸关联的功能。

信息

图纸位置：显示列表中图纸的位置（文档选项卡）以及工程中所含图纸的总数。

校对

当前校对：显示分配至图纸的校对系数。您可以通过单击 [...] 按钮来管理校对。

属性

图纸类型：显示图纸的类型。可以是封面、布线方框图、原理图、混合原理图、报表。此设置不可修改，但原理图和布线方框图图纸可以更改为混合图图纸类型。

文件名：显示文件名。不要重命名此文件，否则与软件的链接将会丢失。

目标文件（仅在文件快捷方式上）：显示文件快捷方式中管理的路径和文件名。

图框：显示图纸中使用的图框名。单击 [...] 按钮可更改关联的图框。如果单击右侧图标 (+)，您可访问图框管理菜单。

说明

图纸的第一个可译数据。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据在整个工程中可用。它用于存储可在图纸中显示的个性化信息。用户数据有两种类型：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

自定义...按钮允许您访问图纸用户数据。

相关章节：

管理工程图纸


预览

图纸右键菜单：预览

打开视图窗口。

菜单栏中的“缩放”命令可用于 DWG 或 DXF 文件。未对图纸作出任何修改。

相关章节：

管理工程图纸


重建图纸

图纸右键菜单：重建

此命令允许您根据存储在工程数据库汇总的数据更新或重新创建图纸。

运行命令后，对话框将打开，显示可用选项。

重建：根据存储在数据库中的信息在图纸中删除并重新生成 DesignSpark Electrical 实体（在数据库中进行管理）。保存由绘制和修改菜单命令绘制的元素（不由数据库管理的实体）。

删除和重建：根据数据库中存储的信息删除和重建图纸。由绘制和修改菜单命令绘制的元素（不由数据库管理的实体）将丢失。

不操作：取消命令。

相关章节：

管理工程图纸


修改位置

图纸右键菜单：修改位置

更改位置命令可用于多个图纸。

图纸属性：位置

每个图纸都与位置关联。创建图纸时将定义此位置。默认情况下，位置与文件集关联。

选择该命令后，位置选择对话框将打开，您可以选择所需位置。

最初与图纸原有位置关联的设备可关联到新位置。打开的对话框允许您选择所需选项。

更改设备位置：与图纸位置相同的设备自动关联到新功能。如果在多个图纸（符号）上绘制设备，则所有表示此设备的符号都关联到新功能（尽管更改的功能并未影响图纸）。

仅更改图纸位置：图纸本身关联到新位置，图纸内容不作出任何改变。

取消：取消当前命令。不更改图纸及其内容。

相关章节：

管理工程图纸

位置


修改功能

图纸右键菜单：修改功能

更改功能命令可用于多个图纸。

图纸属性：功能

每个图纸都与功能关联。创建图纸时将定义此功能。默认情况下，功能与文件集关联。

选择该命令后，功能选择对话框将打开，您可以选择所需功能。

最初与图纸原有功能关联的设备可关联到新功能。打开的对话框允许您选择所需选项。

更改设备功能：与图纸功能相同的设备自动关联到新功能。如果在多个图纸（符号）上绘制设备，则所有表示此设备的符号都关联到新功能（尽管更改的功能并未影响图纸）。

仅更改图纸功能：图纸本身关联到新功能，图纸内容不作出任何改变。

取消：取消当前命令。不更改图纸或其内容。

相关章节：

管理工程图纸

功能


获取图纸

搜索文档

此功能允许您在工程的所有文档中查找文档、图纸或其他项目。

可停靠面板 > 工程的右键菜单：获取图纸

可停靠面板 > 文件集的右键菜单：获取图纸

可停靠面板 > 文件夹的右键菜单：获取图纸

可停靠面板 > 图纸的右键菜单：获取图纸

菜单：工具 > 搜索 > 搜索文档

菜单：视图 > 搜索文档

对话框左侧显示工程树形图，右侧显示工程中包含的文档预览或列表。

列表模式：显示图纸列表（包括名称、说明等）。

缩略图模式：显示图纸的缩略图预览。

预览：在“预览”对话框中打开图纸。无法在此修改图纸。

配置：管理对话框中项目的显示设置。

属性：打开选定图纸的属性对话框。

为帮助您进行搜索，您可以根据四个过滤条件筛选结果：标注、说明、文件类型、功能、位置、文件集和打开的图纸。这让您能够显示所有工程图纸，或者仅显示用户或其他用户打开的图纸。

选择图纸并单击打开按钮以将其打开。


移动图纸

选择想要移动的图纸，使用“拖放”技术，将其移动到最终位置（保持按住左侧鼠标键）。

您可以将图纸从一个文件夹移动到另一个文件夹，或从一个文件集等级移动到文件夹，反之亦然。此技术还可用于移动整个文件夹。

相关章节：

管理工程图纸


重新编号文档

文件集右键菜单：重新编号文档

文件夹右键菜单：重新编号文档

菜单：处理 > 重新编号文档

此命令允许您重新编号工程、文件夹、文件集和图纸的所有文档。

打开的对话框可使您根据所需参数重新编号文档。

选择

整个工程：重新编号所有工程的文档。

当前文件集：只对当前文件集（此文件集关联当前原理图）中的文档重新标号。

当前文件夹：只对当前文件夹（此文件夹关联当前原理图）中的文档重新编号。

选定文档：单击 [...] 按钮选择您要重新编号的文档。

重新编号模式

更新标注：如果您更改了格式编号（ORDERNO 值不变），则允许更新文档标注。

重新计算序号：重新计算所有文档编号（顺序号值不变），手动修改的编号除外。您必须勾选重新计算手动标注框以重新计算所有文档标注。

元素

元素：显示可用文档列表。

选择：该复选框允许您选择想要重新编号的元素。它还显示要重新编号的元素数目。

第一个编号：输入分配到元素的第一个编号。

增量：输入增量值。例如，如果‘第一个编号’= 10，‘增量’= 2，则元素将编号为：10、12、14、16…

格式：显示工程配置中管理的标注格式。

Fx：[...] 按钮允许您访问格式管理器，以修改用于将元素重新编号的格式。如果您更改格式，它将替换工程配置格式。

标注配置：允许访问工程配置的标注选项卡。

当您确认重新编号时，相关文件集、文件夹和图纸将重新编号。如果修改了标注格式，它们将在工程配置中自动更新。

相关章节：

管理工程图纸


复制/粘贴图纸

文件集右键菜单：剪切 - 复制 - 粘贴 - 特定粘贴

文件夹右键菜单：剪切 - 复制 - 粘贴 - 特定粘贴

图纸右键菜单：剪切 - 复制 - 粘贴 - 特定粘贴

DesignSpark Electrical 拥有独立于 Windows 的集成剪切板功能。剪切板上的元素可自动替换之前的元素。

剪切

将选定图纸（文件集或文件夹）的副本置于 DesignSpark Electrical 剪切板并删除源图纸。

复制

将选定图纸（文件集或文件夹）的副本置于 DesignSpark Electrical 剪切板并保留源图纸。

粘贴

将现有图纸粘贴到 DesignSpark Electrical 剪贴板上。根据工程中的现有标注，图纸编号和这些图纸所在设备的设备标注将自动进行计算（如适用）。

特定粘贴

与粘贴命令相同。打开的对话框允许您 管理标注。

请注意：剪切命令在右键单击文件集时不可用。

相关章节：

管理工程图纸


浏览图纸

菜单：视图 > 上一页图纸 - 下一页图纸

快速工具栏

这些命令允许访问上一页/下一页图纸。如果已达到工程的最后一页，单击下一页按钮时，DesignSpark Electrical 将提示您新建图纸。

相关章节：

管理工程图纸


删除一张图纸

文件集右键菜单：删除

文件夹右键菜单：删除

图纸右键菜单：删除

删除一张或多张选定图纸。当此命令用于文件集或文件夹时，该文件集或文件夹中的图纸都将被删除。

删除图纸时，其内容也将删除。某些元素可能会保留在数据库中（如电缆或端子）。

图纸、文件集或文件夹都可以通过选择对象并按 [Del] 键进行删除。

您无法取消或撤消删除操作。

相关章节：

管理工程图纸


图框管理

每种图纸类型具有关联的图框（工程配置）。然而，您可以修改现有图纸中的图框。

还可在图纸的属性中更改图纸关联的图框。

图纸右键菜单：图框

更新：如果图框的定义已修改，此命令用于更新图纸的图框。还可用于多个选择。

替换：用于在工程配置中将带有当前图纸的不同图框与该图纸的原图框关联。该 图框选择器 将打开，使您可以选择新的图框。替换之后，DesignSpark Electrical 将询问您是否要将此图框应用到使用原始图框的所有图纸。您也可以使用此新的图框更新工程配置。

移除：允许您删除图纸中插入的图框。

打开：打开图框修改界面。如果图框已修改，且您想要将这些修改应用到现有图纸中，请使用更新命令。

添加至数据库：将图纸上的图框添加到库。

相关章节：

图框选择器


图框选择器

文件集右键菜单：图框 > 替换

文件夹右键菜单：图框 > 替换

图纸右键菜单：图框 > 替换

每种图纸类型具有关联的图框（工程配置）。此命令可使您更改此默认配置。

可以通过图纸属性更改关联到图纸的图框。

图框选择器允许您选择要与图纸关联的新图框。

属性：打开选定图框的属性对话框。

预览：打开“预览”对话框中的图框。在此视图中，不能修改图框。

列表模式：显示图框列表（名称、说明...）。

缩略图模式：以缩略图预览的形式显示图框。

配置：管理对话框中项目的显示设置。

分类

此选项卡以树形式显示图框分类。

对话框左侧显示图框分类。对话框右侧显示当前选定分类中的图框。

显示子类内容：勾选此框将显示选定分类及其下级分类中的所有图框。

筛选器

该选项卡可使您筛选图框列表。所有筛选条件显示在图框属性中。

对话框右侧显示与选定条件对应的图框。

移除筛选器：移除所有筛选条件。

如果需要应用整个工程图纸或某种特殊图纸类型（如原理图图纸），建议在工程配置级别应用新图框。更改一个图纸的参数后，将询问您是否将此新图框应用到相同类型的所有图纸。

相关章节：

管理工程图纸

图框管理


添加数据文件

DesignSpark Electrical 允许您管理任何文档类型（如 PDF 或 Excel 文件）。唯一的限制是您需要安装可以打开这些文件类型的程序。DesignSpark Electrical 自动使用 Windows 关联来打开这些文件。

菜单：工程 > 新建 > 附件

文件集右键菜单：新建 > 数据文件

文件夹右键菜单：新建 > 数据文件

DesignSpark Electrical 将源文件复制并把它存入工程目录中，在压缩工程时可将内容压缩在内。

附件添加到工程后，双击可打开该文件及其关联应用程序。

相关章节：

数据文件

超链接


图纸/文件夹选择器

图纸/文件夹选择对话框让您能够根据上下文选择一个或多个图纸或文件夹。还允许您创建新文件夹。

打印管理器：图纸选择

报表管理器 > 报表图纸目标：目标文件夹

对话框左侧显示工程树形图，右侧显示工程中包含的文档预览或列表。

新建文件夹：仅当您必须选择一个文件夹时才会出现此图标。允许您创建新文件夹。

列表模式：显示图纸列表（包括名称、说明等）。

缩略图模式：显示图纸的缩略图预览。

预览：在“预览”对话框中打开图纸。无法在此修改图纸。

配置：管理对话框中项目的显示设置。

属性：打开选定图纸的属性对话框。

为帮助您进行搜索，您可以根据过滤条件筛选结果：标注、说明和文件类型。打开的图纸过滤器让您能够显示所有工程图纸或仅显示用户自己或其他用户打开的图纸。

根据上下文，选择一个或多个图纸或文件夹，然后单击确定按钮进行验证。

相关章节：

管理工程图纸


文档选择器

执行 DesignSpark Electrical 某些功能需要选择工程文档（如图纸、文件夹或文件集）。文档选择器会帮助您做到这一点。

打印管理器：图纸选择 > [...]

导出 DWG 文件：图纸选择 > [...]

导出 PDF 文件：图纸选择 > [...]

...

打开的对话框允许您选择元素。对话框内容符合其环境且显示您必须选择的元素（如图纸、文件夹或文件集）。

属性：打开选定元素的属性对话框。

预览：在“预览”对话框中打开图纸。在此视图中，不能修改图纸。

列表模式：显示元素列表（名称、说明...）。

缩略图模式：以缩略图预览的形式显示元素。

配置：管理对话框中项目的显示设置。

对话框还包含一个筛选区域，此区域可帮助您查找元素。其他一些功能可以显示在菜单中，这取决于上下文

有时，您可以在元素之前找到复选框，以将其选中。示例：在打印命令中，如果选择一个文件夹（勾选框），此文件夹中包含的所有图纸也将选中。


位置

菜单：工程 > 位置

可停靠面板 > 工程的右键菜单：工程 > 位置管理器

位置是一个地点。不同位置通常由电缆连接。

每个电气设备（如设备或端子）属于一个位置。因此可按位置包括电气设备，以基于每个位置中包含的设备获取不同列表。

每一个图纸都与一个位置关联，因此当您在图纸中放置符号时，它将自动与此位置相关联。

对话框将打开，允许您管理工程的位置。

其中一些功能接受多选，例如删除或属性。

新位置：允许您创建新位置。

创建多个位置：允许您在一个操作中创建多个位置。

删除：删除选定的位置。

属性：打开选定位置的属性对话框。如果您选择多个位置，则属性对话框将只显示共同属性。

默认位置：选定位置定义为默认位置。

树显示：显示树形图中的位置。

列表显示：以列表形式显示位置。

您还可以管理位置层级。

在上面的例子中，位置 L3 包括在位置 L1 中。通过拖放方法，您可以将 L3 幻灯片拖放到 L1，还可以在创建 L3 之前选择 L1。

  • 新建一个位置

  • 创建多个位置

  • 位置属性

  • 默认位置

  • 插入位置轮廓线


新建一个位置

位置管理器：新位置

可停靠面板 > 工程的右键菜单：新建 > 位置

可停靠面板 > 位置的右键菜单：新建 > 位置

1. 选择工程。

2. 单击新位置图标。

3. 位置属性对话框打开，可输入位置信息。

要创建附属位置（依赖于其他位置的位置），请选择上级位置，然后单击新建位置图标。

相关章节：

创建多个位置

位置属性

默认位置

插入位置轮廓线


创建多个位置

位置管理器：创建多个位置

1. 单击创建多个位置图标

2. 将打开一个对话框，让您输入想要创建的位置数量。

确认后，这些位置将添加到列表中并自动计算标注。

您可以打开每个位置的属性，以应用所需的其他信息。

相关章节：

新建一个位置

位置属性

默认位置

插入位置轮廓线


位置属性

位置管理器：属性

位置轮廓线的右键菜单：位置属性

1. 选择一个位置。

2. 单击属性图标，以打开位置属性对话框。

创建新位置时，对话框会自动打开。

属性选项卡

标注

将根据工程设置自动计算位置标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

源：显示与位置 (L) 关联的源。

数量：显示分配至位置的序号。您可以更改此序号，但不可使用现有序号。

层级结构

主：表示子位置或附属位置所属主要位置的名称。

关联文件集：可以向文件集关联一个位置。

说明

位置的第一个可译数据。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据在整个工程中可用。用于存储可在图纸中显示的个人信息。用户数据有两种类型：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

图纸应用的默认位置存在于创建图纸的文件集应用的位置。

自定义...按钮可让您访问和定义位置的用户数据。

设备型号选项卡

使用此选项卡以将设备型号关联至位置。

相关章节：

新建一个位置

创建多个位置

默认位置

插入位置轮廓线


默认位置

位置管理器：默认位置

DesignSpark Electrical 定义工程内的默认位置。创建原理图时，图纸将自动关联默认位置，即使该位置从属于关联其他位置的文件集。

1. 从列表中选择位置。

2. 单击默认位置图标。

默认位置以图片形式显示。

可停靠面板中也会显示其图标。

相关章节：

新建一个位置

插入多个位置

位置属性

插入位置轮廓线


插入位置轮廓线

菜单：原理图 > 位置轮廓线

菜单：布线方框图 > 位置轮廓线

位置轮廓线允许在图纸内绘制一个（地理）位置。位置轮廓线可用矩形表示，或用始终闭合的多边线创建。

绘制轮廓线

输入坐标：您可以通过在图形区域单击点或输入坐标来绘制位置轮廓线。如果使用矩形轮廓线，只需单击第二点绘制矩形对角线。如果使用多边轮廓线，则需要单击第二点画出一条线，然后继续直至绘制出闭合的轮廓线。可停靠面板中的关闭按钮让您可以将轮廓线的最后一个点连接至第一个点。

选项：启动该命令时，可停靠面板允许您在两个模式之间进行切换。

选择位置

位置轮廓线闭合后，选择位置对话框将打开。

1. 选择所需位置。

2. 单击选择按钮。

对话框关闭，图纸自动更新所选位置。

放置在轮廓线内的设备可以关联到选定的位置。

3. 单击所需选项以更改设备的位置或保留最初关联的位置。

相关章节：

新建一个位置

创建多个位置

位置属性

默认位置


功能

菜单：工程 > 功能

可停靠面板 > 工程的右键菜单：工程 > 功能管理器

功能允许您对安装中构成功能的设备进行分组。它们不应与装配体中与位置关联的位置混淆。

每个电气设备（设备、端子）属于一个功能。因此可按功能包括电气设备，以基于每种功能中包含的设备获取不同列表。

每一个图纸都与一个功能关联，因此当您在图纸中放置符号时，它将自动与此功能相关联。

功能管理对话框打开，允许您管理工程的功能。

其中一些功能接受多选，例如删除或属性。

新功能：允许您创建新功能。

创建多个功能：允许您在一个操作中创建多个功能。

删除：删除选定的功能。

属性：打开选定功能的属性对话框。如果您选择多个功能，则属性对话框将只显示共同属性。

默认功能：选定功能定义为默认功能。

树显示：显示树形图中的功能。

列表显示：以列表形式显示功能。

功能可以显示为树或列表形式（树显示和列表显示图标）。

您还可以管理功能层级。

在上面的例子中，功能 F3 包括在功能 F1 中。通过拖放方法，您可以将 F3 幻灯片拖放到 F1，还可以在创建 F3 之前选择 F1。

  • 创建功能

  • 创建多个功能

  • 功能属性

  • 默认功能

  • 插入功能轮廓线


创建功能

功能管理器：新功能

可停靠面板 > 工程的右键菜单：新建 > 功能

可停靠面板 > 功能的右键菜单：新建 > 功能

1. 选择工程。

2. 单击新功能图标。

3. 功能属性对话框打开，可输入功能的相关信息。

要创建附属功能（依赖于其他功能的功能），请选择上级功能，然后单击新建功能图标。

相关章节：

创建多个功能

功能属性

默认功能

插入功能轮廓线


创建多个功能

功能管理器：创建多个功能

1. 单击创建多个功能图标。

2. 将打开一个对话框，让您输入想要创建的功能数量。

确认后，这些功能将添加到列表中并自动计算标注。

您可以打开每个功能的属性，以应用所需的其他信息。

相关章节：

创建功能

功能属性

默认功能

插入功能轮廓线


功能属性

功能管理器：属性

功能轮廓线右键菜单：功能属性

1. 选择一个功能。

2. 单击属性图标以打开‘功能属性’对话框。

创建新功能时，功能属性对话框也会打开。

标注

将根据工程设置自动计算功能标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

源：显示与功能 (N) 关联的源。

数量：显示分配至功能的序号。您可以更改此序号，但不可使用现有序号。

层级结构

主：子功能或附属功能所属主要功能的名称。

关联文件集：将一个功能关联至文件集及其中的所有图纸。

说明

功能的第一个可译数据。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据在整个工程中可用。用于存储可在图纸中显示的个人信息。用户数据有两种类型：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

图纸应用的默认功能存在于创建图纸的文件集中。

自定义...按钮允许您访问功能属性中显示的用户数据设置。

相关章节：

创建功能

创建多个功能

默认功能

插入功能轮廓线


默认功能

功能管理器：默认功能

DesignSpark Electrical 定义工程内的默认功能。创建原理图时，图纸将自动关联默认功能，即使该功能从属于关联其他功能的文件集。

1. 从列表中选择功能。

2. 单击默认功能图标。

默认位置更改时，图形将更新。

可停靠面板中也会显示默认功能的图标。

相关章节：

创建功能

创建多个功能

功能属性

插入功能轮廓线


插入功能轮廓线

菜单：原理图 > 功能轮廓线

菜单：布线方框图 > 功能轮廓线

功能轮廓线允许在图纸内绘制一个功能区域。功能轮廓线可用矩形表示，或用始终闭合的多边线创建。

绘制轮廓线

输入坐标：通过在图形区域单击点或输入坐标可以绘制功能轮廓线。如果使用矩形轮廓线，只需单击第二点绘制矩形对角线。如果使用多边轮廓线，则需要单击第二点画出一条线，然后继续直至绘制出闭合的轮廓线。可停靠面板中的关闭按钮让您可以将轮廓线的最后一个点自动连接至第一个点。

选项：启动该命令时，可停靠面板允许您在两个模式之间进行切换。

选择功能

功能轮廓线闭合后，选择功能对话框将打开。

1. 选择所需功能。

2. 单击选择按钮。

对话框关闭，图纸自动更新所选功能。

放置在轮廓线内的设备可以关联到选定的功能。

3. 单击所需选项以更改设备的功能或保留最初关联的功能。

相关章节：

创建功能

创建多个功能

功能属性

默认功能


分配位置/功能

符号属性：符号编辑 > 位置（功能）

电缆属性：上游位置（下游位置）

设备的位置（功能）根据设备创建/插入方式自动定义。例如，在原理图中插入符号时，该符号自动采用图纸或者其插入的位置/功能轮廓线的位置和功能。如果没有可供设备采用的位置/功能，设备将使用工程的默认位置/功能。

1. 单击所需位置或功能的行。

2. 在打开的“位置/功能选择器”中，选择所需位置或功能。

3. 单击选择按钮以应用新位置或功能。

相关章节：

管理位置

管理功能


管理设备

设备表示电气设备或端子。设备由符号表示且带有标注。即使没有图形展示（无需将符号插入到图纸中），设备也可以显示在工程中。

设备在可停靠面板的特定选项卡中列出。

双击设备的符号时，允许您打开将在其中插入此符号的图纸。

显示设备

如有需要，您可以使用 [F5] 键或工程右键菜单中的刷新命令来刷新设备列表。

工程的右键菜单中提供了几种设备列表显示模式，位于视图子菜单中。

位置视图/功能视图：此模式允许您显示按位置或按功能分组的设备。

按层级结构划分的子设备/实际位置（功能）的子设备：此选项允许您在父层下面显示子设备，或者在子设备的实际位置（功能）不同于其父层时在其实际位置（功能）下面显示。

按功能（位置）分类/按标注排序：允许您按标注或位置（功能）对设备排序。

隐藏附件端子：允许您隐藏附件端子。

添加新设备

从位置右键菜单或现有设备（设备相互依赖）添加设备。

创建新设备

设备：如果选择设备选项，将只添加一个标注（在没有选择设备型号的情况下）。

将显示‘设备属性’对话框，使您可以管理设备标注并决定是否要将其分配至设备型号。

从设备型号创建新设备

设备型号：选择设备型号选项将打开一个对话框，您可从中选择设备型号。

参阅分配设备型号章节了解关于此对话框的更多信息。

根据所选设备和（尤其是）其所属分类，将自动生成一个标注并添加至设备列表中。

您还可以管理要创建的设备数量。设备型号选择对话框关闭后，请输入设备数量，然后确认。

要创建新设备，您可以单击确定（继续），设备型号选择对话框将重新打开以搜索新设备型号。

删除设备

删除命令在设备右键菜单中。

无法删除已插入到图纸中的设备。

设备属性

可以通过使用右键菜单属性命令或符号的设备属性来修改设备。

它让您可以访问设备属性对话框，您可以在其中修改标注和关联设备型号。

相关章节：

设备属性


设备属性

设备右键菜单：属性

符号上下文菜单：设备属性

打开“设备属性”对话框，以显示设备的相关信息。

标注及数据

标注

将根据工程设置自动计算设备标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

源：根据设备分类显示与设备关联的源。

数量：显示分配至设备的序号。您可以更改此序号，但不可使用现有序号。

层级结构

分类：允许您更改设备分类。应用设备型号时会更改符号分类。允许您定义在自动标注时使用的“源”。

主：显示依赖于其的子级或子设备的主设备名称（如 PLC 卡及其机架）。

位置/功能：插入符号时，如果符号插入在轮廓线内，则自动获取图纸或位置（功能）轮廓线的位置（功能）。您可以单击 [...] 按钮并选择所需位置（功能），以分配不同位置（功能）。

制造商数据

此数据来自设备型号，但可以手动修改。数据类型在分类定义中指定。

说明

设备的第一个可译数据字段。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据字段可用于输入您想要管理设备的所有信息。单击自定义...按钮可编辑名称。

设备型号与回路

1. 单击设备型号与回路选项卡可分配设备型号。

2. 参阅分配设备型号了解更多信息。


分配设备

此命令允许您关联多个符号，以将其分配至某个设备。

符号右键菜单：分配设备

侧面板将显示选项。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

确认选择。

选择：显示选定符号的列表。您可以单击图形区域中的其他符号以完成列表。

设备：在列表中选择要与选定符号相关联的设备。

删除：移除列表和选定符号。

如果确认关联时选择了不同类型的符号（例如符号和端子），则会打开消息框提示您确认选择。

确认后，选定符号将自动关联至现有设备。符号标注将使用设备标注进行更新。


搜索设备

可停靠面板：设备 > 右键菜单 > 搜索设备

菜单：工具 > 搜索 >搜索设备

插入接头：选择现有设备

此命令允许您使用筛选器在工程设备列表中查找设备。

1. 输入与您查找的设备对应的条件。

2. 将自动开始搜索。

3. 结果显示在对话框的左侧。右侧显示选定元素的预览。

条件列表

标注：根据设备标注启动搜索。

描述：根据设备描述启动搜索。

主：在层叠标注情况下，根据设备的父标注启动搜索。

位置：根据设备型号的位置启动搜索。

功能：根据设备型号的功能启动搜索。

目标：仅在选定文件集或文件夹中启动搜索。

分类：根据设备型号的分类启动搜索。

设备型号：根据与设备型号关联的设备型号，启动搜索。

设备型号类型：根据设备型号的类型，启动搜索。

图标含义

启动搜索管理器。

重置所有筛选器。

打开选定元素的图纸。

允许您在可停靠面板中查找设备型号列表中的设备型号。


添加回路

详细布线：添加虚拟回路

编辑符号图形：多个设备连接点

设备型号的属性：添加多个

设备属性 > 回路：添加虚拟回路...

此功能允许您在设备上添加新回路。

添加：允许您添加新回路至列表。回路由默认值进行初始化。您可以直接在列表中对其进行更改。

删除：删除选定回路。

从设备型号初始化：打开设备型号管理器。选定设备型号的回路将自动添加至回路列表。

添加回路类型后，修改类型和数量。

数量：表示回路序号。

回路类型：在列表中选择与设备、符号或设备型号相对应的回路类型。

回路数：输入想要添加的回路数量。

每个回路的端子数：输入回路中的端子数。

信息传送：选择回路的传送模式。

相关章节：

详细布线

编辑符号图形


修改端子号

符号右键菜单：编辑符号端子

设备属性 > 制造商零件和回路 > 回路的右键菜单：编辑端子

回路：显示回路数。

指数：显示回路序号。

标注：用于输入设备的端子号。默认情况下，与设备关联的设备型号提供端子号。

方向：允许您指定连接点，尤其是端子的方向。

最大线号：用于输入可以连接到设备端子的电缆芯或电线的编号。

使用：允许输入任意文本。这可关联至连接的特定标注。

最大电线截面积 (mm²)/最小电线截面积 (mm²)：用于输入端子设备的截面积。


设备选择器

设备选择器将所有工程设备分组。此对话框允许您选择设备。

插入印刷电路板：选择现有印刷电路板

特定粘贴：关联设备

设备按位置分组。

1. 双击位置图标可显示设备。

有时，设备列表仅显示设备类型（如接头或 PCB），具体取决于上下文。

2. 选择需要的设备。

3. 通过单击选择按钮进行确认。


布线方框图

布线方框图是安装布线的简单、但完整展示。布线方框图允许您生成布线列表，无需实现所有电气原理图。布线方框图包含表示各个位置、端子排和设备之间的连接（电缆）的图纸。它允许您预设可用于原理图的电缆芯。

相关章节：

绘制电缆

布线方框图符号

宏


绘制电缆

您可以在布线方框图或混合原理图图纸中绘制电缆。

菜单：布线方框图 > 绘制电缆

您现在可以在图形区域绘制电缆。

1. 单击电缆的第一个点。

2. 单击电缆的第二个点。

可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次用于绘制电缆后停止该命令。

结束命令。

撤消上一操作。

电缆样式

选择工程中定义的任一电缆样式（电缆样式管理器）。

插入后操作

不操作：电缆绘制完成后结束该命令。

询问我：打开一个带两种选择的对话框、选择电缆型号，或者显示详细布线对话框。

绘制连接到符号的电缆时，注意第一个点对应符号标注（默认情况下为绿色捕捉）。

相关章节：

电缆样式管理

跳转

预设电缆

详细布线

添加电缆

电缆标注

显示电缆标注


跳转

菜单：布线方框图 > 跳转

菜单：原理图 > 跳转

跳转可以创建不同原理图图纸中电线之间的导通链接，如果需要，也可以在同一张图纸中创建。可以在布线方框图中创建电缆的导通链接或者在原理图中创建电线的导通链接。

根据此命令生成的跳转被视为手动跳转。

选中此命令时，管理对话框将显示。它分为两个部分：上半部分包含起点（图纸 1）原理图，下半部分包含终点（图纸 2）图纸。您可以使用鼠标滚轮缩放图纸的任意部分，这有助于确保您仅选择要链接的电线。

此命令启动时，图纸 1 在图形区域中处于活动状态。

以下命令可用于图纸 1 和图纸 2。

上一个：让您可以查看工程图纸列表中的前一图纸。

下一个：让您可以查看工程图纸列表中的后一图纸。

选择器：允许您打开图纸选择器，以选择所需图纸。

上一页图纸和下一页图纸：这些选项允许向后（上一页）或向前（下一页）逐一翻阅工程图纸。将转至起点和终点图纸的上一页/下一页图纸。

起点符号：让您可以选择用于表示起点箭头的符号。如果选择的符号不当（例如目标符号），则会显示一条消息以阻止您选择。

目标符号：让您可以选择用于表示终点箭头的符号。如果选择的符号不当（例如源符号），则会显示一条消息以阻止您选择。

起点和终点符号显示电线之间的交叉引用。它们具有延伸图纸标注、包标注、图纸的行和列或电位编号等信息的特定标注。

水平和垂直平铺允许您管理显示模式。

单项插入

让您可以管理一条电线到另一条电线的链接。

1. 单击单项插入图标。

2. 单击原理图电线/电缆的末端。

3. 选择另一原理图电线/电缆的末端。

这将插入箭头并自动与另一端交叉引用。

多项插入

让您可以管理一个多线集到另一个多线集的链接。

1. 单击多项插入图标。

2. 在起点图纸上，单击起点多线集的第一条电线和最后一条电线。

3. 在终点图纸上，单击终点多线集的第一条电线和最后一条电线。

删除

删除：允许您删除一个现有的起点 - 终点箭头。选择箭头以将其删除。

多项删除：允许您删除多个现有的起点 - 终点箭头。与多项插入类似，选择第一条电线和最后一条电线，然后验证删除操作。

删除一个链接时，此链接的所有构成元素（起点和终点箭头、符号及文本）都将被删除。

相关章节：

绘制电缆（布线方框图）

绘制电线（原理图）


预设电缆

菜单：布线方框图 > 电缆预设

布线方框图电缆的右键菜单：预设电缆和缆芯

通过选择新电缆图标，您可以管理当前的现有电缆或创建新电缆。

新电缆：打开电缆目录，您可在其中选择引用以添加到工程。

删除：删除选定电缆。如果电缆芯正在使用中，则无法删除电缆。

属性：显示选定电缆的属性。

复制：复制包含零件、功能路径等所有其关联属性的单个或多个电缆。编号将自动增加。

替换：可将选定电缆替换为目录中的其他电缆。新电缆中必须含有至少与要替换的电缆同样的缆芯数。

切换：切换电缆的起点和终点。

取消关联电缆芯：断开选中的电缆芯。

树形图：管理电缆列表显示的类型。电缆可按功能或源/目标分组。

筛选器：按标注、部件型号或源/目标位置筛选列出的电缆。

预设电缆：自动隐藏除预设电缆外的所有电缆。再次单击此图标删除筛选条件。

要预设电缆芯：

1. 勾选与缆芯相对应的框。

2. 勾选电缆旁边的框以预设该电缆的所有电缆芯。

您可使用菜单中选择电缆芯部分的两个图标（自动和手动）来选择缆芯。

3.单击确定将关闭对话框并保存选择。

警告：这些操作只能预设电缆芯。而非安装中的实际布线。

与选定电缆相对应的文本将自动放置在线上。可在工程属性（字体选项卡）中自定义设置此文本（的样式和内容）。

相关章节：

电缆管理器

添加电缆

详细布线


详细布线

菜单：布线方框图 > 详细布线

布线方框图电缆的右键菜单：详细布线

此对话框分为 3 部分。中间显示电缆；左侧和右侧显示源和目标以及端子排。

您可以在源或目标端子上拖动缆芯。然后在源和目标处通过显示缆芯编号的绿色区域表示连接。

完成布线后，源和目标绿色区域将填充连接信息。

编辑设备。

添加虚拟回路至设备。

添加端子至端子排

图标

添加电缆：添加一个新电缆。

预设缆芯：打开电缆和预设缆芯对话框。

替换：在电缆目录中选择新电缆替换选定电缆。新电缆中必须含有至少与要替换的电缆同样的缆芯数。

连接：将选定设备和缆芯与电缆芯相连接。

关联电线：选定电缆与未连接电缆的电线匹配时，电缆芯将自动连接。

取消此端：断开选中的电缆芯。

断开缆芯：断开另一侧的选定缆芯。

切换：在源与目标之间的切换电缆芯。

电线样式：显示与选定电缆芯关联的电线样式。

显示从属设备：仅显示设备串联标注。

只显示设备：仅显示设备（隐藏从属设备）。

预览：显示或隐藏源和目标视图窗口。

仅预设的接线端：只显示已预设的接线端。

连接设备的电缆芯：仅显示当前构成链接的电缆芯。

所有缆芯：显示所有接线端。

相关章节：

电缆管理器

预设电缆和缆芯

原理图布线


添加电缆

电缆管理器：新电缆

菜单：布线方框图 > 添加电缆

布线方框图电缆的右键菜单：添加电缆

预设电缆：新电缆

布线细节：添加电缆

打开电缆型号搜索对话框，允许您选择需要添加到工程中的电缆型号。

分类/筛选

在分类选项卡中，对话框左侧显示电缆系列列表。对话框右侧显示所选系列的电缆。

在筛选器选项卡中，可编辑多个筛选条件以查找所需型号。

添加选定的型号。

在对话框的下半部分删除所选型号。

数量：输入想要添加的电缆数量。

通过验证后，电缆将自动添加至工程。每根电缆都有根据工程配置中定义的标注公式自动计算的标注。如果想要修改这些标注，请在电缆管理器中将其选中，然后单击属性图标。

相关章节：

电缆管理器


显示电缆标注

使用此功能可显示或隐藏显示电缆标注的文本。

菜单：布线方框图 > 显示电缆标注

1. 在图形区域中选择要隐藏或显示标注的电缆。

已显示的文本会隐藏，已隐藏的文本会显示出来。


文本对齐

使用此功能可对齐文本；电位编号、电线编号或电缆文本。

菜单：布线方框图 > 文本对齐

菜单：原理图 > 文本对齐

1. 在图表区域中，选择要对齐的可用文本。

2. 画一条与文本插入点对应的垂直或水平轴线。

3. 单击一侧（上、下、左或右）。

所有选定文本都会在此轴线上移动和对齐（文本对齐方式不会改变）。

可用文本是等电位编号、电线编号、电缆标注（原理图）、位置和功能标签以及通过命令添加文本插入的文本。


布线方框图符号

设备还称为设备 (component)，它由一个或多个工程符号表示。仅来自库的一个符号可能会被考虑由 DesignSpark Electrical 管理。

布线方框图具有特殊设备，仅可插入布线方框图或混合图中。

有三种插入符号的方法可选。

  • 插入符号

  • 符号控制面板

  • 可停靠面板


插入符号

菜单：布线方框图 > 插入符号

首次使用时，符号选择器将打开，允许您选择想要插入的符号。然后，将记录此符号，在您下次使用命令时提示。

可停靠面板将显示可用选项。

确保命令连续，插入符号后，命令保持可用。

放置符号后命令结束。

结束命令。

指定要插入的符号

其他符号：打开可在其中选择其他符号的符号选择器。

选项

自动标注：对话框不打开，将根据工程设置自动计算和应用标注。

调整大小以适合图纸单位：允许管理尺寸单位冲突。例如，用英制单位将 IEC 符号插入到带图框的图纸。

1. 单击点以插入符号。

相关章节：

符号选择器

符号属性


符号选择器

插入符号命令：其他符号

可用于所有符号类型：原理图、布线方框图

选择器中的符号存储在符号库中。

属性：打开所选的符号属性对话框。

预览：打开所选符号的预览窗口。

列表模式：显示符号列表（名称、说明、分类）。

缩略图模式：以缩略图预览的形式显示符号。

配置：管理对话框中项目的显示设置。

1. 选择需要的符号。

2. 单击选择按钮进行确认。

选定的符号将自动添加至符号插入侧面板中。

分类

此选项卡以树形式显示符号分类。

对话框左侧显示符号分类，右侧显示当前选定分类中的符号。

显示子类内容：勾选此框以显示选定分类及其下级分类中的所有符号。

筛选器

该选项卡可使您筛选符号列表。显示符号属性的筛选条件。

对话框的右侧显示选定条件对应的符号。

移除筛选器：删除所有筛选条件。

相关章节：

符号管理器

插入布线方框图符号

插入原理图符号

插入黑盒

插入端子


符号控制面板

可停靠面板：符号

对符号类型有效：原理图符号和布线方框图

每种图纸类型（原理图/布线方框图/混合图）都有自己的符号控制面板。符号栏中包含常用的符号，并且可以添加工程库中所有可用的符号。

符号控制面板完全自定义，您可添加或者删除分组中的符号，还可以添加或删除符号。

您可以在工程配置的数据库和控制面板选项卡，以及控制面板配置中配置符号控制面板的使用。

要插入符号：

1. 双击该符号，或者使用拖放方法。

2. 单击图纸中的一个点以插入符号。

组管理

为方便查找，符号将按类别分组。控制面板有右键菜单，可用于管理这些组。

添加符号：将符号添加至选定组。符号选择器打开，可以在其中选择要添加的符号。

编辑符号：打开符号编辑器上的符号进行修改。

删除符号：删除选定符号。

新建组：允许创建新组。组属性对话框打开，可以定义名称以及缩略图。

组属性：允许编辑组名称和设置缩略图的大小。

删除组：允许删除组。包含在组内的符号不会从库中删除。

激活组：打开列出所有组的子菜单。选择所需组。

搜索符号

控制面板中有用于搜索特定符号的选项。搜索范围不限制在符号控制面板，而是整个符号数据库。

在该框中，

1. 输入所需文本。

2. 单击查找按钮。

所有包含说明字段中所输入文本的符号都会列出在搜索结果中。

将符号添加到控制面板

与宏一样，您可以将图形区域中插入的符号添加到控制面板。

1. 打开要向其中添加符号的控制面板组。

2. 选择图形区域中的符号

3. 将其拖放到控制面板组

相关章节：

符号选择器

符号属性

端子属性


可停靠面板

可停靠面板：设备 > 设备的右键菜单 > 插入符号

可用于所有类型的符号：原理图和布线方框图

启动此命令后，符号选择器将打开，使您可以选择要插入的符号。

根据当前的图纸类型推荐符号类型。例如，如果您已打开布线方框图页面，则选择器仅显示布线方框图符号。

1. 选择符号。

2. 单击选择按钮。

3. 单击图纸中的一个点以插入符号。

当设备型号与多个符号相关联（关联在每个回路上）时，将显示一个消息框。

从设备型号回路中插入符号：打开设备型号回路选择器对话框，您可在其中选择要插入的符号。

取消：插入关联至设备型号的符号。如果没有关联的符号，符号选择器对话框将打开，以允许您选择要插入的符号。

相关章节：

符号选择器

符号属性

端子属性


符号属性

原理图和布线方框图中的“符号属性”对话框相同。

符号上下文菜单：符号属性

“符号属性”对话框将在您插入符号后自动打开，除非您勾选了自动标注选项。您也可以通过符号右键菜单中的符号属性命令访问该对话框。

根据选定符号，可以禁用几个属性。如果您选择多个符号，将仅启用共同属性。

与现有标注关联

如果您想要将符号与现有标注关联，请从列表的右侧选择，或手动为其提供一个相同标注，并使用 [= >] 按钮以创建关联。

对话框顶部的筛选器可帮助您查找现有设备。

编辑符号

标注

将根据工程设置自动计算符号标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

源：根据符号分类显示与符号关联的源。

数量：显示分配至符号的序号。您可以更改此序号，但不可使用现有序号。

永久设备：最后一个代表设备的符号删除后，设备也将删除。如果勾选此框，将不删除设备。

要删除永久设备，请在设备选项卡（可停靠面板）中使用其右键菜单中的删除设备命令。

层级结构

分类：允许您更改符号分类。分配设备型号时会更改符号分类。允许您定义在自动标注时使用的“源”。

主：显示依赖于其的子级或子设备的主设备名称（如 PLC 卡及其机架）。

位置/功能：插入符号时，如果符号插入在轮廓线内，则自动获取图纸或位置（功能）轮廓线的位置（功能）。您可以单击 [...] 按钮并选择所需位置（功能），以分配不同位置（功能）。

制造商数据

此数据来自设备型号，但可以手动修改。数据类型在分类定义中指定。

说明

设备的第一个可译数据字段。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据字段可用于输入您想要管理设备的所有信息。

符号数据：

交叉引用类型：为当前正在编辑的符号选择交叉引用等级。默认情况下，显示的值为在符号属性中配置的值（请参见章节：符号属性）


原理图

详细的原理图表示，通过使用图形符号，网络的不同部分、可连接或功能相关的安装或设备。详细的原理图图纸目的在于解释设备的工作、提供安装基础和帮助进行试用及维护。

在图形界面上打开原理图类型的图纸时，专用于原理图创建的特殊菜单将显示相关命令。

相关章节：

绘制电线

原理图符号

黑盒

端子

宏


绘制电线

有两种电线类型：单线（命令电线类型）和多线（电源类型）。使用不同命令创建这两种类型的电线。

每根电线需要一种电线样式。电线样式编号无穷，您可以根据需要创建可能多地电线样式。它们在电线样式管理器中管理。电线样式为工程指定。

电线允许您连接不通设备，它们可以进行编号且可表示电缆芯。

相关章节：

电线样式管理器

绘制多线

绘制单线

跳转

电线编号


电线样式选择器

可停靠面板：绘制电线命令 > [...]

您可以单击电线名称右侧的 [...] 按钮更改线样式。

电线样式选择器对话框将显示，允许您从工程内的可用电线类型中选择一种。

如果您想创建新电线或修改现有电线/群，请单击管理器按钮以打开电线样式管理器。

相关章节：

电线样式管理器

绘制多线

绘制单线


绘制单线

菜单：原理图 > 绘制单线样式

运行命令时，可停靠面板将更新为显示所选电线参数。然后，您可以在当前视图中开始绘制。

1. 单击图形区域，显示开始绘制电线的起点。

2. 单击第二点以表示电线终点。

可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次用于绘制单线后停止此命令。

结束命令。

返回至上一界面。

撤消上一操作。

电线样式选择

名称：您可以单击电线名称右侧的 [...] 按钮更改电线样式。电线样式选择器对话框将打开，您可以在其中选择所需电线样式。

线间距离：您可以修改电线之间的距离。此值根据工程设置以毫米或英寸为单位（请参见工程配置设置中的单位系统）。

连接线数目：如果该电线由多条（相同）导线构成，则请指定要绘制的数量。

选项

绘制折弯（C 键）：按键盘上的 [C] 键可以插入折弯。

绘制非正交 (F8)：按键盘上的 [F8] 键可以禁用允许在正交轴上插入电线的锁。

相关章节：

电线样式管理器

绘制多线

管理起点/终点箭头


绘制多线

菜单：原理图 > 绘制多线

运行命令时，可停靠面板将更新为显示所选电线参数。然后，您可以在当前视图中开始绘制。

1. 单击图形区域，显示开始绘制电线的起点。

2. 单击第二点以表示电线终点。

可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次用于绘制单线后停止此命令。

结束命令。

返回至上一界面。

撤消上一操作。

电线样式选择

名称：通过单击组名右侧的 [...] 按钮修改可停靠面板中编号组的名称。这将会打开电线样式选择器对话框，让您可以访问管理器并选择组名。

线间距离：修改电线之间的距离。此值根据工程设置以毫米或英寸为单位（请参见工程配置设置中的单位系统）。

可用电线：列出构成当前所选编号组的电线。勾选要绘制的导线的框。

选项

相位反转（空格）：按键盘上的 [Space] 键可以反转导线。

绘制折弯（C 键）：按键盘上的 [C] 键可以插入折弯。

绘制非正交 (F8)：按键盘上的 [F8] 键可以禁用允许在正交轴上插入电线的锁。

相关章节：

电线样式管理器

绘制单线

管理起点/终点箭头


电位属性

电线右键菜单：电位属性

打开电位属性对话框，可使您编辑此电位内的电线公用数据。

此数据来自电线所属的 电线样式属性生成。

如果您修改电线样式的属性，这些更改将自动传递至电位属性以及此电位的电线属性。

标注和/或电位属性的修改只会影响运行该命令的电位。

标注

电位标注由电线编号自动计算，或者通过电线标注编辑器手动输入。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

数量：显示分配至电位的序号。您可以更改此序号，但不可使用现有序号。

基本信息

直径：允许您输入电线的直径。

截面积或规格：允许您输入电线的截面积。

电线尺寸标准：允许您选择要在工程中使用的标准。

颜色：允许您选择电线的真实颜色。

弯曲半径（x 直径）：允许您输入计算弯曲半径所需的参数（参数 x 直径 = 弯曲半径）。

信号：允许您输入电线所传递的信号。

关联数据

电线样式：显示与电位关联的电线样式。

电线数目：表示该电位代表的电线数目（电线接线方向中的线数目）。

文件：显示电位开始的图纸标注。

行：显示电位开始的行号。

列：显示电位开始的列号。

用户数据

用户数据字段可用于输入您想要管理相关电位的所有信息。

自定义...按钮允许您访问 用户数据 管理。

相关章节：

电线样式属性

电线属性


电线属性

电线右键菜单：电线属性

打开“电线属性”对话框，允许您编辑电线的特定信息。

此数据来自电线所属的 电位属性 ，由 电线样式属性生成。

如果您修改电线样式或电位属性，这些修改将自动传递至电线属性。

标注和/或电线属性的修改只会影响使用该命令的电线。

标注

电线标注由电线编号自动计算，或者通过电线标注编辑器手动输入。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

数量：显示分配至电线的序号。您可以更改此序号，但不可使用现有序号。

基本信息

直径 (mm)：允许您输入电线的直径。

截面积或规格：允许您输入电线的截面积。

电线尺寸标准：允许您选择要在工程中使用的标准。

颜色：允许您选择电线的真实颜色。

弯曲半径（x 直径）：允许您输入计算弯曲半径所需的参数（参数 x 直径 = 弯曲半径）。

信号：允许您输入电线所传递的信号。

关联数据

电线样式：显示电线样式。

电位：表示与此电线关联的电位编号。

接线方向：显示电线接线方向行号。

源：显示连接到电线（源）的设备的标注。

目标：显示连接到电线（目标）的设备的标注。

电缆芯：如果电线关联到电缆芯，则此字段表示电缆标注和电缆芯标注。如果此电线代表跳线，则图标变为代表该跳线。

用户数据

用户数据字段可用于输入您想要管理相关电位的所有信息。

自定义... 按钮允许访问 用户数据 管理。

相关章节：

电线样式属性

电位属性


解决电位冲突

电线右键菜单：解决电位冲突

设计或修改原理图时，将不具有相同电位的电线有时会导致编号冲突。在图形选项卡的工程 配置中激活电位冲突管理。

运行命令后，将打开一个对话框，询问您是否手动解决冲突。

1. 选择显示在原理图中的线号。


延伸电线样式

电线右键菜单：电线样式 > 延伸

停止命令，以确保该命令持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

此命令允许您将所选线段的电线样式延伸到已连接线段。可停靠面板将显示传输选项。

延伸

到电位：允许传输到具有相同电位号的连接。

穿过回路：传输符号之间的电线样式，仅在电线样式与符号的上游和下游相同时传输。


替换电线样式

电线右键菜单：电线样式 > 替换

停止命令，以确保该命令持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

此命令允许您将工程中使用的电线样式替换为另一个电线样式。可停靠面板将显示用于选择电线的选项。

替换范围

整个工程：工程中的所有电线。

当前文件集：仅限当前图纸所在的文件集。

当前文件夹：仅限当前图纸所在的文件夹。

当前原理图：仅限当前图纸。

选择原理图：打开图纸选择器，以便您可选择要处理的图纸。

原理图中选中的项：仅限原理图中选中的电线。

延伸到电位：具有相同电位的电线。

延伸穿过回路：替换符号之间的线样式，仅线样式与符号的上游和下游相同时替换。


管理原理图文本

有多个命令可用于管理软件自动插入的文本，比如等电位编号或电缆标注。

  • 文本对齐

  • 显示电线标注

  • 显示电缆标注


显示电线标注

使用此功能可显示或隐藏显示等电位或电线标注的文本。

菜单：原理图 > 显示文本 > 显示/隐藏电线标注

1. 选择要显示或隐藏文本的电线。

已显示的文本会隐藏，已隐藏的文本会显示出来。


显示电缆标注

使用此功能可显示或隐藏显示电缆标注的文本。

菜单：原理图 > 显示文本 > 显示/隐藏电缆标注

1. 在图形区域中选择要隐藏或显示标注的电缆。

已显示的文本会隐藏，已隐藏的文本会显示出来。


原理图符号

符号可以表示一个电气设备或者电气设备的一部分。

符号在数据库中分类，您可以添加自己的符号。符号还可以在显示在可停靠面板中的控制面板中分类和分组。

在原理图或混合原理图图纸中插入符号。

为您提供多种插入符号的方法：

  • 插入符号

  • 符号控制面板

  • 可停靠面板


插入符号

菜单：原理图 > 插入符号

第一次使用此命令时，符号选择器对话框会打开，让您可以选择要插入的符号。此符号将被保存，再次使用此命令时，会自动调用此符号。

可停靠面板将显示可用选项。

固定命令，以确保该命令在首次用于插入符号后持续有效。

首次用于插入符号后停止命令。

结束命令。

指定要插入的符号

显示上次插入的符号。如果未保存任何符号，符号选择器将自动打开。

如果您不想使用当前显示的符号，请单击其他符号按钮。符号选择器将打开，让您可以在其中选择其他符号。

符号方向

此选项让您可以在插入前旋转符号。您可以通过使用鼠标右键单击来选择旋转角度。

选项

手动标注：如果选中此选项，将打开“符号”对话框并且标注将自动显示在手动模式下。

查找属性：如果未选中此选项，将不打开“符号”对话框，将根据工程设置自动计算和应用标注。

调整大小以适合图纸单位：允许管理尺寸单位冲突。例如，用英制单位将 IEC 符号插入到带图框的图纸。

1. 单击图纸中的一个点以插入符号。

相关章节：

符号选择器

符号属性


设备型号回路选择器

当您插入来自设备树（可停靠面板）的符号以及多个符号关联至该设备型号时，从设备型号中选择回路对话框将打开。

可停靠面板：设备 > 设备的右键菜单 > 插入符号 > 插入来自设备型号回路的符号

可用于所有类型的符号：原理图和布线方框图

对话框将显示设备型号回路。选择回路后，对话框右侧将显示关联符号的预览。多个回路可关联至某符号。

1. 单击确定以确认并插入符号。


编辑符号标注

允许您添加、删除或编辑与符号相关联的标注。此命令允许选择多项。

符号右键菜单：标注 > 编辑标注

端子右键菜单：标注 > 编辑标注

黑盒右键菜单：标注 > 编辑标注

将打开对话框，以显示现有标注的列表。所有以 # 开头的标注由 DesignSpark Electrical 管理，其他标注由用户管理。

此对话框还显示每个标注的设置。

数量：标注索引（不可更改）。

名称：标注名称。仅可更改用户标注名称。

提示：标注说明仅在 DesignSpark Electrical 标注上可用。

值：图形区域显示的文本（标注值）。

位置 X：标注位置的 X 坐标。

位置 Y：标注位置的 Y 坐标。

高度：图形区域所显示文本的高度。

文本样式：用于在图形区域中显示文本的文本样式。

不可见：允许显示/隐藏文本。

颜色：图形区域所显示文本的颜色。

角度：文本的方向。

对齐：在列表中选择要用于文本的文本对齐方式。

倾斜角：允许创建斜体文本。

宽度系数：允许压缩文本宽度。

用户标注：将向列表添加新标注。修改其设置。

预定义标注：标注管理器对话框将打开，您可以选择要添加的标注。选择的新标注将添加到列表。修改其设置。

删除：删除选定标注。此标注将在图形区域中移除。

符号：列出图形区域中所选符号。如果选择 <全部>，修改将应用于所有选定符号。如果只想修改一个符号，请在列表中将其选中。

1. 单击确定以确认。

2. 符号将根据您添加、删除或更改的标注自动更新。


黑盒

黑盒是一个通用的符号，它可以代表任何设备，在无需新的独特符号或没有时间创建符号时，它可以节约时间。黑盒符号是一个矩形符号框，并自动根据连接线生成连接点。

只能在原理图或混合原理图类型的图纸中插入黑盒。

黑盒的连接点

在电线和黑盒轮廓线之间的每一个交点处都会插入一个连接点，它代表设备端子。根据配置设置，您可能有一个基本连接点（端子号为文本）或一个带标注的定向连接点。

插入黑盒有两种方式。

  • 插入黑盒

  • 可停靠面板

  • 更新黑盒

  • 添加设备连接点


插入黑盒

菜单：原理图 > 插入黑盒

第一次使用时，符号选择器会打开，以让您添加要插入的符号。然后符号会被保存，再次运行符号插入命令时，您可以选择此符号。

可停靠面板将显示可用选项。

已固定该命令。解除锁定之前您可以继续使用此命令。

插入一个符号后停止该命令。

停止该命令。

指定要插入的符号

显示上次插入的符号。如果未保存任何符号，符号选择器会自动打开。

如果您不想插入显示的符号，请单击其他符号按钮。符号选择器将打开，您可以在其中选择其他符号。

选项

手动标注：如果选中此选项，将打开“符号”对话框并且标注将自动显示在手动模式下。

查找属性：如果未选中此选项，将不打开“符号”对话框，将根据工程设置自动计算和应用标注。

调整大小以适合图纸单位：允许您管理尺寸单位冲突。例如，用英制单位将 IEC 符号插入到带图框的图纸。

1. 在图形界面中，单击插入点。

2. 单击标注黑盒尺寸的点。

相关章节：

更新黑盒

添加连接点


更新黑盒

黑盒右键菜单：更新黑盒

该命令可使您调整连接到黑盒的电线。连接将位于黑盒的轮廓线上，其中引脚将自动放置。

相关章节：

插入黑盒

添加设备连接点


添加连接点

黑盒的右键菜单：添加连接点

在黑盒轮廓线上插入设备连接点。

1. 单击黑盒轮廓线上的一个或多个点。

根据配置设置，您可以插入某一特定符号，以具体化连接点或默认连接点。

可以使用黑盒右键菜单中的编辑符号端子命令编辑这些设备连接点。

相关章节：

插入黑盒

更新黑盒


端子

端子由属于端子排，端子分类的特殊符号表示，与经典符号相比，前者可提供特殊状态，因此可对其执行特殊处理。端子必须附加到端子排上。

在原理图或混合原理图图纸中插入端子符号。

为您提供多种插入端子符号的方法：

  • 插入端子

  • 符号控制面板

  • 可停靠面板


插入端子

菜单：原理图 > 插入端子

第一次使用此命令时，符号选择器对话框会打开，让您可以选择要插入的符号。此符号将被保存，再次使用此命令时，会自动调用此符号。

可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次用于插入符号后停止命令。

结束命令。

选择显示端子的符号

如果默认符号不是需要的符号，则单击其他符号按钮。

符号选择器将显示，包含已过滤端子的列表，其中您可以选择所需的端子符号。

符号方向

此选项让您可以在插入前旋转符号。您可以通过使用鼠标右键单击来选择旋转角度。

1. 单击图纸以插入端子。

2. 如果端子插入到电线上，系统将提示您定义电缆的方向。

3. 然后，将显示端子属性对话框。

插入多个端子

菜单：原理图 > 插入多个端子

4. 单击两个点，这两个点对应与电线垂直的一条线的端点。

5. 在每个轴线与连接线的交点处都会添加一个端子。

6. 定义端子的方向。

可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次用于插入符号后停止命令。

结束命令。

选择显示端子的符号

如果默认符号不是需要的符号，则单击其他符号按钮。

符号选择器将显示，包含已过滤端子的列表，其中您可以选择所需的端子符号。

选项

绘制轴线：轴图纸可选。如果不需要轴线，则取消选中此框。

然后，将显示端子属性对话框。

相关章节：

符号选择器

端子属性


端子属性

端子的右键菜单：符号属性

端子编辑将在插入后自动显示。

与现有标注关联

如果您想要将端子排或端子与现有标注关联，请从右侧列表选择，或者手动为其提供一个相同标注，然后使用 [= >] 按钮以创建关联。

对话框顶部的筛选器可帮助您查找现有设备。

对于多层端子，您也可以通过在列表中选择相应的回路仅关联所需的层。

端子排

标注

将根据工程设置自动计算端子排标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

源：基于端子排分类显示与端子排相关联的源。

数量：显示分配至端子排的序号。您可以更改此序号，但不可使用现有序号。

永久设备：最后一个代表端子排的符号删除后，端子排也将删除。如果勾选此框，将不删除端子排。

要删除永久端子排，请在设备选项卡（可停靠面板）中使用其右键菜单中的删除设备命令。

层级结构

分类：允许您更改端子排分类。应用设备型号时会更改符号分类。允许您定义在自动标注时使用的“源”。

主：显示子设备或附属设备所属主要端子排的名称。

位置/功能：插入符号时，如果符号插入在轮廓线内，则自动获取图纸或位置（功能）轮廓线的位置（功能）。您可以单击 [...] 按钮并选择所需位置（功能），以分配不同位置（功能）。

端子

标注

将根据工程设置自动计算端子标注。

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

源：根据端子分类显示与端子相关联的源。

数量：显示分配至端子的序号。您可以更改此序号，但不可使用现有序号。

永久设备：最后一个代表端子的符号删除后，设备也将删除。如果勾选此框，将不删除端子。

要删除永久设备，请在设备选项卡（可停靠面板）中使用其右键菜单中的删除设备命令。

层级结构

分类：允许更改端子分类。应用设备型号时会更改符号分类。允许您定义在自动标注时使用的“源”。

主：显示子设备或附属设备所属主要设备（端子排）的名称。

位置/功能：插入符号时，如果符号插入在轮廓线内，则自动获取图纸或位置（功能）轮廓线的位置（功能）。您可以单击 [...] 按钮并选择所需位置（功能），以分配不同位置（功能）。

制造商数据

此数据来自设备型号，但可以手动修改。数据类型在分类定义中指定。

说明

设备的第一个可译数据字段。您可以在工程中为管理的所有语言输入说明。

用户数据/可译数据

用户数据字段可用于输入您想要管理设备的所有信息。


管理多层端子

多层端子是可在其上连接多个电线或电缆芯的特殊端子。与仅具有一个回路的单个端子不同，它们具有多个回路。要标识多层端子，您可以通过指示层编号设置特殊的标注。

多层端子标注

与其他元素不同，多层端子标注不在工程配置中设置。每个端子可以具有其自己的标注样式。您可以使用与符号相同的标注样式，也可以使用在其中具有端子编号、分隔符（句点）和层编号的特定标注；例如 1.3 表示端子 1、层 3。

与其他设备一样，您可以使用设备属性对话框来影响多层端子。在标注部分中，选择使用层标注选项以激活之前的标注样式。如果您想要与其他设备一样标注多层端子，则使用传统的标注模式（自动或手动）。

创建或编辑多层端子

要创建多层端子，您必须先创建单个端子。然后，您可以将多个端子分组到一起来生成多层端子。

重新编号多层端子

重新编号端子排端子对话框中有一个特定于多层端子的部分。为了帮助您了解结果，将根据选定选项显示一个图形。

请参阅重新编号端子章节了解有关此功能的更多信息。


撤消/恢复

即使工程在多个工作台中打开，大多数图形功能也可以撤消。

部分功能，主要是处理功能无法撤消，因为它们对数据库的影响非常重大且无法取消。

菜单：编辑 > 撤消

菜单：编辑 > 恢复

撤消命令可以取消上一次使用的命令。恢复命令可以取消上一次使用撤消命令所获得的结果。

撤消和恢复图标带有箭头，以显示上一次使用的命令。如果您选择其中一个实体，则将一次性撤消或恢复所有之前的操作。

在某些界面中，您可以使用 [Ctrl]+[Z] 快捷方式撤消上一操作。


宏

宏是您已绘制原理图的一部分，您可以在其他图纸或其他工程中对其重用。宏存储在数据库中。

  • 原理图宏

  • 宏选择器


原理图宏

原理图宏是您已绘制的原理图、布线方框图的一部分，您可以在其他图纸或其他工程中对其重用。

宏在库里集中，这些宏在所有工程中都能使用。

可停靠面板上的宏选项卡允许您存储您首选的原理图宏。您可以管理自己的控制面板。

当您在控制面板中新建原理图宏时，会自动把宏添加到宏数据库中。

  • 创建原理图宏

  • 插入原理图宏

相关章节：

控制面板配置


创建原理图宏

可停靠面板：宏

要创建宏，

1. 请打开包含您想要存储在数据库中的元素的图纸。

2. 在可停靠面板中，激活宏选项卡。

3. 在图形区域中选择要保存的实体

此步骤中，您有几种创建宏的可能：

4. 将其拖放到控制面板的一个部分中。

或者，

4. 使用宏组右键菜单中的保存到宏命令。

或者，

4. 使用编辑菜单的插入点复制命令。

5. 使用宏组右键菜单的粘贴为新宏命令。

将打开一个对话框，以允许您填写与宏相关的数据。

此宏可自动添加至宏管理器中，因此可用于插入其他工程。

在可停靠面板中，下拉菜单允许您访问特定命令。

添加现有宏：使您可以选择存储在数据库中的宏，并将其添加到控制面板中的宏列表。

保存选项至宏：允许您将选定元素保存到宏。启动该命令时，将在组中创建宏。

粘贴为新宏：如果您使用了插入点复制命令，剪切板中的选定图形元素可粘贴为新宏。

编辑此宏：可在图形界面中打开宏，以进行修改。宏被视为一个工程。它显示在可停靠面板的文档选项卡中。

删除此宏：从控制面板删除选定的宏（不是从数据库删除）。

新建组：创建新的宏组：

组属性：访问选定组的属性。

删除组：删除选定组

激活组：激活从右键菜单选择的组。

相关章节：

插入原理图宏

宏管理器

控制面板配置


插入原理图宏

从功能区菜单中插入宏

菜单：原理图 > 插入宏

菜单：布线方框图 > 插入宏

第一次使用此命令时，宏选择器对话框会打开，让您可以选择要插入的宏。此宏将被保存；再次使用此命令时，会自动调用此宏。

可停靠面板将显示可用选项。

固定命令，以确保该命令在首次用于插入宏后持续有效。

首次用于插入符号后停止命令。

结束命令。

选择要插入的宏

显示上次插入的宏。如果未保存任何符号，宏选择器将自动打开。

如果您不想使用当前显示的宏，请单击其他宏按钮。宏选择器将打开，您可以在其中选择其他宏。

从控制面板中插入宏

可停靠面板：宏

1. 打开您要在其中插入宏的图纸。

2. 从可停靠面板拖动宏。

3. 将其放置在图形区域中。

搜索宏

控制面板中有用于搜索特定宏的选项。此搜索并不限制于宏控制面板，它可在整个宏数据库中搜索。

在框中键入要搜索的文本，然后单击查找按钮。所有包含说明字段中所输入文本的宏都会列在搜索结果中。

管理标注

插入宏后，标注管理对话框将打开，允许您计算新的标注或保持现有标注。

此对话框的工作方式在 特定粘贴 章节中有介绍。

相关章节：

创建原理图宏

宏管理器

控制面板配置


宏选择器

宏组的右键菜单：添加现有宏

符号属性：关联的宏

宏选择器中显示的宏存储在宏数据库中。

对话框左侧显示宏的分类，右侧显示选定类别中的宏列表。

属性：打开所选宏的属性对话框。

视图：打开所选符号的预览窗口。

列表模式：让您显示宏列表（名称、说明、分类）。

缩略图模式：以缩略图形式显示宏（预览）。

配置：允许您管理对话框中所含内容的参数。

1. 选择需要的宏。

2. 单击选择按钮进行确认。

相关章节：

宏管理器


复制/粘贴

该复制命令允许您将选定元素放置在 DesignSpark Electrical 剪切板中。粘贴命令允许您提取这些元素。复制/粘贴命令可用于复制或移动现有元素。

复制/粘贴命令可以在软件的各个位置使用，但是用于复制/剪切的对象类型则取决于启动命令的环境。

  • 剪切

  • 复制

  • 插入点复制

  • 粘贴

  • 特定粘贴


剪切

剪切命令允许您将选定元素放置在 DesignSpark Electrical 剪切板中。该命令可用于移动多种类型的元素，而且它可在软件的各个位置使用。

可通过粘贴或特定粘贴命令插入或创建剪切板中的元素。

图形区域

菜单：编辑 > 剪切

图形元素的右键菜单：剪切

1. 单击该命令。

2. 选择图形区域中的实体。

3. 确认选择。

元素将突出显示，而且这些元素可插入到与粘贴或特定粘贴命令相同或不同的图纸中。插入时（粘贴命令），源元素将被删除。

管理器

管理器 > 剪切

1. 选择要剪切的元素。

2. 单击该命令。

将保留源元素，并且这些元素将粘贴到其他分类中。创建新元素时，源元素将被移除。

工程文档

工程、文件集、文件夹或图纸的右键菜单：剪切

1. 选择要剪切的元素。

2. 在右键菜单中，单击该命令。

将保留源元素，并且这些元素将粘贴到一致的地方（例如文件集无法粘贴到文件夹中）。创建新元素时，源元素将被移除。

相关章节：

复制

插入点复制

粘贴

特定粘贴


复制

该复制命令允许您将选定元素放置在 DesignSpark Electrical 剪切板中。该命令可用于复制多种类型的元素，而且它可在软件的不同位置使用。

可通过粘贴或特定粘贴命令插入或创建剪切板中的元素。

图形区域

菜单：编辑 > 复制

图形元素的右键菜单：复制

1. 单击该命令。

2. 选择图形区域中的实体。

3. 确认选择。

元素可插入到与粘贴或特定粘贴命令相同或不同的图纸中。将保留源元素。

管理器

管理器 > 复制

1. 选择要复制的元素。

2. 单击该命令。

将保留源元素，并且这些元素将粘贴到相同或不同分类中。

工程文档

工程、文件集、文件夹或图纸的右键菜单：复制

1. 选择要复制的元素。

2. 在右键菜单中，单击该命令。

将保留源元素，并且这些元素将粘贴到一致的地方（例如文件集无法粘贴到文件夹中）。

相关章节：

剪切

插入点复制

粘贴

特定粘贴


插入点复制

该插入点复制命令允许您将选定元素放置在 DesignSpark Electrical 剪切板中。该命令用于复制多种类型的元素，而且它仅可用于图形区域。

可通过粘贴或特定粘贴命令插入或创建剪切板中的元素。

菜单：编辑 > 复制

图形元素的右键菜单：复制

1. 单击该命令。

2. 选择图形区域中的实体。

3. 确认选择。

4. 在图形区域中，单击插入点

当您插入实体（粘贴或特定粘贴命令）时会使用插入点。

元素可插入到与粘贴或特定粘贴命令相同或不同的图纸中。将保留源元素。

相关章节：

剪切

复制

粘贴

特定粘贴


粘贴

粘贴命令用于插入 DesignSpark Electrical 剪切板中的对象。在软件的不同菜单中都可以使用这个命令，插入的对象类型取决于命令运行的环境。如果剪切板为空，则取消粘贴。

图形区域

菜单：编辑 > 粘贴

图形元素的右键菜单：粘贴

1. 单击该命令。

2. 在图形区域中，单击插入点。

如果 DesignSpark Electrical 剪切板中的对象具有标注（如符号、电线或图纸），则使用粘贴命令时，标注将根据工程中的现有对象自动重新计算。如果您想自行管理标注，您应该使用 特定粘贴 命令。

管理器

管理器 > 粘贴

1. 单击该命令。

管理器中的对象（如符号、电缆或设备型号）同样可以复制/粘贴。将创建新对象且后缀 +n（n = 序号）将添加到新对象的名称中。

工程文档

工程、文件集、文件夹或图纸的右键菜单：粘贴

1. 选择要剪切的元素。

2. 在右键菜单中，单击该命令。

如果原理图或布线方框图是复制/粘贴命令的对象，则将创建新图纸且将自动复制其内容。您可以复制相同工程或其他工程中的工程（工程内容）、文件集、文件夹或图纸。

相关章节：

剪切

复制

插入点复制

特定粘贴


特定粘贴

菜单：编辑 > 特定粘贴

图形元素的右键菜单：特定粘贴

工程、文件集、文件夹或图纸的右键菜单：特定粘贴

与 粘贴命令类似，特定粘贴命令用于插入 DesignSpark Electrical 剪切板中的对象。在软件的不同菜单中都可以使用这个命令，插入的对象类型取决于命令运行的环境。

当您插入宏时，特定粘贴界面也会打开。

此时将打开对话框，以允许您新建标注或保留现有标注。

切记：相同标注将自动关联，除非一个是自动标注，另一个是手动标注。

“粘贴”选项卡的选项

对话框显示剪切板中包含的所有对象。在每个对象类型上，选择所需操作。

对象类型：列出剪切板中包含的不同对象。

对象数量：找到的对象数量。

动作

以下列出的所有操作是默认用于所有元素类别的操作。您可以在其他选项卡中单独对其进行更改。

创建新标注：粘贴元素的标注将根据现有元素自动重新计算。

保留已有标注：在已复制元素和已粘贴元素中，标注相同。

删除编号：此操作专用于电位编号。它允许您重新计算这些编号。

保留已有编号：此操作专用于电位编号。它允许您保留这些编号。

在列表中选择所需操作（新建标注或保留现有标注）。注意：对某些对象来说，操作已禁用。在其他选项卡中可以更改每个单个对象设置。将不计算新标注，只有单击完成按钮时才会计算。

重置手动标注：仅自动标注用于特殊粘贴命令。如果还想管理手动标注，请选择重置手动标注框。

如果已管理其他选项卡并更改粘贴选项选项卡中的某个选项，则会打开一个对话框以确认您的选择（您可能会丢失已完成的设置）。

“对象”选项卡

对话框显示对应于已复制对象的几个选项卡。在每个选项卡中，您都可以单独管理对象标注。

关联：已复制的对象与现有对象相关联。选择器将打开，以允许您选择现有对象。

重命名：此时将打开一个对话框，以允许您更改标注。新标注将创建为手动标注。

新标注：如果在第一个选项卡中选择保留现有标注，您可以在每个对象上输入一个新标注。

列表显示：以列表形式显示元素。

树形图：显示树形图中的元素。

这些命令还可在每个对象的右键菜单中使用。

搜索功能允许您查找现有标注。输入标准，然后单击箭头便可查找。

颜色代码允许您识别标注状态。

绿色：新标注。

橙色：现有标注。

蓝色：新标注和已重命名的标注。

“粘贴就绪”选项卡

最后一个选项卡显示之前选项相对应的结果。

1. 单击完成按钮开始复制。

将根据现有标注自动计算新标注。

相关章节：

剪切

复制

插入点复制

粘贴


多语言文本

多语言文本十分特殊，因为可以使用工程内指定的所有语言来输入。与普通文本不同，多语言文本存储在数据库中。当工程语言改变时，多语言文本也会自动切换语言。此界面与多语言文本的插入和编辑界面相同。

菜单：绘制 > 多语言文本

可停靠面板将更改，以显示文本位置选项。

结束命令。

返回至上一界面。

请输入坐标

1. 单击图形区域，输入文本的插入点坐标。

文本

2. 以不同显示语言输入文本。

格式

3. 单击复选框以使用工程设置参数，或使用文本的特定参数。后一种情况下，选择字体名称、高度、样式和文字颜色。

对齐

4. 设置文本对齐。

旋转角度

5. 输入文本的旋转角度。


超链接

菜单：绘制 > 超链接

原理图的上下文菜单、布线方框图或报表实体。

超链接允许您将外部文件或工程图纸链接到图形元素。它还可用于链接至图像文件、PDF 文件等项。

对话框打开，允许您创建超链接。

要显示的文本：输入超链接文本。此文本将在已创建超链接的实体的内容菜单中显示。

相对路径：选择此选项可显示相关模式中的文件路径。

图纸超链接：单击 [...] 按钮以选择链接的文件。

绝对文件路径：表示绝对模式中的文件路径。

当前文件夹：表示当前工程的文件夹。

工程图纸超链接：单击 [...] 按钮以选择当前工程的图纸。

移除链接：允许您删除链接。

目标：允许您使用与文件关联的应用程序来打开文件。如果目标是工程图纸，则将在图形区域中打开。

在具有超链接的实体的上下文菜单中，您可使用命令管理超链接。

修改：允许修改超链接。

删除：允许移除超链接。

注意：压缩工程时，与超链接关联的文件将不集成到压缩文件中。如果您想要这些文件在压缩时可用，请将其作为附件添加至工程。

相关章节：

附件


处理

因为数据存储在工程数据库中，所以可以进行处理（如编辑端子排、电缆或报表）。设计原理图后，将自动填充此数据库。

所有过程均在特定菜单（过程）中分组，但某些命令还在工程菜单下。

  • 交叉引用

  • 分配设备型号

  • 电线布线方向

  • 电缆布线

  • 电线编号

  • 重新编号标注

  • 更新工程数据

  • 翻译工程文本

  • 校对

  • 报表管理器

  • 添加到篮

  • 打印管理器

  • 导出图纸


原理图元素的右键菜单

原理图中的每一项（如符号、端子或电线）都带有右键菜单，其中有多个与选定项目相关的命令。

许多命令都具有多选功能。如果无法使用多选功能，命令将显示为灰色。

  • 电线的右键菜单

  • 符号的右键菜单

  • 黑盒的右键菜单

  • 端子的右键菜单


电线（关联菜单）

电线样式 ►

属性：打开电线样式属性对话框。任何更改均会影响工程中的所有电线。

延伸：用于将选定线段的电线样式延伸到连接的线段。可停靠面板将显示传输选项。到等电位选项用于延伸具有相同电位编号的电线。穿过回路选项仅在电线样式是符号相同的上游和下游时通过符号传输电线样式。

替换：用于将工程中使用的电线替换为另一种电线样式，这取决于电线样式。可停靠面板将显示电线选择选项。

电缆属性：仅在选择电线/电缆后显示。打开工程电缆属性对话框，以编辑电缆属性。

电线属性：打开 电线属性对话框，以管理其标注和与电线关联的技术数据。

电位属性：打开通用于此电位的电线的属性对话框。允许您管理电位编号和与此电位关联的技术数据。

编辑电线标注：用于编辑分配给电线的编号（电线或电位）。

对齐文字：用于对齐电线标注文字。选择要对齐的文字并绘制与电线垂直的轴线。文字将与此轴对齐。

显示/隐藏电线标注：用于显示或隐藏分配给电线的电线或电位编号。此命令还可用于多选。

关联电缆芯：用于创建电线布线。

取消关联电缆芯：取消关联与选定电线相关联的电缆芯。

接线方向：用于管理电线的接线方向。

创建/删除跳线：允许您创建两个或多个设备（或端子）之间的跳线。运行此命令时，选择表示跳线的电线并进行验证。电线将自动采用工程配置中定义的特性。此命令还使您可以删除跳线。在图形界面中选择显示为跳线的电线，然后使用删除跳线选项。

显示/隐藏电缆芯文本：用于在电线布线后显示或隐藏与电缆芯相关的文本。

移动：用于移动选定电线或电线。

复制：用于在 DesignSpark Electrical 剪切板中放置选定电线。

插入点复制：复制符号到 DesignSpark Electrical 剪切板，并定义插入点。

剪切：与复制命令相同，选定电线稍后将移除。

超链接：创建/编辑外部文档的链接。

删除：删除选定电线。


符号（关联菜单）

本章节介绍所有符号类型，如布线方框图、原理图、跳转符号。右键菜单因选定符号而不同。

符号属性：打开符号属性对话框。

分配设备：分配选定符号至现有设备。

标注 ►

编辑标注：允许您修改符号标注。

管理符号标注的显示。

编辑交叉引用类型编辑交叉引用类型：打开交叉引用 配置 对话框。

编辑符号端子：打开对话框以 编辑设备的设备端子 。

符号 ►

在符号右键菜单中，四个指令用于在打开的任意右键菜单中编辑符号。

更新：根据符号库中的定义，更新以插入的符号。

替换：使用数据库中其他符号替换已插入的符号。

打开符号：允许在编辑界面中打开符号，可以修改其图形、标注、设备连接点等。

添加至数据库：将已插入的符号添加到符号库中。

设备属性：打开编辑设备对话框，分配标注、位置和功能，输入设备数据并分配设备型号。

设备 ►

更改位置：更改符号关联的位置。

更改功能：更改符号关联的功能。

分配设备型号：给符号分配一个或多个设备型号。

删除设备型号：删除符号关联的设备型号。

插入符号：允许您插入此设备的符号。

转至 ►

进入浏览器：在设备选项卡中显示与选定设备关联的符号的列表。如果设备是由大量符号定义的，则将使用此功能。

其他项允许您根据交叉引用在具有相同设备的不同符号之间进行导航。

布线 ►

管理布线和接线方向。

接线方向：管理符号的上下游接线方向。

电缆芯关联：用于生成符号与上下游的接线方向。

方向 ►

更改符号方向。

特殊角度 (0° / 90° / 180° / 270°)

自由旋转：使用鼠标转动符号。

反转：镜像符号图像。

移动：允许您移动符号。

剪切：将符号复制到 DesignSpark Electrical 剪切板。符号已删除。

复制：将符号复制到 DesignSpark Electrical 剪切板。

插入点复制：复制符号到 DesignSpark Electrical 剪切板，并定义插入点。

超链接：创建/编辑外部文档的链接。

删除：在图纸中删除此符号。


黑盒（右键菜单）

符号属性：打开符号属性对话框。

编辑交叉引用类型：打开交叉引用 配置 对话框。

分配设备：分配选定符号至现有设备。

标注 ►

管理符号标注的显示。

编辑标注：允许您修改符号标注。

编辑符号端子：打开对话框以 编辑设备的设备端子 。

符号 ►

在右键菜单中，四个指令用于在打开的任意右键菜单中编辑符号。

更新：根据符号库中的定义，更新以插入的符号。

替换：使用数据库中其他符号替换已插入的符号。

打开符号：允许在编辑界面中打开符号，可以修改其图形、标注、设备连接点等。

添加至数据库：将已插入的符号添加到符号库中。

设备属性：打开编辑设备对话框并分配标注、位置和功能，然后输入特定于设备的数据并分配设备型号。

设备 ►

更改位置：更改符号关联的位置。

更改功能：更改符号关联的功能。

分配设备型号：给符号关联一个或多个设备型号。

删除设备型号：删除符号关联的设备型号。

插入符号：插入该设备的符号。

转至 ►

使用交叉引用在相同零件的不同符号之间进行导航。

更新黑盒：更新黑盒。

添加设备连接点：在黑盒边缘周围添加设备连接点。

删除设备连接点：删除黑盒上的设备连接点。

布线 ►

管理布线和接线方向。

接线方向：生成符号的上下游接线方向。

电缆芯关联：生成符号的上下游接线。

移动：移动符号。

复制：复制符号到 DesignSpark Electrical 剪切板。

插入点复制：将符号复制到 DesignSpark Electrical 剪切板并要求您指定插入点。

剪切：复制符号到 DesignSpark Electrical 剪切板。符号已删除。

超链接：创建/编辑外部文档的链接。

删除：在图纸中删除此符号。


端子（关联菜单）

符号属性：打开符号属性对话框。

分配设备：分配选定符号至现有设备。

标注 ►

编辑标注：允许您修改符号标注。

管理符号标注的显示。

编辑符号端子：打开对话框以 编辑设备的设备端子 。

符号 ►

在符号右键菜单中，四个指令用于在打开的任意右键菜单中编辑符号。

更新：根据符号库中的定义，更新以插入的符号。

替换：使用数据库中其他符号替换已插入的符号。

打开符号：允许在编辑界面中打开符号，可以修改其图形、标注、设备连接点等。

添加至数据库：将已插入的符号添加到符号库中。

设备属性：打开编辑设备对话框，分配标注、位置和功能，输入设备数据并分配设备型号。

设备 ►

更改功能：更改符号关联的功能。

分配设备型号：给符号分配一个或多个设备型号。

删除设备型号：删除符号关联的设备型号。

插入符号：允许您插入此设备的符号。

定义层级：允许您定义选定端子上的层级数量。一个对话框打开，帮助您输入层级数量。

更改端子排：允许您将选定端子移动到其他端子排中。

转至 ►

允许您根据交叉引用在具有相同设备型号的不同符号之间进行导航。

端子排属性：打开端子位于的端子排的属性。

布线 ►

管理布线和接线方向。

接线方向：管理符号的上下游接线方向。

电缆芯关联：用于生成符号与上下游的接线方向。

方向 ►

更改符号方向。

特殊角度 (0° / 90° / 180° / 270°)

自由旋转：使用鼠标旋转符号。

反转：镜像符号图像。

移动：允许您移动符号。

剪切：将符号复制到 DesignSpark Electrical 剪切板。符号已删除。

复制：将符号复制到 DesignSpark Electrical 剪切板。

插入点复制：复制符号到 DesignSpark Electrical 剪切板，并定义插入点。

超链接：创建/编辑外部文档的链接。

删除：在图纸中删除此符号。


交叉引用

一个设备有时通过一个或多个符号表示当由多个符号表示时，可能插入到不同的图纸中。交叉引用表示不同符号之间的关联。

根据所使用标准和符号类型的不同，交叉引用分为不同的等级。

- 父行类型符号（例如断路器）

- 父图表类型符号（例如线圈）

- 子类型符号（例如触点）

- 同等级类型符号（例如推动按钮）

- 无交叉引用（例如电源供给）

交叉引用为实时计算，同时与已链接符号相关的每一个操作（移动、删除...）都会更新交叉引用。

交叉引用缩略图的自动生成取决于符号的定义（回路）和配置参数。

  • 回路管理

  • 交叉引用等级

  • 利用交叉引用导航


回路管理

设备中的回路对应于设备的各“极”。这些回路在符号定义中使用，还能在设备型号定义中使用。通过对比符号的回路和设备型号的回路，可以生成交叉引用并显示端子。

回路定义

此软件管理多种类型的回路，分别对应不同类型的电气设备。

例如，三极断路器包含三个断路器，开关回路。

设备的回路是此设备关联的所有符号回路的总和。

上述示例表明 Schneider 型号为 LC1D09006B7 的产品回路定义。它包含一个线圈和一个 3 极电源触点、常开和常闭触点。

分配制造商零件时，该软件将对制造商零件和代表设备的多种符号中的回路进行比较。如果两者相符，设备端子号将自动传递到符号回路并显示在原理图中。如果设备型号回路与符号回路有所差别，将一起添加并保留这两个回路。端子号也不会显示在原理图中。

回路在交叉引用中的作用

如交叉引用配置中所示，某些回路类型与交叉引用缩略图（图形符号）关联。这些是与子级或同等级符号相关联的回路（父级符号不会生成交叉引用缩略图）。

生成交叉引用缩略图时，该软件列出设备关联的所有回路并进行过滤，以仅保留子级或同等级回路，并使用回路类型关联的交叉引用缩略图生成图形。自动添加设备端子的编号，作为工程和图纸中的符号位置。

在上述示例中，在图纸 10 第 4 列中有 3 个常开电源触点类型回路，在图纸 04 第 4 列有一个常开触点。常闭触点包含在设备型号中，但没有在图纸中应用（而是已保留预设）。第二个常开触点（图纸 04 第 6 列）不在设备型号中。

回路和组

要关联回路，需在各回路上输入一个编号（或名称）。要关联的回路须拥有相同编号。

例如，在换向接触器使用的回路组上，一个线圈与一个接触器相连，第二个线圈与第二个接触器相连。

组编号存储在设备型号数据中。插入符号设备时，交叉引用将自动更新组编号。

相关章节：

交叉引用配置

交叉引用等级

通过交叉引用导航


交叉引用等级

根据所使用标准和符号类型的不同，交叉引用分为不同的等级。

- 父行类型符号（例如断路器）

- 父图表类型符号（例如线圈）

- 子类型符号（例如触点）

- 同等级类型符号（例如推动按钮）

- 无交叉引用（例如电源供给）

-默认图示标准 ANSI 符号

每个不同等级的交叉引用，都有不同的与符号关联的图示。

父图表：包含回路和位置信息（图纸/列）图形展示的块将自动在图纸下半部分中的父图表类型符号对齐中生成。

父行：包含回路和位置信息（图纸/列）图形展示的块将自动在父图表类型符号旁边生成。

子或同等级：交叉引用信息在符号标注 #CROSS_REF中以文本形式传输。

无：不生成交叉引用。

默认图示：包含回路和位置信息（图纸/列）图形展示的块将自动在已插入符号的列的右侧父图表类型符号对齐中生成。

交叉引用的等级在符号参数中定义（参见符号库）。

相关章节：

回路管理

通过交叉引用导航


利用交叉引用导航

一个设备有时通过多个符号表示，并可能插入到不同的图纸中。 DesignSpark Electrical 为更好了解原理图，自动生成交叉引用信息。该信息能够以图形（缩略图）或文本形式显示在符号标注下方。

您可以直接导航至关联此设备的其他符号

在设备符号右键菜单中选择转至选项（该选项还可用于交叉引用缩略图）。

相关章节：

回路管理

交叉引用配置

交叉引用等级


设备型号与回路

符号属性：设备型号与回路

端子属性：设备型号与回路

黑盒属性：设备型号与回路

位置属性：设备型号

此选项卡显示分配到设备的设备型号及其回路的定义。

设备型号

搜索：打开一个对话框，允许您在库中搜索设备型号。

添加设备型号：打开对话框以创建新的设备型号。

添加电气装配体：打开一个对话框，允许您创建新的电气装配体。

删除：删除选定的设备型号。

属性：打开选中设备型号的属性对话框。

上移/下移：允许您整理设备型号的列表。

回路

该位置属性对话框中未提供回路定义。

从列表中选择型号时，DesignSpark Electrical 会对组成设备（符号）的回路和设备型号中包含的回路进行比较。

绿色表示符号回路与设备型号中的回路一致。

红色表示符号回路与设备型号中的回路不一致。某些回路符号不在设备型号中。因此需要添加辅助设备或修改设备以在设备型号中添加符号。

蓝色表示设备型号中包含符号中不存在的回路（保留的回路）。

黄色表示存在虚拟回路，但既不是符号也不是设备型号（手动添加）。

编辑端子：允许您编辑选定回路的端子号。

添加虚拟回路：允许您添加新的回路。设备型号和符号中不存在虚拟回路。

删除虚拟回路：允许您删除选定的虚拟回路。

切换符号回路：允许您在回路列表中的两个选定回路之间进行切换。

取消关联符号回路：只有绿色回路才必须取消关联。取消关联回路时，会将其自动设为预设（蓝色），并且符号的回路将设为红色。

向上/向下：允许您整理虚拟回路。

回路的右键菜单中也提供了这些命令。

相关章节：

分配设备型号

设备型号属性

回路管理


分配设备型号

您可以根据需要添加设备型号到目录并进行管理。每一个由 DesignSpark Electrical 管理的设备都可以与一个或多个设备型号相关联。根据元素类型的不同，设备型号可在软件中有不同应用。

  • 分配设备的设备型号

  • 分配符号的设备型号

  • 分配位置的设备型号

  • 分配端子的设备型号

  • 分配端子排的设备型号

  • 手动编辑设备型号

当设备型号关联元素后，图纸将自动更新，例如交叉引用和符号上的设备端子号。

在每个制造商零件的特定选项卡中，单击搜索按钮以访问选择制造商零件对话框。

有两个搜索设备型号的选项。勾选自动刷新框以自动显示设备型号列表。

如果未勾选此框，则只在单击搜索按钮时更新设备型号列表。

分类

此选项卡以树形式显示设备型号分类。

对话框左侧显示设备型号分类。对话框右侧显示当前选定分类中的设备型号。

筛选器

筛选设备型号列表。所有筛选条件显示在设备型号属性中。

对话框右侧显示与选定条件对应的设备型号。

删除筛选器：移除所有筛选条件。

分类：分类是第一个搜索条件。您可以使用要在其上分配制造商零件的对象的分类、相同基础分类或所有分类。

要更改默认分类，请单击 [...] 按钮并选择所需的分类或子类。

其他所有条件在制造商零件属性中显示。

管理您要添加的数量。

添加选定设备型号。

使用列表中选定的型号替换之前分配的设备型号。

删除已关联的所有设备型号。

用于排序设备型号。

分配设备的设备型号

设备为与设备型号相关联的电气设备。

当新建设备后，DesignSpark Electrical 会自动提示您给它关联一个设备型号。

分配符号的设备型号

符号属性：设备型号与回路

对话框的下半部分显示构成设备的回路列表（构成设备的所有符号）。

单击搜索按钮以搜索设备型号，或者单击添加设备型号以创建一个新的设备型号。

设备型号的右键菜单可以访问设备属性、激活或者关闭回路测试。

激活测试后，DesignSpark Electrical 会比较组成设备（符号）的回路和设备型号中的回路。

绿色表示符号回路与设备型号中的回路相吻合。

红色表示符号回路与设备型号中的回路不一致。某些回路符号不在设备型号中。因此需要添加辅助符号或修改设备型号中的符号。

蓝色表示设备型号中包含符号中不存在的数据（保留的回路）。

分配位置的设备型号

位置属性：设备型号

单击设备型号选项卡中的搜索按钮以搜索设备型号。

分配端子的设备型号

端子属性：设备型号与回路

选择要应用设备型号的端子，然后单击设备型号图标。

分配端子排的设备型号

端子排属性：设备型号与回路

单击设备型号选项卡中的搜索按钮以搜索设备型号。选定设备型号将被分配到端子排，而非端子。此功能可以用于选择端子的配件（不要与设备混淆）。

手动编辑设备型号

以上情况中的设备型号都存在于制造商目录中。您也可以手动输入设备型号，例如目录中没有您需要的设备型号且无需永久输入时。

属性对话框：设备型号 > 手动添加

输入参数，然后按确定按钮来确认数据。

当输入设备型号和名称时，如果设备型号已存在于目录，则显示一则消息，询问您是想要恢复现有设备型号的属性还是仅继续输入其属性。

如果设备型号已存在于目录中，请单击确定按钮。如果新设备型号的属性与原有型号属性不同，则显示一则消息，询问您是否想要将新数据更新到目录还是仅将数据应用于设备。

输入新设备型号后，DesignSpark Electrical 将询问您是否要将此设备型号添加到制造商目录中。

相关章节：

设备型号目录

交叉引用


接线方向

有两种电位类型：

  • 简单电位。这仅连接两个设备。

  • 复杂电位。这连接三个或更多设备。

接线方向使您可以定义这些设备连接的方式。

仅复杂电位受布线方向的影响。

它允许您优化电线和电缆长度并确定布线方向（从/到），这使其更易于在连接和电缆列表中读取。

有两种不同类型的接线方向：自动接线方向（由 DesignSpark Electrical 自动生成）和手动接线方向（由用户手动生成）。

  • 管理接线方向

相关章节：

线号

布线


管理接线方向

可在整个工程内或一根电线上执行接线方向。

菜单：工程 > 电线接线方向（处理工程中的所有电线）

可停靠面板 > 工程的右键菜单：工程 > 电线接线方向管理器（处理工程中的所有电线）

电线的右键菜单：电线接线方向（仅处理选定电线）

对话框左侧显示工程复杂电位列表。上方显示连接到同一电线的不同符号。

下方显示接线方向的从/到结果。

接线方向还可让您管理电缆芯（参阅接线章节）。

电位

自动 添加电线：管理工程所有复杂电位的接线方向。设备的连接方向将取决于其标注（字母数字顺序）。此操作生成的接线方向称为自动接线方向。

删除电线：允许您删除整个工程中的接线方向。

自动 为选定项添加电线：与自动添加电线功能具有相同行为，但仅作用于选定电位。

为选定项删除电线：与删除电线功能具有相同行为，但仅作用于选定电位。

如果通过电线右键菜单启动该命令，则只有选中的电位显示在列表中。如果通过工程菜单启动该命令，则从左侧列表中选择要调整的电位。

连接到电位的设备

由以下命令生成的接线方向称为手动接线方向。

从点添加电线：选择列表中的一个标注，然后单击从点添加电线按钮。标注将自动添加到源列。

用点替换源：更改源。

添加电线到此点：选择列表中的一个标注，然后单击添加电线到点按钮。标注将自动添加到目标列。

用点替换目标：更改目标。

可以使用设备右键菜单中的转至命令打开其中插入了符号的图纸。您也可以双击设备。

您还可将标注从源拖放到目标（反之亦然），或将左上方标注拖放到任意连接线上的源或目标处。

电位电线

自动添加电线按钮可让您在复杂线束上自动生成接线方向。

删除电线按钮可让您删除所选接线。

切换源和目标按钮可让您反转设备标注的源和目标。

关联电缆芯和取消关联电缆芯按钮会影响接线。


电缆布线

工程中使用的电缆集中在电缆管理器中。

电缆目录将提供给您，其中包含大量的电缆型号，您还可以创建自己的电缆型号。

安装过程中的布线可以在多个层面完成：布线方框图以及原理图中。

在布线方框图中预设的电缆可以在后期原理图中使用。

  • 电缆管理器

  • 原理图布线

  • 详细布线


电缆管理器

电缆管理器集合在您的工程中使用的所有电缆。

菜单：工程 > 电缆

可停靠面板 > 工程的右键菜单：工程 > 电缆管理器

电缆显示在可根据您的需要筛选的列表中。您可以整理有关电缆源/目标的信息，并使用布线方框图中预设。

其中一些功能接受多选，例如删除或属性。

新电缆：打开电缆目录，您在其中可选择添加到工程所需的引用。

删除：允许您删除选定电缆。如果电缆芯已在使用中，则无法删除电缆。

属性：显示选定电缆的属性。如果您选择多个电缆，则属性对话框将只显示共同属性。

复制：复制单个或多个电缆，包括其所有关联属性，例如型号或路径。标注将自动增加。

替换：允许您将选定电缆替换为目录中的其他电缆。新电缆中必须含有至少与要替换的电缆同样的缆芯数。

切换：允许您切换选定电缆的源和目标，反之亦然。

取消电缆芯关联：允许您释放（断开）选定电缆芯。

树形模式：管理电缆列表显示的类型。电缆可按功能或源/目标分组。

多个筛选器允许您显示按名称、部件号或源/目标位置筛选的电缆。

预设电缆：自动隐藏除预设电缆外的所有电缆。再次选择此图标以删除筛选器。

相关章节：

电缆型号管理器

添加电缆

电缆属性


工程电缆属性

电缆管理器：属性

电线（原理图）的右键菜单：电缆属性

电缆（布线方框图）的右键菜单：电缆属性

“电缆属性”对话框可使您修改电缆标注（将电缆添加到工程时自动创建）。根据配置参数计算标注。

标注

模式：如果选择自动模式，标注将根据配置设置自动计算。如果选择手动模式，您必须在标注设置中手动输入标注。

标注：显示自动标注或用于输入手动标注。

源：显示与电缆关联的源。

数量：显示分配至电缆的序号。您可以更改此序号，但不可使用现有序号。

层级结构

上游位置：电缆的‘开始’位置。

下游位置：电缆的‘终点’位置。

功能：电缆具体的使用功能。

电缆型号

电缆型号属性：单击 [...] 按钮可以打开电缆型号属性对话框（数据不可修改）。

这部分的其他参数与电缆型号的数据相关。

特性

3D 布线软件中的数据。

计算

允许您计算电缆的压降。

说明

第一个可译数据字段用于电缆。您可以为工程中管理的所有语言输入说明。

用户数据/可译数据

用户数据存在于整个工程。它用于存储可在图纸中显示的个性化信息。用户数据有两种类型：可译用户数据（在工程翻译过程中翻译）和不可译用户数据。

自定义...按钮可让您访问电缆用户数据。

相关章节：

电缆管理器


原理图布线

原理图中每条电线只要与符号或端子相连接，都可以添加电缆线。布线命令在电线的右键菜单中。

电线的右键菜单：关联电缆芯

选择多条线时可以启用布线命令。

此界面与电缆管理器类似，但允许您管理电缆芯布线。

关联电缆芯：在对话框的上半部分选择要使用的缆芯，在下半部分选择要布线的电线。

电缆芯按照所示顺序关联。列表上的第一个缆芯将分配到列表上的第一根电线，第二个缆芯分配到第二根电线，以此类推。建议根据缆芯列表组织电线列表。

蓝色电缆芯（粗体）：关联电线。

绿色电缆芯（粗体）：分配到其中一根选定电线。

粗体表示电缆芯位于原理图中，非粗体蓝色电缆芯仅位于布线方框图中。

取消电缆芯关联：删除选定缆芯的布线。

确定更改后，原理图自动更新。与电缆相对应的文本将自动放置在线上。可在工程属性（字体选项卡）中自定义设置此文本（的样式和内容）。

相关章节：

电缆管理器

布线方框图布线


电线编号

在原理图中绘制的每条电线都可以进行编号。线号标注让您可以管理和优化安装布线。此编号可选，可以选择仅对某些线型编号组编号。

还有两种编号模式：一种是电位编号模式（同一电位上连接的所有电线），另一种是电线编号模式（连接设备的物理电线）。

电线编号遵循简单的规则；从第一页图纸开始，按可停靠面板中显示顺序对图纸内的电线进行编号。在图纸内部，将需要考虑电线的实际位置。编号从左上开始，向右下继续增加。

编号参数将在线样式管理器和工程配置中定义。您可以在工程开发的任何时候开始对电线编号。您也可以手动添加线编号，或者修改任意已编号的电线。

  • 新电线编号

  • 电线重新编号

  • 编辑电线标注

相关章节：

编号设置


新电线编号

菜单：处理 > 新电线编号

此命令只会影响未编号的电线。已经编号的电线不受此命令影响。

在对电线编号时，必须将电线连接至符号或端子。未连接的电线将不会编号。

相关章节：

编号设置

电线重新编号

编辑电线标注


电线重新编号

菜单：处理 > 对电线进行重新编号

可根据用户定义选项将此命令应用于工程中的所有电线。

选择

整个工程：所有工程电线重新编号。

当前文件集：仅当前文件集（此文件集关联当前原理图）中的电线重新编号。

当前文件夹：仅当前文件夹（此文件夹关联当前原理图）中的电线重新编号。

当前原理图：仅当前原理图中的电线重新编号。

在原理图中选定的电线：仅原理图中选定的电线重新编号。

选择原理图：打开原理图选择器以选择要处理的原理图。仅这些原理图中的电线重新编号。

线号

删除线号：移除现有线号。执行新编号操作以再次显示编号。您必须勾选重新计算手动编号框以重新计算所有编号。

为新线号并重新计算现有电线标注：为新电线编号并重新编号现有线号，例如编号参数已更改时。计数器值不受此重新编号操作影响，除非更改格式专门对其产生影响。

重新计算线号：重新计算所有线号，除非编号已手动修改。您必须勾选重新计算手动编号框以重新计算所有编号。

电线样式管理器：此按钮允许您打开电线样式管理器以编辑电线样式。

相关章节：

编号设置

新电线编号

编辑电线标注


编辑电线标注

电线的右键菜单：编辑电线标注

此选项可用于单线或多线。

该命令打开的对话框可使您修改电线编号。

对话框指示电线编号为自动生成还是手动生成。对话框的左侧显示电位编号，右侧显示线号。

1. 编辑新建列中的文本以更改编号。

如果您输入的编号已经存在于工程中，将显示一则警告消息。

相关章节：

编号设置

新电线编号

电线重新编号


重新编号标注

如果对工程配置中的标注设置进行了修改，则工程中现有元素的标注必须更新（如设备或位置）。

菜单：处理 > 重新编号标注

选择

整个工程：处理所有工程元素。

当前文件集：仅处理当前文件集（与当前原理图关联的文件集）中包含的元素。

重新编号模式

更新标注：允许您在标注格式修改后，对元素部分列表中的选定元素重新编号。顺序号码和手动标注都将保留。

重新计算序号：允许您对元素部分列表中的选定元素重新编号。顺序号将根据在图纸中的位置重新计算，而且如果勾选重新计算手动标注，则手动标注也会重新编号。

元素

勾选重新编号命令要处理的元素。

单击标注配置...按钮以访问标注设置。

相关章节：

标注设置


将数据延伸至已连接的对象

此功能允许您延伸数据丢弃连接对象，例如，您想要将 PLC 的通道地址分配到与此通道相连的电线数目。第一步是选择数据源。它可以是整个工程、整个工程的一部分或是在图纸中选择的对象。第二步是创建延伸规则，最后一步是选择要更新的对象。

菜单：流程 > 将数据延伸至已连接的对象

选择

整个工程：将数据延伸至工程的所有对象上。

当前文件集：只在当前文件集（此文件集关联当前原理图）的对象上延伸数据。

当前文件夹：只在当前文件夹（此文件夹关联当前原理图）的对象上延伸数据。

当前原理图：只在当前原理图的对象上延伸数据。

原理图中的选定对象：只在当前原理图中选择的对象上延伸数据。

选择原理图：打开原理图选择器以选择要处理的原理图。仅处理这些原理图中的电线。

要延伸的信息

添加延伸：允许您创建新的延伸规则。

删除：删除所选的延伸规则。

当您创建新的延伸规则时，表中将添加新线。选择不同列中的值以创建规则。要整理规则时间顺序，请使用向上和向下图标来管理规则处理次序。此复选框允许您激活或停用延伸规则。

从对象复制：在列表中选择要用于延伸数据的对象。

要延伸的数据：在列表中选择要延伸的数据类型。此数据特定于所选的对象。

目标对象：在列表中选择您要延伸之前所选数据的对象。

目标数据：在列表中选择将复制延伸数据的数据类型。

更新对象属性

即便对象将以延伸的数据自动更新，您仍需激活更新复选框以延伸使用公式的数据。


更新数据

当 DesignSpark Electrical 数据（符号/设备型号等）已更改时，可能需要更新工程数据来反映最新更改。

菜单：处理 > 更新数据

此命令自动显示更新过程数据向导。

第 1 步。更新工程数据

与 DesignSpark Electrical 中的其他向导不同，更新数据的命令没有保存/加载配置文件的选项。在默认情况下处理所有数据，可以单击完成按钮来自动更新所有被管理的工程数据。

如果有选择性地更新工程数据，请选择下一步按钮。

第 2 步。选择

助手第二步列出了要更新的数据。

已选中要更新的数据类型但无需选择数据类型时，将显示一则警告消息。

第 3 步。设备型号

状态：状态列显示选定设备型号的有效性。双击状态字段将显示一个弹出窗口，包含与型号替换无效原因相关的信息。

状态字段仅提供信息；所有设备型号将被替换，无论数据是否兼容。

制造商：显示工程内的制造商名称。

型号：显示工程设备型号。

已有实例：显示整个工程中的实例数量。

不同设备：显示要更新的设备数量。

选择：勾选数据更新过程中要包括的设备型号的框。

第 4 步。电缆型号

状态：状态列显示选定设备型号的有效性。双击状态字段将显示一个弹出窗口，包含与型号替换无效原因相关的信息。

状态字段仅提供信息；所有设备型号将被替换，无论数据是否兼容。

制造商：显示工程内的制造商名称。

型号：显示工程型号。

已有实例：显示整个工程中的实例数量。

不同设备：显示要更新的设备数量。

选择：勾选数据更新过程中要包括的型号的框。

第 5 步。符号

状态：状态列说明所选符号的有效性。双击状态字段将显示一个弹出窗口，包含与符号替换无效原因相关的信息。

状态字段仅提供信息；所有符号将被替换，无论数据是否兼容。

名称：显示工程内的符号名称。

已有实例：显示整个工程中的实例数量。

不同设备：显示要更新的设备数量。

选择：勾选数据更新过程中要包括的符号的框。

对话框右侧的预览图显示当前/现有符号和所要更新的符号。

第 6 步。图框

状态：状态列说明所选图框的有效性。双击状态字段将显示一个弹出窗口，包含与图框替换无效原因相关的信息。

状态字段仅提供信息；所有图框将被替换，无论数据是否兼容。

名称：显示工程内的图框名称。

已有实例：显示整个工程中的实例数量。

不同设备：显示要更新的设备数量。

选择：勾选数据更新过程中要包括的图框的框。

对话框右侧的预览显示当前/现有图框和所要替换的图框。

第 7 步。更新工程数据

选择完成按钮将更新工程图纸和数据库中选定要更新的项。

注意：此命令不可逆。如果用户不确定更新数据的影响，建议您在运行此命令前压缩工程进行备份。

相关章节：

设备型号目录

电缆目录

管理符号

管理图框


翻译工程文本

DesignSpark Electrical 允许您以多种语言输入数据。可在一个界面中查看所有这些翻译。

菜单：进程 > 翻译

可停靠面板 > 工程的右键菜单：翻译

对话框将打开，以允许您输入或修改工程内不同设备属性和多语言文本中的翻译。

单击对应的文本以编辑翻译。

导出/导入：管理其他应用程序中的翻译（Excel、Access、Sqlite 格式）。仅导出一处文本。

在语言选择器对话框中，选择翻译的基本语言。一个消息框将打开，以询问您是否打开文件。

不要修改文件结构，否则您将无法导入翻译。

添加/删除语言：允许选择要在您的工程中使用和翻译的语言。语言选择器对话框将打开，选择语言对应的框。仅显示工程中不存在的语言。如果删除现有语言，将显示一条消息框，以要求您确认选择。

删除翻译：删除选定文本的所有翻译，工程属性中使用的主要语言除外。

查找/替换：允许您搜索并 替换文本。

在筛选区域输入文本列表将显示包含所输入字符串的文本。

配置：允许您管理该对话框中项目的显示设置。

隐藏空文本：隐藏主要语言中的空文本。

隐藏已翻译的文本：隐藏翻译为所有语言的文本。

相关章节：

语言设置

用户数据


查找/替换文本

工程翻译：查找/替换

此命令允许您搜索和/或替换工程中的可译文本。

语言：选择您想要启动搜索的语言。

查找：输入要搜索的文本并单击查找下一个按钮。选定找到文本的行。如果您再次单击查找下一个按钮，DesignSpark Electrical 将在剩余列表中搜索文本存在的其他位置。

替换：输入要插入替换搜索文本的文本。单击替换按钮以替换发现的第一处文本。如果想要替换搜索到的所有文本，请单击全部替换按钮。

区分大小写：此选项执行考虑大小写字母的搜索。

开始自：此选项搜索以所输入文本开始的文本。

全部匹配：此选项搜索包含输入文字且前后有空格的文本。

查找下一个：在列表中进行搜索文本的下一个搜索。

替换：将第一处出现的现有文本替换为输入的文本。

全部替换：将所有出现的现有文本替换为输入的文本。


语言选择器

语言选择器对话框有多种用途。在管理器中，它用于在说明字段中选择语言；在工程翻译中，它用于在各种功能中选择语言。

符号管理器 > 符号属性：说明

图框管理器 > 图框属性：说明

电缆型号管理器 > 电缆属性：说明

设备型号管理器 > 设备型号属性：说明

在各种管理器中，语言选择器对话框允许您选择在元素说明中想要管理的语言。选定语言将自动添加到元素属性中。

“翻译”对话框：添加

在翻译对话框中，语言选择器对话框可拥有两种外观：如果您必须选择一种或多种语言时，则显示复选框；如果您必须仅选择一种语言，则不显示复选框。


校对

仅为文件集、封面和图纸分配校对编号。校对编号单独管理，不在工程等级管理。根据工程配置参数格式化校对编号。

您可在图纸创建期间设置校对索引。

文件集右键菜单：校对

图纸的右键菜单：校对

分三个步骤管理校对索引。首先是创建索引，其次是确认索引，最后是验证索引。

当在文件集上管理校对索引时，您可以将此索引延伸至此文件集内的所有图纸。

新校对：创建新校对索引。必须先确认当前校对才能创建新校对。

确认：向最新校对索引输入“已确认”状态。这将记录确认校对的日期和用户名。

验证：向最新校对索引输入“已验证”状态。这将记录验证校对的日期和用户名。

移除确认：移除到最新校对索引的最新状态。

删除：删除最新校对索引。

属性：编辑：打开校对属性对话框以编辑与校对索引关联的数据。

自定义...按钮可让您访问与校对索引特殊相关的用户数据参数。

创建新的校对索引后，将打开不同对话框，让您打印文件集文档、将文件集文档导出到 PDF 文件以及创建快照。


校对属性

文件集右键菜单：校对 > 属性

图纸右键菜单：校对 > 属性

此对话框将列出校对索引属性。

只可更改用户名和用户数据。


报表和绘图规则管理器

报表

报表是对生产或制造（如设备列表或电缆）很有用的列表。

菜单：工程 > 报表

可停靠面板 > 工程的右键菜单：工程 > 报表管理器

报表检索存储在工程数据库中的数据。数据可生成为图纸形式，或者导出为可在 DesignSpark Electrical 之外访问的不同文件格式，如 Excel 或文本文件。

报表基于提供布局和格式化数据的报表配置。

使用报表管理器可管理想要在工程中使用的报表。对话框的左侧显示工程中使用的报表配置列表。右侧显示选定报表的结果。

添加：允许您在工程中添加新报表配置。

删除：删除所选报表。

顺序：允许您管理顺序，可按此顺序生成报表。

更新：当软件在客户端/服务器模式下使用时更新报表数据（数据可由其他用户修改）。

生成图纸：生成或更新报表图纸。

导出 Excel：使用报表配置导出到 Microsoft Excel 文件工程数据。

导出 Txt：导出到文本文件使用报表配置的工程数据。

导出 XML：导出到 XML 文件使用报表配置的工程数据。

使用链接

报表预览可包括导航到工程元素（例如符号、位置属性或设备型号）的链接。链接具体化为带下划线的蓝色文本。要使用链接，请单击文本（默认链接）或使用右键菜单选择元素（如果多个对象关联到工程）。

要在报表中创建链接，请使用报表配置中的转至设置。

当您单击依赖于链接对象的链接时，操作完成。

对象 | 操作
文档 | 转至图纸
设备 | 在可停靠面板（‘设备’选项卡）中显示设备。 显示与设备关联的所有符号（转至图纸中的符号），包括 2D 布局图。
回路 | 显示与此回路关联的符号。
符号 | 转至图纸中的符号，在其范围内进行缩放。
电缆 | 显示预设电缆的布线方框图（转至与该电缆连接的第一个设备）。 显示原理图图纸中的电缆芯（转至与该电缆芯连接的第一个设备）。
电位 | 显示原理图图纸中的电位。
电线/电缆芯 | 显示原理图图纸中的电线（转至与该电线连接的第一个设备）。
设备型号 | 显示关联到此型号的符号并转至此符号（2D 布局图、布线符号、3D 设备）。
位置 | 打开位置属性对话框。
功能 | 打开功能属性对话框。


添加报表

报表管理器：添加

添加或移除工程中的报表配置。

对话框上方区域显示一系列筛选条件以便更轻松地搜索报表配置。

选中想要使用的报表配置框，然后单击确定按钮。

报表管理器将更新并显示提取数据的预览。

相关章节：

报表管理器

计划报表

生成报表图纸

导出 Excel

导出 TXT

导出 XML


计划报表

报表管理器：顺序

管理报表的启动顺序。

使用下降和上升图标管理报表的启动顺序。

报表将按放置到列表中的顺序生成。

相关章节：

报表管理器

所有报表

生成报表图纸

导出 Excel

导出 Txt

导出 XML


生成报表图纸

此命令可使您生成或更新报表图纸。

报表管理器：生成图纸

在文件集级别生成报表。如果工程包含文件夹，则单击报表右侧的 [...] 按钮，然后选择所需的目标文件夹（可以多选）。

勾选您想要生成报表旁边的框，然后单击确定来创建报表。

文件集或文件夹的右键菜单：在此绘制报表

选择配置...：打开一个对话框，您可以在其中管理要生成为图纸的报表。

工程的所有报表：将所有工程生成为清单。

更新所选报表：如果在此文件夹或文件集内已经包含报表，此选项将激活。使用此选项更新图纸。

相关章节：

报表管理器

所有报表

计划报表

导出 Excel

导出 Txt

导出 XML


导出 Excel

报表管理器：导出 Excel

使用报表配置将工程数据导出至 Excel 文件。

首先，向导会要求您选择要导出的报表。

第 1 步。导出 Excel

导出所有报表：选择此选项以导出所有报表。或者使用列表选择您想要导出的报表。

步骤 2

每个分隔一页：根据报表中定义的分隔生成一页图纸。

添加已创建文件到工程：激活此选项时，将在工程的存储目录中创建 XLS 文件并且作为附件添加到工程中（如果已存在，则进行更新）。如果未激活此选项，将在您定义的目录中生成文本文件。

目标文件夹：输入文件的目标目录。单击 [...] 按钮。如果您激活了将已创建文件添加到工程选项，您必须选择工程中某个文件夹或文件集。如果未激活此选项，您必须选择一个目录。

打开文件：在应用程序中打开与 XLS 文件关联的生成文件。

步骤 3。完成

单击完成开始生成 Excel 文件。

如果导出的 XLS 文件在工程文档中，那么当您运行某些命令（例如打印、导出到 PDF 文件或新建校对）时，这些文件将自动更新。还可以使用其右键菜单中的更新导出的报表进行更新。

相关章节：

报表管理器

添加报表

计划报表

生成报表图纸

导出 TXT

导出 XML


导出 TXT

报表管理器：导出 TXT

以 TXT 文件形式生成数据。

将已创建文件添加到工程：在工程的存储目录中创建 TXT 文件并将其作为附件添加到工程中（如果已存在，则进行更新）。如果未激活此选项，将在您定义的目录中生成 TXT 文件。

目标文件夹：输入文件的目标文件夹。单击 [...] 按钮。如果已激活将已创建文件添加到工程选项，您必须在工程中选择某个文件夹或文件集。如果未激活此选项，您必须选择一个本地目录。

导出所有报表：选择此选项以导出所有报表。您也可以在列表中选择要导出的报表。

在第一行里包含列标题: 在文件的第一行生成数据库字段的名称。

文本标识符、文本分隔符和文件类型是文本格式参数。应根据文件将导入到的软件的要求进行选择。

勾选打开文件框以在创建后打开生成的文件。

如果导出的 TXT 文件在工程文档中，那么当您运行某些命令（例如打印、导出到 PDF 文件或新建校对）时，这些文件将自动更新。还可以使用其右键菜单中的更新导出的报表进行更新。

相关章节：

报表管理器

添加报表

计划报表

生成报表图纸

导出 Excel

导出 XML


导出 XML

报表管理器：导出 XML

导出 XML 可使您以文本格式生成数据。

将已创建文件添加到工程：在工程的存储目录中创建 XML 文件并将其作为附件添加到工程中（如果已存在，则进行更新）。如果未激活此选项，将在您定义的目录中生成 XML 文件。

目标文件夹：输入文件的目标文件夹。单击 [...] 按钮。如果已激活将已创建文件添加到工程选项，您必须在工程中选择某个文件夹或文件集。如果未激活此选项，您必须选择一个本地目录。

导出所有报表：选择此选项以导出所有报表。您也可以在列表中选择要导出的报表。

打开文件：在与 XML 文件关联的应用程序中打开生成的文件。

如果导出的 XML 文件在工程文档中，那么当您运行某些命令（例如打印、导出到 PDF 文件或新建校对）时，这些文件将自动更新。还可以使用其右键菜单中的更新导出的报表进行更新。

相关章节：

报表管理器

添加报表

计划报表

生成报表图纸

导出 Excel


添加到篮

为帮助您管理材料报价，特定的报表配置允许您将材料列表导出为 Excel、TXT 或 XML 文件。

菜单：处理 > 添加到篮

您可以为每个位置或每个工程导出材料列表。选择要导出材料列表的位置。

全选：选择所有工程位置。

导出 Excel：将列表导出到 Excel 文件。

导出 Txt：将列表导出到 TXT 文件。

导出 XML：将列表导出到 XML 文件。

更新产品详细信息：更新 Web 服务中设备型号的价格和库存状况列。

添加到篮命令使用报表功能在 Excel、TXT 或 XML 文件中导出数据（请参阅这些章节了解更多信息）。


验证工程

使用 DesignSpark Electrical 时，软件可能会生成错误的数据，例如分配给文件夹的图纸不存在或分派给位置的设备已被删除。验证工程功能不检查电气设计错误。

要修复数据库错误，您可以使用验证工程功能。

菜单：工具 > 验证工程

使用此功能之前，建议压缩工程。

在图纸中，将纠正或移除不一致的实体。将自动修复图纸文件中的错误。

在该流程结束时，将打开一个对话框显示纠正操作的结果。建议您检查纠正操作以适应所需的工程（移动的图纸、删除的电线或设备等）。


打印管理器

菜单：工程 > 打印

可停靠面板 > 工程的右键菜单： 打印

可停靠面板 > 文件集的右键菜单： 打印

从文件集的右键菜单运行此命令时，将仅打印此文件集内选中的图纸。

可将打印设置保存到一个配置文件中，以供将来使用。您可以随意创建多个配置文件。

打印预览：打开选定图纸的打印预览窗口。

从所选项中删除：从所选项中删除选定的图纸。

打印多种配置：使用多种不同配置打印图纸。

列表模式：显示图纸列表。

缩略图模式：显示图纸的缩略图预览。

配置：管理对话框中项目的显示设置。

打印设置

允许选择之前创建的打印配置文件以加载所需的打印设置。单击 [...] 按钮以访问打印配置文件管理器。

页面设置

定义打印机以及页面大小。属性按钮允许您访问打印机设置。

导出 PDF 文件

勾选此框以将选中图纸生成为 PDF 格式。

方向

定义页面方向。

图纸

允许您访问对话框，以便选择要打印的图纸。

副本

定义要打印的副本数量和装配体模式。

比例

允许选择所需的比例系数（建议选择校准格式选项）。

绘制类型

允许您选择绘制类型。DesignSpark Electrical 中使用的所有颜色可有打印色彩和线宽。因此您可以将绘制类型用于设置打印时的颜色和线宽。如果不更改样式，将应用与工程中所使用颜色相同的颜色。使用单色打印机时，打印为灰色。

如果您要使用不同的配置打印工程图纸，请从列表选择配置文件。然后选择要使用此配置打印的图纸。根据需要对其他配置文件重复此操作。单击打印多种配置图标，然后勾选要打印的配置。

相关章节：

管理打印配置文件

导出 PDF


管理打印配置文件

打印管理器：打印配置 > [...]

管理打印配置文件。这些文件包含打印参数和图纸选择集。

使用右侧的按钮创建、复制或删除配置文件。

相关章节：

打印管理器


导出图纸

可以使用 DWG 或 PDF 格式导出图纸。

所有导出的图纸不能还原为 DesignSpark Electrical 能够识别的图纸，只能作为附件。

  • 导出 DWG 文件

  • 导出 PDF 文件


导出 DWG 文件

DesignSpark Electrical 中创建的所有图纸均以 EWG 格式存储。这些图纸可导出为各种版本 DWG/DXF 格式，以便在其他机构之间共享数据，即使这些机构没有自己的 DesignSpark Electrical。

EWG 名称由 DesignSpark Electrical 自动生成且与工程图纸名称无关。请勿重命名工程目录下的 EWG 文件。这将导致 DesignSpark Electrical 文件完整性丢失。

菜单：导入/导出 > 导出 DWG 文件

将打开一个对话框，可使您为 DWG 文件选择一个目录。

图纸可导出为能够反映工程结构方式的树结构，如同在可停靠面板中显示的一样。

文件夹和文件

基础文件夹路径：允许您选择要导出的文件夹/目录图纸。

文件夹名称格式：使用格式管理器格式化主文件夹/目录的名称。

文件名格式：使用格式管理器格式化生成的文件名称。

导出后打开文件夹：选择此选项后，在导出过程结束时，将在以上定义的基础文件夹/目录中打开文件浏览器。

导出所有图纸到一个文件：组合所有选定图纸以导入至一个文件。每个图纸都放置在一个 DWG 展示模式（图纸空间）中。

格式和版本

选择生成的文件格式（DXF 或 DWG）和文件版本。

要导出的图纸

选择要导出的图纸。[...] 按钮将打开图纸选择器，所有选项将选中工程中的所有图纸。

图纸样式：图纸样式按钮让您能够更改文本和颜色对象的设置。如果您未为工程分配图纸样式配置文件，则将显示一则消息通知您。

相关章节：

导出 PDF

附件


导出 PDF 文件

以 Acrobat (PDF) 格式生成工程图纸。

菜单：导入/导出 > 导出 PDF 文件

可停靠面板 > 工程的右键菜单： 导出 PDF 文件

可停靠面板 > 文件集的右键菜单： 导出 PDF 文件

从文件集的右键菜单运行此命令时，将仅导出此文件集内选中的图纸。

以 PDF 格式导出使用内部程序，而且不必安装 PDF 打印机，这与 PDF Creator 等不同。

PDF 导出功能使用打印管理器。

首先，选择 PDF 文件将要保存到的目录。可参考章节打印管理器了解此对话框的使用方法。

创建书签和超链接：在 PDF 文件内的页面中创建导航链接。您也可以使用可停靠面板内文档和设备选项卡中的内容创建书签列表。如果链接在报表配置中管理，则报表还可以集成这些链接。

按文件集导出 PDF：如果工程包含多个文件集，选中此选项以在导出结束时在文件创建目录打开文件浏览器。如果工程只包含一个文件集，PDF 文件在导出后打开。

相关章节：

打印管理器


管理数据

DesignSpark Electrical 一直连接至数据库。某些数据特定于当前工程，其他数据特定于应用程序，如制造商目录或数据库管理器。

创建原理图和使用不同流程时，将自动更新工程数据。

应用程序数据（数据库或目录）用于创建原理图绘图。还可用于添加工程数据。

不建议使用不同数据库编辑软件来修改 DesignSpark Electrical 以外的这些数据。 DesignSpark Electrical 带有的工具允许您添加信息至数据库（如数据导入或符号创建）。DesignSpark Electrical 的每个新版本均可包含自动添加到现有数据的新数据。

  • 查找管理器

  • 数据安装

  • 数据库管理器

  • 原理图数据

  • 目录


查找管理器

菜单：工具 > 搜索

此命令允许您搜索特定工程元素，如设备或图纸。

运行命令时，对话框将打开。

搜索的目标类型：勾选与要查找元素对应的框。

标注：输入您要查找的元素的标注。

说明：输入您要查找的元素的说明。

1. 单击搜索按钮开始搜索。

与您输入的搜索条件对应的标注的列表显示在对话框的中心。

对话框的右侧显示选定元素的预览区域。

打开选定元素的图纸。

允许您在可停靠面板中查找设备型号列表中的设备型号。

打开选定元素的属性对话框。

元素的右键菜单使您可以在设备树中进行查看，或打开找到元素位置的图纸。


数据安装

运行完整的安装或重新安装程序将会创建名为 UPDATE 的临时目录，将在其中储存所有数据库、制造商目录、报表配置、配置文件。然后，用户可以选择更新数据的方式。

启动 DesignSpark Electrical 后，只要名为 UPDATE 的临时文件夹存在，便会显示一个向导，以帮助用户管理数据更新进程。

如果取消更新，下次启动 DesignSpark Electrical 时此选项会自动显示。

数据类型选择

向导的第二个屏幕允许您选择要更新的数据类型。

勾选要包括在更新进程中的数据类型。

强烈建议一开始就选定所有数据类型。

单击下一步继续，或者取消选中要排除在更新进程之外的所有数据类型。

更新助手会将当前数据与最先安装数据进行比较。

选择每种数据的动作类型。

动作定义

可以使用 Shift - Ctrl - Ctrl+A...键对所列数据进行多项选取。

添加：已安装版本中不含有此数据，将被添加。

替换：使用最新数据替换原有数据。

不操作：不安装新数据，保留原数据。

全部保留：保留原数据，并且新数据采用新名称安装。

更新：此选项仅对制造商目录（电缆和设备）有效。目录型号会自动更新。

推荐使用默认操作类型；这根据以下规则进行定义。

- 新数据将添加。

- 如果现有数据已修改，将自动标注为不操作。

- 如果数据仍然存在且用户未更改，但是新文件已被软件开发商标注为“已更新”，则将标注为已替换。

- 电缆和设备目录始终标注为已更新。

数据类型

符号 - 图框：助手会显示元素的名称、说明、修改日期，以及创建/修改当前元素用户的名称。如果用户想要保留原数据，再安装相同元素的最新数据，请为新数据指定一个新名称。

电缆和制造商目录：统一管理目录（所有制造商目录型号）。如果型号不存在，将自动添加。如果型号存在并且用户已做过修改，新型号数据则不添加。如果型号存在且用户未做过任何修改，但已被软件开发商更新，则自动安装新型号并覆盖已有型号。

工程模板：仅添加新模型和已被软件开发商（根据修改时间的不同）修改的模型。用户创建的模型将被保留。

配置文件：只有新增的配置文件和由开发商修改过的配置文件（根据修改时间的不同）将安装。用户创建的配置将被保留。

控制面板：只有新增的控制面板和软件开发商修改过的控制面板（根据修改时间的不同）将安装。用户创建的控制面板将被保留。

开始数据安装

助手的最后一个选项卡显示要管理数据类型的总结。

单击完成按钮开始安装。此过程根据要处理的数据量将会占用不同的时间。

安装完成后，UPDATE 目录将自动移除。

相关章节：

安装


数据库属性

数据库管理器

菜单：数据库 > 数据库管理器

数据库管理器允许您管理所有应用程序的数据库。它不特定于当前工程。

新建：允许您添加新的数据库。

删除：从列表中选择要删除的数据库，然后单击删除图标。仅删除数据库。不删除其内容（如符号、图框和型号）。

属性：允许您编辑数据库的特性、其名称、说明和所包含对象的类型。

配置：允许您管理该对话框中项目的显示设置。

相关章节：

数据库属性

数据库

数据库配置


数据库属性

数据库管理器：属性

数据库管理器：新建

打开选定的“数据库属性”对话框，然后命名数据库、应用说明并向其分配数据库类型。

输入数据库名称和说明，然后选择与此数据库中所含对象类型对应的选项。

相关章节：

数据库管理器


图形数据

图形数据存储在管理器内集中的数据库中。图形数据管理器（如符号管理器）允许编辑现有元素和添加新数据。

这些管理器具有通用功能，如导入 DWG 文件或压缩/解压缩文件功能。

  • 图形命令

  • 多重标注

  • 管理器配置

  • 分类选择器

  • 导入 DWG 文件

  • 压缩/解压缩

  • 图框管理器

  • 符号管理器

  • 宏管理器


图形命令

命令共分为五组：

  • 用于管理文件的命令

  • 用于创建图形实体的命令

  • 尺寸命令

  • 用于编辑图形实体的命令

  • 管理器

相关章节：

图框

符号

2D 布局图


文件管理命令

文件管理命令允许您管理外部文件和 DesignSpark Electrical 文件。

  • 新建

  • 打开

  • 另存为

  • 关闭

  • 打印

  • 页面设置

  • 打印预览

  • 退出

  • 保存


新建

菜单：文件 > 新建

新建 DWG 文件并在图形区域的新选项卡中将其打开。


打开

菜单：文件 > 打开

打开对话框可选择现有 DWG 文件。

对话框打开后，文件将显示在图形区域的新选项卡上。


页面设置

菜单：文件 > 页面设置

启用“打印设置”对话框，以便设置活动 DWG 文件或 DesignSpark Electrical 文件的打印参数。

打印机

名称：选择您想使用的打印机。如要访问 Windows 打印机参数，请单击属性按钮。

状态：显示已选打印机的状态。

类型：显示打印机类型（此信息来自打印机参数）。

放置：显示打印机所连接的端口。

注释：显示与打印机关联的注释（此信息来自打印机参数）。

纸张

尺寸：在列表中选择由打印机管理的预定义纸张格式。

来源：在列表中选择要使用的纸张来源。

英寸/毫米：选择用于管理打印文件的单位。

打印区域：以所选单位显示打印区域的尺寸。

打印偏移

居中绘制：勾选此框以在打印页面上居中。

X：输入水平偏移值。

Y：输入垂直偏移值。

纸张方向

纵向/横向：选择页面方向。

反向打印：如要打印对称图形实体，请勾选此框。

打印比例

在列表中选择预定义比例或者键入具体比率（打印单位 = 文件单位）。校准格式设置将图形实体根据所选纸张大小调整至合适尺寸。

打印区域

选择以下之一选项：

显示：实体按照屏幕上的显示方式打印。

全部范围：所有文件实体都打印在纸张部分中定义的页面上。

限制：文件限制中包含的所有实体也将打印。

绘图样式表格

图形实体上使用的每一种屏幕颜色都与纸张上的颜色和宽度对应。如果您不使用绘图样式表格，则纸张上的屏幕颜色和线宽将不变。

您可以使用绘图样式表格来自定义关联。

在列表中选择要使用的绘图样式表格。

您可以通过单击修改绘图样式表格文件编辑选定的绘图样式表格。在打开的对话框中，您可以关联各个屏幕颜色、打印颜色和宽度。

在绘图样式表格列表中，如果您选择无并勾选打印线宽框，则屏幕和纸张上的颜色和线宽将不变。

网络：允许您访问网络打印机。

预览：以在页面上打印后的状态显示图形实体。


打印预览

菜单：文件 > 打印预览

使用在页面设置中设置的选项，显示活动 DWG 文件或 DesignSpark Electrical 文件的图像。

您可以在 DWG 文件或 DesignSpark Electrical 图纸上使用打印预览。

打印：打印当前文件。

页面：尚未实施。

缩放：选择页面显示缩放。

页数：允许您显示一个或多个页面。

参数：打开页面设置以修改打印参数。

关闭预览：退出预览窗口，不打印文件。


打印

菜单：文件 > 打印

打印活动 DWG 文件或 DesignSpark Electrical 文件。

打印设置对话框将打开，以调整打印参数。

单击确定后，文件将发送至打印机。


保存

菜单：文件 > 保存

保存活动文档。

如果当前文件为 DWG 文件且尚未保存，则以新名称、新的文件格式或新文件夹保存活动文档的对话框就会出现。

如果当前文件为 DesignSpark Electrical 图纸，则不必使用保存命令。文件关闭时将自动保存。


另存为

菜单：文件 > 另存为

以新名称、新文件格式或新文件夹保存活动文档。

不要将另存为（“文件”菜单）用于 DesignSpark Electrical 图纸。


关闭

菜单：文件 > 关闭

关闭活动文档。

注意：您可以单击“文件”菜单或图形区域右上角的关闭。

如果您已打开并修改 DWG 文件并单击关闭，则保存至...对话框将询问您在关闭之前是否要保存文件。

关闭 DesignSpark Electrical 图纸时，应用程序将自动保存文档，然后再关闭。


退出

菜单：文件 > 退出

退出软件。

如果您已打开并修改 DWG 文件并单击退出，则另存为...对话框将询问您在退出之前是否要保存每个打开的文件。

如果您已打开并修改 DesignSpark Electrical 图纸并单击退出，则应用程序将在退出之前自动保存文档。


绘图参数

绘图参数对话框为特定于当前文件的所有设置进行分组。可以是 DWG 文件或原理图图纸。

菜单：显示 > 绘图选项

右键单击状态栏

对象捕捉模式

每个图形实体都拥有特定点，这些点可用于编辑或放置其他实体。例如，一条线有两个端点和一个中点，一个圆有一个圆心和四个象限点。

绿色图标表示每个模式的标注形式。

在列表中选择要使用的模式。

激活对象捕捉：激活或禁用特定点的使用。您还可以在状态栏上单击 OSNAP，或者按 F11。

图纸

通过在状态栏中单击参数或使用键盘快捷方式，您可以开启或关闭正交和网格等参数。

捕捉开启 (F9)：让您的光标捕捉到最佳位置，且一定不要与网格设置混淆。

网格开启 (F7)：在图纸中显示或隐藏网格。

正交开启 (F8)：打开或关闭正交阀，这可在 X 或 Y 轴上固定光标移动。

开启线宽 (F10)：打开或关闭线宽，这将显示或隐藏各种线宽。

显示消隐边框：显示或隐藏消隐轮廓线。

捕捉间距：在两个虚拟捕捉点之间定义空格。

网格间距：在两个虚拟网格点之间定义空格。

线型比例：您可以根据当前文件中使用的单位修改线外观。仅复杂线型（如轴和不连续）受此参数影响。线型上使用的比例系数可增大或减小空格和线。

测量系统：定义测量的单位系统。

网格区域：定义网格显示所在的区域坐标。您还可以单击该按钮并以图形方式定义此区域。


绘图命令

您可以通过绘图菜单创建组中的命令创建 2D 图形实体。

带有这些命令的图形仅用于图形目的。由于这些命令不受工程数据库管理，因此不会受数据处理命令的影响。

您可以使用这些命令创建图框、符号、2D 布局图等。但是，不得使用绘制命令生成电气原理图。

  • 线

  • 多线

  • 弧

  • 圆

  • 椭圆

  • 椭圆弧

  • 矩形

  • 云

  • 填充

  • 消隐

  • 附加图像

  • 插入图像

  • 添加文本

  • 多行文本

  • 超链接

  • 标注

  • 创建块

  • 插入块


线

菜单：绘制 > 线

在当前活动文档中创建一系列线段。

由于线段不受工程数据库管理，因此不要使用线或线系生成电气原理图。

每条线段有两个可移动的端点。创建线时，请采用以下方式定义其端点：

*单击该文档以动态定义端点。

*指定端点坐标以手动定义端点。

创建一系列线后，您可单独编辑或移动每条线段。编辑或移动线时，您仅可动态重新定位线及其端点。

文档中出现新线实体时，可停靠面板将显示可用选项。

结束命令。

撤消上一操作。

键盘输入：允许您输入以逗点分隔的 X 和 Y 坐标（如150,125）；输入以“<”分隔的距离和角度（如150<45）；还可以输入到前一个点的相对坐标（如@10,150）。

关闭：末段的最后一个点对应首段的第一个点且创建了一个封闭区域。


多线

菜单：绘制 > 多线

绘制一连串定义多线的线段或弧。所有的直线或弧构成一个实体。多线可使用指定宽度。第二个实体的第一个点对应第一个实体的第二个点。

文档中出现新多线时，可停靠面板将显示可用选项。

结束命令。

撤消上一操作。

键盘输入：允许您输入以逗点分隔的 X 和 Y 坐标（如150,125）；输入以“<”分隔的距离和角度（如150<45）；还可以输入到前一个点的相对坐标（如@10,150）。

线：允许基于最后所绘制实体的最后一个点绘制线段。

弧：允许基于最后所绘制实体的最后一个点绘制弧。在面板下方选择弧位置选项。

宽度：允许对下一个实体设置特定宽度。此宽度将应用于之后的所有实体。

关闭：最后一个实体的最后一个点对应第一个实体的第一个点且创建了一个封闭区域。

此实体类型不得用于生成电气原理图。使用此命令的图形实体不受工程数据库控制。


弧

菜单：绘制 > 弧

绘制一个弧形。

通过指定三个点来定义新弧的位置。

结束命令。

键盘输入：允许您输入以逗点分隔的 X 和 Y 坐标（如150,125）；输入以“<”分隔的距离和角度（如150<45）；还可以输入到前一个点的相对坐标（如@10,150）。

选项：在面板下方选择弧位置选项。

此实体类型不得用于生成电气原理图。使用此命令的图形实体不受工程数据库控制。


圆

菜单：绘制 > 圆

绘制一个圆。要绘制一个圆，需先定义中心点和圆周上的一点。

文档中出现新圆时，可停靠面板将显示可用选项。

结束命令。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。

半径：输入圆半径长度或者单击图形区域的另一点。

此实体类型不得用于生成电气原理图。使用此命令的图形实体不受工程数据库控制。


椭圆

菜单：绘制 > 椭圆

绘制一个椭圆。要在活动文档中定位一个椭圆，要先定义中心点，然后确定实体的两个轴。

可停靠面板将显示可用选项。

结束命令。

输入坐标：为 X 和 Y 坐标输入值。两个坐标之间必须用逗点分隔（如150,125）。

距离：输入第一和第二个椭圆轴的长度。

此实体类型不得用于生成电气原理图。使用此命令的图形实体不受工程数据库控制。


椭圆弧

菜单：绘制 > 椭圆弧

要在活动文档上绘制椭圆弧，需定义中心点、椭圆的两个轴和圆弧的两个端点。

可停靠面板将显示可用选项。

结束命令。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。

距离：输入第一和第二个椭圆轴的长度。

此实体类型不得用于生成电气原理图。使用此命令的图形实体不受工程数据库控制。


矩形

菜单：绘制 > 矩形

绘制一个矩形。

要定位活动文档中的矩形，请定义对角线尺寸，或者在可停靠面板中指定其长度和宽度。

结束命令。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。

尺寸：输入对应其长度和宽度的值。

旋转：输入对应角度的值（单位：度）。

此实体类型不得用于生成电气原理图。使用此命令的图形实体不受工程数据库控制。


云

菜单：绘制 > 云

绘制由连续圆弧组成的特定形状。例如，它们用于在校对步骤中引起对图形展示的注意。使用多语言文本注释校对云。

可使用三种不同形式表示该云：矩形、椭圆或徒手画。可直接在功能区中选择这些形式，或者在插入过程中在可停靠面板中选择。

结束命令。

撤消上一操作。

形状：选择要使用的形状。根据您选择的形状，命令选项会有所不同。

输入坐标：为 X 坐标和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。

云半径：指定连续圆弧线段的半径。

指定矩形模式的选项

尺寸：输入与其长度和宽度相对应的值（仅可用于矩形模式）。

旋转：输入与其角度相对应的值，以度为单位（仅可用于矩形模式）。

指定椭圆模式的选项

距离：输入第一和第二个椭圆轴的长度（仅可用于椭圆模式）。

指定徒手画模式的选项

弧/线：选择要绘制的实体类型。弧模式在可停靠面板底部显示其他放置选项。

宽度：输入线/弧的宽度。

关闭：关闭窗体。结束点与起始点的坐标相同。

此实体类型不得用于生成电气原理图。使用此命令的图形实体不受工程数据库控制。


填充

菜单：绘制 > 填充

您可以在打开的填充对话框中通过所选填充模式，在绘图实体内部或实体之间选择填充区域。

您可以在文档中选择定义填充区域的实体，然后单击填充。或者，您可以在单击填充对话框中的选择对象之后，选择实体。

选择对象：您可以选择具体化要填充区域轮廓的对象。

类型：选择预定义模式或用户定义。

图案：此选项仅在已选中预定义时可用。请选择图案类型。

颜色：请选择图案颜色。

角度：请选择图案角度。

比例：此选项仅在已选中预定义时可用。请选择图案比例。

间距：此选项仅在已选中用户定义时可用。输入两条线之间的距离。

双倍：此选项仅在已选中用户定义时可用。如要添加垂直填充，请选择此选项。

单击确定后，填充将自动生成。

不能使用此实体类型来生成电气原理图。使用此命令的图形实体不受工程数据库控制。


消隐

菜单：绘制 > 消隐

定义一个盖住或隐藏其他实体的多边区域。

要实施消隐，需要先定义起点，然后确定该形状的各个后续点。

结束命令。

返回至上一界面。

撤消上一操作。

单击图形区域的区域顶点或者输入坐标。区域后端添加的图形元素将隐藏（不删除）。使用修改菜单中的顺序命令管理实体和消隐的相对位置。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。


附加图像

菜单：绘制 > 附加图像

打开一系列对话框中第一个，并将工作台上存储的图像链接至活动文档。附加后，链接图像预览出现在文档中。

您可在打开的对话框中管理附加的图像。

附加：允许您附加图像文件。选择文件后，会打开一个用于定义插入参数的对话框。

移除：从列表中删除所选图像文件引用并从活动文档移除预览图像。

要压缩含有附加图像的工程，需要使用数据文件命令将附加图像文件添加至工程。


插入图像

菜单：绘制 > 插入图像

打开一系列对话框中的第一个，并将工作台上存储的图像插入到文档中。插入的图像将成为文档文件的一部分。

插入点：设置插入点的坐标。选择稍后指定可在图形区域中插入图像时设置插入点。

比例：设置比例系数。选择稍后指定可在图形区域中插入图像时设置比例系数。

旋转：设置旋转角度。选择稍后指定可在图形区域中插入图像时设置旋转角度。


添加文本

菜单：绘制 > 添加文本

打开创建文本对话框，在文档中插入一行文本。

文本：输入要在当前文件中插入的文本字符串。文本不能为空。

文本选项

对齐：定义文本对齐。

文本样式：定义文本样式。单击文本样式管理器可访问文本样式定义。

旋转：设置旋转角度。选择稍后指定可在图形区域中插入文本时设置旋转角度。

高度：设置文本高度。选择稍后指定可在图形区域中插入文本时设置文本高度。

倾斜角：定义倾斜文本的角度值（以度为单位）。

宽度系数：在扩大文本时保持文本高度。

颠倒：插入可垂直翻转的文本。

反向：插入可水平翻转的文本。

插入点

设置文本坐标。选择稍后指定可在图形区域中插入文本时设置插入点。

注意：与通过多语言文本插入命令添加的文本不同，通过添加文本（绘制菜单）添加的文本不显示在工程数据库中。


多行文本

菜单：绘制 > 多行文本

打开对话框以插入多行块文本。

当前工具菜单的文本样式管理器中所选的文本样式可控制多行文本的外观。

一个对话框将打开，您可以输入文本。

注意：与通过多语言文本插入命令添加的文本不同，通过多行文本（绘制菜单）添加的文本不显示在工程数据库中。


标注

菜单：绘制 > 标注

打开一个对话框以创建标注。标注通常可让您在每次插入块时添加不同文本。

对话框允许您创建标注。

标注

名称：标注名称。块定义中的标注名称必须唯一。

提示：用于在您插入含标注的块时显示提示消息。

值：包含标注的默认值。

模式

隐藏：用于在您插入块时隐藏标注值。

固定：用于在您插入块时在标注中应用固定值。

确认：用于在您插入块时确认值。

预定义：用于在您插入块时恢复默认值。

文本选项

对齐：定义标注对齐。

文本样式：定义文本样式。文本样式管理器允许您访问文本样式定义。

旋转：设置旋转角度。选择稍后指定可在图形区域中插入标注时设置旋转角度。

高度：设置标注高度。选择稍后指定可在图形区域中插入标注时设置标注高度。

倾斜角：定义倾斜文本的角度值（以度为单位）。

宽度系数：允许在不改变文本高度的条件下放大文本。

颠倒：插入可垂直翻转的标注。

反向：插入可水平翻转的标注。

插入点

设置标注坐标。选择稍后指定可在图形区域中插入标注时设置插入点。


创建块

菜单：绘制 > 创建块

在活动文档中创建已命名的实体块或群，您可以向文档中多次插入它们。

已命名块将仅显示在活动文档的块定义表格中。因此，您只能将已定义块用于当前文件。

结束命令。

返回至上一界面。

选择块实体后，一个对话框将打开，您可以在其中输入块参数。

名称：块名称。该名称必须在 DWG 文件中唯一。

选择对象

保持为独立实体：将所选实体保持为单独实体。这些实体不会转换为块。

转换为块：将所选实体转换为块。

删除：删除所选实体。您可以使用插入块命令来重新插入这些实体。

基点

输入插入点坐标或者选择在屏幕上指定选项（关闭对话框时，必须单击图形区域中的插入点）。


插入块

菜单：绘制 > 插入块

在文档中插入已命名块或实体组。

控制功能将启用对话框序列，您可以添加当前块定义表中所指定的块，或者将外部 DWG 文件的块内容插入到文档中。

如果块中含有标注，您可以在向活动文档插入块时编辑标注。

浏览：您可以选择您工作台中存储的 DWG 文件。此文件中包含的所有实体都已插入。

块名称：如果激活此选项，您必须选择要插入的块的名称。

分解：分解已插入的块。构成块的所有实体都可单独插入。

插入点

设置插入点的坐标。选择稍后指定可在图形区域中插入块时设置插入点。

比例

设置比例系数。选择稍后指定可在图形区域中插入块时设置比例系数。如果已选择分解，则此设置不可用。

旋转

设置旋转角度。选择稍后指定可在图形区域中插入块时设置旋转角度。

不能使用块插入来生成电气原理图。使用此命令的图形实体不受工程数据库控制。


尺寸命令

通过绘制菜单中尺寸组中的命令，您可以向 2D 布局图纸添加尺寸。

尺寸命令使用尺寸样式设置，您可以通过尺寸样式管理器管理该设置。

  • 线性尺寸

  • 对齐尺寸

  • 直径尺寸

  • 半径尺寸

  • 纵向尺寸

  • 角度尺寸


线性尺寸

菜单：绘制 > 线性尺寸

在平行线上创建 X-Y 轴尺寸。

结束命令。

单击对应于第一个延长线起点的点或者输入坐标。

单击对应于第二个延长线起点的点或者输入坐标。

单击尺寸线位置。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。


对齐尺寸

菜单：绘制 > 对齐尺寸

创建尺寸并使其平行于连接两个选定原点的直线。

结束命令。

单击对应于第一个延长线起点的点或者输入坐标。

单击对应于第二个延长线起点的点或者输入坐标。

单击尺寸线位置。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。


直径尺寸

菜单：绘制 > 直径尺寸

创建弧或圆的直径尺寸。

结束命令。

确认选择。

在图形区域中选择一个圆或弧并指定尺寸位置。


半径尺寸

菜单：绘制 > 半径尺寸

创建弧或圆的半径尺寸。

结束命令。

确认选择。

在图形区域中选择一个圆或弧并指定尺寸线位置。


纵向尺寸

菜单：绘制 > 纵向尺寸

创建测量两点间水平或垂直距离的尺寸。

结束命令。

定义测量的两点并指定尺寸线位置。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。


角度尺寸

菜单：绘制 > 角度尺寸

创建角度尺寸。

结束命令。

确认选择。

选择角度的两条线并指定尺寸线位置。


修改命令

使用修改菜单上的编辑和更改组中的命令，您可以操作一系列现有实体。

注意：您可以使用修改命令更改电气实体。注意：这些更改将自动更新工程数据库的实体记录，其方式与电气原理图的绘图规则不一致。因此，您不必使用全部修改命令来对电气原理图进行更改。

  • 属性

  • 画笔

  • 阵列

  • 清除

  • 移动

  • 多项复制

  • 偏移

  • 旋转

  • 比例

  • 镜像

  • 圆角

  • 拉伸

  • 修剪

  • 延伸

  • 块对齐

  • 距离

  • 清除

  • 分解

  • 图层

  • 多重标注

  • 编辑标注

  • 编辑文本

  • 编辑填充

  • 更新尺寸

  • 顺序 - 设置最前端

  • 顺序 - 设置最后端

  • 顺序 - 下移实体

  • 顺序 - 上移实体


画笔

菜单：修改 > 画笔

将一个实体的属性复制到另一实体。

更改一个或一组实体的‘画笔’属性时，可停靠面板将显示可用选项。

结束命令。

确认选择。

选择设备型号实体，然后选择将在其中应用复制属性的实体。

不得在电气原理图上使用画笔命令。


清除

菜单：修改 > 清除

删除所选实体。

删除实体时，可停靠面板将显示可用选项。

结束命令。

确认选择。

选择要删除和确认的实体。您也可以选择实体并按 [Del] 键。

注意：对所有符号、电线和其他电气原理图应用此命令时，系统将自动更新项目数据库。


移动

菜单：修改 > 移动

将选定实体按指定距离和方向移动。

结束命令。

确认选择。

选择要移动的实体，然后指定基点坐标（源）和终点坐标（目标）。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。

距离：您可以为动作输入长度。使用此句法 (Line length<Angle)。示例：100<45 将所选实体移动 100 个单位且角度为 45°。

此命令用于电气实体（如符号和电线）时，工程数据库将自动更新。


多项复制

菜单：修改 > 多项复制

为所选实体创建多个副本。

在活动文档中插入多个副本时，可停靠面板将显示可用选项。

结束命令。

确认选择。

选择要复制的项目，然后指定基点（源）和终点（目标）。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔。示例：150,125。

距离：您可以为副本输入长度。使用此句法 (Line length<Angle)。示例：100<45。

此示例表示将所选实体复制 100 个单位且角度为 45°。

注意：对符号、电线和其他电气原理图实体使用此命令时，工程数据库将会自动更新。


阵列

菜单：修改 > 阵列

以水平和垂直模式创建选中实体的多个副本。

添加阵列时，可停靠面板将显示可用选项。

结束命令。

确认选择。

行：输入您想要的行数量（垂直副本数量）。

列：输入您想要的列数量（水平副本数量）。

对象选择：单击此按钮并选择要复制的实体。

行偏移：输入每个复制实体之间的距离，或者单击此按钮以图形形式定义此距离。

列偏移：输入每个复制实体之间的距离，或者单击此按钮以图形形式定义此距离。

注意：对所有符号、电线和其他电气原理图应用此命令时，系统将自动更新工程数据库。


旋转

菜单：修改 > 旋转

根据基点修改实体的方向。

结束命令。

确认选择。

选择要处理的实体，然后单击图形区域中的一个点或者输入一个值，以指定基点和旋转角度。

指定旋转角度：输入角度值（单位：度）。

此命令用于电气实体（如符号和电线）时，工程数据库将自动更新。


比例

菜单：修改 > 比例

更改所选实体在 X、Y 方向上的比例大小。

更改所选实体大小时，可停靠面板将显示可用选项。

结束命令。

确认选择。

选择实体。

输入坐标：在图形区域中单击或者使用其坐标指定基点。

标注：如果您想要将比例系数应用到图框标注，则选中保留相同尺寸选项。

请输入轴的比例系数：选择所需模式（缩小或放大），然后通过单击图形区域指定第二点或输入比例系数值。

不得在电气原理图中使用比例来更改实体属性。


镜像

菜单：修改 > 镜像

使用指定的对称轴为所选实体创建反向副本。

添加所选实体的镜像时，可停靠面板将显示可用选项。

结束命令。

确认选择。

选择要处理的实体，再指定对称轴的两个端点，然后选择是否清除源对象。

输入坐标：为 X 和 Y 坐标输入值。这两个坐标之间必须用逗点分隔（如150,125）。

距离：为线输入长度。使用此句法 (Line length<Angle)。示例：100<45 绘制一条长度为 100 单位且角度为 45° 的线。

删除源对象：移除原实体。

注意：对符号、电线和其他电气原理图实体使用此命令时，工程数据库将会自动更新。


圆角

菜单：绘制 > 圆角

使用指定半径的弧连接两条相交的线。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

调整/不调整：允许切断（不切断）弧末端的线。

修改半径：允许输入弧半径。

选择您想要添加圆角的两条线。


偏移

菜单：修改 > 偏移

创建同心圆、平行线或平行弧线。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

根据现有实体或给定点创建指定距离外的新实体。

偏移定义

通过点：单击原实体和副本之间距离对应的两个点。

距离：输入原实体和副本之间的距离。

选择要复制的实体，然后单击一个点以表示您想要复制实体的侧边目标位置。

此命令用于电气实体（如符号和电线）时，工程数据库将自动更新。


拉伸

菜单：修改 > 拉伸

移动实体上的选定点。

如果只选中实体的一部分点，则未选中的点仍留在当前位置。因此，您可以通过移动所选点来拉伸实体。

如果选中实体上的所有点，则您可以移动整个实体。

结束命令。

确认选择。

拉伸命令仅移动选择窗口内的点。不能修改选择窗口外的点。选择窗口内的所有对象都将移动。选择要拉伸的点，然后指定基点和终点。

距离：为距离输入长度。使用此句法 (Length<Angle)。示例：100<45 绘制一条长度为 100 单位且角度为 45° 的线。


修剪

菜单：修改 > 修剪

修剪活动文档中与其他实体相交或重叠的实体。

允许结束命令。

确认选择。

选择用作修剪限制的实体，然后选择要修剪的实体。


延伸

菜单：修改 > 延伸

延伸一个实体以使其与另一个实体接触或相交。

延伸实体时，可停靠面板将显示可用选项。

结束命令。

确认选择。

选择限制延伸的实体，然后选择要延伸的实体。


块对齐

菜单：修改 > 块对齐

将选定块与参考块对齐。

第一步是选择参考块。可停靠面板将显示可用选项。

结束命令。

确认选择。

选项

最近：根据选定块的插入点位置，将其垂直或水平移动。使用与其位置最近的轴。

水平：选定块的插入点与水平轴对齐。

垂直：选定块的插入点与垂直轴对齐。

选择其中一个选项，然后选择您想与参考块对齐的块。

将与参考块的插入点进行对齐。


距离

菜单：修改 > 距离

测量两点之间的距离。

测量两点之间的距离时，可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

单击图形区域中的两点。

会出现一则显示距离、角度和 X 与 Y 轴偏移值的消息。


清除

菜单：修改 > 清除

允许您删除文档定义表中无用的线块、文本样式、线型和其他元素。清除 DWG 文件可降低或优化文件大小。

对话框中显示了可清除和不可清除的元素。

如果元素未在 DWG 文件中使用，则可清除该元素。

在该对话框中选择要清除的元素。您可以使用多选键（Ctrl、Shift）。

清除 DWG 文件时，“清除”对话框中将显示可用选项：

确认删除每个元素：选定后，每次删除将打开一个消息框。您必须确认每次删除。

清除嵌套元素：选定后，任何嵌套元素（依赖于其他元素的元素）也将被删除。

清除选择：清除选定元素。

全部清除：清除所有元素，无论是否选择。

不得在包含电气原理图的文档中使用清除（修改菜单）。


分解

菜单：修改 > 分解

将一个块分解为构成实体。

结束命令。

确认选择。

选择要分解的块。如果此块包含标注，则标注值丢失。

不得在电气原理图中的实体上使用分解（修改菜单）。


图层

菜单：修改 > 图层

通过打开的对话框您可以管理当前 DWG 文件的图层。每个 DWG 文件都有无数个图层。

管理 DWG 文件中的图层时，图层管理器对话框中将显示可用选项。

添加图层：创建新图层。您可以在名称列中更改图层名称。

删除选择：删除所选图层。不能删除包含实体的图层。

将选定图层设置为当前图层：在列表中选择一个图层，以将其分配为当前图层。当前图层即为您要在其上绘制的图层。它在列表中以特殊图标标识。

每个图层都默认与颜色、线型和线宽相关联。在此图层上绘制的实体将默认使用这些参数。您可以通过单击对应于图层的单元格来选择上述项。

您可以隐藏图层以查看和打印。

活动/非活动：图层中置入的实体处于隐藏状态，无法打印。

冻结/解冻：此命令的图形功能类似于活动/非活动命令。

对于大文件而言，建议使用活动/非活动命令。所有实体的显示会更快。

打印：定义图层可否打印（隐藏图层无法打印）。

不得在包含电气原理图的文档上使用图层（修改菜单。


编辑标注

菜单：修改 > 编辑标注

在包含块的文档中，系统将显示对话框，以允许您对所选块的标注属性进行编辑。

编辑块标注时，可停靠面板将显示启动对话框的要求。

结束命令。

确认选择。

选择块。对话框中将显示块标注的列表。

块名称：显示块名称。

添加标注：您可以添加新标注。列表末尾将会添加一个新行。您可以修改新标注的属性。

删除标注：删除选定标注。

您可以修改与标注相关的所有参数。

关闭对话框时，块标注将自动更新。

不得在电气原理图中的实体上使用编辑标注。


编辑填充

菜单：修改 > 编辑填充

在包含已填充区域的文档中，您可以更改选定填充区域的选项。

允许结束命令。

确认选择。

打开的对话框显示填充选项，您可以修改特性。

类型：选择预定义模式或用户定义。

图案：此选项仅在已选中预定义选项时可用。请选择图案类型。

颜色：请选择图案颜色。

角度：请选择图案角度。

比例：此选项仅在已选中预定义选项时可用。请选择图案比例。

间距：此选项仅在已选中用户定义选项时可用。输入两条线之间的距离。

双倍：此选项仅在已选中用户定义选项时可用。如要添加垂直填充，请勾选此框。

对话框关闭时，填充将自动更新。


更新尺寸

菜单：修改 > 更新尺寸

将所选尺寸更新为当前尺寸样式。如果您在使用此命令前未选择新的默认尺寸样式，则系统不会更新。

更新尺寸样式时，可停靠面板将显示当前的默认尺寸样式。

结束命令。

尺寸使用当前样式中定义的参数。

选择要更新的尺寸。


顺序 - 设置最前端

菜单：修改 > 顺序 > 设置最前端

将选定实体拉拽至相对于其他实体的最前端。

将实体拉拽至最前端时，可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

选择要设置为最前端的实体。


顺序 - 设置最后端

菜单：修改 > 顺序 > 设置最后端

相对于活动文档中其他所有实体，将所选实体推动至最后端。

将实体推动至最后端时，可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

选择要设置为最后端的实体。


顺序 - 下移实体

菜单：修改 > 顺序 > 下移实体

将第一组所选实体推动到第二组所选实体后面。

将第一组实体推动到第二组实体后面时，可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

首先选择最前端中的已绘制实体，然后选择最后端中的已绘制实体。


顺序 - 上移实体

菜单：修改 > 顺序 > 上移实体

将第一组所选实体拉拽到第二组所选实体前面。

将第一组实体拉拽到第二组实体前面时，可停靠面板将显示可用选项。

固定命令，以确保该命令在首次使用后持续有效。

首次使用后停止命令。

结束命令。

返回至上一界面。

首先选择最后端中的已绘制实体，然后选择最前端中的已绘制实体。


图形格式管理器

所有 DWG 文件和 DesignSpark Electrical 图纸都可以包含线、文本和尺寸。您可以通过线型、文本样式和尺寸样式的保存定义控制这些元素的外观。您还可以设置新建、自定义定义并编辑现有定义。

通过“工具”菜单的图形格式组中的命令，您可以管理各种实体的格式。

  • 线型管理器

  • 文本类型管理器

  • 尺寸类型管理器


线型管理器

菜单：工具/线型

打开“线型管理器”对话框，对话框中列出了您能够用于 DWG 文件或电气原理图中的当前可用线型。

当前可用线型显示于列表中。由于每个文档的可用线型数量要单独设置，因此各文件的列表可能不同。

您可以使用以下选项管理活动文档的线型。

加载：此按钮将打开您可以在文件中使用的全部线型的列表。线型存储在 XLIN 文件中，您可以通过单击打开按钮来选择此文件。在此列表中，选择要导入到当前文件的线型。

删除选择：删除所选线型。DWG 文件（或电气原理图）中使用的线型无法删除。

将选定线型设置为当前线型：在 DWG 文件（或电气原理图）中将所选线样式定义为当前线样式。


加载线型

菜单：工具 > 线型 > 加载

该软件仅将选定线型加载至每个 DWG 文件或电气原理图。因此，各文档的可用线型列表可能不同。

如果想使用活动文档中不可用的已定义线型，您可以加载默认 XLIN 文件中所列线型或者导入自定义 XLIN 文件中的线型。

打开：打开 XLIN 文件。

加载选择并关闭：选择要导入到管理器的线型。对话框关闭后，线型将自动添加至管理器列表。

全部加载并关闭：全部线型将导入到管理器。对话框关闭时，线样式将自动添加到管理器列表中。


文本样式管理器

菜单：工具 > 文本样式

打开文本样式管理器对话框，对话框中列出了您能够用于 DWG 文件或电气原理图中的当前可用文本样式。您选择新文本样式时，所有向活动文档添加文本的命令都使用既定样式。由于您必须为每个文档定义文本样式，因此不同文件或工程的可用样式列表不尽相同。

请使用以下选项选择活动文档的当前文本样式，或者查看、添加、编辑或从可用样式列表中删除文本样式：

添加文本样式：添加新的文本样式。列表末尾将会添加一个新行。您可以更改其名称和参数。

删除选择：删除所选文本样式。您不能删除 DWG 文件（或电气原理图）中使用的文本样式。

将选定样式设置为当前样式：在 DWG 文件（或电气原理图）中将所选文本样式定义为当前。


尺寸样式管理器

菜单：工具 > 尺寸样式

打开尺寸样式管理器对话框，对话框中列出了您能够在 DWG 文件或电气原理图中使用的尺寸样式。

选择一个当前新建尺寸样式时，所有向活动文档添加尺寸的命令都使用此定义样式。此外，使用更新尺寸（修改菜单）更新的尺寸将更改为当前新尺寸样式。由于您必须为每个文档定义尺寸样式，因此不同文件或工程的可用样式列表不尽相同。

要选择当前尺寸样式，或者要查看、添加、编辑或从可用样式列表中删除尺寸样式，请使用以下一个选项：

设置为当前：在 DWG 文件（或电气原理图）中将所选尺寸样式定义为当前。

新建：允许您添加新的尺寸样式。您可以通过对话框命名尺寸样式并选择现有基本样式。

修改：允许您修改所选尺寸样式参数。显示所有尺寸样式设置的对话框打开。

比较：比较两个尺寸样式。

删除：删除所选尺寸样式。您不能删除 DWG 文件（或电气原理图）中使用的尺寸样式。


新建尺寸样式

菜单：工具 > 尺寸样式 > 新建

启动对话框序列，以创建新的尺寸样式。

新建样式：定义新尺寸样式的名称。该名称必须在 DWG 文件（或电气原理图）中唯一。

复制自：选择一个现有尺寸文件。此现有尺寸样式的所有设置均将复制到新尺寸样式中。

关闭“创建”对话框时，“尺寸样式编辑”对话框将允许您修改尺寸样式参数。


修改尺寸样式

菜单：工具 > 尺寸样式 > 修改

打开修改尺寸样式对话框，以编辑和预览现有尺寸样式。此对话框还可设置新尺寸的参数。

对话框的右侧显示所选尺寸样式的预览。

线和箭头

尺寸线：定义尺寸线的颜色和宽度。基线间距参数暂不可用。

延长线：定义延长线的颜色和宽度。您还可以控制延长线的位置和长度。

箭头：定义箭头大小。

文本

文本外观：定义具体化尺寸值的文本的颜色、样式和高度。

文本位置：定义具体化尺寸值的文本的位置。

文本对齐：定义具体化尺寸值的文本的对齐。

调整

调整选项：优化尺寸位置。

调整：定义小尺寸。

尺寸对象比例：定义分配给尺寸对象的比例系数。

主单位

线性尺寸：为线性尺寸定义精度和分隔符。

测量比例：定义所有尺寸的比例系数（真实值 x 比例系数 = 显示值）。

角度尺寸：定义角度尺寸的测量模式和精度。


比较尺寸样式

菜单：工具 > 尺寸样式 > 比较

打开比较尺寸样式对话框，对话框上显示两个选定尺寸样式之间的差异。

选择您要比较的两个尺寸样式。

对话框中显示了不同的项目。


管理器配置

无论打开哪个管理器，除内容外，以下所述功能对所有管理器通用。

配置

符号管理器：配置

图框管理器：配置

宏管理器：配置

一个对话框将打开，您可以输入管理器显示的不同配置参数。

列表模式

对话框左侧允许选择在“列表”模式下显示的列。

缩略图模式

缩略图尺寸：输入缩略图尺寸。

2 个缩略图的间距：输入缩略图的间距：宽度和高度。缩略图上显示的说明或名称将显示于此区域。请在两个缩略图间留有足够的空间。

缩略图下方的文本：选择要显示的文本类型。

显示缩略图：如果不想显示属性（用于传输数据），请勾选此框。

缩略图模式/列表模式

符号管理器：列表模式/缩略图模式

图框管理器：列表模式/缩略图模式

2D 布局图管理器：列表模式/缩略图模式

宏管理器：列表模式/缩略图模式

列表模式：以列表形式显示数据。右键单击列标题可选择要显示的列。左键单击列标题，您便可以对此列排序。

缩略图模式：以图形形式显示数据。

在每个模式下，右键菜单都允许您访问该元素的多项可用功能。

显示子类内容

数据库中生成的元素所拥有的标准可用于将其分类（在左侧区域中，参阅带树形结构形式的列表）。在树形结构列表中选择某个分类时，右侧列表将简化为只显示与此选定分类对应的元素。

如果勾选显示子类内容框，对话框还会显示此分类子类中包含的元素。

编辑符号 - 图框 - 宏时关闭管理器

编辑某个元素（符号、图框）以修改其图形时，您可以保留管理器对话框的打开状态或将其关闭。

相关章节：

图框管理器

符号管理器

宏管理器


分类选择器

符号管理器 > 属性：分类名称

图框管理器 > 属性：分类名称

宏管理器 > 属性：分类

制造商零件选择器：分类

编辑符号、宏或图框时，分类选择器允许您选择与此元素关联的分类。

分类选择器将自动调整以适应元素类型。

在制造商零件选择器对话框中，分类被用作搜索条件。


压缩/解压缩

无论打开哪个管理器，除内容外，以下所述功能对所有管理器通用。

此功能不应与工程压缩/解压功能混淆。此处生成的压缩包（TEWZIP 文件）包含一个或多个元素（符号、图框），这些元素可以在其他工作台解压缩。TEWZIP 文件中的元素将在解压缩过程中自动保存在数据库中。此功能应在（如两个公司间）交换符号时使用。

符号管理器：压缩（解压缩）

图框管理器：压缩（解压缩）

宏管理器：压缩（解压缩）

压缩

1. 选择要压缩的元素。

2. 单击压缩图标。

一个对话框打开，允许您保存压缩文件。

解压缩

一个对话框打开，允许您选择 TEWZIP 文件以进行解压缩。更新数据助手会自动打开。请参阅压缩/解压缩章节了解更多信息。

相关章节：

图框管理器

符号管理器

宏管理器

压缩/解压缩


导入 DWG 文件

无论打开哪个管理器，除内容外，以下所述功能对所有管理器通用。以下章节将向您展示导入符号的方法。导入图框时这些功能也通用。

要填充数据库（如符号和图框），您可以导入 DWG 格式的文件。

符号管理器：导入 DWG 文件

图框管理器：导入 DWG 文件

导入助手的显示方式因要导入的元素而不同。

第 1 步。符号（图框）导入向导

添加文件：打开“文件选择”对话框。您可以选择包含符号或图框的 DWG 文件或压缩文件 (ZIP)。

添加文件夹：打开“目录选择”对话框。此文件夹/目录中的所有 DWG 文件将添加到导入助手中。

删除：删除列表中选定的元素。

要继续下一步，请单击下一步。

步骤 2。符号（图框）起点

导入配置：让您可以选择一个包含导入参数的配置文件。

信息

已创建用于显示要导入元素的列表。

步骤 3。导入新符号（图框）

导入助手显示要导入元素的列表。

全选：允许您选择列表中显示的所有符号。

属性：打开所选符号（图框）的属性对话框。当您选择多个符号（图框）时，对话框将只显示共同属性。您可以通过双击来编辑符号（图框）属性。

操作：在列表中选择您要分配给该符号（图框）的操作。

名称：显示符号（图框）名称。

说明：可以通过编辑属性添加说明。

单位系统：在列表中选择符号（图框）绘制的单位系统。

分类：您可以将分类关联至所选元素。

数据库：选择要在其中存储元素的数据库。

修改日期：显示导入的日期。

步骤 4。转换标注

下一步涉及将该软件所管理的标注与导入元素中可能存在的标注相关联。

替换为：单击 [...] 按钮以选择新标注。

操作：选择所需选项（替换/删除/不操作）。

步骤 5。保存设置

此助手的最后一步允许您保存导入所用的各种设置。这些参数可以重复用于新的导入过程。

保存导入配置

如果已使用配置文件，您可以对其进行更新。如果未使用配置文件，您可以在新配置文件中保存设置。

单击完成以导入元素，或者单击取消以取消导入。这是允许您取消导入的最后一个对话框。

相关章节：

图框管理器

符号管理器

宏管理器


图形管理器

符号、2D 布局图、图框存储在名为 Managers 的特定数据库中。在这些管理器中，您可以创建自己的元素。

这些元素可在一个图形界面中打开，以修改其图形展示。您可以添加标注，以延伸项目数据库中存储的信息。

  • 图框管理器

  • 符号管理器

  • 宏管理器

  • 标注管理


标注管理

符号和图框标注传输数据库中存储的信息。 DesignSpark Electrical 提供工具来帮助您管理标注。

  • 插入标注

  • 多重标注

  • 标注属性

  • 替换标注

  • 标注管理工具

  • 管理修订版属性


插入标注

符号、2D 布局图和图框标注传输数据库中存储的信息。特定的界面允许您进行选择并将其插入到图形区域中。

菜单：编辑符号 > 插入标注

菜单：编辑图框 > 插入标注

启动命令时，对话框将列出可用的标注。

已存在于符号或图框中的标注显示为蓝色。

1. 选择所列标注旁边的复选框将使其可用于插入到符号或图框中。

2. 单击确定可关闭对话框并显示标注插入可停靠面板。

您可在此面板更改放置前应用到标注的设置（如字体和高度）。

属性

允许您水平或垂直放置标注、为标注定义字体设置、对齐、高度和其他属性以及定义每个标注之间的间距。

标注列表

添加一个新标注。

删除选定标注。

重新排列标注。

3. 在图形区域中，单击标注组的插入点。

相关章节：

标注属性


多重标注

标注作为符号、图框和 2D 布局图（块）中的特殊文本字符串存在。它包含标签（名称）、提示（说明）和值（要显示的文本）。

标注用于传输工程信息或软件数据库。有时这些数据表示为定量长度的文本，这可能妨碍原理图的设计。

多重标注命令允许根据现有（单一）标注创建多重标注，它的值可以分多行文本来显示。

菜单：修改 > 多重标注

菜单：编辑符号 > 多重标注

菜单：编辑图框 > 多重标注

在图形界面中选择一个要转换为多重标注的单一标注。

可停靠面板将更改，以显示创建选项。

设置为多重标注

标注数：输入数据所延伸的行数。

标注间距：输入两个标注之间的距离，以指定行间距。

在屏幕上指定位置：如果标注数参数大于 2，则取消选中此框以自动一上一下放置标注。否则，您需要单击每个标注的插入点。

标注名称已修改。后缀 {n} 位于末端，n 等于多重标注的序号。

输入要延伸至下一行多重标注的信息时，字符 | 必须用作行分隔符，例如：断路器 | 四极 | 4P 3D


标注属性

标注属性的名称和文本定义可以修改。

标注右键菜单：属性

标注属性显示在属性可停靠面板上。

基本信息

输入标注名称及其说明。

标注名称很重要。 DesignSpark Electrical 使用标注名称将工程数据延伸到插入的标注。如果软件无法识别该名称，则不会显示相关信息。

几何图形

在此部分中可输入文本设置。文本设置将在插入标注时使用。


替换标注

此功能允许您将选定标注替换为另一个标注。

标注右键菜单：替换标注

菜单：编辑符号 > 替换标注

菜单：编辑图框 > 替换标注

1. 在图形区域中选择您要替换掉的标注。

2. 在标注选择器对话框中，选择新标注。

此功能仅在您选择标注时可用。


标注管理工具

显示标注

菜单：编辑符号 > 显示标注

菜单：编辑图框 > 显示标注

为简化标注管理（例如位置或文本大小），此功能允许您在图形区域中显示不同样式的标注。这仅改变图形外观，而不会修改名称。

显示标注：显示标注名称或允许您显示隐藏的标注。

显示示例值：将标注替换为其可接收的示例值。在此模式中，您无法编辑标注属性。

显示标注说明：将标注替换为其说明。在此模式中，您无法编辑标注属性。

隐藏标注：隐藏标注。

手动修改标注

软件中有一些标注由指示语言、索引或数据索引的特定字符组成。

#AIO_0_TZ_1_L1：标注类型（在此示例中为输入/输出）。

#AIO_0_TZ_1_L：标注类型中的序号（在此示例中，第一个输入/输出）。

#AIO_0_TZ_1_L1：与上一值关联的可译用户数据 1（在此示例中，第一个输入/输出的第一个可译数据）。

#AIO_0_TZ_1_L1：上一值的语言（在此示例中，第一个输入/输出的第一个可译数据的语言）。

系数：上一代码定义的标注类型中的序号的索引字符。0 是第一个， 1 是第二个...

数据索引：遵循标识数据类型（TX：用户数据和 TZ：可译用户数据）的代码的数据索引字符。0 将拓展第一个用户数据（或可译用户数据）的值，1 将拓展第二个用户数据（或可译用户数据）的值...

语言：L1 拓展工程主语言中的文本，L2 第二语言...您可以通过将这些字符替换为相应的语言代码 (EN - FR - ES...) 来强制更改语言。例如，如果您想要文本始终以英语显示（无论工程语言是什么），则将该字符替换为 EN。

您可以使用一些命令来管理这些代码。将根据您选定的标注类型显示这些命令。

修改索引：允许您更改标注类型的序号。在对话框中，输入新的索引。

修改 TX/TZ 数据索引：允许您更改用户数据或可译数据数。在对话框中，输入新的数据索引。

修改语言代码：允许您更改用户数据或可译数据语言。在列表中选择工程所用的一种语言或选择另一语言，即使未在工程配置中设置该语言。

修改校对系数：允许您更改校对的索引代码。在对话框中，输入新的校对索引（仅在图框上可用）。

标注列表

要生成包含所有符号和图框标注的 Excel 文件，请使用 ewExportUsedAttributes 命令（仅在命令行中可用）。


管理修订版属性

修订版属性显示在图框的修改网格中并且可在图框编辑器中对其进行管理。

菜单：编辑图框 > 修改校对索引

修订版属性的右键菜单：修改校对系数

每个修订版属性具有一个可以是正值（绝对模式）或负值（相对模式）的系数。

标注模式

相对：将从当前修订版计算系数。系数“-0”显示当前修订版系数。“-1”则显示上一修订版系数。

例如，在 0AB 模式下，如果当前修订版是“E = sixth index”，则“-2”系数将延伸至修订版系数“C = fourth index”(6-2=4)。

配置设置使您可以选择修订版系数的位置：

- 在图纸修改网格的底部

- 根据修订版属性的位置

绝对：系数对应于修订版系数。系数“0”对应于第一个修订版系数，系数“1”对应于第二个修订版系数。要在图纸中显示修订版系数，您必须在图框的修改网格中插入其相应的属性。

系数：在绝对模式下，它仅显示负值。在相对模式下，它仅显示正值。根据选定模式，该值对应于您所需的系数。


插入点管理

对于符号，插入点与用于插入到原理图的虚拟点对应。通常，这与电线的设备连接点对应。

对于图框，插入点与图框左下角对应。通常，为确保数据完整性（交叉引用位置和跳转极性），我们建议您将图框插入点置于坐标‘0,0’。

菜单：编辑符号 > 插入点（符号）

菜单：编辑图框 > 插入点（图框）

单击与图形界面中插入点对应的点。一个红色斜叉号表示此点。


图框管理器

图框管理器集中了可用于设计原理图的所有图框。图框具有分类的筛选条件。

菜单：数据库 > 图框管理器

“图框管理器”对话框将打开。这允许您添加、编辑或删除图框。

管理器左侧部分有两个选项卡。

分类

此选项卡显示树中的图框分类。

对话框左侧显示图框分类。对话框右侧显示当前选定分类中的图框。

筛选器

此选项卡允许您筛选图框列表。所有筛选条件都与图框属性中显示的相同。

对话框右侧显示与选定条件对应的图框。

移除筛选器：单击此按钮可移除所有筛选条件。

管理器的右侧显示与选项对应的图框或您在管理器左侧输入的搜索条件。

图框显示为列表形式（列表模式图标）或缩略图形式（缩略图模式图标）。

其中一些功能接受多选，例如删除或属性。

新建：允许您添加数据库中的新图框。

打开：打开图形界面上或 DraftSight 中的选定图框进行修改。

导入 DWG 文件：允许您导入 DWG 文件为图框。

删除：删除选定图框。

属性：打开选定图框的属性对话框。如果您选择多个图框，则属性对话框将只显示共同属性。

预览：打开“预览”对话框中的图框。此界面不允许进行修改。

剪切：将选定图框的副本置于 DesignSpark Electrical 剪切板并删除源图框。

您也可以使用以下快捷方式：[Ctrl] + [X]

复制：将选定图框的副本置于 DesignSpark Electrical 剪切板并保留源图框。复制命令还可用于将选定元素列表复制到其他应用程序中，例如 Excel（仅限列表模式）。

您也可以使用以下快捷方式：[Ctrl] + [C]

粘贴：粘贴 DesignSpark Electrical 剪切板上的图框。新图框已创建。

您也可以使用以下快捷方式：[Ctrl] + [V]

全选：允许您选择管理器右侧显示的所有图框。

列表模式：以列表形式（名称、说明、分类）显示图框。在此模式中，您可以将选定元素列表复制到其他应用程序中，例如 Excel。

缩略图模式：以缩略图预览的形式显示图框。

配置：允许您管理该对话框中项目的显示设置。

压缩：选择想要压缩的元素，然后单击压缩图标。

一个对话框打开，允许您保存压缩文件。

解压缩：一个对话框将打开，您可在其中选择 TEWZIP 以进行解压缩。更新数据助手会自动打开。请参阅压缩/解压缩章节了解更多信息。

显示下级内容：勾选此框后，将显示选定分类的子类中包含的所有对象。

保持对话框开启：选中此选项后，当您打开对象时对话框不会关闭。

  • 添加新图框

  • 图框属性

  • 编辑图框图形


添加新图框

图框管理器：新建

图框属性对话框将打开，其中显示了其参数。

此时只创建了特性。您必须在编辑器中打开图框，以便创建图形。

要创建与现有图框相似的新图框，请使用复制和粘贴命令，然后修改副本。

相关章节：

图框属性

编辑图框图形


图框属性

图框管理器：新建

图框管理器：属性

打开“属性”对话框，以修改与图框相关联的数据。

如果图框已存在，该对话框左侧将显示编辑模式的预览（包含标注）。

如果您选择多个图框，将仅显示共同属性。

基本信息

名称：定义图框名称。此名称必须唯一。

说明：定义软件中管理的所有语言的文本说明。此说明显示在缩略图下方。单击特定图标可以将说明设置为所有语言。语言选择器将打开，您便可以选择所需语言。

分类：定义存储图框的分类。

单位系统：定义图框模式。该选择非常重要。从此图框中的图纸创建的图框和原理图必须使用相同的单位系统。创建新符号时，DesignSpark Electrical 将使用与您选定的单位系统相对应的模板文件。

数据库：定义存储图框的数据库。

系统

此部分为只读部分。显示有关创建或修改日期和创建者姓名的信息。

行

带行：激活图框中的行管理。

第一行标注：允许标注第一行。第一行以下的行将自动标注。

第一行位置：允许在第一行中输入 Y 坐标。

行高：定义行高度。如果第一行位于图框顶部，最后一行位于图框底部，则在值前方放置‘-’标记。所有行必须高度相同。

行数：定义图框中的行数。

行编号：图框拥有多列时，请选择要使用的模式。

列

带列：激活图框中的列管理。

第一列标注：允许标注第一列。第一列以下的列将自动标注。

第一列位置：允许在第一列中输入 X 坐标。

列宽：定义列宽度。所有列必须宽度相同。

列数：定义图框中的列数。

选项

交叉引用偏移：定义父图表类型符号的交叉引用缩略图插入高度。

相关章节：

添加新图框

编辑图框图形


编辑图框图形

数据库中的图框由两部分组成：一个图形展示和存储在数据库中的一组参数。必须通过图框管理器插入图框，否则将无法通过该软件管理图框。

图框拥有标注，这样您便可以传输数据库中保存的工程数据。

图框管理器：打开

‘文档’选项卡 > 图纸的右键菜单 > 图框：打开

在图形界面中打开选定的图框。如果您尚未激活保持对话框开启选项，管理器对话框将关闭。如果未选择，可手动将其关闭或调整其大小。

编辑器打开时，功能区菜单发生变化。将显示编辑图框部分。

可停靠面板将显示图框属性。

通过以下步骤并使用 DesignSpark Electrical 来管理符号：

  • 插入点管理

  • 标注管理

关闭文件时，系统将要求您保存。

文件可以在 DraftSight 中打开，以编辑图形。

相关章节：

图形命令

添加新图框

图框属性

用户数据


符号管理器

符号管理器集合了可用于绘制原理图的所有符号。符号具有分类的筛选条件。

菜单：数据库 > 符号管理器

“符号管理器”对话框打开。这允许您添加、编辑或删除符号。

管理器左侧有以下两个选项卡：

分类

此选项卡将符号分类显示为树。

对话框左侧显示符号分类。对话框右侧显示当前选定分类中的符号。

显示下级内容：勾选此框后，将显示选定分类及其子类中包含的所有符号。

筛选器

此选项卡允许您筛选符号列表。所有筛选条件都与符号属性中显示的相同。

对话框右侧显示与选定条件对应的符号。

移除筛选器：单击此按钮可移除所有筛选条件。

管理器的右侧显示与选项对应的符号或您在管理器左侧输入的搜索条件。

符号显示为列表形式（列表模式图标）或缩略图形式（缩略图模式图标）。

其中一些功能接受多选，例如删除或属性。

新建：允许您添加新符号至数据库。

打开：在图形界面或 DraftSight 中打开选定符号以进行修改。

导入 DWG 文件：允许您导入 DWG 文件为符号。

删除：删除选定符号。

属性：打开选定符号的属性对话框。如果您选择多个符号，则属性对话框将只显示共同属性。

预览：打开预览对话框中的符号。此界面不允许进行修改。

剪切：将选定符号的副本置于 DesignSpark Electrical 剪切板并删除源符号。

您也可以使用以下快捷方式：[Ctrl] + [X]

复制：将选定符号的副本置于 DesignSpark Electrical 剪切板并保留源符号。复制命令还可用于将选定元素列表复制到其他应用程序中，例如 Excel（仅限列表模式）。

您也可以使用以下快捷方式：[Ctrl] + [C]

粘贴：粘贴 DesignSpark Electrical 剪切板上的符号。新符号已创建。

您也可以使用以下快捷方式：[Ctrl] + [V]

全选：允许您选择管理器右侧显示的所有符号。

列表模式：以列表形式（名称、说明和分类）显示符号。在此模式中，您可以将选定元素列表复制到其他应用程序中，例如 Excel。

缩略图模式：以缩略图预览的形式显示符号。

配置：允许您管理该对话框中项目的显示设置。

压缩：选择想要压缩的元素，然后单击压缩图标。

一个对话框将打开，您可以保存压缩文件。

解压缩：“文件选择”对话框打开，您可以选择 TEWZIP 文件进行解压缩。更新数据助手会自动打开。请参阅压缩/解压缩章节了解更多信息。

显示下级内容：勾选此框后，将显示选定分类的子类中包含的所有对象。

保持对话框开启：选中此选项后，当您打开对象时对话框不会关闭。

  • 添加新符号

  • 符号属性

  • 编辑符号图形


添加新符号

符号管理器：新建

符号属性对话框将打开，其中显示了其参数。

此时只创建了特性。您必须在编辑器中打开符号，以便创建图形。

要创建与现有符号相似的新符号，请使用复制和粘贴命令，然后修改副本。

相关章节：

符号属性

编辑符号图形


符号属性

符号管理器：新建

符号管理器：属性

打开符号的“属性”对话框，以修改与符号相关联的数据。

如果符号已存在，则对话框的左侧将显示编辑模式的预览（包含标注和设备连接点）。

根据选定符号，可以禁用几个属性。如果您选择多个符号，将仅启用共同属性。

基本信息

名称：创建符号时，名称将会自动添加。此名称必须唯一，并且您可以在必要时进行更改。

描述：用于说明符号。如果在数据库中选择缩略图模式，则说明文本会显示在缩略图下方。符号按说明的字母顺序排列。单击特定图标可以将说明设置为所有语言。语言选择器将打开，您便可以选择所需语言。

分类：定义在其中存储符号的分类。

符号类型：定义符号的类型：

多用途符号将对可插入原理图图纸中的符号分组。

布线方框图符号将对可插入布线方框图图纸中的符号分组。

黑盒符号将对可用于黑盒的符号分组。

端子符号将对表示端子的符号分组。

转移符号将对用于起点-终点管理的符号分组。

交叉引用符号将对用于表示交叉引用的符号分组。

电缆标注将对用于表示电缆标注的符号分组。

接线图符号将对用于表示接线图符号的符号分组。

电线标注将对用于放置电线标注的符号分组。

电位标注将对用于放置电位标注的符号分组。

位置标注将对用于放置位置标注的符号分组。

被动符号将对被动符号（即没有标注的符号）分组。这些符号存储在工程的数据库中，但处理或报告时不予考虑。

单位系统：定义绘制符号所用的单位模式。创建新符号时，DesignSpark Electrical 将使用与您选定的单位系统相对应的模板文件。

数据库：定义符号在其中分类的数据库。

设备型号

制造商：定义制造商名称。此参数不能与型号参数取消关联。

型号：关联 设备型号和符号。插入符号后，此设备型号自动关联到符号。单击 [...] 以分配设备型号。

系统

此部分为只读部分。显示创建/修改日期和创建者。

特性

标注源：显示在插入符号时要使用的标注源。如果未输入值，将使用带有分类的标注源。

关联的宏：将宏与符号关联。插入符号后，在可停靠面板中选择插入关联的宏命令，或者在设备的上下文菜单中选择设备选项卡。

标准：定义用于符号的标准。

交叉引用类型：定义符号的默认交叉引用等级。您可以在插入符号时进行修改。

选项

显示设备连接点：在原理图中显示设备连接点。

保持属性方向：选定后，标注将不随符号旋转。

相关章节：

添加新符号

编辑符号图形


编辑符号图形

数据库中的符号由图形展示和数据库中存储的一组技术特性组成。该软件不会生成未通过符号管理器插入的符号。该符号没有标注且无法与设备型号关联。

符号包含可在其上放置设备连接点的回路。这些设备连接点允许您切断电线。设备连接点还可用于传输设备型号所提供设备端子的数量。

符号也拥有标注（文本），这样便可在整个原理图中传递数据库中存储的特定信息（如标注或交叉引用文本）。

符号管理器：打开

符号上下文菜单：符号 > 打开符号

在图形界面中打开选定的符号。如果您尚未激活保持对话框开启选项，管理器对话框将关闭。如果未选择，可手动将其关闭或调整其大小。

编辑器打开时，功能区菜单发生变化。将显示编辑符号部分。

可停靠面板将更改，以显示符号属性和回路定义。

通过以下步骤并使用 DesignSpark Electrical 来管理符号。

  • 插入点管理

  • 回路管理

  • 连接点管理

  • 标注管理

关闭文件时，系统将要求您保存。

文件可以在 DraftSight 中打开，以编辑图形。

相关章节：

图形命令

添加新符号

符号属性

用户数据

设备型号

管理回路


回路管理

使用可停靠面板中的符号结构部分管理符号回路。

回路号码从 0 到“n”，一般是相对符号插入点自左向右（或自上向下）排列。此软件管理多种类型的回路，分别对应不同类型的电气设备。

符号回路必须匹配要与此符号关联之设备型号的回路。

菜单：编辑符号 > 新建回路

打开的对话框可让您选择回路特性。

数量：输入想要添加的回路数量。

回路类型：选择回路的类型。列表取决于符号的分类。要访问整个回路列表，请选择更多回路类型。

信息传送：定义回路是否必须允许某些信息通过，如相数或电位编号。

可中断：（只允许相数通过）。

在大多数原理图符号上使用。输入连接点与输出设备连接点之间的电位编号不同。

通过：（电位通过符号）

电位在两个连接点之间在通过回路处继续，但是对于回路的每个点，都有不同的布线方向。

Hyper 通过：（电位通过符号）

如果您希望使用已链接设备的两个或更多不同回路上的电位线号相同，并且拥有相同的回路和连接点数据（例如母线接线板分割为多段。电线不会通过回路），则使用 hyper 通过回路。

Hyper hyper 通过：（电位和电线通过符号）

Hyper hyper 通过回路最多连接拥有相同连接点细节（例如屏幕，将在这些点之间延伸电位）的两个或更多个符号。但是连接点在连接报表中未详细介绍，因为它们是透明的，就像电线直接连接到两个终端设备之间。典型的案例是跳转。

回路的属性显示在可停靠面板的下部。


设备连接点管理

在电线中插入符号时，设备连接点会自动切断连接线。同样当所绘制的线路穿过符号时，也会自动切断。此功能只在符号中含有设备连接点时有效。

在插入符号时，设备连接点需要与线路重合。设备连接点具有一个标注，可以关联设备型号设备端子编号。

菜单：编辑符号 > 设备连接点

有三种类型的设备连接点：

设备连接点（默认）：此设备连接点可用于所有符号，线路中断转移符号除外。

输入/输出设备连接点：这些设备连接点有方向（输入/输出），并且只能用于极性起点 - 终点符号。

插入连接点时，请确保捕捉选项为活动状态，并且解析齿距与符号回路间的距离以及两条电线之间的距离保持一致（例如电源线两相位间的距离）。

设备连接点放置的位置必须是符号切断电线的位置。

要插入连接点：

1. 请在可停靠面板中选择连接点所在的回路。

2. 在菜单中选择命令。

3. 按正确的方向转动连接点（在键盘上按空格键，以根据电线的角度旋转连接点）。

4. 在图形区域中单击连接点的插入点。

插入设备连接点后，会显示消息 (N:0-C:0)。C 后的数字代表回路的号码。N 后的数字代表此回路中的序号。

分配给 N 的值不重要；即使回路有两个设备连接点，您仍可使用 N:6。必须比较给定回路中 N 的所有值。随后，程序将根据 N 的不同值将所有回路的设备连接点分类。

对于回路 C1，允许有 N:1 和 N:4。N:1 代表回路中的第一个设备连接点，N:4 代表回路中的第二个设备连接点。分配设备型号的原理与分配设备端子上编号的原理相同。第一个设备端子号将关联到回路上的第一个设备连接点。第二个材料端子号将分配到回路上的第二个设备连接点，以此类推至所有设备的回路。

可以将一种端子类型关联到符号的连接点。但是，如果您在此符号上分配设备型号，则会应用该设备型号的端子类型。

使用右键菜单可编辑现有设备连接点。

多个设备连接点

菜单：编辑符号 > 多个设备连接点

除了同时创建回路，此命令类似于设备连接点命令，可帮助您在定义后放置所有设备连接点。

一个对话框将打开，以让您可以添加属于此符号的回路。

添加回路。

删除选定回路。

选择设备型号及其回路定义。此设备型号可与符号相关联。

添加回路类型，并在回路数量字段中指出数量。输入设备上的端子号以及每个回路的端子号。如果选择了设备型号，此数据将自动输入。单击确定确认并退出该对话框。

设备连接点附着于光标。根据可停靠面板中的说明一一放置设备连接点。


宏管理器

DesignSpark Electrical 具有一个数据库，您可以在其中存储原理图零件，该数据库称为宏。

宏在宏管理器中组合到一起，因此可用于所有工程。宏的筛选条件允许分类。

菜单：数据库 > 宏管理器

宏管理器对话框打开。这允许您添加、编辑或删除宏。

管理器左侧部分有两个选项卡。

分类

此选项卡将宏分类显示为树。

对话框左侧显示宏分类，右侧显示当前选定分类中的宏。

显示下级内容：勾选此框后，将显示选定分类及其子类中包含的所有宏。

筛选器

此选项卡允许您筛选宏列表。所有筛选条件都与宏属性中显示的相同。

对话框右侧显示与选定条件对应的宏。

删除筛选器：单击此按钮可移除所有筛选条件。

其中一些功能接受多选，例如删除或属性。

打开：宏被视为工程。单击“打开”图标后，宏将自动添加到可停靠面板的文档选项卡中。它被替换为星号，以避免在工程内混淆。双击图纸可显示宏，允许您在图形界面中打开。

删除：删除所选宏。

属性：打开宏属性的对话框。如果您选择多个宏，则属性对话框将只显示共同属性。

视图：打开“预览”对话框中的宏。此界面不允许进行修改。

剪切：将选定宏的副本置于 DesignSpark Electrical 剪切板并删除源宏。

您也可以使用以下快捷方式：[Ctrl] + [X]

复制：将选定宏的副本置于 DesignSpark Electrical 剪切板并保留源宏。复制命令还可用于将选定元素列表复制到其他应用程序中，例如 Excel（仅限列表模式）。

您也可以使用以下快捷方式：[Ctrl] + [C]

粘贴：粘贴 DesignSpark Electrical 剪切板上的宏。创建新宏。

您也可以使用以下快捷方式：[Ctrl] + [V]

全选：允许您选择管理器右侧显示的所有宏。

列表模式：以列表形式（名称、说明、分类）显示宏。在此模式中，您可以将选定元素列表复制到其他应用程序中，例如 Excel。

缩略图模式：以缩略图预览的形式显示宏。

配置：允许您管理该对话框中项目的显示设置。

压缩：选择想要压缩的元素，然后单击压缩图标。用于保存文件的对话框打开，可以保存压缩文件。

解压缩：“文件选择”对话框打开，您可以选择 TEWZIP 文件进行解压缩。更新数据助手会自动打开。请参阅压缩/解压缩章节了解更多信息。

显示下级内容：勾选此框后，将显示选定分类的子类中包含的所有对象。

保持对话框开启：选中此选项后，当您打开对象时对话框不会关闭。

要添加宏，请参阅创建宏章节。

相关章节：

宏属性

管理宏

图形命令


宏属性

宏创建

宏管理器：属性

打开宏的“属性”对话框，以修改与该宏相关联的数据。

如果您选择多个宏，将仅显示共同属性。

名称：该宏为自动命名。您可以更改其名称，但必须唯一。

层级结构

分类名称：单击 [...] 按钮打开分类选择器，然后选择要在其中排序的分类。

数据库：选择宏数据库。宏在宏数据库环境下插入。如果更改此类型，插入宏时您可能得到不一致的结果。

系统

此部分显示关于宏创建和修改的信息。

信息

在此部分，您可以使用此列表中可用的值更改宏类型。

它还显示关于宏版本的信息。

说明

允许您使用软件所管理的所有语言输入说明。

用户数据

允许您管理与宏关联的用户数据。

可译数据

允许您管理与宏关联的可译数据。


制造商目录

DesignSpark Electrical 包含电气设备型号和电缆型号。但是，您也可以输入自己的型号。

有两种不同的管理器可处理型号数据：一种用于设备型号，另一种用于电缆型号。

  • 电缆型号管理器

  • 设备型号管理器


列配置

菜单：数据库 > 电缆型号管理器 > 配置

菜单：数据库 > 设备型号管理器 > 配置

菜单：文件 > 工程管理器 > 配置

菜单：工程 > 报表（绘图规则检查） > 属性 > 列选项卡 > 配置

您可通过此命令显示或隐藏管理器或报表模板中的列。其内容根据管理器或报表模板的类型而不同。

勾选要显示的信息对应的框。


解压缩目录

菜单：数据库 > 电缆型号管理器 > 解压缩

菜单：数据库 > 设备型号管理器 > 解压缩

针对电缆目录和设备型号的解压缩命令提供了两个选项。

解压缩向导：允许您通过使用解压缩向导解压缩目录。允许您选择要更新的目录。

使用默认选项解压缩：允许您在不使用向导的情况下解压缩目录。将使用由解压缩生成的型号来系统地更新现有型号。


电缆型号管理器

所有电缆型号存储在单个数据库中。它们经分类且具有多个条件，以易于搜索。

菜单：数据库 > 电缆型号管理器

启动命令后，“电缆型号管理”对话框将打开。

对话框左侧的分类选项卡显示分类列表、型号分类的第一个标准。筛选器选项卡允许您搜索型号以进行操作，如修改其属性。

对话框右侧显示包含在选定分类中的型号列表或满足筛选条件的电缆列表。

其中一些功能接受多选，例如删除或属性。

新型号：要添加新电缆型号，请在管理器左侧部分选择某分类，然后单击新型号图标。您还可以在创建新型号时选择电缆型号（管理器的右侧）。此型号将自动接收选定型号的特性。

型号属性对话框打开，允许您对其进行修改。

多项插入：此命令与新型号命令类似，不同之处在于属性对话框不会在验证后关闭，而是询问您是否创建其他新型号。

导入：此命令允许导入自定义的型号列表，以将其集成到目录中。

删除：允许您删除选定型号。

属性：打开选定电缆型号的属性对话框。如果您选择多个电缆型号，则属性对话框将只显示共同属性。

剪切：将选定型号的副本置于 DesignSpark Electrical 剪切板并删除源符号。

您也可以使用以下快捷方式：[Ctrl] + [X]

复制：将选定型号的副本置于 DesignSpark Electrical 剪切板并保留源符号。复制命令还可用于将选定元素列表复制到其他应用程序中，例如 Excel（仅限列表模式）。

您也可以使用以下快捷方式：[Ctrl] + [C]

粘贴：粘贴 DesignSpark Electrical 剪切板上的型号。创建新型号。

您也可以使用以下快捷方式：[Ctrl] + [V]

全选：允许您选择管理器右侧显示的所有型号。

配置：允许您管理该对话框中项目的显示设置。

压缩：选择想要压缩的型号，然后单击压缩图标。

一个对话框将打开，您可以保存压缩文件。

解压缩：一个文件选择对话框将打开，您可在其中选择 TEWZIP 文件以进行解压缩。更新数据助手会自动打开。请参阅压缩/解压缩章节了解更多信息。

：用于从互联网访问可下载的设备型号压缩文件。这些文件包含最新的设备型号。

尺寸单位：在列表中选择要用于标出电缆尺寸的单位系统。

添加目录

可按目录中的制造商和制造商名称对电缆型号进行分类。并非所有电缆型号都包含在目录中。如果需要，可以从 Electrical Content Portal 下载它们。

在线内容：用于访问从网络下载的压缩文件。这些文件包括最新型号更新。

相关章节：

电缆属性

压缩/解压缩


电缆属性

电缆型号管理器：属性

电缆型号管理器：新型号

电缆型号管理器：多个插入

属性

基本信息

型号：表示型号的代码。

制造商：电缆品牌或制造商的名称。

分类：电缆所属分类。单击分类框以修改电缆所属的分类。然后，在对话框中选择分类。

物料编码：用户管理的内部信息。

外部 ID：外部 ID 用于将元素与外部应用程序中的对应元素进行链接。

数据库：选择电缆型号所在的数据库。

系列：选择或新建系列，以便于归类电缆型号。

标准：电缆标准。

系列：通常，电缆型号按系列分组。

说明：电缆说明。

供应商

供应商名称：允许您输入供应商名称。

物料编号：允许您输入供应商的物料编号。

信息

创建者：型号创建者名称（用户或系统）。

创建日期：创建型号时自动生成的日期。

修改日期：最后修改型号时自动生成的日期。

特性

电缆的相关信息，如颜色、直径、截面积或弯曲半径。对于预制电缆，您可以输入其长度。

ERP 数据

激活 ERP 连接时此部分可用。您可以在用户数据字段中输入特定值。此信息可用于更新您的个人数据库。

电缆芯

此选项卡可让您管理构成电缆的缆芯定义。

添加：在列表末端添加缆芯。

插入：在所选元素上方添加缆芯。

删除：删除所选缆芯。

向上/向下：重新排列缆芯。

分组/解组：将所选电缆芯（一对）分组或解组。

相关章节：

电缆目录

电缆型号管理器


设备型号管理器

所有设备型号存储在唯一的数据库中。它们经分类且具有多个搜索条件。

菜单：数据库 > 设备型号管理器

启动命令后，“设备型号管理器”对话框将打开。

对话框左侧分类选项卡显示不同分类的列表。分类的第一个条件是型号。筛选器选项卡允许您搜索设备型号以进行操作，如修改其属性。

对话框的右侧显示包含在选定分类中的设备型号列表。

有两个显示设备型号的选项。如果勾选自动刷新框，设备型号列表将自动显示。

如果您未选中自动刷新框，在您单击刷新按钮时将仅更新设备型号列表。

其中一些功能接受多选，例如删除或属性。

添加设备型号：复制您之前已选定的一个现有设备型号，以创建新的设备型号。最好选择与您想要添加的设备型号紧密匹配的设备型号，然后单击添加设备型号按钮。

多项插入：此命令与添加设备型号命令类似，不同之处在于属性对话框不会在验证后关闭，而是提示您创建其他设备型号。

导入：此命令允许导入自定义的型号列表，以将其集成到目录中。

删除：允许您删除选定的设备型号。

属性：打开设备型号属性的对话框。如果您选择多个设备型号，则属性对话框将只显示共同属性。

剪切：将选定设备型号的副本置于 DesignSpark Electrical 剪切板并删除源型号。

您也可以使用以下快捷方式：[Ctrl] + [X]

复制：将选定设备型号的副本置于 DesignSpark Electrical 剪切板并保留源型号。复制命令还可用于将选定元素列表复制到其他应用程序中，例如 Excel（仅限列表模式）。

您也可以使用以下快捷方式：[Ctrl] + [C]

粘贴：粘贴 DesignSpark Electrical 剪切板上的设备型号。创建新设备型号。

您也可以使用以下快捷方式：[Ctrl] + [V]

全选：允许您选择管理器右侧显示的所有设备型号。

配置：允许您管理该对话框中项目的显示设置。

压缩：单击压缩图标以选择想要压缩的设备型号。

用于保存文件的对话框打开，可以保存压缩文件。

解压缩：“文件选择”对话框打开，您可以选择 TEWZIP 文件进行解压缩。更新数据向导将自动打开。请参阅压缩/解压缩章节了解更多信息。

管理回路

当您导入多个设备型号时，回路无法导入，而且您必须将其添加到每个导入的设备型号。为帮助您，您可以针对回路使用设备型号右键菜单中的特定‘复制/粘贴’。

复制回路：在剪切板中复制选定设备型号的回路。

粘贴回路：将剪切板上的回路粘贴到选定的设备型号。

移除回路：删除选定设备型号的回路。

获取更多内容

可按目录中的制造商和制造商名称对设备型号进行分类。并非所有设备型号都包含在目录中。如果需要，可以从 Electrical Content Portal 下载它们。

在线内容：用于访问从网络下载的压缩文件。这些文件包含最新的设备型号。

获取产品详细信息

从 DesignSpark Electrical Web 服务中，您可以获得有关设备型号价格和库存的信息。

获取产品定价：单击此图标以更新选定设备型号的价格列。

更新库存状态：单击此图标以更新选定设备型号的库存状况列。

该价格显示为免增值税价值和货币代码（例如欧元用 EUR 表示 �）。

该库存状况表示库存中可用的数量或无现货（如果知道，表示可用日期）。

相关章节：

设备型号属性

电气装配体

设备型号导入

压缩/解压缩

CAD 文件下载程序


设备型号属性

设备型号管理器：属性

设备型号管理器：添加设备型号

设备型号管理器：多个插入

设备型号的技术数据存储在几个选项卡中。

  • 属性

  • 用户数据

  • 回路和端子

如果已同时选择多个设备型号或同时创建多个型号，请单击下一步转至下一个设备型号的属性。

单击上一步可转回到上一个型号。


设备型号属性

设备型号管理器：属性 >‘属性’选项卡

所有这些值都可在搜索设备型号过程中使用。

基本信息

型号：表示设备型号的代码。

制造商：制造商或设备品牌的名称。

分类名称：设备所属分类。要修改设备型号所属分类，请单击 [...] 按钮并选择分类。

数据库：选择设备型号分类所在的数据库。

类型：有几种类型：

基础设备型号类型（元素在图纸中有图形展示并显示设备销钉号码，例如断路器）。

辅助设备型号类型（在图纸中有图形展示并属于基础子级的元素。例如触点）。

附件设备型号类型（在图纸中无图形展示并属于基础或辅助子级的元素。例如标签）。

还有其他特定设备类型。

物料编码：用户管理的内部信息。

外部 ID：外部 ID 用于将元素与外部应用程序中的对应元素进行链接。

系列：通常，设备型号按系列分组，如 Schneider 目录中的 TESYS。

数据表：允许您为制造商零件分配链接。该链接是类似“使用说明”或“技术规格”或网络链接的文件。要创建链接，请单击 [...] 按钮，然后选择文件或输入网址。打开按钮允许您打开链接。

标注源：允许在创建设备时使用源标注。如果未输入值，将使用带有分类的标注源。

描述：允许您使用由软件管理的所有语言输入说明。特定图标允许您打开语言选择器。

商业设备型号：商业设备型号。例如，您可以使用内部型号或设备范围。使用由软件管理的所有语言输入值。特定图标允许您打开语言选择器。

供应商

供应商名称：允许您输入供应商名称。

物料编号：允许您输入供应商的物料编号。

价格：表示设备型号价格。

库存状况：表示设备型号是否有现货。

信息

此部分为只读。显示创建/修改日期和创建者。还显示回路和设备端子的数量。

图示

允许您将符号关联到设备型号。单击 [...] 按钮打开符号选择器，然后选择所需符号。

您可以使用关联符号/回路将多个符号与某设备型号相关联。此功能允许您将一个符号关联至一个或多个回路。

尺寸

此部分可使您输入设备型号尺寸。

使用/控制/值

输入设备型号的电气数据。这些值将用作查找设备型号的条件。

制造商数据

此部分显示的制造商数据取决于您在基本信息部分选择的分类。为这些数据输入不同的值。


用户数据

设备型号管理器：属性 > 用户数据选项卡

它显示所有用户数据和可译数据。自定义按钮允许您管理这些数据。


设备型号属性/回路，端子

设备型号管理器：属性 > ‘回路，端子’选项卡

该选项卡可使您管理与回路相关的设备型号定义以及设备端子数量。

以上示例是一个四销钉断路器的定义。您必须有四个断路器，开关类型的回路。列表中的第一个回路与图形最左侧的元器件对应（垂直插入时）。

对于设备端子号，每个回路有两个端子。第一个号码对应回路上方的端子（垂直插入时）。第二个号码对应下方的端子。

回路

添加多个：打开添加回路对话框以添加多个回路。

添加：在列表末端添加一个回路。

插入：在选定回路的上方添加新回路。

从新回路列表选择所需回路。

删除：删除选定回路。

向上/向下：重排回路顺序。

数量：显示回路数。

类型：定义回路类型。

端子标注：显示在端子部分中输入的设备端子标注。

组：显示组编号（用于分组多个回路）。

符号：显示与回路关联的符号的名称。

端子

选择回路以访问其端子标注。

添加：在列表末端添加一个端子。

插入：在选定端子的上方添加新端子。

删除：删除选定端子。

向上/向下：重排端子顺序。

回路：显示回路数。

系数：显示回路中端子的顺序。

标注：定义设备端子的编号。

端子类型：在列表中选择与端子相关联的端子类型。

最大线号：定义可以连接到设备端子的线号或电缆芯编号。

助记：让您插入助记通道 (PLC) 或个性化文本。

最大电线截面积 (mm²)/最大电线规格 (AWG)：您可以输入设备端子的截面积，它与连接到此端子电线的最大截面积对应。

最小电线截面积 (mm²)/最小电线规格 (AWG)：您可以输入设备端子的截面积，它与连接到此端子电线的最小截面积对应。

管理其他设备型号的回路

创建相似设备型号时，您可以使用一设备型号的回路定义，将其复制到新的设备型号。在设备型号管理器中，在设备型号的右键菜单中，您可以找到管理回路的特定命令。

复制回路：允许您复制 DesignSpark Electrical 剪切板中选定设备型号的回路。

移除回路：删除选定设备型号的回路。

粘贴回路：允许您将 DesignSpark Electrical 剪切板中的回路粘贴到选定的设备型号。


CAD 文件下载程序

首次访问 CAD 文件下载程序时，您必须输入您的 Electrical Content Portal (ECP) 账户的登录名和密码。

CAD 文件下载程序对话框显示从设备型号目录中下载的 2D 布局图或 3D 部件。

菜单：数据库 > 设备型号管理器 > 2D 布局图

设备型号管理器：制造商零件的右键菜单 > 2D 布局图

在“设备型号管理器”对话框中，选择设备型号并单击该命令开始下载。现有文件已与设备型号关联时，系统将询问您是否要将其覆盖。

已下载的 2D 布局图将自动存储在与设备型号分类相同的 2D 布局图管理器中。

停止：停止下载选定的 2D 布局图。

重试：停止后重新开始下载 2D 布局图。

打开：打开选定的 2D 布局图。此功能有三个选项。您可以在预览窗口 中打开图形界面中的布局图（单击打开）。

删除：删除选定 2D 布局图。

设备型号管理器：打开“设备型号管理器”对话框。

属性：打开选定 2D 布局图的属性。

注销：关闭您的 ECP 会话。

相关章节：

2D 布局图管理器


端子类型管理器

端子类型用于定义如何在设备上连接电缆芯或电线。它们在特定管理器中分组，您可以在其中找到主要使用的端子。您可以添加或编辑自己的端子。

端子类型在设备上（符号的连接点）和设备型号（端子）上管理，并使用特定标注来传播其数据。一份专用报表允许您合成在工程中使用的所有端子类型。

菜单：库 > 端子类型管理器

管理器对话框将会打开。它允许您添加、编辑或删除端子类型。

新建：允许您在库中添加新的端子类型。

删除：删除选定的端子类型。

属性：打开选定端子类型的属性对话框。如果您选择多个端子类型，则属性对话框将只显示共同属性。

列表模式：以列表形式显示端子类型（代码、说明、日期和符号名称）。

缩略图模式：以缩略图预览形式显示端子类型。

配置：允许您管理该对话框中项目的显示设置。

压缩：选择想要压缩的元素，然后单击压缩图标。

一个对话框将打开，您可以保存压缩文件。

解压缩：“文件选择”对话框打开，您可以选择 TEWZIP 文件进行解压缩。更新数据助手会自动打开。请参阅压缩/解压缩章节了解更多信息。

  • 端子类型属性


端子类型属性

端子类型管理器：新建

端子类型：属性

打开端子类型的属性对话框，以修改关联的数据。

如果端子类型已存在，该对话框左侧将显示编辑模式的预览（包含标注）。

如果您选择多种端子类型，将仅启用共同属性。

基本信息

名称：用于识别端子类型的端子类型名称。该名称必须在端子类型管理器中具有唯一性。

说明：描述端子类型。如果在管理器中选择缩略图模式，则说明文本会显示在缩略图下方。端子类型按说明的字母顺序排列。单击特定图标可以将说明设置为所有语言。语言选择器将打开，您便可以选择所需语言。

符号：允许您选择一个可关联到端子的符号。特定图标允许在符号管理器中选择符号。

系统

此部分为只读部分。显示创建/修改日期和创建者。


端子类型选择器

符号的连接点属性（编辑模式）：端子类型

设备型号的端子属性：端子类型

编辑设备的端子：端子类型

端子类型选择器允许您选择要关联到设备端子的端子类型。

列表模式：显示符号列表（名称、说明、分类）。

缩略图模式：以缩略图预览的形式显示符号。

配置：管理对话框中项目的显示设置。

1. 选择需要的符号。

2. 单击选择按钮进行确认。


压缩/解压缩

数据压缩可将数据保存为一个特定文件以用于备份系统、将数据从一个工作台传输到另一个工作台，或者传送给其他公司。

解压缩可以打开已压缩的文件，还可提供用于处理压缩数据对现有数据影响的管理工具。

  • 压缩

  • 解压缩


压缩

数据压缩可将数据保存为一个特定文件，您可以备份系统、在工作台之间传输数据或传送给其他公司。

可以根据压缩数据的类型，在软件内的多个点进行数据压缩。每种压缩功能都会创建一个特定文件。

可以根据文件扩展名区分压缩文件数据类型。

  • 环境压缩：.TEWZIP

  • 工程压缩文件：.PROJ.TEWZIP

  • 符号压缩文件：.SYMB.TEWZIP

  • 图框压缩文件：.TITLE.TEWZIP

  • 宏压缩文件：.MACRO.TEWZIP

  • 设备型号压缩文件：.PARTS.TEWZIP

  • 电缆型号压缩文件：.CABLE.TEWZIP

  • 模板压缩文件：.CONFIG.TEWZIP

某些压缩类型含有设计相关数据。例如，工程压缩文件包含符号、图框和配置，而宏压缩文件可能包含部件和符号。解压缩过程中，用户可以管理设计相关数据的集成。

  • 压缩环境

  • 压缩工程

  • 压缩符号

  • 压缩图框

  • 压缩设备型号

  • 压缩电缆型号

  • 压缩宏

  • 压缩配置

压缩环境

有时需要恢复 DesignSpark Electrical 管理的所有数据。例如，当原理图（如图框、符号、报表和配置）已自定义时。环境压缩可以将所有数据保存到一个压缩文件中。这使用户可以在相同的环境设置下将数据传给分包商和其他人员。环境压缩也会使工程管理器中的所有工程可用。

菜单：文件 > 压缩环境

将会出现一个向导。压缩选项显示在对话框的左侧。

自定义：自定义要集成到压缩文件中的元素。选择选项卡允许您选择数据类型，以将其包含在压缩过程中。其他选项卡则允许您更准确的管理每种数据类型。

所有工程：仅包括显示在工程管理器中的工程及必要项目，如分类。

所有对象：包含所有元素而无需单独选择。

来自选定数据库的对象：允许您在下一步中仅选择选定数据库中包含的元素。

用户修改的对象：只向压缩文件添加修改过的元素。

用户曾修改的对象：只包含在两个特定日期之间修改的元素（自定义日期或上次存档的日期）。

提醒我在以下天数后执行定期存档：提醒您执行定期压缩。选择此选项可将其激活，然后输入两次存档之间间隔的天数。

选择选项之后，您可以在这些不同的选项卡之间导航，以指定您想要包含在存档文件中的元素。单击完成以创建存档文件。

压缩文件的大小取决于所选数据的数量。

激活命令后，系统将要求您输入文件名。

环境压缩文件的扩展名为 .TEWZIP。

压缩工程

压缩一个工程可将所有文档和数据备份到该工程中，还会将符号、图框和设置等设计工作所需的内容备份到其中。工程管理器中提供了工程压缩命令。

工程管理器：压缩

选择工程，然后单击压缩图标。

压缩工程之前必须先将其关闭，除非它仅在您的工作台中打开。如果在其他工作台中打开工程，则其将被锁定。

在压缩工程的过程中，将对所有其他用户锁定该工程。

如果您选定多个工程，则它们将全部包含到一个压缩文件中。

系统将要求您输入文件名。工程压缩文件的扩展名为 PROJ.TEWZIP。压缩后的工程将仍保留在工程管理器中。

压缩符号

压缩符号将创建包含所有符号数据（图形、回路、设备连接点）的压缩文件。符号管理器中提供了符号压缩。

符号管理器：压缩

选择要包含的符号，然后单击压缩图标。

符号压缩文件的扩展名为 SYMB.TEWZIP。

压缩图框

压缩图框将生成包含所有图框数据（如图形和标注设置）的压缩文件。图框管理器中提供了此命令。

图框管理器：压缩

选择要包含的图框，然后单击压缩图标。

图框压缩文件的扩展名为 TITLE.TEWZIP。

压缩设备型号

设备型号压缩主要用于在不同工作台或不同公司之间共享/传递设备型号。设备型号管理器中提供压缩命令。

设备型号：压缩

选择要包含的设备型号，然后单击压缩图标。

设备型号压缩文件的扩展名为 PARTS.TEWZIP。

压缩电缆型号

电缆型号压缩主要用于在不同工作台或不同公司之间共享/传递电缆型号。电缆型号管理器中提供可用命令。

电缆型号管理器：压缩

选择要包含的型号，然后单击压缩图标。

电缆型号压缩文件的扩展名为 CABLE.TEWZIP。

压缩宏

宏压缩文件包含宏设计中使用的所有数据。宏管理器中提供可用压缩命令。

宏管理器：压缩

选择要包含的宏，然后单击压缩图标。

宏压缩文件的扩展名为 MACRO.TEWZIP。

压缩配置

使用此命令压缩所有配置（工程配置文件和电线配置文件除外）。某些压缩配置可能含有依赖性，如端子或自动配置。

配置管理：压缩

在压缩过程中，不同配置（如端子块和过程）之间没有区别。无论何种压缩类型，文件扩展名都相同。因此您必须注意压缩文件使用的名称，以便在之后轻松识别其类型。使用不正确的管理器无法解压缩配置文件。例如，您无法在自动配置管理器中解压缩端子配置。

配置压缩文件的扩展名为 CONFIG.TEWZIP。

相关章节：

解压缩


解压缩

解压缩可以打开压缩文件并提取其中的数据。这些数据与已有数据进行对比。

根据文件扩展名，可以判断压缩文件的类型。

  • .TEWZIP：环境压缩文件

  • .PROJ.TEWZIP：工程压缩文件

  • .SYMB.TEWZIP：符号压缩文件

  • .TITLE.TEWZIP：图框压缩文件

  • .MACRO.TEWZIP：宏压缩文件

  • .PARTS.TEWZIP：设备型号压缩文件

  • .CABLE.TEWZIP：电缆型号压缩文件

  • .CONIG.TEWZIP：模板/配置压缩文件

必须从对应的管理器解压缩文件。（请参阅压缩部分。）

本章节中的信息通用于除工程外的所有压缩文件。请参阅解压缩工程以了解更多信息。

选择解压缩打开解压缩向导，您可在其中管理要解压缩的数据。此向导与更新数据向导类似。

在选择选项卡中选择要导入的数据。

解压缩向导可将要解压缩的数据与已有数据进行比对。随后，您可以为每种数据类型选择一种动作。

动作

使用 Shift、Ctrl 或 Ctrl+A 键向多个项目应用相同动作类型。

右键单击行可打开一个菜单，其中显示了元素属性。

添加：由于数据未存在于当前安装中，因此需将其添加。

替换：将现有数据覆盖为最新版本。

不操作：保留现有信息。不添加新数据。

全部保留：保留现有信息，并添加使用新名称的新信息。

更新：更新目录零件。此选项仅对设备目录有效（电缆和设备）。

推荐使用基于以下规则的默认操作类型：

- 新数据将标注为添加。

- 如果用户创建的现有数据已被用户修改，则会将其标记为替换。

- 如果软件编辑器创建的现有数据已被用户修改，则会将其标记为不操作。

- 如果数据仍然存在且您未更改，但是新文件已被软件编辑器标注为“已更新”，则将其标注为替换。

- 电缆和设备目录标注为更新。

数据类型

符号 - 图框：向导会显示元素的名称、说明、修改日期以及创建/修改当前元素的用户名。如果您想要保留现有元素并安装相同元素的最新版本，请为新元素指定一个新名称。

电缆和制造商目录：统一管理目录，包括所有型号。如果型号不存在，将自动添加。如果型号存在并且您已做过修改，新型号数据则不添加。如果型号存在且您未做过修改，但已被软件开发商更新，则自动安装新型号并覆盖已有型号。

工程模板：仅安装新模型或已修改（根据修改时间的不同）的模型。您创建的模型将会保留。

报表配置：您创建或修改的报表配置将会保留。软件开发商创建或修改的配置将会自动安装。

配置文件：仅安装新配置文件或已修改（根据修改时间的不同）的配置文件。您创建的配置文件将会保留。

控制面板：仅安装新控制面板或已修改（根据修改时间的不同）的控制面板。您创建的控制面板将会保留。

相关章节：

压缩

数据安装


已锁定工程

当您想要打开正在被另一用户压缩或另一用户正在执行。