メインコンテンツへスキップ

コメント

9件のコメント

  • Boss .

    I find your link blocked by Norton....

    0
  • Brad Levy

    Martin,

    Norton flagged that web site when I went to look at it, too.

    Does the pour look okay on-screen in DS PCB (i.e., filled in with same color as the other copper on the bottom layer)?

    If not, make sure you remembered to pour the copper after defining the pour area.

    If the pour looks okay on screen, then go to Output > Manufacturing Plots, click on Bottom Copper in the list of plots to select it. Then click on the Settings tab (over to the right of the box listing the available plots). Then make sure that Pads-Only (Resist/Mask) Plot is not checked. (If it is checked, that would exclude the pours and most traces.)  Then run your plots again.

    -Brad

     

    0
  • Martin Dusek

    This is my personal FTP storage: http://martin.dusek11.sweb.cz/Border2.zip Hopefully it works now.

    I think my settings are correct. The only abnormality for my pcb is that I poured copper with no net (as this design is just a border for my pcb panel).

    0
  • Boss .

    I think you may just need to try again. Make sure you have done the pour as Brad suggested.

    Your Gerber is wrong, but my Gerber was correct, so have no idea of the reason except for the pour being missing. Brad may have some additional thoughts. Assigning to a net should not have any impact.

    0
  • Brad Levy

    I get the same result as Boss. The pour is missing in the gerber file in your zip, but if I run the plot here, the pour comes out fine. The time on the date on the .pcb file is more recent than on the .gbr file. DS PCB here used the .mop file (which contains the plot settings) which you included in the .zip file, so it doesn't look like a plot settings issue.

     

     

     

    0
  • Boss .

    As Brad sees the same result, it may have been an issue when you performed the copper pour.
    If you have a pour area selected (say top in your case) when yo perform the pour ONLY the selected pour area is poured.

    If no pour area is selected ALL pour areas are poured.

    0
  • Martin Dusek

    Guys, thanks for your reactions.

    I see what the problem is. Please go to gerber Device setup and uncheck Hardware Fill (G36, G37) (I have it unchecked because of https://designspark.zendesk.com/hc/en-us/requests/5498 - not sure if this issue is fixed or not).

    My DSPCB version is 8.1.2.

    0
  • Brad Levy

    Hi Martin,

    I think the zendesk link you posted is private to you and tech support. I got a page not found.

    But I think I have the solution to your problem.

    I looked at your pour on the top copper, and compared it to your pour on the bottom copper.

    In the shape settings of your top copper pour, you have a width of 0.127. In the bottom copper pour, you have the width set to zero. Changing the shape width setting on the bottom pour to 0.127 fixed the problem.

    If you have hardware fill turned off, DS PCB has to do the fill as a series of adjacent lines. It is probably using the shape's width parameter to decide how wide each line should be. (The finer the width of the shape outline, the finer you would want the fill lines to be so they can match up to the outline cleanly.)  When the width is set to zero, it would need an infinite number of fill lines, which you wouldn't want and it can't do. So it ignores that fill. Setting the width to a non-zero value allows it to compute a finite number of fill lines, and the pour works. The smaller the width, the more fill lines it will take, and the larger your file size will be. So you don't want to make it arbitrarily small. (Especially if you are outputting to a milling machine for prototyping.)

    I hope this helps.

    -Brad

     

    1
  • Martin Dusek

    Hi Brad,

    oh, you can't see the zendesk link. I had some issue with gerber plots when hardware fill was turned on. I had to turn it off.

    So, I now understand why the gerber files export won't work with hardware fill turned off and zero width of copper pour area. I will set it to 0.127.

    Thanks

    0

サインインしてコメントを残してください。