メインコンテンツへスキップ

Minimum radius when rounding edges

コメント

11件のコメント

  • Brad Levy

    Just another user here. I took a reasonably thorough look around, tried some possible options, but didn't find any method to round to a radius below 0.1 mm. This was on version 2?, not the new version 4.

    One thing I didn't try was creating a 0.1 mm round, then scaling the entire object to a smaller size.

    -Brad

    0
  • Jacant

    The image shows two 1mm cubes.

    All of the edges had a 'Round' of 0.1mm first, while still highlighted changed to 0.01 mm.

    This does not work if only one edge or the edges of one face are selected.

    You could select the rounds not wanted and 'Delete' them or use the 'Fill' tool, as on the second cube.

    1
  • David Martinez

    Hi Jacant,

    I have not been able to follow your procedure, when I try to change radius from 0.1 mm to 0.01 mm I get an error message. Are you using version 4 of DSM? I did not realized that this new version was available I will try using it in case this is the cause.

    Anyway, thank you for your effort.

    David

    0
  • David Martinez

    Hi Brad,

    thank you for your time testing this issue. I am working with version 2, I will update to version 4 in case some improvement has been introduced.

    David

    0
  • David Martinez

    I was not able to follow Jacant procedure either on version 4 of DSM, when I have selected all edges and type a radius smaller than 0.1 mm I get and error creating roundings.

    Anyway, I tried what Brad suggested and it works. I create a 10 mm size cube, then I round one edge to 0.1 mm, then I scale the whole cube down to 0.1, and I get a 1 mm cube with 0.01 mm rounded edge. Anyway, if you try to change radius to anything below 0.1 mm (0.02 mm ie) DSM removes rounding, so you need to scale up the cube, change the rounding to 0.2 mm and then scale down again.

    It is not very elegant, but it works.

    1
  • Brad Levy

    I tried Jacant's method too, and wasn't able to get it to work.

    I'm glad the scale up : round : scale down technique worked. I'm still pretty new to DesignSpark Mechanical, but learned with more extensive experience with DesignSpark PCB that sometimes inelegant but functional workarounds could be found with a bit of creativity. These workarounds can nicely stretch the capability of these programs.

    0
  • Nicos Bou

     

    It's Discovery SpaceClaim but same thing with DSM2, I tested it.

    Best regards.

    0
  • Brad Levy

    I found another way to accomplish it. DS Mech lets you make variable radius (tapered) rounds. You can create a smaller than .1 radius for one end, and 0.1 for the middle or large end. Then go back and re-radius the large end to less than 0.1.

     

     

    0
  • Jacant

    Hi David 

    I only use the original V1. It has many tools that have been omitted in later versions.

    However the options that Nicos Bou shows are not available in V1.

    0
  • Brad Levy

    I see Nicos also found the variable round solution to the problem and posted before me. Nicos used the variable round interface more directly, too. (I had encountered the variable round accidentally while exploring this problem using the graphic interface. Using the check box like Nicos does eliminates the need to specify two radii for the different ends of the round. Not only is the check box simpler, but it means not having to figure out how to actually enter two different rounds on a circular edge, which has no "ends".

    I can verify though that it does work with version 2 of DesignSpark Mechanical.

    I also learned more about creating variable rounds in exploring all of this. So I'm happy.

    0
  • David Martinez

    Thanks to all of you who spent some time trying to find a solution to my problem. Nicos Bou proposal works both in DSM2 and DSM4 and it is more direct than scaling up and down. I think this is an optimal solution to this issue.

    Best regards.

    0

サインインしてコメントを残してください。