Aller au contenu principal

Attachment?

Commentaires

8 commentaires

  • Jacant

    I don't know what you mean by "I ended up with two solids and not a web as a part of a solid,"

    Could be more explicit. An image would be helpful.

    To add an attachment, use the insert image icon above.

    0
  • Tim Heeney

    In 'Options - Pull Tab' and also in the 'Mini tool bar'  you overide the set behaviour ( DSM Options>Advanced>Pull Tool, a) Automatic, b) Add, c)  Cut, d) No Merge of Pulled faces and 'Bodies' with  touching / overlapping faces.

    Experiment and use the F1 help - use Index and searh for 'Pulling'

    Scroll down to 'Pull Options' for further explanations...

    ( Posted simultaneously with Jacants above...)

    0
  • towlerg

    I created both webs (either side of the cutout) in the same way ie. sketch the line at approx 45 deg. and pulled the resultant surface. I've tried filling ,combining and pulling upto. The most helpful error message is from combine "cannot merge bodies (operation failed because the fase and edges would combine in a way that does not form a valid solid or surface".

     

    0
  • Tim Heeney

    Lets check 2 things about the geometry and accuracy.

    1. Is the actual geometry integrally without errors - do a geometry check. I ask because i see an odd line marked in my pics - could be a small step - i can't tell from here.

    2. Is your geometry what you think it is - check accuracy using the measure command ( key 'e' ) is typed shortcut. Single select or add ctrl click for a pair measure - hit 'e' before or after selection, works either way.

     

     

     

    0
  • Tim Heeney

    If the geometry is accurate - i can't find a reason why it doesn't work. I usually work with No Merge set on in DSM Options. That way any touching existing body face, won't be merged with the new body created. Choose 'Add' ( as shown) to overide.

    One done in non constraint sketcher.

    Constraint Sketcher version.

    I put my money on a geometry accuracy issue.

    You said ' "cannot merge bodies (operation failed because the fase and edges would combine in a way that does not form a valid solid or surface"...

    0
  • towlerg

    Thanks guys for taking the time to respond.

    @Tim FWIW I got rid of "Line?" with Fill. I do have merge on, it work for the first web. I've gone back to a previous version, same. I really don't want to draw the whole thing again. It prints OK, so I guess I'll put it down to, stuff that happens.

    @Jacant I don't know what you mean by "Lets check 2 things about the geometry and accuracy.". The web is just a strengthening member it's exact size/position are not that important.

     

     

    0
  • Tim Heeney

    No problem responding at all and i hope the quick measuring and geometry checks will be of future use...

    But and btw, it was me who said "Lets check 2 things about the geometry and accuracy." because you said...'The most helpful error message is from combine "cannot merge bodies (operation failed because the fase and edges would combine in a way that does not form a valid solid or surface", from that, i inferred there could be a part inaccuracy.

    0
  • towlerg

    @Tim Oops, sorry re. attribution

    I'm sure you're correct, I just can can't find what I did wrong, ho hum, happy new year all.

    0

Vous devez vous connecter pour laisser un commentaire.