Skip to main content

Display Scaling

Comments

7 comments

  • Tim Heeney

    At which screen resolution, did the tool bars / dialogue boxes scale incorrectly ?

    Could it be, the Dell XPS ( specs?) with that particular OLED screen at 3840 x 2160 combo that's the problem - just wondering if all other apps are working correctly with this set-up/ res.

    It could be a new XPS - but are the graphics drivers all up to date?

    Screen monitors also have driver specs - check you got the latest?

    Have you checked the specs of either the integrated IRIS XE ( probably not this) or UHD or Nvidia GeForce graphics systems with the OLED screen?

    Some more information might help in establishing into the problem - you get new kit and it doesn't work is very frustrating!

     

    0
  • Keith Jacobs

    The screen resolution is set at 3840 x 2160. All other apps work 100% perfectly. The NVIDIA drivers were updated today. It only seems combo boxes that scale incorrectly, often they are unusable. Yes very frustrating as I updated the laptop specifically for DSM. The XPS is awesome

    0
  • Tim Heeney

    Sorry, i don't have any immediate answers for you.

    Please add specifcs on the XPS / graphics , OLED screen and OS - it will help in solving your problem.

    Thanks.

    0
  • Keith Jacobs

    Does this information help at all:

    Operating System: Windows 10 Home, 64-bit
    DirectX version: 12.0
    GPU processor: NVIDIA GeForce GTX 1650
    Driver version: 466.11
    Driver Type: DCH
    Direct3D feature level: 12_1
    CUDA Cores: 1024
    Core clock: 1560 MHz
    Memory data rate: 8.00 Gbps
    Memory interface: 128-bit
    Memory bandwidth: 128.03 GB/s
    Total available graphics memory: 12151 MB
    Dedicated video memory: 4096 MB GDDR5
    System video memory: 0 MB
    Shared system memory: 8055 MB
    Video BIOS version: 90.17.1C.40.4B
    IRQ: Not used
    Bus: PCI Express x16 Gen3
    Device Id: 10DE 1F91 09051028
    Part Number: 4905 0010

    [Components]
    nvui.dll 8.17.14.6611 NVIDIA User Experience Driver Component
    nvxdplcy.dll 8.17.14.6611 NVIDIA User Experience Driver Component
    nvxdbat.dll 8.17.14.6611 NVIDIA User Experience Driver Component
    nvxdapix.dll 8.17.14.6611 NVIDIA User Experience Driver Component
    NVCPL.DLL 8.17.14.6611 NVIDIA User Experience Driver Component
    nvCplUIR.dll 8.1.940.0 NVIDIA Control Panel
    nvCplUI.exe 8.1.940.0 NVIDIA Control Panel
    nvWSSR.dll 27.21.14.6611 NVIDIA Workstation Server
    nvWSS.dll 27.21.14.6611 NVIDIA Workstation Server
    nvViTvSR.dll 27.21.14.6611 NVIDIA Video Server
    nvViTvS.dll 27.21.14.6611 NVIDIA Video Server
    nvLicensingS.dll 6.14.14.6611 NVIDIA Licensing Server
    nvDevToolSR.dll 27.21.14.6611 NVIDIA Licensing Server
    nvDevToolS.dll 27.21.14.6611 NVIDIA 3D Settings Server
    nvDispSR.dll 27.21.14.6611 NVIDIA Display Server
    nvDispS.dll 27.21.14.6611 NVIDIA Display Server
    PhysX 09.20.0221 NVIDIA PhysX
    NVCUDA64.DLL 27.21.14.6611 NVIDIA CUDA 11.3.70 driver
    nvGameSR.dll 27.21.14.6611 NVIDIA 3D Settings Server
    nvGameS.dll 27.21.14.6611 NVIDIA 3D Settings Server

    0
  • Tim Heeney

    I've just found this article by Scan2CAD...

    Although 2 years old it does lay out clearly some issues CAD software may have with 4K resolution.

    ' https://www.scan2cad.com/cad/4k-monitors-for-cad/ '

    If nobody else comes up with any switch within DSM, fixing the issue, a software support ticket will have to be raised with the hope of supporting 4K in the next release.

     

    0
  • Tim Heeney

    This article may well solve your problem...

    https://designspark.zendesk.com/hc/en-us/articles/214031765

    You need to rmb a desktop DSM start icon , Properties>Compatability Tab>

    '

    Note

    In Windows 10 Version 1703 and later version of Windows, the text of the Disable display scaling on high DPI settings option is changed to Override high DPI scaling behavior, scaling performed by: Application.

    Having not had this issue due to my lower res monitor  - i hope this solves it for you...

     

    0
  • Keith Jacobs

    Thanks for that it does appear to solve the problem. The display isn't so nice and crisp though but at least I can use it. 

    0

Please sign in to leave a comment.