Skip to main content

design rule check - white lines after

Comments

7 comments

  • kdahlmann

    Thanks. About crossover/wine - I know that there is no support for particular errors showing up only on this platform and officially only plain windows is supported. But in my experience I can say, it works very good with crossover I use now for about 6 month on OS Catalina. If errors like this, this is mainly code errors and not related to stability or problems with display drivers.

    So if anyone want to use it on Mac - I would say DesignSpark PCB Pro (and the consumer version) is very reliable in my experience.

    1
  • Boss .

    What are the properties of the line?

    Do they reappear after a further DRC?

    One other thought have you tried redrawing the screen using CTRL+R 

    0
  • kdahlmann

    There are no properties as the white lines are not selectable nor do have a layer. When I switch of all layers, the white lines stay within the board outlines. 

    Redraw or zoom let the lines reappear always and when I do a new DRC the lines are deleted during start of DRC and reappear when finished. The lines do always appear even with DRC with errors, so I thought they are normal. They can be deleted when deleting all errors but when no errors present, I can not delete (button greyed).

    0
  • kdahlmann

    Don't you have these lines ?
    I am using Crossover/Wine on Mac but I don't think, this will cause this kind of error. 

    0
  • Boss .

    Hi, no I had never seen these lines, but assuming it was something to do with a setting I explored and can now reproduce this. I have logged with support also.

    Using the ChipKits Max I set the DRC for all checks enabled and then got this artefact.

    By elimination and viewing by layer, they are on the Documentation2 layer in this design.

    Then again by a process of elimination, I found the DRC check box that caused these was "Copper Shape Verification".

    Can you check to see if that check is causing your issue?
    Also as your layers will be different, on what layer does it occur?
    I'll then update the support ticket.

    0
  • kdahlmann

    Yes you are right. Clicking off Copper Shape Verification will avoid these white lines.
    Thanks for your help.
    For me this is not bound to a (visible) layer.
    I selected all layers off but white lines stay.
    I have Top Documentation and Bottom Documentation but deselect the layers in view will not remove this and I have no layer with colour white.

    0
  • Boss .

    You are welcome, I have added your comments to the ticket and hopefully we will get a patch soon.
    Good news for you that it's not related to crossover/wine though.

    0

Please sign in to leave a comment.