I am getting an Authorisation Service Error - what to do?

Follow

Comments

19 comments

  • Avatar
    Johan Geel

    still get the authorisation error.

    i shall remove the program and give up....

  • Avatar
    Martin Ohye

    I am getting "DesignSpark PCB is unable to verify authorisation", I click OK and then get "DesignSpark PCB must be authorised in order to continue". I click OK and it just closes. This is from ver 8.0 that I just downloaded and installed after ver 7.2 was giving the same errors. I am on Win 10 64 bit.  

  • Avatar
    Beymer Bevill

    I've had ver 7.2 on my windows school 7 machine and it has been working. It stopped yesterday ... I get the same must be authorized error and it never opens. I now get the same thing on both my home win 10 machines. My account information says I'm activated. ?????

    I've tried reinstalling and everything else I could find on the Internet. Note this happens not only on my school network but also on my home network!

  • Avatar
    jared parker

    I ran into this same authorization error as well. I installed designspark electrical.  Which installed and registered fine.  Afterwards I tried launching designspark pcb again and it now launches perfectly and goes to the activation page like it is suppose to.  During the DSelectrical install it updated my Microsoft Visual C++ redistributable versions.  So maybe the DSPCB needs those updated and doesn't have them bundled in with the installer.  If that's the case they need to fix the installer to include the Pre-Reqs. Thought I'd share in case it may help anyone else.

  • Avatar
    Martin Ohye

    Thanks Jared! Installing DSElectrical got DSPCB working. Just installing was not enough - I had to go through its registration process too. After that when I opened DSPCB it worked.

    I am still left very concerned - any software that can just stop working and lock me out of all existing work does not inspire confidence at all.

  • Avatar
    jared parker

    Glad to have it confirmed that installing DSelectrical fixed the issue with dspcb.  I didn't check to see if DSpcb worked until after I registered Electrical. So maybe its not the Visual C++ that was the issue.  Looks like others have only recently starting having issues.  So maybe a windows update caused it to stop working.  Who knows.  Anyways good luck with your project. 

  • Avatar
    Tomas Vicente

    Instalking DSelectrical its solved.

  • Avatar
    Beymer Bevill

    Thanks! I have to try that. Although I have been looking at Advanced Circuits PCB Artist as a replacement ... looks a lot like DSPCB!!! It doesn't make me register/login. But I really, really do like DSPCB! Sad!

     

  • Avatar
    Paul Towle

    Agree. I have W10 64 bit & got the "Authorisation Service Error" too.

    Read the recommended "How do I activate DesignSpark PCB", which was ABSOLUTELY no help whatsoever.

    Installed DSelectrical, registered, launched DSPCB and..... problem solved!

    Mr RS. You need to get this fixed!!

  • Avatar
    Beymer Bevill

    Downloaded the DS Electrical and registered it.  Now I can start up DSPCB! Thanks! But I'm still considering switching over to PCB Artist ..... I'm 62 today and I'm getting to old to be switching tools and computer languages and simulators! C/C++, Python, LTSpice XV11, DirectX, Blender, GIMP, Musescore, Audacity, and now I need to choose ... DSPCB or PCB Artist?

  • Avatar
    Bob Rutter

    Was working Friday, now gives me the "Authorization Service Error". Using Win7. Have de-installed and re-installed. Still the same error. This is just not acceptable. I hate to do this but I don't have time to be screwing around with getting the software to work. It's clearly time to move on.

  • Avatar
    Ramesh Dodamani

    I was getting the same Authorization error and it wouldn't start.

    Did "Run as Administrator" for the DesignSpark.exe file and the login/registration  panel came up. After filling up, program starts. I am on Win 10 - 64 bit on an AMD machine.

  • Avatar
    Mark Ferris

    Also getting "Designspark PCB is unable to verify authorisation".  Got it running v7.1 and then upgrading to v8 on Win8.1 64bit.  I'm just gonna move on and not use it.

  • Avatar
    Tony Moore

    I was using V6.1 very happily for years now, then got the dreaded request to activate in order to get 'save' options. I disagree that this has anything to do with firewalls etc. since the link is clearly visible and it will give error 404 in every browser.

    One used to be able to see the activation codes in one's profile, sadly no longer available.

    I eventually got V7.2 to work by

    uninstalling all Design Spark products,
    removing every occurrence of "designspark" from the registry. 
    Installing DesignSpark Electrical,(come up with no text in the registration form, so I guessed where the username and password went!)
    Installed V7.2 and got the registration screen, so now it is ok but for how long? 


    Very many thanks to jared parker and this thread for the information, 

    Tony

     

     

     

     

  • Avatar
    Judith Rastall

    I too am having trouble with V8.0 running on Windows 7 Pro. The program has suddenly stopped being able to authorize itself after running quite happily since I installed it last year. I have read through your troubleshooting notes, I don't have a proxy server enabled, it makes no difference right-clicking to run as admin. Judging by the number of complains on here there has to be a problem at your end. It has taken me a week to find this site so I expect there will be a lot more folk out there who are also having problems but who cannot find how to ask for help.

  • Avatar
    Judith Rastall

    BTW, I tried installing V8.1 and it failed to authorise at all so I've had to roll back to V8.0.

     

  • Avatar
    Judith Rastall

    Further to the above, several people in my organisation are currently using DesignSpark PCB and you are in danger of losing a lot of users.

  • Avatar
    Boss .

    @judith, these previous posts are all over a year old and relate to an issue when the activation process was changed. I helped to beta test and investigate the issue and it was resolved some time ago. If you have a current problem I suggest contacting support.

    I do not recall any posts related to this on the forum so cannot help, but I have found V8.1.1 very stable and don't recall any issues posted, but I noticed the Status FAQ reports the opposite to what you describe and suggests V8.0 may have an issue (but the date is wrong!)

    https://designspark.zendesk.com/hc/en-us/articles/115001396665-DesignSpark-PCB-Status.

     

  • Avatar
    Judith Rastall

    I would love to be able to update to 8.1 but it won't authorise and would not load at all. I was forced to roll back to 8.0 and this worked perfectly well for some time. Then a week ago it suddenly decided to not authenticate even though I wasn't doing anything different.

Please sign in to leave a comment.