Back to DesignSpark
Follow

I am getting an Authorisation Service Error - what to do?

We have one installation error affecting a very small number of users that prevents the registration screen being displayed (see details below). Please Recheck you have launched the program correctly as described in point 6 of the A&Q answer titled “How do I activate DesignSpark PCB?” which also gives the "Authorisation Service Error" message if not followed.

The Authorisation Service Error indicates the registration form contact with the registration server is being blocked. The reasons for this can be any of the following:
1. Antivirus software
2. Firewall
3. Other security software
4. Your Internet Service Providers own Firewall and security settings
5. Your OS is not up to date with Microsoft updates
6. Internet Explorer is not up to date
7. Your company Proxy Server or Firewall has not got the required settings
8. Malware or a virus infection blocking access
However the majority of incidents reported to the support inbox are not following the requirement to run the software with Admin rights as mentioned at the top of this answer.

NOTE: Microsoft has ceased support for Windows XP which has a legacy version of IE. Please update this with the latest updates available as it may resolve XP installation issues (Note: although no longer supported many users have successfully installed on XP and Vista). 
For details of supported OS' please see
http://www.rs-online.com/designspark/electronics/eng/knowledge-item/designspark-pcb-supported-operating-systems

FAQ: XP specific issue.
A key setting identified (by "remarked" in 2016) that requires to be set in IE on Windows XP is TLS1.0

Check the IE settings in
--> Control Panel --> Internet Options --> Advanced
Scroll down to the bottom and make sure that "Use TLS 1.0" has a tick next to it.
TLS1.0.png

This tip has assisted many XP users.

FAQ: Proxy Server issues to consider to fix this error.  
We have identified that in many cases the issue relates to an incorrect setting on the Users System regarding their LAN settings.
Prior to this install the "Proxy Server" has become enabled by error and this now blocks our registration process. 
To investigate this please follow the following steps:

  • Go to your OS Control Panel.
  • Select your Internet Options.
  • Select the connections tab.
  • Then select the LAN settings button.
  • Uncheck the Proxy Server check box if enabled.

The above image is from Windows 7.

FAQ: I can't use the above, I am on a Proxy Server  
The URL's that need to be enabled/whitelisted by your IT department are as follows below. These can also be used in your firewall and AV software:-

http://pcb.designspark.info/DS_data_files/Data
www.rs-online.com/designspark/api/activate

From previous experience it's normally possible to configure exceptions/whitelist entries with wildcards, these may be better to account for any future changes of the URL.

*pcb.designspark.info*
*rs-online.com/designspark/api/*

NOTE: using these directly in a browser will not result in a valid response as they are used for the registration dialogue.

Other details: TCP over normal Port 443 https protocol (secure) with SSL

 

See Also

How do I activate DesignSpark PCB?

 

 

Was this article helpful?
0 out of 5 found this helpful
Have more questions? Submit a request

14 Comments

  • 3
    Avatar
    Johan Geel

    still get the authorisation error.

    i shall remove the program and give up....

  • 3
    Avatar
    Martin Ohye

    I am getting "DesignSpark PCB is unable to verify authorisation", I click OK and then get "DesignSpark PCB must be authorised in order to continue". I click OK and it just closes. This is from ver 8.0 that I just downloaded and installed after ver 7.2 was giving the same errors. I am on Win 10 64 bit.  

  • 0
    Avatar
    Beymer Bevill

    I've had ver 7.2 on my windows school 7 machine and it has been working. It stopped yesterday ... I get the same must be authorized error and it never opens. I now get the same thing on both my home win 10 machines. My account information says I'm activated. ?????

    I've tried reinstalling and everything else I could find on the Internet. Note this happens not only on my school network but also on my home network!

  • 1
    Avatar
    jared parker

    I ran into this same authorization error as well. I installed designspark electrical.  Which installed and registered fine.  Afterwards I tried launching designspark pcb again and it now launches perfectly and goes to the activation page like it is suppose to.  During the DSelectrical install it updated my Microsoft Visual C++ redistributable versions.  So maybe the DSPCB needs those updated and doesn't have them bundled in with the installer.  If that's the case they need to fix the installer to include the Pre-Reqs. Thought I'd share in case it may help anyone else.

  • 1
    Avatar
    Martin Ohye

    Thanks Jared! Installing DSElectrical got DSPCB working. Just installing was not enough - I had to go through its registration process too. After that when I opened DSPCB it worked.

    I am still left very concerned - any software that can just stop working and lock me out of all existing work does not inspire confidence at all.

  • 0
    Avatar
    jared parker

    Glad to have it confirmed that installing DSelectrical fixed the issue with dspcb.  I didn't check to see if DSpcb worked until after I registered Electrical. So maybe its not the Visual C++ that was the issue.  Looks like others have only recently starting having issues.  So maybe a windows update caused it to stop working.  Who knows.  Anyways good luck with your project. 

  • 0
    Avatar
    Tomas Vicente

    Instalking DSelectrical its solved.

  • 0
    Avatar
    Beymer Bevill

    Thanks! I have to try that. Although I have been looking at Advanced Circuits PCB Artist as a replacement ... looks a lot like DSPCB!!! It doesn't make me register/login. But I really, really do like DSPCB! Sad!

     

  • 0
    Avatar
    Paul Towle

    Agree. I have W10 64 bit & got the "Authorisation Service Error" too.

    Read the recommended "How do I activate DesignSpark PCB", which was ABSOLUTELY no help whatsoever.

    Installed DSelectrical, registered, launched DSPCB and..... problem solved!

    Mr RS. You need to get this fixed!!

  • 0
    Avatar
    Beymer Bevill

    Downloaded the DS Electrical and registered it.  Now I can start up DSPCB! Thanks! But I'm still considering switching over to PCB Artist ..... I'm 62 today and I'm getting to old to be switching tools and computer languages and simulators! C/C++, Python, LTSpice XV11, DirectX, Blender, GIMP, Musescore, Audacity, and now I need to choose ... DSPCB or PCB Artist?

  • 0
    Avatar
    Bob Rutter

    Was working Friday, now gives me the "Authorization Service Error". Using Win7. Have de-installed and re-installed. Still the same error. This is just not acceptable. I hate to do this but I don't have time to be screwing around with getting the software to work. It's clearly time to move on.

  • 0
    Avatar
    Ramesh Dodamani

    I was getting the same Authorization error and it wouldn't start.

    Did "Run as Administrator" for the DesignSpark.exe file and the login/registration  panel came up. After filling up, program starts. I am on Win 10 - 64 bit on an AMD machine.

  • 0
    Avatar
    Mark Ferris

    Also getting "Designspark PCB is unable to verify authorisation".  Got it running v7.1 and then upgrading to v8 on Win8.1 64bit.  I'm just gonna move on and not use it.

  • 0
    Avatar
    Tony Moore

    I was using V6.1 very happily for years now, then got the dreaded request to activate in order to get 'save' options. I disagree that this has anything to do with firewalls etc. since the link is clearly visible and it will give error 404 in every browser.

    One used to be able to see the activation codes in one's profile, sadly no longer available.

    I eventually got V7.2 to work by

    uninstalling all Design Spark products,
    removing every occurrence of "designspark" from the registry. 
    Installing DesignSpark Electrical,(come up with no text in the registration form, so I guessed where the username and password went!)
    Installed V7.2 and got the registration screen, so now it is ok but for how long? 


    Very many thanks to jared parker and this thread for the information, 

    Tony

     

     

     

     

Please sign in to leave a comment.