ようこそ

DesignSpark Electrical ヘルプへようこそ

DesignSpark Electrical は、電気配線図を作成するためのオープンな、直感的で包括的なソフトウェア パッケージです。回路図設計、結線図、およびレポートの包括的な管理用パッケージが収録されています。プロジェクト データは (SQLite) データベースに格納され、リアルタイムで更新されます。

DesignSpark Electrical を使用するためには、ログインおよびパスワードからなるアカウントが必要です。アカウントがない場合は、作成してください。

このヘルプ プログラムでは、配線図の作成プロセスおよびソフトウェアの管理方法 (インストール、ドキュメント設定、プロセス管理など) について説明します。

表記規則

XXXX | 重要なインターフェイス用語は太字で強調表記されます。
リンク | 関連ページやリソースのリンクを示します。関連情報を表示するには、リンクをクリックします。
緑色のテキスト | 非表示のメモを示します。メモを表示または非表示にするには、緑色のイタリック体で表示されたテキストをクリックします。
1.斜体のテキスト | 機能を使用するために従う手順を示します。
 | 動画を示します (インターネット接続が必要)。
 | ダウンロード可能なファイルを示します (インターネット接続が必要です)。
 | メモまたはヒントを示します。
 | リスク、または危険を引き起こすおそれのある操作を示します。

関連トピック:


ヘルプ メニュー

メニュー: ヘルプ

ヘルプ/F1: DesignSpark Electrical オンライン ヘルプを開きます。このヘルプは状況依存型であり、キーボードの F1 キーを押してアクセスできます。F1 キーを押すと、現在の機能を説明するセクションが開きます。

チュートリアル パネル: ソフトウェア インターフェイスのチュートリアルがポップアップ ウィンドウで開きます。チュートリアルはオンラインでも使用できます。

ドキュメント: Windows エクスプローラーが開き、すべてのソフトウェア ドキュメント ファイルを検索できます。

情報の収集: 潜在的な問題を解決するため、コンピューティング環境に関する情報を収集します。

オンライン コンテンツ: インターネットから部品参照アーカイブ ファイルのダウンロードにアクセスするために使用されます。これらのファイルには、最新の部品更新が含まれます。

DesignSpark Electrical ホーム ページ: DesignSpark Electrical Web サイトが表示されます。

製品について: ソフトウェアのバージョンが表示されます。


チュートリアル - 2D

チュートリアル - DesignSpark Electrical

このプログラムでは、一連の簡単な演習によって DesignSpark Electrical の概要を説明し、プロジェクトを作成できるようにします。このプログラムを完了すると、このソフトウェアのほとんどの機能を使用できるようになります。

すべての演習は個別に行うことができますが、順序に従うことをお勧めします。ほとんどの演習は以前の演習に基づいています。演習を行っていない場合は、特定のリンクをクリックするとダウンロードできます。

付録

演習での作業を簡単にできるため、積極的に各種の付録を印刷してください。

ビデオ

各演習の最後では、ヘルプ用のビデオを視聴できます。全画面モードと高解像度でビデオを視聴することをお勧めします。

演習 1 | 環境を解凍
演習 2 | プロジェクトの作成
演習 3 | ロケーションの管理 総観の作成 ケーブル リスト
演習 4 | ワイヤの挿入 シンボルの挿入 メーカー部品の割り当て
演習 5 | オブジェクトの処理 ブラック ボックスの挿入 パターンの作成 コピー/貼り付け 材料端子の交換
演習 6 | 多言語テキスト 極性の始点と終点 等電位番号の割り当て 端子台の配線
演習 7 | メーカー部品
演習 8 | DesignSpark Electrical では該当しません
演習 9 | DesignSpark Electrical では該当しません
演習 10 | DesignSpark Electrical では該当しません
演習 11 | リビジョンの管理


演習 01

DesignSpark Electrical - 演習 01

最初の演習では、DesignSpark Electrical ソフトウェアの基礎、特定の環境を使用する方法、単純なファイルと配線図の相違点、およびインターフェイス ツールを使用する方法を習得できます。

  • 環境の解凍

  • 演習を始める前の推奨事項

環境の解凍

このリンクから、環境アーカイブ ファイルをダウンロードし、解凍します。

環境アーカイブ ファイルには、シンボル、メーカー部品、構成、プロジェクトなど、DesignSpark Electrical で必要なすべてのデータが含まれています。これは、他社や別のワークステーションにデータを転送するために使用します。また、ソフトウェアを再インストールする前に使用してデータを保存することもできます。

1.アーカイブ ファイルをダウンロードした後、解凍コマンドを使用して開きます。

メニュー: ファイル > 環境を解凍

2.EnvironmentForTraining.tewzip ファイルを選択します。

3.[選択] タブでは、復元するオブジェクトを選択できます (すべて選択)。

4.[完了] ボタンをクリックします。 DesignSpark Electrical は、復元/インポートされたすべてのオブジェクトを一覧表示します。

演習を始める前の推奨事項

ファイル/図面

ファイルと図面は作図を行うことができるドキュメントですが、これら 2 種類のドキュメントの相違点を認識しておく必要があります。図面または電気図面はデータベースに自動的に保存され、レポートなどの自動プロセスが可能になります。「ファイル」はシンプルな DWG ファイルで、インテリジェントな機能はありません。電気配線図は図面にする必要があります。DWG ファイルにはしないでください。

拡大/縮小

図面を拡大/縮小するには、[表示] メニューのコマンドを使用するか、マウス ホイールを使用します。ホイールを回すと拡大/縮小します。クリックすると保持され、ホイールをクリックするとリアルタイムにパニングします。ホイール上でダブルクリックすると、すべての図面エンティティ上でズーム範囲が設定されます。

選択モード

配線図の設計時にはオブジェクトを選択する必要があります。次の手順でオブジェクトを選択します。

1 つのオブジェクトを選択する場合、操作は非常に簡単で、クリックするだけです。複数のオブジェクトを選択する場合は、選択時に Ctrl キーを押したままにしてオブジェクトをクリックします。複数のオブジェクトを選択するには、長方形で選択する方法も使用できます。オブジェクトを囲むように左から右へ、(対角線により定義される) 長方形を描画します。長方形の輪郭内に含まれるすべてのオブジェクトが選択されます。また、キャプチャ選択という別の方法もあります。長方形で選択するのと同じ手法ですが、右から左へ描画します。長方形の輪郭内に一部がかかっているすべてのオブジェクトが選択されます。

関連トピック:

次の演習

目次


演習 02

DesignSpark Electrical - 演習 02

この演習の最初のステップでの目的は、プロジェクト テンプレートから新しいプロジェクトを作成することと、プロジェクトのプロパティを開いて個人データを入力することです。続いて、プロジェクト言語を選択する必要があります。ブックや図面などのプロジェクト要素を操作します。完了するには、新しいプロジェクトから新しいプロジェクト テンプレートを作成します。

  • プロジェクトの作成

  • プロジェクト プロパティの編集

  • プロジェクト言語の構成

  • プロジェクト要素の管理

  • プロジェクト テンプレートの作成

プロジェクトの作成

1.プロジェクト マネージャーを開きます。

メニュー: ファイル > プロジェクト マネージャー

2.[新規] アイコンをクリックします。

プロジェクト マネージャー > 新規

3.テンプレートのリストで、[IEC] テンプレートを選択します。

4.[プロジェクト言語] ダイアログ ボックスで、言語は [英語] を選択します。

5.プロジェクト名を入力します。

新しいプロジェクトが自動的にプロジェクト マネージャーに追加されます。

プロジェクト プロパティの編集

1.プロジェクトのプロパティを開きます。

プロジェクト マネージャー > プロパティ

2.プロジェクトのプロパティを入力します。

契約番号 | 123456
顧客名 | Trace Software
アドレス 1 | 76430
アドレス 2 | St Romain
アドレス 3 | France
設計事務所名 | 会社
アドレス 1 | 郵便番号
アドレス 2 | 市区町村
アドレス 3 | 電話番号
説明行 1 | トレーニング用プロジェクト

プロジェクト言語の構成

プロジェクト構成を開くには、プロジェクトはドック可能パネルの [ドキュメント] タブで開かれ、表示されている必要があります。プロジェクトを開くには、プロジェクト マネージャーで選択して、[開く] ボタンをクリックします。

英語のみを使用し、第 2 言語は除去してください。

1.プロジェクト構成を開きます。

ドック可能パネル > ドキュメント タブ > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...

2.[全般] タブで、メイン言語として「英語」を選択し、第 2 言語にはお使いの言語を選択します。

構成を完了すると、プロジェクトが自動的に更新されます。

プロジェクト要素の管理

ブック エディション

1.ブックのプロパティを開きます。

ドック可能パネル > ドキュメント タブ > ブックのコンテキスト メニュー: プロパティ

2.以下のブックのプロパティを入力します。

説明 | マイ ブック
ユーザー データ 1 (作図者) | A.B.
ユーザー データ 2 (日付) | 07/09/2016

[ユーザー データ] ラベルを変更するには、[カスタマイズ...] ボタンをクリックします。ダイアログ ボックスの左側で、[ユーザー データ 1] を選択し、ラベルを使用するために必要な言語で正しいラベル (作図者) を入力します。[ユーザー データ 2] に対して操作を繰り返します。

図面を作成/移動/削除します。

1.新しい図面を作成します。

ドック可能パネル > ドキュメント タブ > ブックのコンテキスト メニュー: 新規 > 配線図

メニュー: プロジェクト > 新規 > 新しい配線図

プロジェクト要素のリストの末尾に、新しい図面が自動的に追加されます。

2.リスト内でこの図面を移動するには、適切な場所にドラッグ アンド ドロップします。

3.この図面を削除するには、図面を選択してから Del キーを押すか、コンテキスト メニューで [削除] オプションを選択します。

ドック可能パネル > 図面のコンテキスト メニュー: 削除

データ ファイルを追加します。

プロジェクトに外部ファイルを追加するには、次の 2 つの方法があります。

1.データ ファイルを追加します。

ドック可能パネル > ドキュメント タブ > ブックのコンテキスト メニュー: 新規 > データ ファイル

2.ソフトウェアの C:\Program Files\...\Documentation ディレクトリに保存されている「ExcelAutomation_EN.pdf」を選択します。

このファイルはプロジェクト内にコピーされます。元のファイルを変更しても、このコピーは影響を受けません。

他に、元のファイルとのリンクを作成することによって、元のファイルを変更すると、プロジェクト内のドキュメントが常に更新されるようにできます。

1.データ ファイルのショートカットを追加します。

ドック可能パネル > ドキュメント タブ > ブックのコンテキスト メニュー: 新規 > データ ファイルのショートカット

2.ソフトウェアの C:\Program Files\...\Documentation ディレクトリに保存されている「ExcelAutomation_EN.pdf」を選択します。

プロジェクト テンプレートの作成

プロジェクト テンプレートは、新しいプロジェクトの作成に使用します。新しいプロジェクト テンプレートを作成する場合は、プロジェクトを消去し、プロジェクト テンプレートに組み込まない要素を削除する必要があります。この演習では、"図面リスト" を削除し、その他の図面の番号を再割り当てする必要があります。これにより、プロジェクト テンプレートを作成できます。

図面を削除

1.図面のコンテキスト メニューで [削除] コマンドを選択することで、図面 02 を削除します。

図面を選択し、Del キーを押して、図面を削除することもできます。

2.追加したデータ ファイルまたはショートカットを削除します。

図面番号を再割り当て

1.ブックの図面番号を再割り当てするには、ブックのコンテキスト メニューを開き、[ドキュメントの番号再割り当て] コマンドを選択します。

ドック可能パネル > ドキュメント タブ > ブックのコンテキスト メニュー: ドキュメントの番号再割り当て

2.[順序番号の再計算] オプションを選択して確認します。

プロジェクト テンプレートの作成

1.プロジェクト マネージャーを開きます。

メニュー: ファイル > プロジェクト マネージャー

[テンプレートとして保存] アイコンが無効になっていることに注意してください。まず、プロジェクトを閉じる必要があります。

2.リストからプロジェクトを選択し、[閉じる] アイコンをクリックして閉じます。

プロジェクト マネージャー > 閉じる

3.プロジェクトを選択し、[テンプレートとして保存] ボタンをクリックします。

プロジェクト マネージャー > テンプレートとして保存

4.新しいプロジェクト テンプレートの名前を入力します。これで、お使いのプロジェクトを使用して新しいプロジェクトを作成できます。

関連トピック:

次の演習

目次


演習 03

DesignSpark Electrical - 演習 03

この演習により、プロジェクトのロケーションを管理する方法を習得し、電気装置の結線図を設計することができます。この演習は、演習 02 で作成したプロジェクトに基づいています。このプロジェクトを完成していない場合は、プロジェクト ファイルをダウンロードして、DesignSpark Electrical で解凍することができます。

プロジェクトのダウンロード

この演習を行うには、演習の PDF ファイルをダウンロードする必要があります。PDF ファイルを印刷することをお勧めします。

PDF ファイルのダウンロード

  • ロケーションの管理

  • 結線図

  • 予約されたケーブル

  • ケーブル リスト

ロケーションの管理

既存の L1 ロケーションを編集して完成させます。

1.L1 ロケーションのプロパティを開きます。

ドック可能パネル > コンポーネント タブ > ロケーションのコンテキスト メニュー: プロパティ

2.L1 ロケーションの説明として「TGBT」と入力します。

他のプロジェクトのロケーションの作成

次のロケーションを追加します。

L2: モーター ルーム

L3: 制御盤

BJ: 接続箱

1.ロケーション マネージャーを開きます。

メニュー: プロジェクト > ロケーション

2.[新しいロケーション] アイコンをクリックします。

ロケーション マネージャー: 新しいロケーション

3.ロケーション プロパティのダイアログ ボックスで「L2」を入力し、説明に「モーター ルーム」と入力します。

4.ロケーション「L3」および「BJ」でもこの手順を繰り返します。「BJ」マークは「手動」モードで入力する必要があります。

結線図

以前にダウンロードした PDF ドキュメント (付録 3a) を使用し、次の手順に従って、結線図上にワイヤ結線図を作成します。

1.図面 02 - 結線図をダブルクリックして開きます。

シンボルの挿入

[シンボルの挿入] コマンドを使用して、ロケーション領域を作図せずに、モーター M1 および M2 を挿入します。挿入は後で行います。

2.[結線図] メニューの [シンボルの挿入] アイコンをクリックします。

メニュー: 結線図 > シンボルの挿入

3. DesignSpark Electrical は最後に挿入されたシンボルを記憶します。シンボルの挿入コマンドを初めて実行すると、ライブラリが直接開く場合があります。そうでない場合、ドック可能パネルの [その他のシンボル] ボタンをクリックします。

4.ライブラリの [分類] タブをクリックします。[モーター] クラスを選択します。右側で対応するシンボルを選択します。

5.[選択] をクリックし、確認します。シンボル サムネイルをダブルクリックすることもできます。

6.シンボルはカーソルに接続されます。グラフィック領域で挿入点をクリックします。シンボルの挿入時には、「スナップ」ロックが有効であることを確認します。

7.マーク「M1」は、[モーター] クラスに最初に挿入されたシンボルであるため、プロパティ ダイアログ ボックスで提案されます。

8.シンボルに割り当てられたロケーションを変更する必要があります。「+L1-TGBT」セル上の [...] ボタンをクリックします。

9.ロケーション ダイアログ ボックスで、[L2 モーター ルーム] を選択します。

10.シンボルのプロパティを確認します。

11.モーター「M2」に対して同じ操作を行います。

マークはロケーション マークを示すことに注意してください。コンポーネントのロケーションは、図面のロケーションと異なります。

ロケーション領域

L3 コントロール パネル ロケーション領域を配置してから、サイド パネルによって 2 つの H1 および H2 インジケーターを挿入します。

(マークへの影響に注意してください。)

1.[結線図] メニューの [ロケーション領域] コマンドを選択します。

メニュー: 結線図 > ロケーション領域

[ロケーション領域] コマンドにオプションが含まれていることに注意してください (アイコンに表示される矢印)。アイコンの上部をクリックすると、オプションを使用してコマンドが実行されます。アイコンの下部をクリックすると、オプションが表示されます。

2.矩形ロケーション領域の場合、グラフィック領域の最初の点をクリックしてから、矩形の対角線の 2 番目の点をクリックします。

3.ポリライン領域では、領域の最初の点をクリックし、次に 2 番目の点をクリックします。完了するには、領域を閉じる必要があります。

シンボル パレット

シンボル パレットを使用してインジケーターを挿入します。

1.ドック可能パネルの [シンボル] タブを開きます。

2.[検索] グループを開きます。検索フィールドに「インジケーター」と入力し、[検索] をクリックします。

3.シンボルをグラフィック領域にドラッグするか、ダブルクリックして挿入します。モーターとは異なり、インジケーターはロケーション領域の内側に挿入されます。 DesignSpark Electrical は、[マーク] ダイアログ ボックスにロケーション [L3 コントロール パネル] を自動的に提案します。

4.付録にあるように、その他のシンボルとロケーション領域を挿入します。

ケーブルの作図

1.[結線図] メニューの [ケーブルの作図] を使用してケーブルを作図します。

メニュー: 結線図（Line diagram）> ケーブルを作図（Draw cable）

2.シンボル領域上で最初の点をクリックします。緑色の点は接続を示します。

3.2 番目のシンボル領域上で 2 番目の点をクリックします。

[コマンド] ドック可能パネルでは、線/ケーブル タイプを選択してケーブル タイプを区別することができます。

予約されたケーブル

4G タイプのケーブルを使用して、M1 および M2 モーターを配線する必要があります。

7 つ以上のコアが含まれるケーブルを使用して、XA2 端子台をインジケーターに接続します。

1.ワイヤのコンテキスト メニューを開き (ワイヤを右クリック)、[ケーブルとコアの予約] コマンドを選択します。

結線図ケーブルのコンテキスト メニュー: ケーブルとコアの予約

2.ケーブル予約ダイアログ ボックスの [新しいケーブル] アイコンをクリックします。

ケーブルとコアの予約 > 新しいケーブル

3.ケーブル参照検索ダイアログ ボックスで [フィルター] タブを使用し、[ファミリー] と [コンダクター数] にフィルターを入力します。

4.新しいケーブルがリストに表示されます。ケーブルのボックスをオンにします。

ケーブルのマークと参照が結線図に表示されます。ケーブルのコンテキスト メニューで [ケーブル テキストの表示/非表示] を使用すると、テキストを表示または非表示にすることができます。

ケーブル リスト

ケーブルのリストを表示します。

1.[プロジェクト] メニューの [レポート] アイコンをクリックします。

メニュー: プロジェクト（Project）> レポート（Reports）

2.[ケーブルのリスト] レポートを選択します。

[レポート マネージャー] ダイアログ ボックスの右側には、プロジェクト内でユーザーが行うすべての操作がリアルタイムで表示されます。

関連トピック:

次の演習

目次


演習 04

DesignSpark Electrical - 演習 04

この演習により、電気配線図を管理する基本コマンドを習得できます。この演習は、演習 03 で作成したプロジェクトに基づいています。このプロジェクトを完成していない場合は、プロジェクト ファイルをダウンロードして、DesignSpark Electrical で解凍することができます。

プロジェクトのダウンロード

この演習を行うには、演習の PDF ファイルをダウンロードする必要があります。PDF ファイルを印刷することをお勧めします。

ファイルのダウンロード

  • ワイヤの挿入

  • シンボルの挿入

  • メーカー部品の割り当て

ワイヤの挿入

配線図 03 を作成します。(付録 4a)

電源ワイヤの挿入

まず、配置オプションを使用してワイヤを配置し、ベンドを管理します。

メニュー: 回路図 > 複数のワイヤの作図

1.現在のワイヤが「N L1 L2 L3」ではない場合、[?] ボタンをクリックしてワイヤ セレクターを開き、ワイヤを選択します。

2.保護コンダクターのボックスをオフにします。

3.バスバーに対応する水平ワイヤの 2 点をクリックします。

4.モーター回路ワイヤを作図するには、前と同じ手順を実行し、[中性] ボックスをオフにします。最初にクリックするときには、カーソルを「L3」の上に置きます。C キーを使用してベンドを挿入し、Space キーを使用してコンダクターを交差したり、それを解除したりします。

5.変圧器のワイヤ アップストリームを作図するには、「L2」上で直接位相を切断しないでください。まず、「L1」に接続してから選択し、ハンドル (青色の四角) を使用して「L1」から切断します。最後に、「L2」に再接続します。

制御コマンド ワイヤの挿入

変圧器のワイヤ タイプ ダウンストリームは 48VDC です。

メニュー: 回路図 > 1 つのワイヤ タイプを作図

必ずドック可能パネルの [?] ボタンをクリックして、ワイヤ セレクターを開き、ワイヤ「= 48V」を選択してください。

シンボルの挿入

生成されるグラフィック モデル (付録 4A を参照)。

ライブラリまたはパレットを使用して、シンボルを配置します。

シンボルを挿入する最も簡単で迅速な方法はパレットを使用することです。最初は時間がかかるように思われますが、独自のパレットを作成すると、作図と特に検索が非常に高速になります。

1.ドック可能パネルの [シンボル] タブを開きます。

2.[保護] グループ ヘッダーをクリックします。3 極回路ブレーカーのシンボルがない場合、グループのコンテキスト メニューを開いて追加します。パレットにある場合は、ダブルクリックして挿入します。

3.また、パレットと「検索」グループを使用することもできます。入力ボックスに「回路ブレーカー」と入力し、[検索] ボタンをクリックします。 DesignSpark Electrical には、パレット内のシンボルだけではなく、条件を満たすライブラリのシンボルすべてのサムネイルが表示されます。

[配線図] メニューの [シンボルの挿入] コマンドも使用できます。

メニュー: 配線図 > シンボルの挿入

1.必要なシンボルがドック可能パネルに表示されていない場合、[その他のシンボル] ボタンをクリックします。

2.[シンボル選択] が開きます。2 つのタブ (フィルダーまたは分類) のいずれかを使用して、目的のシンボルを検索します。

M1 モーターを結線図のシンボルに関連付けます。「ポンプ モーター」テキストを追加します。

M1 モーターを結線図のシンボルに関連付けるには、同じマークを割り当てます。

1.マークのダイアログ ボックスの右側でコンポーネントのリストから「M1」マークを選択し、[OK] をクリックします。

メーカー データはメーカー部品によって提供されます。ユーザー データはユーザーが入力します。

関連付けられた属性がシンボルの定義に存在する限り、このデータはシンボルに反映できます。

ヒューズ F3 は F2 のコピーです。

1.[コピー] コマンドは [配線図] メニューで使用できます。

メニュー: 配線図 > 複数コピー

既存のシンボルをコピーすると、マークは自動的に増加します。元のシンボルに関連付けられたメーカー部品もコピーされます。

配置オプションを使用して F4 と K1 接点を挿入します。

シンボルがワイヤに挿入されると、ワイヤに応じて自動的に方向が決定します。ワイヤ外に挿入された場合、ユーザーが方向を管理します。

クロス リファレンスの自動生成に注意してください。

F4 ワイヤと K1 の自動供給ワイヤを完了します。

生成されるグラフィック モデル (付録 4B を参照)。

メーカー部品の割り当て

装置レポートを使用してメーカー部品を割り当てます (付録 4C)。

1.コンポーネントのプロパティを開きます。

シンボルのコンテキスト メニュー: コンポーネント プロパティ

2.[メーカー部品と回路] タブに移動します。

3.[検索] ボタンをクリックして、メーカー カタログの部品を検索します。

- クラスを選択します。

- メーカーを選択します。

- 参照型番がわかる場合は、[参照] フィールドに入力します。

- [自動更新] ボックスをオンにしていない場合は、[検索] ボタンをクリックします。

- 結果のリストから部品を選択します。

- [+] ボタンをクリックして追加します。

接点ブロックなどの補助参照を追加するには、手順を繰り返し、[タイプ] フィールドの [補助] を選択します。

場合によっては、[クラス] 条件のチェックを外して補助またはアクセサリを検索する必要があります。これらは別のクラス (複数の参照に共通) に保存できます。

関連トピック:

次の演習

目次


演習 05

DesignSpark Electrical - 演習 05

この演習では、既存のオブジェクトを作成することができます。この演習は、演習 04 で作成したプロジェクトに基づいています。このプロジェクトを完成していない場合は、プロジェクト ファイルをダウンロードして、DesignSpark Electrical で解凍することができます。

プロジェクトのダウンロード

初めての場合は、演習の PDF ファイルを開いて熟読してください。PDF ファイルを印刷することをお勧めします。

ファイルのダウンロード

  • オブジェクトの処理

  • ブラック ボックスの挿入

  • 既存の要素のコピー

  • 回路管理

  • 端子の挿入

オブジェクトの処理

M1 モーター回路を修正し、モデルに合わせます (付録 4a)。

1.選択の「キャプチャ」モードを使用して、モーター シンボルとその垂直方向の上にあるワイヤを選択します。コンタクター シンボルの下にこれらを移動します。不要なワイヤを削除します。

メニュー: 配線図 > 移動

[コピー] コマンドを使用して、M1 モーター回路を複製します。

1.モーター回路全体を選択します。[配線図] メニューの [複数コピー] アイコンをクリックします。始点と終点を選択します。

メニュー: 配線図 > 複数コピー

コンポーネント マークが自動的に増加します。メーカー部品は保持されます。

ブラック ボックスの挿入

EV1 バリエーター (ブラック ボックス) を挿入し、その他のクラスに関連付け、材料端子を修正します。

1.[配線図] メニューの [ブラック ボックスの挿入] アイコンをクリックします。

メニュー: 配線図 > ブラック ボックスの挿入

2.[その他] クラスを割り当てます。

3.ルートを EV に変更します。

4.材料端子の番号を変更するには、ブラック ボックスのコンテキスト メニューの [シンボル端子の編集] コマンドを使用します。

ブラック ボックスのコンテキスト メニュー: シンボル端子の編集

5.[マーク] 列で材料端子番号を変更します。

既存の要素のコピー

配線図を移動または一部をコピーする場合、コピー/貼り付け ([Ctrl] + [C] / [Ctrl] + [V]) を使用するか、パターンとして保存できます。繰り返し要素では、パターンを使用することをお勧めします。

コピー/貼り付け。新しい配線図で K1 コマンド回路を移動します (マーク: 04 - 説明: コマンド)。

1.「キャプチャ」または「選択」モードを使用してエンティティを選択します。

2.Ctrl + C キーを使用して、選択したエンティティをコピーします。

3.図面 04 を作成して開きます。

4.列 6 で、高低極性ワイヤ (48VDC)、および戻りスイッチ接点が含まれる回路をプロットします (付録 5b)。

5.Ctrl + V キーを使用して、コピーしたエンティティを図面 04 で貼り付けます。

6.図面 03 で、K1 コマンド回路を削除します。

6.図面 04 で、シンボルのプロパティを使用して、シンボル マークを確認して適応します。

シンボルのコンテキスト メニュー: シンボル プロパティ

7.アセンブリを拡大して、モデルを拡大表示します (付録 5b)。

[コピー/貼り付け] コマンドは、ある図面から別の図面にエンティティを移動する最適の方法ではありません。このコマンドでは、既存のエンティティを削除し、コンポーネントのマークを管理する必要があります。切り取り/貼り付けコマンドを使用したほうが便利です。

コピー/形式を選択して貼り付け。図面 04 において、列 04 で K1 コマンド回路をコピーし、マークを再適応します。

1.Ctrl + C キーを使用してエンティティをコピーします。

2.Ctrl + Shift + V キーを使用して、選択したオブジェクトを貼り付けます。

3.付録 5b と矛盾しないようにオブジェクト マークを管理します。Q2 および K2 接点を、図面 03 の Q2 および K2 コンポーネントに関連付けます。

パターンの使用。図面 04 で、K2 コマンド回路を削除し、K1 コマンド回路から構成されているパターンを作成し、それを列 04 に挿入します。

1.エンティティを削除した後、K1 コマンド回路のエンティティを選択し、ドック可能パネルの [パターン] タブの [コマンド] グループへドラッグします。

2.パターンを挿入するには、ドック可能パネルからグラフィック領域にドラッグします。

3.[形式を選択して貼り付け] コマンドのように、コンポーネント マークを管理します。

パターンはコピー/形式を選択して貼り付けに類似して、パターン マネージャーに保存されているグラフィック オブジェクトが再使用されます。

回路管理

シンボルとメーカー部品の両方に回路が割り当てられています。デバイスの各極は回路に関連付けられています。それらの管理は、クロス リファレンスや材料端子表示の結果を良好にするのに非常に重要です。

材料端子の交換。図面 04 を修正し、K1 NO 接点の材料端子が「53/54」ではなく「83/84」になるようにします。

1.「K1」コンポーネントを編集し、[メーカー部品と回路] タブに移動します。

シンボルのコンテキスト メニュー: シンボル プロパティ

2.回路のリストで接点 (53/-54) を接点 (83/-84) にドラッグします。

関連トピック:

次の演習

目次


演習 06

DesignSpark Electrical - 演習 06

この演習では、等電位番号の割り当ての配線について学習します。この演習は、演習 05 で作成したプロジェクトに基づいています。このプロジェクトを完成していない場合は、プロジェクト ファイルをダウンロードして、DesignSpark Electrical で解凍することができます。

プロジェクトのダウンロード

初めての場合は、演習の PDF ファイルを開いて熟読してください。PDF ファイルを印刷することをお勧めします。

ファイルのダウンロード

  • ドック可能パネルからのシンボルの挿入

  • 多言語テキスト

  • 極性の始点と終点

  • 等電位番号の割り当て

  • 端子台の配線

ドック可能パネルからのシンボルの挿入

ケーブル結線図を削除します (02)。

新しい図面 (05)、信号を作成します。

ドック可能パネルのコンポーネントのリストを使用して、ワイヤを作図し、インジケーターを配置します。

1.ドック可能パネルの [コンポーネント] タブを開きます。

2.[L3] ロケーションを開きます。

3.「H1」のコンテキスト メニューで、[シンボルの挿入] コマンドを選択します。

4.シンボル セレクターが開き、インジケーター シンボルを選択できるようになります。

多言語テキスト

図面 05 上で、次の翻訳可能テキストを配置します。「Motor 1 On」と「Motor 2 On」。このテキストは、Arial フォント、高さ 6 mm、青字で表示されます。

基本テキストよりも多言語テキストを使用した方が適切です。多言語テキストはプロジェクト データベースに保存されています。

1.「多言語テキスト」挿入コマンドは [作図] メニューにあります。

メニュー: 作図 > 多言語テキスト

ドック可能パネルが変化し、作図オプションが表示されます。グラフィック領域でテキストの挿入点をクリックします (X および Y 座標を入力することもできます)。

2.テキストの回転角度を入力するか、グラフィック領域でグラフィカルに方向を指定します。

3.プロジェクトで管理されるメイン言語でテキストを入力します。

ドック可能パネルの下部には、各テキストの書式と両端揃えが表示されます。

4.複数行でテキストを作成するには、復帰改行コードを挿入します。

例

次のテキストの入力: 「Motor 1 \P ON」

結果は次のようになります。

極性の始点と終点

図面 03 と図面 04 の間に極性の始点と終点を配置します。

まず、始点/終点インターフェイスで複雑なナビゲーションを回避するために、「始点」矢印を受信する図面に移動してから、コマンドを実行することをお勧めします。

1.[始点/終点] コマンドは [配線図] メニューで使用できます。

メニュー: 回路図 > 渡り配線

2.「始点」と「終点」の図面の読み込みを確認します。必要に応じてナビゲーション アイコン (前の図面、次の図面、またはセレクター) を使用し、最初の始点/終点を作成します。

渡り配線 > 単一挿入

3.左側の図面上のワイヤの終点をクリックします (外向きの矢印 > 始点)。

4.右側の図面上のワイヤの終点をクリックします (内向きの矢印 > 終点)。

等電位番号の割り当て

ワイヤ番号の割り当て処理を実行します。

1.これは最初の番号割り当てであるため、[プロセス] メニューの [新しいワイヤの番号割り当て] コマンドを使用します。

メニュー: プロセス > 新しいワイヤの番号割り当て

列 1 の図面 03 上で F1 (N.R.S.T) のワイヤ アップストリームを修正します。

1.図面 03 を開き、列 1 のヒューズ断路器のワイヤ アップストリームを拡大します。

2.ワイヤ コンテキスト メニューで、[ワイヤ マークの編集] コマンドを選択し、番号を修正します。4 つのコンダクターを選択した状態でこの処理を実行できます。

ワイヤのコンテキスト メニュー: ワイヤ マークの編集

図面番号を含む 48VDC ワイヤの番号割り当て数式を修正します。

1.[ワイヤ スタイル構成] タブを開きます。

メニュー: プロジェクト > 構成 > ワイヤ スタイル

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ワイヤ スタイル...

2.ワイヤ「=48V」を選択し、[プロパティ] アイコンをクリックします。

ワイヤ スタイル マネージャー > プロパティ

3.等電位番号の割り当て数式に対応するボックスをクリックします。

4.数式マネージャーで、行 [ファイル マーク/等電位カウンター] をダブルクリックします。

番号の割り当て処理を再実行して図面を更新します。

1.図面で等電位番号を更新するには、[プロセス] メニューの [ワイヤ番号の再割り当て] コマンドを選択します。

メニュー: プロセス > ワイヤ番号の再割り当て

2.[ワイヤ番号の再割り当て] ダイアログ ボックスで、[手動番号の再計算] ボックスを選択せずに、[ワイヤ番号の再計算] オプションを選択します。

テキスト位置の管理

1.[テキストの配置] コマンドを使用して軸上にテキストを配置します。

メニュー: 配線図 > テキストの配置

2.位置合わせするテキストを選択します。

3.ワイヤに対して垂直な軸を作図し、テキスト基準位置に対応するサイドを選択します。

[テキストの配置] コマンドでは、ワイヤに沿ってテキストを移動することもできます。

4.[ワイヤ マークを表示/非表示] コマンドを使用して、テキストを表示または非表示にします。

メニュー: 配線図 > テキストを表示 > ワイヤ マークを表示/非表示

5.テキストを表示または非表示にするワイヤを選択します。

等電位番号からの自動渡り配線。

1.図面 05 を開き、極性ワイヤの番号を編集します。上部ワイヤの番号は 03/5 で下部ワイヤの番号は 03/6 です。

2.渡り配線を自動的に生成するには、[渡り配線] コマンドの [自動挿入] を選択します。

メニュー: 回路図 > 渡り配線/自動挿入

3.ダイアログ ボックスで、[同一マークのあるすべての等電位を接続] オプションを選択します。

ワイヤに同じ番号が割り当てられているため、ワイヤは自動的に接続されます。

ワイヤの番号割り当てを再実行し、図面 05 の等電位番号を修正します。

端子台の配線

図面 05 では、すべてのケーブルの図面で（結線図で予約されたケーブルを使用して）端子を配置して配線します。

1.図面 05 を開きます。

2.ワイヤのコンテキスト メニューを開いてケーブル コアを受信し、[ケーブル コアの関連付け] コマンドを選択します。

ワイヤのコンテキスト メニュー: ケーブル コアの関連付け

- ダイアログ ボックスの上部のリストで「W4」コアを選択します。

- ダイアログ ボックスの下部に表示されたワイヤを選択します。

- [ケーブル コアの関連付け] アイコンをクリックします。

- すべてのケーブルでこの操作を繰り返します。

複数のコンダクターを選択し、後からコマンドを実行すると、この操作を実行できます。これにより、選択したすべてのワイヤを配線できます。

関連トピック:

次の演習

目次


演習 07

DesignSpark Electrical - 演習 07

この演習の目的は、メーカー部品の操作、メーカー部品のコンポーネントへの割り当て、メーカー部品の作成、および電気コンテンツ ポータルの使用です。この演習は、演習 06 で作成したプロジェクトに基づいています。このプロジェクトを完成していない場合は、プロジェクト ファイルをダウンロードして、DesignSpark Electrical で解凍することができます。この演習を行うには、演習 01 にある環境を解凍する必要があります。

プロジェクトのダウンロード

初めての場合は、演習の PDF ファイルを開いて熟読してください。PDF ファイルを印刷することをお勧めします。

ファイルのダウンロード

  • メーカー部品の割り当て

  • 手動メーカー部品

  • メーカー部品の作成

メーカー部品の割り当て

ドック可能パネルを使用して、メーカー部品を参照されていないコンポーネントに割り当てます。(付録 7a を参照)

1.[コンポーネント] タブのドック可能パネルに移動し、参照する要素を選択します。

2.このコマンドはコンテキスト メニューで使用できます。

コンポーネントのコンテキスト メニュー: コンポーネント > メーカー部品の割り当て

注意: 既にメーカー部品がコンポーネントに割り当てられている場合は、このメーカー部品が削除され、選択したメーカー部品で置換されます。

3.[フィルター] タブに移動します。[自動更新] ボックスをオフにし、さまざまな条件を入力します。

4.[検索] ボタンをクリックします。

5.同じ方法でロケーションとデバイスを参照します。

手動メーカー部品

EV1 コンポーネントの部品を手動で入力します。

部品: 56356

メーカー: Siemens

説明: バリエーター

反転スイッチ材料端子を修正します (11、12、14)。

メーカー部品はカタログに追加されません。

1.コンポーネント「EV1」のコンテキスト メニューを開き、[コンポーネント プロパティ] コマンドを選択します。

シンボルのコンテキスト メニュー: コンポーネント プロパティ

2.[プロパティ] ダイアログ ボックスの [メーカー部品と回路] タブに移動します。

3.[手動追加] ボタンをクリックして、必要なデータを入力します。

4.[OK] をクリックします。この部品をカタログに保存するかどうかを確認するメッセージが表示されます。

5.部品はこのコンポーネントでのみ使用できます。

メーカー部品の作成

メーカー カタログを開き、次の部品を作成します。

部品: 123456

メーカー: Training

クラス: スターター\反転スイッチ

ライブラリ: ユーザー

タイプ: ベース

説明: コンタクター回路ブレーカー変流器

配線図シンボル: TR-TELE006

高さ: 105

幅: 203

奥行き: 104

この部品には 3 つの「NO 電源接点回路」があります。

デバイス端子は「1, 2, 3 –4, 5, 6」です。

1.メーカー部品マネージャーは [ライブラリ] メニューで使用できます。

メニュー: ライブラリ（Library）> メーカー部品マネージャー（Manufacturer parts manager）

2.[スターター] クラスを選択します。

3.[部品の追加] アイコンをクリックします。

メーカー部品マネージャー > 部品の追加

4.必要なデータを入力します。

この新しい部品をアーカイブします (他社に送信する場合など)。

5.前に作成した部品をアーカイブするには、部品を検索して選択します。メーカー部品マネージャーの [アーカイブ] アイコンをクリックします。

メーカー部品マネージャー > アーカイブ

このコンポーネントをプロジェクト (ドック可能パネル) に追加し、関連付けられたシンボルを図面のいずれかに挿入します。次に、挿入されたシンボルを削除します。

1.ドック可能パネルの [コンポーネント] タブに移動します。ロケーションのコンテキスト メニューで、新規 > コンポーネント メーカー部品コマンドを選択します。

サイド パネル: コンポーネント > ロケーションのコンテキスト メニュー > 新規 > コンポーネント メーカー部品

2.[スターター/反転スイッチ] クラスを選択します (マーク ルートが付きます)。

3.メーカーの「Training」から部品「123456」を検索します。

4.リストの最後に新しいマークが追加されます。

5.新しいコンポーネントのコンテキスト メニューを開き、[シンボルの挿入] コマンドを選択します。

ドック可能パネル: コンポーネント > シンボルの挿入

6.メーカー部品に関連付けられているシンボルが自動的に選択されます。それを挿入し、メーカー部品の関連付けを確認します。

関連トピック:

次の演習

目次


演習 11

DesignSpark Electrical - 演習 11

チュートリアルのプロジェクトの完成を目的としたこの演習では、リビジョン管理、印刷およびプロジェクト アーカイブのコマンドを分類しています。演習 10 を完了していない場合は、前の演習のプロジェクト ファイルをダウンロードしてください。これを DesignSpark Electrical で解凍します。

プロジェクトのダウンロード

  • リビジョンの管理

  • 印刷

  • アーカイブ

リビジョンの管理

[図面リスト] レポートを更新した後、リビジョン「A」をすべての図面に追加します。

1.レポート マネージャーで使用できるコマンドを使用すると、[図面リスト] レポートを手動で更新できます。リビジョン プロセスでは、図面レポートの更新を行うことができます。

レポート マネージャー: 図面の生成

2.まず、構成設定を修正します (プロジェクト構成 > 全般 > リビジョンの番号付け)。

メニュー: プロジェクト > 構成 > プロジェクト...> 全般 > リビジョンの番号付け

必要な形式を設定します。

リビジョンの番号付け: 0AB

3.ブックのコンテキスト メニューで [リビジョン] コマンドを選択します。

ブックのコンテキスト メニュー: リビジョン

4.[リビジョン インデックス管理] ダイアログ ボックスで、インデックス「0」の説明を入力します。

5.[確認] ボタン、[検証] ボタンの順にクリックします。 DesignSpark Electrical は、ブックのすべての図面をこのインデックスに増分するかどうかを確認します。

6.[OK] ボタンをクリックして終了します。

7.DesignSpark Electrical により提案されるその他の操作をキャンセルします。

8.この手順を繰り返し、インデックス「A」まで増分します。

印刷

すべてのプロジェクト図面が含まれる PDF ファイルを生成します。

PDF ファイルを生成するには、[印刷] コマンドを使用する方法と、[PDF ファイルのエクスポート] を使用する方法の 2 つの方法があります。

1.[インポート/エクスポート] メニュー (推奨)。

メニュー: インポート/エクスポート > PDF ファイルのエクスポート

2.PDF ファイルを保存するディレクトリを指定します。

3.デフォルトのパラメーターを保持します。

4.[印刷] ボタンをクリックして PDF ファイルを生成します。

アーカイブ

プロジェクトをアーカイブします。

1.プロジェクト マネージャーを開きます。

2.リストでプロジェクトを選択し、[閉じる] ボタンをクリックします。アーカイブするには、図面とプロジェクトを両方とも閉じる必要があります。

3.[アーカイブ] アイコンをクリックします。

プロジェクト マネージャー > アーカイブ

4.[図面の更新] オプションを選択し、すべてのプロジェクト図面を確実に更新します。

5.[ファイルのバックアップ] ダイアログ ボックスが開き、ディレクトリを選択し、ファイル名を修正できます。

関連トピック:

次の演習

目次


設定

DesignSpark Electrical には複数の構成レベルがあり、アプリケーション レベル (アプリケーション言語、グラフィック オプション、データベースなど) とプロジェクト レベルのパラメーターに分けられます。

プロジェクト レベルの構成パラメーターはプロジェクト レベルで保存されます (設定は当該のプロジェクトにのみ適用されます)。アプリケーション レベルの構成パラメーターは、その構成を使用するすべてのプロジェクトに適用されます。

  • アプリケーション設定

  • インターフェイス設定

  • プロジェクト構成

  • 数式マネージャー


アプリケーション設定

メニュー: ツール > アプリケーション設定

これらのパラメーターでは、データベース アクセス設定を構成できます。

  • データベース

関連トピック:

インターフェイス設定


データベース

メニュー: ツール > アプリケーション設定 > データベース

アプリケーション データのフォルダー: データベースの保存場所を表示します。

プロジェクトを含むフォルダー: プロジェクトのファイルを保存するフォルダーを表示します。

接続タイプ: 使用するデータベースのタイプを表示: SQL Server または SQLite。

サーバー名: SQL Server データベースのサーバー名を表示します。

ユーザー名: SQL Server データベースに接続するためのユーザー名を表示します。

パスワード: SQL Server データベースへの接続パスワードを表示します。

データベース名: 使用するデータベースの名前とバージョンを表示します。

[クエリ実行エラー ログの表示] ボタンを使用すると、ソフトウェアの使用中に失敗したクエリを含むファイルを開くことができます。


インターフェイス設定

メニュー: ツール > インターフェイス設定

これらのパラメーターでは、ユーザー インターフェイスの言語、およびソフトウェアのグラフィック要素を設定できます。

  • グラフィック オプション

  • アプリケーション言語

関連トピック:

アプリケーション設定

プロジェクト構成


グラフィック オプション

メニュー: ツール > インターフェイス構成 > グラフィック オプション

選択カーソル

ピックボックス サイズ (ピクセル): ピクセルで表記されます。カーソル サイズを設定できます。

クロスヘア (画面サイズに対する %): 画面サイズのパーセンテージで表記されます。十字カーソルのサイズを設定できます。

マウス ホイール ズーム

ズーム方向を反転: マウス ホイールを回したときのズーム方向を反転します。

ズーム速度 (%): マウス ホイールを回したときのズーム レベルのパラメーターを設定できます。

色

図面の背景色: 図面の背景色を定義できます。

マーカー色: 任意のマーカー色を設定できます。

位置とスタイル

リボンのフォント高さ: リボンで使用されるフォント サイズを変更できます。

オプション

開くことができるドキュメントの数 (Number of opened documents allowed): ソフトウェア セッションで開くことができるドキュメントの数を入力します。それぞれのドキュメントでメモリが使用されるため、あまり多くのドキュメントを開くとワークステーションの処理速度が低下することがあります。この制限を超えると、メッセージが表示されます。

選択モード: デフォルトでは、複数のエンティティを選択する場合は、最初のエンティティを選択してから [Ctrl] キーを押したままにして 2 番目のエンティティを選択する必要があります。このオプションでは、[Ctrl] キーを押すことなく複数のエンティティを選択できます。

単位系: プロジェクト外部で生成されたすべてのファイルに対して、ソフトウェアで使用される単位モード (ヤード・ポンド法またはメートル法) を設定します。

テキスト表示モード:テキスト表示品質を管理します。中国語などの一部の言語では、ベクトル モードで表示する必要があります。

テキスト印刷モード: テキスト印刷品質を管理します。中国語などの一部の言語では、ベクトル モードで表示する必要があります。

グラフィック アクセラレーション: グラフィック カードが互換の場合、グラフィック エンティティの編集時に、アクセラレーションを有効化してパフォーマンスを向上させます。問題が生じる場合は、無効にするか、別のオプションを試します。値を変更した場合、新しいレンダリングﾞモードを有効化するには、開いているドキュメントを閉じて再度開く必要があります。

ヘルプ: デフォルトのヘルプ ファイルを選択できます。ワーク ステーションにインストールされているもの (CHM ファイル) またはインターネット ヘルプ機能 (インターネット接続が必要) を選択できます。

プロジェクトを開く際に最近使用したファイルを開く: DesignSpark Electrical プロジェクトで最後に使用した図面を保存します。プロジェクトを再度開いたときに、この図面を自動的に再度開くことができます。使用するオプションをリストで選択します。

翻訳されたテキストを除去するかを確認: このオプションを選択した場合、メインの言語で説明（たとえば、コンポーネント プロパティまたはシンボル プロパティで利用可能）を変更するとき、DesignSpark Electrical でオプション ダイアログ ボックスが開き、このテキストの既存の翻訳を削除するかどうかを確認されます。

起動時にようこそページを表示: 選択すると、ソフトウェアの起動時に情報ダイアログ ボックスが開きます。このオプションの選択を解除しても、新規バージョンをインストールすると、毎回ようこそページが開きます。

[すべてのインターフェイスのリセット] ボタンを使用すると、ソフトウェアのすべてのダイアログ ボックスの位置とサイズ変更が消去されます。


アプリケーション言語

メニュー: ツール > インターフェイス構成 > アプリケーション言語

このタブでは、アプリケーション言語を定義できます。また、ライブラリとカタログで使用するデフォルトの言語も設定できます。

インターフェイス言語

使用するソフトウェア言語を設定します。この設定を変更する場合は、アプリケーションを再起動する必要があります。

マネージャーで使用する言語

マネージャーで使用可能にする言語を定義するには、このチェックボックスをオンにします。


プロジェクト構成

メニュー: プロジェクト > 構成

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成

  • プロジェクト...

  • ワイヤ スタイル...

  • 結線図の線種...

  • レポート...

  • ユーザー データ...

  • パレット...

プロジェクト構成パラメーターでは図面をパーソナル化し、独自のニーズに合った結果とプロセスを生成できます。

新しいプロジェクトが作成されるときには、構成パラメーターは「プロジェクト テンプレート」から取得されます。大量のパラメーターがある場合、すべての構成パラメーターを設定する必要がある「空の」プロジェクトを作成することは困難です。

アプリケーションおよびプロジェクト構成

特定のパラメーターはプロジェクト レベルでのみ管理されます (プロジェクト、ワイヤ スタイル、クロス リファレンス図面)。また、プロジェクト レベルまたはアプリケーション レベルで管理できるものもあります (、端子図面、ユーザー データなど)。

構成は 2 つの部分に分割され、ダイアログ ボックスに表示されます。ダイアログ ボックスの左側には、アプリケーション レベルに保管存された構成が表示されます。右側には、現在のプロジェクトに保管された構成が表示されます。

このダイアログ ボックスを使用しない構成タイプの場合、プロジェクトでのみパラメーターが有効です。

アプリケーション レベルで構成パラメーターを修正するときには、この構成を使用するすべてのプロジェクトで適用されます。このため、プロジェクト レベルで保存される構成パラメーターを修正するときには、そのプロジェクトでのみ有効です。

特定のアイコン ([プロジェクトに追加] および [アプリケーションに追加]) では、プロジェクト構成をアプリケーションへ、またはアプリケーション レベルからプロジェクトへ渡すことができます。


プロジェクト設定

メニュー: プロジェクト > 構成 > プロジェクト...

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...

ダイアログ ボックスにはさまざまなタブがあり、構成パラメーターにアクセスできます。これらのパラメーターは現在のプロジェクト固有ではありません。パラメーターは、多くの使用目的がありますが、特にマークやプロジェクトを構成する要素のグラフィック オプションの定義を容易にするために使用されます。これらのパラメーターはプロジェクト固有ではありません。

  • 全般

  • グラフィック

  • テキスト

  • マーク

  • タイトル ブロック

  • ライブラリとパレット

関連トピック:

プロジェクト構成


全般

メニュー: プロジェクト > 構成 > プロジェクト...> 一般

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...> 一般

プロジェクト言語

プロジェクトで使用する言語を選択します。最大 3 つの言語を選択します。第 2 言語または第 3 言語を使用していない場合は、リストから <空白> を選択します。

複数の言語で作業する場合は、プロジェクト言語を変更すると、テキストは自動的に表示されます。

標準

単位系: プロジェクトの単位 (メートル法またはヤード ポンド法) を定義します。このオプションは、配線図の単位に使用されます。

寸法の単位: プロジェクトの要素（メーカー部品の寸法）に使用する単位のタイプを選択します。

デフォルト ケーブル サイズ規格: ケーブルの測定 (断面、ゲージ、サーキュラー ミル - kcmil) に使用する規格を定義します。

日付の表示形式

表示形式: 使用する日付の形式をリストから選択します。独自の形式を入力することもできます。

システム日付: Windows の日付形式を使用します。

dd/mm/yyyy: 日/月/年の形式を使用します。

mm/dd/yyyy: 月/日/年の形式を使用します。

%d-%m-%y: 独自の日付形式を作成できます（%d = 日、%m = 月、%y = 年（2 桁）および %Y = 年（4 桁））。

使用可能な変数:

%a: 略式の曜日名 (例: Mon)

%A: 完全な曜日名 (例: Monday)

%b: 略式の月名 (例: Jan)

%B: 完全な月名 (例: January)

%c: ローカルの形式の日時

%d: 数値形式の月の日 (01 - 31)

%H: 24 時間形式の時間 (00 - 23)

%I: 12 時間形式の時間 (00 - 12)

%j: 数値形式の通日 (001 – 366)

%m: 数値形式の月 (01 - 12)

%M: 数値形式の現在の時間の分 (00 – 59)

%p: 12 時間形式の AM/PMの表示

%S: 数値形式の現在の分の秒 (00 – 59)

%U: 年の週 (日曜日を週の最初の曜日とする) (00 - 53)

%w: 数値による曜日 (0 – 6、日曜日 = 0 )

%W: 年の週 (月曜日を週の最初の曜日とする) (00 - 53)

%x: ローカル形式の日付

%X: ローカル形式の時刻

%y: 2 桁の年

%Y: 4 桁の年

%z、%Z: タイム ゾーン

プレビュー: 現在の表示形式設定の結果を表示します。

リビジョンの番号付け

書式: 必要なリビジョン モード (数字または英字、先頭に 0 を付けるかどうか) をリストから選択します。次のカスタム設定を使用するには、[カスタム] を選択します。

カスタム数式: 前の設定で [カスタム] 項目を選択した場合に限って使用します。数式マネージャーにアクセスし、固有の数式を作成します。

最新リビジョンの属性を入力: このオプションでは、相対モードで作業する際のリビジョン属性の表示を管理できます。

常に小さいインデックス属性を入力: このオプションでは、属性のインデックス番号を考慮することなく、リビジョン グリッドの下部でリビジョン インデックスを強制的に表示します。

インデックスから属性を入力: このオプションでは、リビジョン インデックスを対応する属性に挿入できます。たとえば、インデックス番号 -0 (現在のリビジョン) である属性がリビジョン グリッドの上部に挿入されている場合、現在のリビジョン インデックスはリビジョン グリッドの上部に挿入されます。

<デフォルト>

ブック: 部品表など) を自動的に生成するときにデフォルト ブックになります。

デフォルト構成

クロス リファレンス: プロジェクトのすべてのクロス リファレンスに使用する、デフォルトのクロス リファレンス構成ファイルを選択します。

オプション

常にロケーション マークの属性を入力する: 対応する属性 (#LOC_TAG) がシンボル定義に存在する場合、この属性にロケーション マークを反映するには、これをオンにします。

常にファンクション マークの属性を入力する: 対応する属性 (#FUN_TAG) がシンボル定義に存在する場合、この属性にファンクション マークを反映するには、これをオンにします。

関連トピック:

数式マネージャー


グラフィック

メニュー: プロジェクト > 構成 > プロジェクト...> グラフィック

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...> グラフィック

接続ドット

シンボル: ワイヤがシンボルに接続する場所にドットを表示する値 ([確認しない]、[常時] またはシンボルがワイヤと接続するときのみ) をリストで選択します。ドットのサイズと色も設定できます。

ワイヤ: [表示] チェック ボックスでは、2 本のワイヤが接続する場所のワイヤの交点にドットを配置して表示するかどうかを設定できます。ドットのサイズと色も設定できます。

線種

ロケーション: ロケーション領域の線タイプと色を定義します。

ファンクション: ファンクション領域の線タイプと色を定義します。

ケーブル コア: ケーブル/コアを表すために図面で使用される線タイプと色を定義します。

ブリッジ: 配線図ページのブリッジ (ワイヤ/ブリッジ) の表示パラメーター (色と線タイプ) を設定します。

等電位の競合: 2 つの異なる等電位 (異なる番号の等電位) を接続すると、等電位の競合が発生します。このチェック ボックスではコントロールが更新されます。線シンボルの線タイプと色を選択することもできます。

ケーブル ラベル: ケーブルをケーブル ラベルに結合している線のタイプや色を定義します。


テキスト

メニュー: プロジェクト > 構成 > プロジェクト...> テキスト

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...> テキスト

多言語テキスト

多言語テキストで使用する言語ごとに、フォント、高さ、スタイル、色を指定します。

その他のテキスト

このインターフェイスでは、グラフィカル図面に表示されるテキストの各種パラメーターにアクセスできます。各タイプのテキストのフォント、高さ、スタイル、色、およびテキストが属す要素を基準にした、X と Y のオフセットを編集できます。

これらのテキストの一部には、テキストのマークを管理するための数式があります。[...] ボタンをクリックすると、数式マネージャーにアクセスします。

[その他のテキスト] セクションで行われるすべての変更によって、既存テキストは自動的に更新されます。

ブラック ボックス接続点にシンボルを使用

このセクションは、有効になっている場合、ブラック ボックスの接続点（端子）の表示に使用されるシンボルの選択および編集を可能にします。シンボルを使用することで、特定のデータをシンボルの属性に反映できます。

シンボル選択を開き、目的のシンボルを選択できます。

シンボルを切り離します。

シンボル エディターを開き、シンボルを変更します。

ブラック ボックスの接続点（端子）を表すシンボルには、方向が指定された接続点（ワイヤの接続用）および属性が必要です。


マーク

メニュー: プロジェクト > 構成 > プロジェクト...> マーク

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...> マーク

数式マネージャーにアクセスできます。数式マネージャーは、セルをダブルクリックする方法でもアクセスできます。

ドキュメント マークを生成する数式

このセクションでは、ブック、フォルダー、および図面をマークする数式を入力できます。これらの数式は変数とテキスト文字列から構成され、区切り文字として「+」を使用します。

たとえば、数式「Bundle」 + BOOK_ORDERNO は次を返します。Bundle 1

[列] および [行] フィールドでは、行および列のマーキングに使用する数式を選択できます (クロス リファレンスおよび渡り配線に使用) 。

渡り配線およびクロス リファレンス

極性の渡り配線テキストとクロス リファレンス テキストの数式を入力できます。

マークの一意性の基準

端子の一意性のタイプを管理します。

コンポーネント: コンポーネント マークの一意性のレベルをドロップダウン リストから選択できます。たとえば、「ロケーション」別にマークを一意にする場合、同じロケーションに 2 つの同じコンポーネン マークを含めることはできません。同じロケーションに属さない場合は 2 つのマークを同じにすることができます。

ケーブル: ケーブル マークの一意性のレベルを管理できます。

ワイヤとコンポーネントの番号の割り当て

方向: このパラメーターを使用して、水平または垂直方向への優先度を管理します。 アイコンを選択した場合、同じ垂直軸に配置された要素のマークは、水平軸に配置された要素のマークに対して優先的に処理されます。

一意の順序の番号: このボックスを選択すると、マーク数式で使用される「Order number」変数から取得された値が連続してプロジェクト全体で使用されます。ボックスをオフにする場合、[マークの一意性の基準] マネージャーで選択された要素を修正するとすぐに、「Order number」は再び「1」から開始します。

たとえば、コンポーネント マークの一意性のレベルが ロケーション に設定され、ロケーション L1 で Q1 にマークされたシンボルを配置した場合、[一意の順序の番号] ボックスがオフなら、挿入されたロケーションに関係なく、2 番目のシンボルは Q2 にマークされます。一方、ボックスがオンの場合は、異なるロケーションに挿入されるとシンボルは Q1 にマークされ、ロケーション L1 に挿入されると Q2 にマークされます。

ワイヤ スタイル マネージャー: ボタンを使用すると、ワイヤ スタイル マネージャーを開き、接続パラメーターの番号割り当てを設定できます。マークは図面の地理的な位置と相対的に計算され、左上の端から開始し、図面の右下の端へ向かいます。

未使用マークを割り当て: このオプションを選択すると、ワイヤまたは等電位番号、あるいは新しいコンポーネント マークまたは新しいケーブルに割り当てられている順序番号のみが新しい番号になります。除去された番号は使用されません。

コンポーネント マークの優先度: マーク番号の再割り当て機能で使用し、番号割り当ての開始に使用するシンボルのタイプを選択します。たとえば、Multiwire symbolオプションを選択すると、番号「1」は、先に結線図シンボルが見つかった場合でも、最初に見つかった配線図シンボルの影響を受けます。

マーク

IEC61346 番号割り当て規格 (=F1+A1-KA1) またはカスタム マークを使用できます。

カスタム マークを選択する場合、ロケーションやファンクションなど、各種のマーキングシステムに対して数式を入力する必要があります。これらの数式は変数とテキスト文字列から構成され、区切り文字として「+」を使用します。

また、マーク パスの区切り文字を選択することもできます。この区切り文字が使用されるのは、コンポーネントをカスケードして、コンポーネント マークと、マスター コンポーネントのマークを分離する場合です。リストで提案される値を選択するか、必要な特定の文字を入力します。

マークでソート

すべてのマーク済み要素のマークのソートには、複数のオプションを使用できます。マーク ソートのオプションが使用できるのは、ドック可能パネルの [コンポーネント] タブ、、配線接続順序、ケーブル、PLC および検索マネージャー内です。

ルート/順番による自動マーク後に手動マーク: 最初にルート (数式で使用されている場合) によりソートされた自動番号、順番 (番号はルートで一意) と表示してから、最後に、アルファベット順でソートされた手動マークを表示します。これがデフォルトのモードです。

自然ソート、自動と手動の混合: Windows エクスプローラーで参照できるのと同様に、すべてのマーク (手動と自動) をアルファベット順でソートします。例: A1、A2、A3、A10、A11、A20...

関連トピック:

数式マネージャー


タイトル ブロック

メニュー: プロジェクト > 構成 > プロジェクト...> タイトル ブロック

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...> タイトル ブロック

このタブでは、さまざまなプロジェクトの図面タイプに関連付けるデフォルト タイトル ブロックを選択できます。関連付けを変更するには、[...] ボタンをクリックします。タイトル ブロック セレクターが開き、適用するデフォルト タイトル ブロックを選択できるようになります。

関連トピック:

タイトル ブロック セレクター


ライブラリとパレット

メニュー: プロジェクト > 構成 > プロジェクト...> ライブラリとパレット

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > プロジェクト...> ライブラリとパレット

表示されたライブラリ

ライブラリ フィルターを設定できます。リストされているライブラリをチェックし、そのライブラリ内に含まれるすべての要素 (たとえば、IEC の場合は IEC 標準シンボル) をプロジェクト設計中に使用可能にします。

使用中のパレット

使用するパレットを設定します。6 個のパレットを使用でき、それぞれに特定の形式をポップダウン メニューから選択できます。


ワイヤ スタイル

メニュー: プロジェクト > 構成 > ワイヤ スタイル

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ワイヤ スタイル...

ドック可能パネルからワイヤを挿入する場合、[...] ボタンをクリックし、[マネージャー] ボタンを選択してもマネージャーを開くことができます。

線種マネージャーは、プロジェクトの回路図で使用できるすべてのワイヤを再グループ化します。線種マネージャーは等電位またはワイヤ番号の割り当てを設定するために使用されます。

これらのパラメーターはプロジェクト固有です。

  • ワイヤ スタイルの管理

  • ワイヤ プロパティ

  • 番号の割り当て構成

  • グループ番号の割り当てプロパティ

関連トピック:

プロジェクト構成


ワイヤ スタイルの管理

メニュー: プロジェクト > 構成 > ワイヤ スタイル...

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ワイヤ スタイル...

ワイヤの作図 > [...]> [マネージャー]

マネージャーでは、新しいタイプの電気ワイヤを追加したり、既存のタイプのワイヤを修正したりできます。

ダイアログ ボックスの左側にはワイヤ グループのリストが表示され、右側には使用可能な異なるワイヤのパラメーターが表示されます。

ワイヤはグループ番号の割り当てに属します。これは同じカウンターを共有するため、ワイヤの番号を割り当てるときに使用されます。

電気ワイヤには 2 種類あります。

  • 通常、ワイヤ コマンドは 1 本のワイヤを作図するために使用されます。

  • 電源ワイヤは複数のワイヤを同時に作図するために使用されます。

構成

[構成] アイコンを使用すると、ダイアログ ボックスの右側に表示される列を選択できます。

グループの管理

グループ番号の割り当ての無効化

グループ番号の割り当てを無効化できます。これはワイヤの番号を割り当てるときには除外されません。グループ名の前にあるチェック ボックスは、グループの状態を示します (チェック ボックス = 有効なグループ)。

グループ番号の割り当てコンテキスト メニューを使用して、目的のオプションを選択します。

新しい番号割り当てグループの追加

新しい番号割り当てグループを追加するには、メイン メニューの [番号割り当てグループの追加] アイコンをクリックします。その他の後にグループが自動的に追加されます。この新しいグループにはすでに新しいタイプに接続があります (グループは接続を含まずに存在できません)。

番号割り当てグループの削除

番号割り当てグループを削除するには、番号割り当てグループを選択し、[削除] アイコンをクリックします。番号割り当てグループのコンテキスト メニューからも、削除コマンドを実行できます。番号割り当てグループが削除されると、回路図で使用されている場合を除き、このグループに含まれるすべてのワイヤが自動的に削除されます。

ワイヤとコンダクターの管理

ワイヤの追加

2 つの方法でワイヤを追加できます。作成や追加を行うワイヤのタイプに従って、[追加] アイコンや [複数追加] アイコンを使用するか、番号割り当てグループからコンテキスト ドロップダウン メニューを使用できます。

選択した番号割り当てグループで、新しいワイヤはリストの最後に自動的に追加されます。

[コピー]、[貼り付け] および [形式を選択して貼り付け] コマンドを使用すると、既存のワイヤ スタイルを複製して新しいワイヤ スタイルを作成することができます。プロジェクト レベルにワイヤ スタイルを貼り付けると、新しいグループに新しいワイヤ スタイルが自動的に作成されます。

コピー/貼り付け/形式を選択して貼り付け機能を使用すると、あるプロジェクトから別のプロジェクトにワイヤの定義をコピーできます。

ワイヤ タイプへのコンダクターの追加

ワイヤのコンテキスト メニュー経由で既存のワイヤ タイプにコンダクターを追加し、[ワイヤをワイヤ スタイルに追加] オプションを選択できます。

下/上

矢印形式の 2 つのアイコンを使用すると、コンダクターを並び替えることができます (上下に移動できます)。

ワイヤ スタイルの削除

ワイヤ スタイルを削除するには、ワイヤ スタイルを選択して [削除] アイコンをクリックするか、削除するワイヤ スタイルを右クリックしてコンテキスト メニューから [削除] オプションを選択します。現在回路図で使用されていない場合にのみ、ワイヤ スタイルを削除できます。

コンダクターの削除

コンダクターを削除するには、コンダクターを選択して [削除] アイコンをクリックするか、コンダクターのドロップダウン メニューの [削除] オプションを選択します。ワイヤ タイプが図面または回路図で使用されていない場合にのみ、コンダクターを削除できます。

関連トピック:

グループ番号の割り当てプロパティ

ワイヤ プロパティ

番号の割り当て構成

ワイヤ番号の割り当て

ワイヤの作図


ワイヤ プロパティ

メニュー: プロジェクト > 構成 > ワイヤ スタイル> プロパティ

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ワイヤ スタイル...> プロパティ

ワイヤの作図 > [...]> [マネージャー] > プロパティ

このダイアログには、選択したワイヤ スタイルを使用しているすべての導体の共通プロパティが表示されます。

複数のワイヤ スタイルを選択して、選択したすべてのスタイルに共通のプロパティ値を変更する際に、選択したスタイルで定義したすべての導体に新しいプロパティ値を適用します。たとえば、線色プロパティが設定されている複数のワイヤ スタイルを選択し、プロパティ値を赤に変更すると、選択したワイヤ スタイルで定義されたすべての導体は、アクティブなドキュメント内で赤に変わります。

ワイヤ タイプまたはコンダクター タイプを選択し、[プロパティ] アイコンを選択するか、コンテキスト メニューから [プロパティ] オプションを選択します。

ワイヤ プロパティ

ワイヤ スタイル

名前: ワイヤの名前。

番号割り当てグループ: ワイヤが属するグループ。

全般

コンダクター: コンダクターのタイプ。非電気コンダクターも指定できます。

線色: [...] ボタンをクリックして、ワイヤを表す線の色を選択します。

線種: ワイヤを表す線のタイプ。

線幅: 特定のワイヤに幅を設定します。この幅は配線図のワイヤに自動的に適用されます。

等電位数式: [...] ボタンをクリックして数式マネージャーを開き、等電位番号の割り当てに使用する数式を定義します。

ワイヤ数式: [...] ボタンをクリックして数式マネージャーを開き、ワイヤ番号の割り当てに使用する数式を定義します。

反映: このワイヤ スタイルのワイヤについて、データの反映機能による更新を容認する場合は、このボックスをオンにします。

ケーブル

このセクションではワイヤ配線のパラメーターを設定します。ケーブル参照を関連付けると、これらのフィールドは参照に従って自動的に更新されます。これらの設定は、配線図内にある当該のタイプのすべてのワイヤに適用されます。

直径: ワイヤの直径。

断面またはゲージ: ワイヤの断面。

ワイヤ サイズ規格: プロジェクトで使用する規格。

ワイヤの色: [...] ボタンをクリックして、ワイヤの実際の色を選択します。

ベンド半径 (x 直径): ベンド半径の計算に必要なパラメーター (パラメーター×直径 = ベンド半径)。

ケーブル参照: [...] ボタンをクリックし、ケーブル参照を関連付けます

技術データ

電圧: 未実装の電気データ。

周波数: 未実装の電気データ。

説明

プロジェクトに必要な説明を各種言語で入力します。

ユーザー データ

このプロパティを使用して、プロジェクト固有のデータをリストします。

翻訳可能データ

このプロパティを使用して、翻訳が必要なデータをリストします。

コンダクター プロパティ

このダイアログ ボックスは、ワイヤの [プロパティ] ダイアログ ボックスに似ています。ただし、このダイアログ ボックスには、ワイヤ スタイルを構成するすべてのコンダクターに共通なプロパティが表示されます。

ワイヤまたはワイヤ スタイル内の導体のプロパティの編集、導体の色の変更、等電位およびワイヤ数式の修正が必要な場合があります。

関連トピック:

ワイヤ スタイル マネージャー

パラメーターの番号の割り当て


番号の割り当て構成

メニュー: プロジェクト > 構成 > ワイヤ スタイル

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ワイヤ スタイル...

ワイヤの挿入 > [...]> [マネージャー]

すべてのワイヤ番号の割り当て設定には 3 つのレベルがあります。

  • プロジェクト構成

  • ワイヤ スタイル マネージャー

  • ワイヤ固有の設定

プロジェクト設定の番号割り当てオプション

プロジェクト レベルの番号割り当て設定は、プロジェクト設定 ダイアログ ボックスの マーク タブからアクセスできます。

利用可能なオプションは次の通りです。

方向: ワイヤの番号割り当ての方向を定義します。可能な設定は、水平方向の順序、垂直方向の順序、水平または水平方向の優先順序です。

ワイヤ スタイル: ワイヤ スタイル マネージャー ダイアログ ボックス内の番号の割り当てマネージャーのオプションに直接アクセスできます。

ワイヤ スタイル マネージャーの番号割り当てオプション

ワイヤ スタイル マネージャー では、いくつかの番号割り当てオプションを使用できます。

DesignSpark Electrical では、次の 2 つの方法でワイヤに番号を割り当てることができます。

- 等電位番号の割り当て｡同じメッシュに接続 (まとめて接続) するすべてのワイヤが同じ番号を使用します。

- ワイヤの番号割り当て｡それぞれの物理ワイヤに個別に番号を割り当てます。

番号の割り当て (ワイヤ/等電位): 等電位 または ワイヤ のいずれかの番号割り当てモードを選択します。

表示: 番号の表示に使用するモードを選択します。番号はセグメントの中央に配置するか、メッシュの最初のセグメントまたは最後のセグメントに配置します。ワイヤ番号の割り当てでは、「ワイヤごとに 1 つの番号」モードは使用できません。

ワイヤ スタイルの番号割り当てオプション

    • グループ番号の割り当てプロパティ

ワイヤは「番号割り当てグループ」にグループ化されるため、グループに属するすべてのワイヤが同じカウンターを使用します。これにより、ワイヤ タイプが異なる場合でも、ワイヤ内での番号が連続することが保証されます。

番号割り当てグループの パラメーターには、コンテキスト メニューの [プロパティ] オプション経由でアクセスできます。

グループ番号の割り当て

最初の設定は、グループの番号です。この番号は変更できません。すべてのグループは自動的に増分する「カウンター」に関連付けられます。これにより、番号割り当てグループ内の 2 つのワイヤに対して、同じ番号が誤って適用されないことが保証されます。

ワイヤ番号の割り当てオプション

番号割り当てを有効にする: グループのワイヤの番号割り当てを有効または無効にできます。

オプションを無効にする場合は、グループのいずれのワイヤにも番号が割り当てられません。

開始番号: グループに適用される最初のワイヤ番号を定義できます。

たとえば、値「100」を入力すると、最初のワイヤ番号は 100、次の番号は 101 というようになります。

マークの一意性の基準: ワイヤ マークの一意性レベルを管理できます。たとえば、一意性のレベルを「プロジェクト」に設定すると、カウンターはプロジェクト全体で連続します。「ブック」に設定すると、ブックを変更するとその都度、カウンターが 開始番号 パラメーターの値で再開します。

複数ワイヤの順序の番号の計算

グループの電源ワイヤの番号割り当てモード定義できます。

最初のモードではすべてのワイヤ コンダクターに異なる番号が割当てられ、次のモードではすべてのワイヤ コンダクターに対して同じ番号が割り当てられます。

このモードでは、番号割り当て数式にプレフィックスを追加することをお勧めします。このようにしないと、すべてのワイヤ コンダクターの値が同一になります。

    • ワイヤ プロパティ

ワイヤ番号の割り当てパラメーターはワイヤ スタイル プロパティで使用できます。

[等電位数式とワイヤ数式] フィールドでは、変数と文字列から構成される数式を入力できます。

使用可能な変数のリストは、等電位番号とワイヤ番号の割り当てによって異なります。

数式生成の詳細については、数式マネージャーの章を参照してください。

関連トピック:

ワイヤ スタイルの管理

ワイヤ番号の割り当て

数式マネージャー


グループ番号の割り当てプロパティ

メニュー: プロジェクト > 構成 > ワイヤ スタイル> プロパティ

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ワイヤ スタイル...> プロパティ

ワイヤの作図 > [...]> [マネージャー] > プロパティ

ワイヤ スタイル マネージャーでは、グループのプロパティはグループのコンテキスト メニューからアクセスできます。また、グループを選択して [プロパティ] アイコンをクリックするという方法もあります。

ワイヤは番号割り当てグループ内でグループ化されるため、そのグループに属するすべてのワイヤが同じカウンターを使用します。これにより、ワイヤ タイプが異なる場合でも、ワイヤ内での番号が連続するようになります。

全般

最初の設定は、グループの番号です。この番号は変更できません。どのグループも、自動増加カウンターに関連付けられています。このため、番号割り当てグループ内の 2 つのワイヤに対して、同じ番号が適用されることはありません。

説明

ソフトウェアにより管理されるすべての言語でグループに名前を入力することができます。

ワイヤ番号の割り当てオプション

番号割り当てを有効にする: グループ内でのワイヤの番号割り当てを有効または無効にします。

オプションを無効にすると、グループのいずれのワイヤにも番号が割り当てられません。

開始番号: グループの最初のワイヤ番号を定義します。

値「100」を入力すると、最初のワイヤ番号は 100、次の番号は 101 というように設定されます。

マークの一意性の基準: ワイヤ マークの一意性レベルを管理できます。一意性のレベルを「プロジェクト」に設定すると、カウンターはプロジェクト全体で連続します。「ブック」に設定すると、ブックを変更するとその都度、カウンターが [開始番号] パラメーターの値で再開します。等電位のロケーションは、その他の情報に関して、始点コンポーネントと同様に、最初のセグメントにより指定されます。始点コンポーネントが存在する場合は、等電位のロケーションはコンポーネントのロケーションです。それ以外の場合は、このセグメントが描画されるファイルのロケーションです (または、ロケーション領域で始まる場合はロケーション領域)。

複数ワイヤの順序の番号の計算

グループのワイヤの番号割り当てモードを定義します。

[各ワイヤで異なる] オプションでは、ワイヤ コンダクターごとに異なる番号を割り当てます。

[異なるワイヤで共通] オプションでは、すべてのワイヤ コンダクターに同じ番号を割り当てます。2 番目のモードでは、番号割り当て数式にプレフィックスを追加することをお勧めします。この操作を行わない場合、すべてのワイヤ コンダクターの値が同じになります。

関連トピック:

ワイヤ スタイル

番号の割り当て構成


結線図の線種

メニュー: プロジェクト > 構成 > 結線図の線種...

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > 結線図の線種...

結線図にワイヤを挿入する場合、ドック可能パネルで [...] ボタンをクリックし、[マネージャー] ボタンを選択することでもマネージャーを開くことができます。

[ケーブル スタイル マネージャー] ダイアログが開き、ケーブル タイプの作成または修正ができます。

追加: 新しいケーブル タイプを作成できます。

削除: 選択したケーブル タイプを削除します。

コピー: 選択したスタイルのコピーをソフトウェアのクリップボードに配置します。

貼り付け: ソフトウェアのクリップボードに存在するスタイルを挿入します。

形式を選択して貼り付け: ソフトウェアのクリップボードに存在するスタイルを挿入しますが、そのマークを管理できます。

コピー/貼り付け/形式を選択して貼り付け機能を使用すると、あるプロジェクトから別のプロジェクトに結線図の線種の定義をコピーできます。

ケーブル タイプを編集するには、修正するケーブル列をクリックします (説明、色、線タイプ)。

関連トピック:

ケーブルの描画


レポート

メニュー: プロジェクト > 構成 > レポート...

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > レポート...

レポート テンプレート マネージャーでは、アプリケーションに添付された構成と、プロジェクトに添付された構成を識別して定義できます。

アプリケーションに添付された構成は、それを使用するすべてのプロジェクトで共通になります。プロジェクトに添付された構成は、現在のプロジェクトでのみ表示されます。

DesignSpark Electrical では、プロジェクトの構成が優先的に使用され、プロジェクトの構成が使用できない場合は、アプリケーションの構成が使用されます。

削除: 選択した構成ファイルを削除します。

プロパティ: 選択した構成ファイルを編集します。

複製 : 構成ファイルをコピーします。修正するファイルを開くかどうかを確認するメッセージが表示されます。

プロジェクト/アプリケーションに追加: アプリケーション レベルで使用可能な構成をプロジェクトに追加します。また、同様にしてプロジェクト用に作成した構成をアプリケーション レベルで使用可能にできます。

アーカイブ: 構成アーカイブ ファイルを作成します。この機能は、構成ファイルを交換するために使用されます。

解凍: 最初にアーカイブされた構成ファイルを回復します。

プロジェクトで使用/プロジェクトから除去: プロジェクトで使用される構成のリストで、ファイルを追加または除去します。

名前の変更: 選択した構成ファイル名を変更します。ダイアログ ボックスが開き、新しいファイル名を定義するように指示されます。

設計ルールの変更: レポート構成を設計ルール構成に変更します。

関連トピック:

レポート マネージャー

レポート設定の編集

レポートの追加

レポートのスケジュール

図面レポートの生成

Excel エクスポート

テキスト エクスポート

XML エクスポート


レポート構成の編集

メニュー: プロジェクト（Project）> 構成（Configurations）> レポート（Report）> プロパティ（Properties）

メニュー: レポート マネージャー > プロパティ

プロジェクトのコンテキスト メニュー: 構成 > レポート >

レポート図面のコンテキスト メニュー: レポート構成の編集

このコマンドでは、選択したレポート構成を編集できます。

すべてのレポート構成パラメーターを表示するダイアログ ボックスが開きます。

プレビュー ウィンドウが開いて設定をチェックできます。

グラフィック領域に合わせてプレビューを調整します。

全般

名前: 構成ファイル名を変更できます。

タイプ: リストで、レポート構成タイプを選択します。

説明: ソフトウェアでサポートされているあらゆる言語で説明を入力できます。

スタイル

テーブルに表示されている各テキスト タイプのフォント、高さ、色、およびスタイルを管理できます。

列

テーブルの列と列の内容を定義できます。

プレビューを変更します。このオプションを有効にすると、プレビューで、図面スペースにテーブルが表示されます。

列の並べ替えに関するヒントが表示されます。

レポート構成で管理する列を選択できます。チェック ボックスは、目的のフィールドに対応します。アイコン (矢印) を使用して、列を並べ替えることができます。

新しい列を追加できます。このアイコンは、エキスパート モードが有効な場合のみ使用できます。

列を削除できます。このアイコンは、エキスパート モードが有効な場合のみ使用できます。

ヘッダー: テーブルの最初の行。ヘッダーには、データ タイプを示すテキストが含まれています。プロジェクトでサポートされているすべての言語でテキストを入力する必要があります。

内容: データ フィールドは、プロジェクト データベースに保存されます。列のプロパティにアクセスするには、セルをクリックします。

移動: コンポーネントのマーク ID などのデータおよびプロジェクトの要素 (コンポーネント) とのリンクを作成できます。

幅: 列の幅を入力します。

合計を計算: このデータはオプションです。数値データのみを合計することができます。

垂直区切りを印刷: このオプションをオフにすると、2 つの列間の縦線が除去されます。

複数線: このオプションが有効になっていて、テキストがセルよりも長い場合は、残りのテキストが 2 行目に表示されます。

ヘッダーの配置: ヘッダー テキストの両端揃えを管理できます。

内容の配置: 内容のテキストの両端揃えを管理できます。

行のマージ: データの値が同じ場合にデータをグループ化します。

リストの重複: 行をマージすると、同じセル内のすべてのデータが以降の列に表示されます。このオプションを有効にすると、同じデータを複数回含まれるようになります。

区切り文字: この文字は、重複するものが存在する場合にデータを区切るのに使用します。

レイアウト

図面のテーブルの位置を設定できます。

図面スペース

高さ: テーブルを描画可能な領域の高さを入力します。

幅: テーブルを描画可能な領域の幅を入力します。

図面スペースに挿入

X 座標/Y 座標: マージンに対応する領域の座標を入力します (テーブルはタイトル ブロックのグリッドに描画できません)。

テーブル間のマージン

水平/垂直: 各テーブル間の距離を入力します。

タイトルとテーブル間のスペース: テーブル タイトルのテキストとテーブル間の距離を入力します。

オプション

'|' 文字を改行として使用: レポートの改行を管理するときは、このオプションを選択します。レポートの種類 (図面や Excel ファイルなど) ごとに、文字「|」(Alt 124) は特定の改行文字に置き換わります。

テーブルを切り取らない: 分割を使用した場合、テーブルが図面全体を占有しないことがあります。このため、2 番目のテーブルを同じ図面に描画することができます。このオプションを選択し、2 番目のテーブルが図面に完全に描画できない場合、そのテーブルは新しい図面に描画されます。

ページごとに 1 つのテーブル: 分割を使用し、このオプションをオンにした場合は、1 ページに複数のテーブルを表示することはでいません。

図面リスト: 図面リストの特別なオプションです。図面リストを実行すると、1 つまたは複数の新しい図面が作成されます。レポートは複数回実行されて、これらの新しい図面が統合されます。

ブックごとに 1 つのレポート: ブックで分割を使用した場合、1 つのブックのすべてのレポート図面をグループ化するか、それらを異なるブックに分散させることができます。

このレポートに関連付けられているタイトル ブロックがこのタブに表示されます。プロジェクト構成に設定されているものと異なっていてもかまいません。

アイコンをクリックしてこれを変更できます。

ソート/分割

データのソートを設定できます。分割では、レポートをテーブルに分割し、同じ値を持つデータをグループ化できます (分割 = テーブルごとに 1 つ)。

テーブルの左上にタイトルを挿入できます。自動または数式を使用して、テーブルのタイトルを設定することもできます。

タイトル数式: 数式マネージャーにアクセスして、テーブルのタイトルの数式を作成できます。

改ページの自動数式: このオプションは、設定した分割から自動的にタイトルを設定します。

ソート順と改ページ条件: ソート用のフィールドを追加します。上下の矢印を使用して順序を管理できます。この順序は、最初のフィールド、2 番目のフィールドの順番に基づいて作成されます。改ページを作成するには、このボックスをチェックします。

フィルター

フィルターは、レポート データでの抽出を可能にします。たとえば、特定のメーカーのメーカー部品、あるいは特定のブックの図面リストを表示できます。

新しいフィルターを作成できます。

選択したフィルターを複製します。

選択したフィルターを削除します。

選択したフィルター定義を開きます。

ファイル名: レポートで使用される各フィルターの名前を表示します。

フィルターの説明: プロジェクトで使用されるメイン言語でフィルターの説明を表示します。

フィルター: フィルター条件を表示します。

ファイル データ

このタブでは、レポート図面のプロパティに転送する情報を自動生成するためのパラメーターを定義できます。右側の列をクリックすると、数式マネージャーが開きます。

名前: この数式では、図面マークを定義できます。空の数式のままにしておくと、構成パラメーターが使用されます。

説明: レポート図面の説明に転送するデータを自動生成するためのパラメーターを定義できます。

ユーザー データ/翻訳可能なデータ: レポート図面のユーザー データに転送するデータを自動生成するためのパラメーターを設定できます。

エキスパート モードの有効化

エキスパート モードでは、レポートを生成するために使用される SQL クエリを直接操作できます。このモードは SQL を使用でき、データベース構造に関する知識を持つユーザーのみを対象としています。

警告: 変更を正しく実行しなかったり十分に考慮せずに実行すると、予期しない結果を引き起こしたり、レポート構成が完全に失われるおそれがあります。

「エキスパート」モードが有効な間は、新しい SQL クエリ タブが表示されます。左側には SQL 形式でクエリが表示されます。右側には使用可能なテーブルとフィールドのリストが表示されます。

カラムの追加と削除: カラムを追加または削除できます。この機能は [列] タブの追加または削除とは異なります。エキスパート モードでカラムを追加または削除すると、クエリのフィールドが追加または削除されます。

ファイルを開く: ファイル エディターで XML ファイルを開きます (レポート構成またはクエリのパラメーターを保存します)。

編集: クエリを編集できます。

テスト: クエリの結果をテストできます。有効な場合、結果を表示するダイアログ ボックスが表示されます。クエリが無効な場合、アラート メッセージが表示されます。

クエリをエクスポート: レポートで使用されたクエリをテキスト ファイルにエクスポートできます。このファイルは、自動的に開きます。

関連トピック:

レポート マネージャー

レポートの追加

レポートのスケジュール

レポート図面の生成

Excel エクスポート

テキスト エクスポート

XML エクスポート


ユーザー データ

メニュー: プロジェクト > 構成 > ユーザー データ...

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ユーザー データ...

ユーザー データは、プロジェクト全体にわたって存在します。ユーザー データは、配線図またはレポートに表示可能な個人情報を保存するために使用します。次の 2 種類のユーザー データがあります。翻訳可能ユーザー データ (プロジェクト翻訳中に翻訳) と翻訳不能ユーザー データの 2 種類です。

ダイアログ ボックスの左側には、すべてのプロジェクトで共通のアプリケーション レベルで使用可能な構成が表示されます。ダイアログ ボックスの右側には、現在のプロジェクトでのみ使用可能なすべての構成のリストが表示されます。

新規: 新しい構成ファイルを作成します。

削除: 選択した構成ファイルを削除します。

プロパティ: 選択した構成ファイルを編集します。

複製 : 構成ファイルをコピーします。修正するファイルを開くかどうかを確認するメッセージが表示されます。

プロジェクト/アプリケーションに追加: アプリケーション レベルで使用可能な構成をプロジェクトに追加します。また、同様にしてプロジェクト用に作成した構成をアプリケーション レベルで使用可能にできます。

アーカイブ: 構成アーカイブ ファイルを作成します。この機能は、構成ファイルを交換するために使用されます。

解凍: 最初にアーカイブされた構成ファイルを回復します。

関連トピック:

ユーザー データ カスタマイズ


ユーザー データ カスタマイズ

メニュー: プロジェクト > 構成 > ユーザー データ...> プロパティ

メニュー: プロジェクト > 構成 > ユーザー データ...> 新規

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ユーザー データ...> プロパティ

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > ユーザー データ...> 新規

ダイアログ ボックスは次の 2 つのタブに分かれています。[全般] タブでは、ユーザー データ構成ファイルの説明を設定できます。2 番目の [編集] では、ユーザー データを管理できます

[編集] タブのダイアログ ボックスの左側にはユーザー データが表示され、右側にはユーザー データまたは選択したグループの名前が表示されます。

ユーザー データはグループの下で再グループ化されます (グループ名「ユーザー データ」と「翻訳可能データ」は変更可能であり、データ タイプを区別する目的でのみ使用されます)。必要な数のグループを作成できますが、特定の要素ではユーザー データ数が制限されています (たとえば、ケーブルの場合、翻訳可能なユーザー データ数は 3 までに制限されています)。

ユーザー データの管理を容易にするために、ユーザー データの各項目の前に順序番号が付いています。この番号は電気オブジェクト プロパティのダイアログ ボックスでも表示されます。

グループの挿入: 新しいユーザー データ グループを挿入できます。

ユーザー データの挿入: 新しいユーザー データ (翻訳不能) を作成できます。ユーザー データは選択したグループで作成されます。

翻訳可能なデータの挿入: 新しい翻訳可能データを作成できます。翻訳可能データは選択したグループで作成されます。

上下に移動: ユーザー データの順序を並び替えます。

削除: 選択したユーザー データを削除できます。

保存: 構成ファイルを保存できます。ダイアログ ボックスが閉じるときに登録することもできます。

切り取り/コピー/貼り付け: 既存のユーザー データを複製できます。


パレット

メニュー: プロジェクト > 構成 > パレット...

ドック可能パネル > プロジェクトのコンテキスト メニュー: 構成 > パレット...

パレットを使用して、配線図または結線図シンボル、配線図パターン の I/O を保存します。

ダイアログ ボックスの左側には、すべてのプロジェクトで共通のアプリケーション レベルで使用可能な構成が表示されます。ダイアログ ボックスの右側には、現在のプロジェクトでのみ使用可能なすべての構成のリストが表示されます。

削除: 選択した構成ファイルを削除します。

プロパティ: 選択した構成ファイルを編集します。

複製 : 構成ファイルをコピーします。修正するファイルを開くかどうかを確認するメッセージが表示されます。

プロジェクト/アプリケーションに追加: アプリケーション レベルで使用可能な構成をプロジェクトに追加します。また、同様にしてプロジェクト用に作成した構成をアプリケーション レベルで使用可能にできます。

アーカイブ: 構成アーカイブ ファイルを作成します。この機能は、構成ファイルを交換するために使用されます。

解凍: 最初にアーカイブされた構成ファイルを回復します。

名前の変更: 選択した構成ファイル名を変更します。ダイアログ ボックスが開き、新しいファイル名を定義するように指示されます。

このインターフェイスでは構成ファイルを修正できません。構成ファイルはパレットが使用されるときに自動的に修正されます。

関連トピック:

プロジェクト構成 > ライブラリとパレット

シンボル パレット

パターン パレット


数式マネージャー

プロジェクト設定 > 全般

プロジェクト設定 > マーク

ワイヤ スタイル マネージャー > ワイヤ プロパティ

DesignSpark Electrical は変数を使用して、データベースから情報を送信します (コンポーネント マーク、ワイヤ番号など)。この情報は数式マネージャー経由で処理され、必要に応じて表示することができます。

例:

データベースの等電位番号: 5

この値は変数 EQU_NO に保存されます。

この情報を 005 として図面に表示する場合 (3 文字で表示) は、次の数式を使用する必要があります: STRZ(VAL(EQU_NO), 3, 0)

数式マネージャーの利用

DesignSpark Electrical には多数の定義済みの数式があり、これらを使用することをお勧めします。ただし、独自の数式を作成する必要がある場合に備えて、簡単な方法で数式を作成するために必要な要素について説明します。

- 数式は変数 (3 番目のタブから使用可能) とテキストから構成されます。テキストの文字列は引用符で囲む必要があり、それぞれの変数またはテキストの文字列は「+」記号で区切る必要があります。例: CHAN_TYP + ":"+ COM_VAL1 + "."+ CHAN_ADDR

- 通常、変数は数値で表示される場合であっても、「テキスト」タイプです (例: 等電位番号を送信する EQU_NO 変数)。

- 多くの場合、特定の関数が変数の処理に使用されます。

STRZ (VAL(FIL_NO),2,0) は 2 文字で表示される図面番号を送信します。ここにない文字は 0 で置換されます (例: 01, 02, ...).

VAL : VAL : 文字のチェーンを数字に変換します。関数 STRZ は数値のみを処理するため、文字列の FIL_NO は数字に変換する必要があります。

STRZ: 特定の桁数 (この例では 2) および小数点以下の桁数 (この例では 0) を指定して数値を変換します。

- 数学関数 (+ - * /) を使用して、変数の結果を修正できます。

STRZ(VAL(EQU_NO)*2,3,0) は 3 文字で表示される等電位番号を送信しますが、偶数のみを使用します。

STRZ((VAL(EQU_NO)*2)-1,3,0) は以前の数式の結果の等電位を送信しますが、奇数のみを使用します。

間違った数式を入力した場合、メッセージがダイアログ ボックス下部に表示されます。

ダイアログ ボックスには、数式を作成するための 4 つのタブがあります。

定義済み数式

このタブは、数式に関連付ける要素に応じてすべての定義済み数式をグループ化します。リストで、数式を選択し、[数式の置換] ボタンをクリックして既存の数式を置換します。

必要に応じて、この数式を手動で変更できます。数式が無効な場合は、メッセージによってそれが通知されます。

最近使った数式

このタブには、以前に使用した数式が表示されます。最初のタブの場合と同様、既存の数式を選択し、[数式を置換] ボタンをクリックして、有効な数式を置換できます。

変数とシンプルな数式

このタブでは、独自の数式を作成できます。

シンプルな数式: この列には、使用可能な変数のリストと、これらの変数を使用したシンプルな数式が表示されます。

説明: この列には、選択した変数の説明が表示されます。

タイプ: VAL や STRZ などの特定の関数を使用する際に役立つ変数のタイプが表示されます。

シンプルな数式の追加数式を作成するには、変数を選択して [シンプルな数式の追加] ボタンをクリックします。

テキストを追加できますが、引用符で囲む必要があり ("TEXT")、各テキストと変数を "+" 記号で区切る必要があります。数式が無効な場合は、メッセージによってそれが通知されます。

ファンクション

このタブには、数式で使用できるすべてのファンクションと演算子が一覧表示されます。

ファンクション: ファンクション名を表示します。ファンクションは、タイプ、数学、テキスト、および各種のファンクションにソートされます。

説明: ファンクションの説明 (定義) を表示します。

例: ファンクションの使用例と構文を表示します。例の最後には、ファンクションの結果が用意されています。

前のタブ同様、[ファンクションを追加] ボタンのクリックで、数式にファンクションを追加できます。


ドック可能パネル

DesignSpark Electrical は、配線図設計に専用パネルを使用します。これらのドック可能パネルは、画面の左側または右側に配置できます。

ドック可能パネルには、特定のアイコンに関連付けられた複数のタブが含まれます。これらのタブは、ドラッグ&ドロップによって、ドック可能パネルから他の位置へ移動できます。

ほとんどのタブの表示方法は、[表示] ([ドック可能パネル] セクション) メニューのコマンドを使って、手動で管理できます。また、[コマンド] タブなど、自動的に開くタブもあります。

ドキュメント: プロジェクト ドキュメントの一覧を表示します。

コンポーネント: コンポーネントの一覧を表示します。

コマンド: 現行コマンドのオプションを表示します。

パターン: パターン パレットを表示します。

シンボル: シンボル パレットを表示します。

プロパティ: 選択した要素のプロパティを開きます。

リソース: ソフトウェアに関連するショートカットを表示します。

ドック可能パネルのレイアウト (タブやパネル位置) を保存したり、保存したレイアウトを復元したり、デフォルトのパネル レイアウトにリセットすることができます。


[コマンド] タブ

ドック可能パネル: コマンド

コマンドが実行されオプションが必要になると、[コマンド] タブの表示がアクティブになります。


[プロパティ] タブ

ドック可能パネル: プロパティ

メニュー: 修正 > プロパティ

ドック可能パネルには、選択した要素のプロパティの表示を可能にする固有のタブが含まれます。プロパティになるのは、プロジェクト データベースまたはソフトウェア データベースに保存されているグラフィック プロパティ (グラフィック エンティティに保存) またはデータです。

この要素は次のとおりです。

  • プロジェクト ドキュメント ([ドキュメント] タブ)

  • コンポーネント ([コンポーネント] タブ)

  • グラフィック電気オブジェクト（グラフィック領域のワイヤ、シンボル、ロケーション、ファンクション領域）

  • 基本エンティティ（グラフィック領域の線、円、円弧、テキスト）

  • シンボル (グラフィック編集モード)

  • 2D フットプリント (グラフィック編集モード)

  • タイトル ブロック (グラフィック編集モード)

オブジェクト プロパティは特定のダイアログ ボックスに表示できます。

プロジェクト要素

プロジェクト要素では、プロジェクト ドキュメント、コンポーネント、電気エンティティなど、プロジェクトに応じてすべての要素がグループ化されます。

プロジェクト要素を選択すると、プロパティを編集するために固有のアイコンが表示されます。

選択した要素の電気プロパティを編集するには、このボタンをクリックします。

プロパティのタブで加えられた変更を確認します。

プロパティのタブで加えられた変更を取り消します。

データはソフトウェアまたはプロジェクト構成によって管理されているため、編集モードで複数のデータを変更することはできません。

この機能では複数選択が可能ですが、同じタイプの要素を選択する必要があります。たとえば、シンボルと図面を選択することはできません。さまざまなタイプのワイヤなど複数の要素を選択すると、共通プロパティのみが表示されます。

複数選択モードでは、グレイのセルは、選択した要素のデータが異なることを表します。編集モードでは、グレイが紫色に変わります。

ドキュメント 要素

[プロパティ] タブには、[ドキュメント] タブで選択された各プロジェクト要素 (プロジェクト、ブック、フォルダー、図面、データ ファイル) のプロパティが表示されます。タイプの異なる要素 (フォルダーや図面など) を選択すると、要素を並べ替えるための新しいタブが表示されます。

たとえば、フォルダーと図面を選択すると、2 つのタブが表示されます。[フォルダー] タブからはフォルダーのプロパティ、[図面] タブからは図面のプロパティにアクセスできます。

コンポーネント要素

ドキュメント要素と同様、[コンポーネント] タブで複数の異なるタイプの要素を選択すると、[プロパティ] タブには各コンポーネントのタイプに応じた新しいタブが表示されます (ロケーション、コンポーネント、端子台)。

グラフィック エンティティ

グラフィック領域で選択した要素のプロパティを編集するには、1 つの要素を選択するか、同じタイプの要素のみを選択 (複数選択) する必要があります。複数のタイプのエンティティを選択すると、[グラフィック プロパティ] タブのみが表示され、電気プロパティは変更できません。

遅延モードが有効である場合、ワイヤ プロパティは使用できません。

選択したエンティティ タイプに応じて、固有のタブが表示されます。たとえば、ワイヤを選択すると、そのワイヤのすべての設定に対応する、複数のタブが表示されます (等電位、ケーブル、ケーブル コア、ワイヤ スタイル)。

[グラフィック プロパティ] タブには、選択した要素のグラフィック設定が表示されます。これらの設定の一部は、構成によって管理されているため、変更できません。このタブの上部には、選択したエンティティをタイプごとにグループ化したリストが表示されます。複数選択の場合、このタブには共通データが表示されます。

ソフトウェア要素

[プロパティ] タブには、線、円、テキストなど、基本的なグラフィック エンティティの設定が表示されます。マネージャーに保存されている要素のデータも表示されます (シンボル、タイトル ブロック、2D フットプリント)。

基本エンティティ

基本エンティティを選択すると、[グラフィック プロパティ] タブのみが使用可能になります。さまざまなタイプのエンティティを選択すると、タブの上部のリストでグループ化されます。表示される設定は、選択したグループまたは選択内容全体の設定です。要素のプロパティを変更すると、グラフィック領域で自動的に更新されます。

マネージャー要素

グラフィック マネージャーで、シンボル、2D フットプリント、タイトル ブロックなどの要素を編集すると、[プロパティ] タブに選択したレベルのデータが表示されます。

シンボルの場合は、シンボル、回路、接続点、属性のプロパティにアクセスできます。2D フットプリントとタイトル ブロックの場合は、プロパティと属性プロパティにもアクセスできます。

選択した要素にグラフィック表示時 (基本的なグラフィック エンティティ、属性、接続点) があるときには、[グラフィック プロパティ] タブを使用できます。


[リソース] タブ

ドック可能パネル: リソース

ソフトウェアに関連するショートカットを表示します。


プロジェクトとドキュメント

プロジェクトはドキュメントから構成されます。これらには、ユーザーが作成した図面 (配線図、結線図など)、またはソフトウェアで自動的に生成された図面 (レポートなど)、またその他のドキュメント (PDF ファイル、DWG ファイルなど) があります。プロジェクト ドキュメントはフォルダーおよびブックに編成されます。

DesignSpark Electrical 以外で作成されたすべての図面は DesignSpark Electrical に反映されず、さまざまなプロセスに含まれることはありません。

  • プロジェクト マネージャー

  • ブックの管理

  • フォルダーの管理

  • 各種ドキュメント

  • プロジェクト図面の管理

  • タイトル ブロックの管理

  • データ ファイルの追加


プロジェクト マネージャー

メニュー: ファイル > プロジェクト マネージャー

クイック アクセス ツールバー

ここには、すべてのプロジェクトを表示するタブ ([すべてのプロジェクト]) と、最近使用したプロジェクトを表示するタブ ([最近のプロジェクト]) の 2 つのタブがあります。

プロジェクトが青色の太字で表示されるときには、そのプロジェクトがドック可能パネルの [ドキュメント] タブにあり、1 つ以上の図面が開いています。これが現行のプロジェクトです。

プロジェクトが青色で表示されるときには、そのプロジェクトがドック可能パネルの [ドキュメント] タブにあり、図面が開いていないことを意味します。

プロジェクトが黒で表示されるとき、そのプロジェクトはドック可能パネルの [ドキュメント] タブになく、図面は開いていません。

デフォルトでは、プロジェクトの説明がソフトウェアの言語で表示されます。別の言語で表示する場合は、リボンにあるリストでその言語を選択します。

新規: 新しいプロジェクトを作成できます。

解凍: 既存のアーカイブ済みプロジェクトを復元できます。

開く: プロジェクト エクスプローラー (ドック可能パネル) で選択したプロジェクトを開くことができます。

現在の項目として設定: 選択したプロジェクトを現在の項目として設定できます。プロジェクトは、ドック可能パネルの [ドキュメント] タブに存在する必要があります。

閉じる: 選択したプロジェクトを閉じます。

アーカイブ: 選択したプロジェクトをアーカイブできます。プロジェクトを終了する必要があります。

複製 : 選択したプロジェクトをコピーします。

テンプレートとして保存: 新しいプロジェクト テンプレートを作成できます。

削除: 選択したプロジェクトを削除します。

プロパティ: 選択したプロジェクトのプロパティを開きます。

構成: プロジェクト マネージャーに表示される列を設定できます。

フィルター: フィルターを有効にして、プロジェクトの検索を容易にします。

これらのコマンドは、プロジェクトのコンテキスト メニューからも実行できます。

  • 既存のプロジェクトの解凍

  • 新しいプロジェクトの作成

  • プロジェクト テンプレートの作成

  • プロジェクトのプロパティ

  • プロジェクトを開く

  • 現在の項目として設定

  • プロジェクトを閉じる

  • プロジェクトのアーカイブ

  • プロジェクトの複製

  • プロジェクトの削除

  • プロジェクトのフィルター


既存のプロジェクトの解凍

プロジェクト マネージャー > 解凍

プロジェクトを解凍すると、以前にアーカイブされたプロジェクトを復元できます。これは以前にアーカイブされたプロジェクトを開くことです。 DesignSpark Electrical では、アーカイブされた TEWZIP ファイルを選択するように指示するメッセージが表示されます。

解凍コマンドには 2 つのオプションがあります。1 つ目の [解凍] オプションでは、オプションを使用してプロジェクトを解凍できます。2 つ目の [解凍して開く] オプションでは、プロジェクトを解凍し、オプションを選択せずに自動的に開くことができます。プロジェクトのプロパティは自動的に確認され、データは更新されません。

[プロジェクト プロパティ] ダイアログ ボックスが開き、プロジェクト データを修正できます。確認後、新しいダイアログが開き、インポートされるデータと処理方法を定義できます。

更新オプションを選択した場合、更新ウィザードが自動的に開き、解凍するデータを管理できます。

次に、ポップアップ ウィンドウが表示され、プロジェクトをただちに開くか、プロジェクト マネージャーを引き続き使用するのかを確認します。

関連トピック:

プロジェクト マネージャー

プロジェクトのアーカイブ


新しいプロジェクトの作成

プロジェクト マネージャー > 新規

新しいプロジェクトを作成するときには、テンプレートを選択するか、空のプロジェクトを作成する必要があります。<未定義のプロジェクト> を選択する場合、このプロジェクトのすべての構成パラメーターを入力する必要があります。

一部のプロジェクト テンプレートでは、プロジェクトで使用するメイン言語を選択できます。

プロジェクト プロパティ ダイアログが表示され、プロジェクト固有のデータを入力できます。

この段階では、プロジェクト構成パラメーターを修正できません。設定内容を検証する必要があります (新しいプロジェクトが作成されます)。これで、構成パラメーターを編集できます。

新しく作成されたプロジェクトは、自動的にドック可能パネルに追加されます。テンプレートが使用された場合、プロジェクトは、テンプレート プロジェクトにあった要素 (配線図や表紙など) に自動的に入力されます。

関連トピック:

プロジェクト マネージャー

プロジェクトのプロパティ

プロジェクト テンプレートの作成


プロジェクト テンプレートの作成

プロジェクト マネージャー > テンプレートとして保存

リストでプロジェクトを選択し、[テンプレートとして保存] アイコンをクリックします。ダイアログ ボックスが開き、プロジェクト テンプレート名を入力できます。

プロジェクト テンプレートには、プロジェクトに存在し、そのプロジェクトを作成するために使用されたすべての要素 (図面、構成など) が含まれます。このプロジェクト テンプレートを使用して新しいプロジェクトを作成するときには、プロジェクト テンプレートのすべての内容が含まれます。

関連トピック:

プロジェクト構成

新しいプロジェクトの作成


プロジェクト プロパティ

プロジェクト マネージャー > プロパティ

ドック可能パネル > プロジェクトのコンテキスト メニュー: プロジェクト プロパティ

メニュー: プロジェクト > プロパティ

選択したプロジェクトのプロパティにアクセスできます。

入力データはタイトル ブロックに表示できます。

名前: プロジェクトの名前。この名前は、プロジェクトのアーカイブ時にファイル名として使用されます。プロジェクト名を空にすることはできません。

全般

契約番号: 契約を識別する契約番号またはコード。このデータの指定は任意ですが、カスタマイズはできません。

顧客

これらのデータの指定は任意であり、カスタマイズはできません。

名前: 顧客の名前。

住所 1/2/3: 顧客の住所。3 行を使用できます。

設計事務所

これらのデータの指定は任意であり、カスタマイズはできません。

名前: 設計事務所の名前。

住所 1/2/3: 設計事務所の住所。3 行を使用できます。

システム

プロジェクトの作成および変更についての情報を表示します。これらのデータは自動的に入力され、変更できません。

作成者: プロジェクトを作成したユーザーの名前。

作成日: プロジェクトの作成日。

変更日: プロジェクトが最後に変更された日付。

情報

プロジェクトのバージョン。

説明

プロジェクトの最初の翻訳可能なデータ。プロジェクトで管理されているどの言語でも説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データはプロジェクト全体で使用できます。このデータには個人情報が保存されます。この情報は図面に表示することができます。ユーザー データには翻訳可能なユーザー データ (プロジェクト翻訳時に翻訳) と、翻訳不能なユーザー データの 2 種類があります。

詳細情報: プロジェクトを開くと、プロジェクトの詳細にアクセスできるようになります。[詳細情報] ボタンをクリックするとダイアログ ボックスが開き、プロジェクトに含まれる要素（図面、メーカー部品、ケーブルなど）の数が表示されます。

カスタマイズ: プロジェクトのユーザー データにアクセスします。

プロジェクト構成: プロジェクト構成 にアクセスします。

関連トピック:

プロジェクト設定

ユーザー データ


プロジェクトを開く

プロジェクト マネージャー > 開く

リストでプロジェクトを選択し、[開く] アイコンをクリックします。

プロジェクトは自動的にドック可能パネルの [ドキュメント] タブに追加され、現在のプロジェクトになります。

プロジェクトがドック可能パネルにある間は、[開く] アイコンは淡色表示されています。

プロジェクト マネージャーには [ダイアログを開いたままにします] というチェック ボックスがあり、プロジェクトが開くとプロジェクト マネージャーが開くようにします。

DesignSpark Electrical データのプロジェクト フォルダーから「.ewg」ファイルを DesignSpark Electrical インターフェイスにドロップした場合に、プロジェクトを開くこともできます。ファイルはグラフィック インターフェイスで開き、プロジェクトはドック可能パネルの [ドキュメント] タブに追加されます。

関連トピック:

プロジェクト マネージャー


現在の項目として設定

現在のプロジェクトとは、使用中のプロジェクトのことです。ドック可能パネルとプロジェクト マネージャーで現在のプロジェクトを区別するため、現在のプロジェクトは太字で表示されます。

プロジェクト マネージャー > 現在の項目として設定

ドック可能パネル > プロジェクトのコンテキスト メニュー: 現在の項目として設定

プロジェクトのいずれかの図面を開くか有効にする (現在の図面) と、プロジェクトは自動的に現在のプロジェクトとして設定されます。


プロジェクトを閉じる

プロジェクト マネージャー > 閉じる

ドック可能パネル > プロジェクトのコンテキスト メニュー: プロジェクトを閉じる

リストからプロジェクトを選択し、[閉じる] アイコンをクリックします。

開いているページが自動的に保存され、閉じます。プロジェクトは ドック可能パネルの [ドキュメント] タブからは削除されますが、プロジェクト マネージャーには保持されます。

プロジェクトをアーカイブ、テンプレートとして保存、削除、またはコピーする前には、プロジェクトが閉じていなければなりません。

関連トピック:

プロジェクト マネージャー


プロジェクトのアーカイブ

プロジェクト マネージャー > アーカイブ

[アーカイブ] コマンドでは、プロジェクトはすべてのドキュメントと、その設計に使用されているすべてのデータ (シンボル、タイトル ブロック、構成など) と一緒に保存できます。

アーカイブされたプロジェクト ファイルの拡張子は「.PROJ.TEWZIP」です。アーカイブされたプロジェクトにはプロジェクト マネージャーからアクセスできます。

1. リストからプロジェクトを選択します。

2. [アーカイブ] アイコンをクリックします。

3. プロジェクトを解凍するときにプロジェクト言語を変更することをユーザーに許可するかどうかを尋ねるメッセージ ボックスが表示されます。

4. ショートカットがプロジェクトにある場合は、オプション ダイアロブ ボックスが開き、ショートカットによって管理されているファイルを含めるかどうか確認されます。

5. [名前を付けて保存] ウィンドウで、アーカイブ ファイルのフォルダーとファイル名を選択します。

関連トピック:

プロジェクト マネージャー

プロジェクトを閉じる

プロジェクトの解凍


プロジェクトの複製

プロジェクト マネージャー > 複製

既存のプロジェクトのコピーを作成します。プロジェクトのすべての要素が複製されます。

リストからプロジェクトを選択し、[複製] アイコンをクリックします。

プロパティ ダイアログ ボックスが開き、新しいプロジェクトの名前とプロパティを修正できるようになります。このプロジェクトはプロジェクトのリストに追加されます。

プロジェクトは複製する前に閉じる必要があります。

関連トピック:

プロジェクト マネージャー

プロジェクトを閉じる

プロジェクトのプロパティ


プロジェクトの削除

プロジェクト マネージャー > 削除

プロジェクトと、そのプロジェクトを構成するすべての要素を削除します。

リストから 1 つまたは複数のプロジェクトを選択し、[削除] アイコンをクリックします。

ダイアログ ボックスが開き、オプションが表示されます:

アーカイブして削除: 削除の前に、選択したプロジェクトが含まれるアーカイブ ファイルが作成されます。削除を確定してよいか不明な場合に、このオプションを使用します。プロジェクトは、解凍機能により復元できます。

バックアップなしで削除: アーカイブ ファイルを作成することなく、プロジェクトが削除されます。

プロジェクトの削除は元に戻せません。また、いったん削除すると回復できません。不明な場合は、削除する前に、プロジェクトのアーカイブを作成しておくことをお勧めします。

プロジェクトを削除するには、プロジェクトを閉じる必要があります。

関連トピック:

プロジェクト マネージャー

プロジェクトを閉じる

プロジェクトのアーカイブ


プロジェクトのフィルター

プロジェクト マネージャー > フィルター

このコマンドでは、条件を入力してプロジェクトのリストを絞り込むことができます。

ダイアログ ボックスの左側には、条件の一覧が表示されます。条件を入力すると、プロジェクトのリストは、その条件に対応するプロジェクトに絞り込まれます。

関連トピック:

プロジェクト マネージャー


ブックの管理

ブックにはプロジェクトを構成するすべてのドキュメントが含まれます。ブックには、フォルダー、図面、およびすべての関連付けられたドキュメントを含めることができます。必要に応じて、1 つのプロジェクトに複数のブックを含めることができます。

ドック可能パネルでは、ブックはマークと説明で識別されます。

新しいブックの作成

メニュー: プロジェクト > 新規 > 新しいブック

ドック可能パネル > プロジェクトのコンテキスト メニュー: 新しいブック

ブックの [プロパティ] ダイアログ ボックスが開き、ブックにマークを割り当て、内容の入力、リビジョンの管理などができます。

ブックの移動

ドラッグ&ドロップによって、ブックを移動できます。移動されたブックは同一プロジェクトになければなりません。新しい位置を定義する黒い線が表示されます。

ブック プロパティ

ブックのコンテキスト メニュー: プロパティ

マーク

ブック マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

番号: ブックに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

階層構造

デフォルトでは、ブックはロケーションとファンクションに関連付けられています。このブックに依存するすべての項目 (図面およびコンポーネント) は、デフォルトでは、自動的にこのロケーションとファンクションに関連付けられます。

ロケーション/ファンクション: [...] ボタンをクリックするとロケーション (ファンクション) セレクターが開き、ブックに関連付けるロケーション (ファンクション) を選択できます。

情報

ドキュメント数: ブックに含まれるドキュメント数を表示します。図面数を制限するバージョンで作業する場合、この情報は必須です。

リビジョン

現在のリビジョン: ブックに割り当てられたリビジョン インデックスを表示します。リビジョンを管理するには、[...] ボタンをクリックします。

説明

ブックの翻訳可能なデータの最初のフィールドです。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データはプロジェクト全体に存在します。これは個人情報の保存に使用され、個人情報は図面に表示できます。ユーザー データには翻訳可能なユーザー データ (プロジェクト翻訳時に翻訳) と、翻訳不能なユーザー データの 2 種類があります。

[カスタマイズ] ボタンを使用すると、ブックのユーザー データにアクセスできます。

ブックの削除

ブックのコンテキスト メニュー: 削除

ブックを削除すると、ブック内のすべての要素 (フォルダー、図面、データ ファイルなど) が削除されます。

関連トピック:

フォルダーの管理

各種ドキュメント


フォルダーの管理

フォルダーはディレクトリと同様のもので、図面や他のフォルダーが格納されます。このシステムには、プロジェクト内で図面を分類およびグループ化するためのツールがあります。

ドック可能パネルでは、フォルダーはマークと説明で識別されます。

新しいフォルダーの作成

メニュー: プロジェクト > 新規 > 新しいフォルダー

ブックのコンテキスト メニュー: 新規 > フォルダー

フォルダーの [プロパティ] ダイアログ ボックスが開き、フォルダーにマークを割り当て、含まれるデータ セットに関する情報を入力できます。

フォルダー プロパティ

フォルダーのコンテキスト メニュー: プロパティ

マーク

フォルダー マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

番号: フォルダーに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

全般

最初の図面番号を定義: このオプションを選択すると、このフォルダーでの最初の図面番号を指定できます。選択しない場合、最初の図面番号は (フォルダーにかかわらず) 前の図面をもとに設定されます。

最初の図面番号: この設定は前の設定が有効である場合に使用できます。フォルダーの最初の図面番号を入力します。

パス: フォルダーが依存するブックのパスを示します。

説明

フォルダーの翻訳可能なデータのうち最初のデータ。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データはプロジェクト全体で使用できます。このデータには個人情報が保存されます。この情報は図面に表示することができます。ユーザー データには翻訳可能なユーザー データ (プロジェクト翻訳時に翻訳) と、翻訳不能なユーザー データの 2 種類があります。

[カスタマイズ] ボタンでは、フォルダー ユーザー データにアクセスできます。

フォルダーの削除

フォルダーのコンテキスト メニュー: 削除

フォルダーを削除すると、フォルダー内のすべての図面が削除されます。

関連トピック:

ブックの管理

ドキュメント タイプ


各種ドキュメント

複数の種類のドキュメントがあります。DesignSpark Electrical で編集可能なすべてのドキュメントは図面と呼ばれます。

ユーザー作成ドキュメント:

表紙 | 表紙またはプレゼンテーション ページ。
結線図 | ブロック図を使用して配線を表すために使用する結線図を作図します。
配線図 | 配線図、電気配線図、またはその他の種類の図面 (既定のドキュメント タイプ)。

DesignSpark Electrical で生成されるドキュメント（ユーザーによる作成は不可）:

レポート

データ抽出に基づくレポート。フォリオのリスト、BOM、ケーブル レポート、配線リストなど。

データ ファイル:

データ ファイルはプロジェクトにコピーされる外部ファイルです。これらはあらゆる形式のすべてのファイルです。

DWG および DXF ファイルは、DesignSpark Electrical ドキュメントとして管理されます。プレビューが表示されます。これらは DesignSpark Electrical で変更および印刷できます。

その他のすべてのファイル形式もプロジェクトに追加できますが、DesignSpark Electrical インターフェイスでプレビューまたは編集できません。これらのファイルを開くには、ファイル タイプに関連付けられたアプリケーションで開きます。

ファイル ショートカット

このファイル タイプは実際のプロジェクト ドキュメントではなく、外部ファイルへのリンクです。名前はプロジェクト ドキュメントのように、固有のアイコン付きで表示されます。

これらのファイルは、Windows で関連付けられているアプリケーションで開くことができます。

  • 表紙

  • 結線図

  • 回路図

  • レポート図面

  • データ ファイル

  • ファイル ショートカット


表紙

表紙は特定の図面であり、表紙では配線図を統合できません。

任意の方法 (ブック、フォルダー) でプロジェクトを整理する場合、プロジェクトの任意の場所で、必要な数の表紙を管理できます。

関連トピック:

各種ドキュメント

表紙の作成


結線図

結線図では、装置のケーブルを作図できます。結線図を開くと、[結線図] メニューが有効になり、ケーブル配線図を作成するために必要なコマンドが表示されます。

[結線図] メニューのコマンドで挿入されるこのタイプの図面で使用されるグラフィック要素は、プロジェクト データベースに保存されます。

関連トピック:

各種ドキュメント

図面の作成


回路図

装置の詳細回路図は、回路図の図面タイプで作成されます。回路図を開くと、[配線図] メニューが有効になり、配線図を作成するための特定のコマンドが表示されます。

[配線図] メニューのコマンドで挿入されるこのタイプの図面で使用されるグラフィック要素は、プロジェクト データベースに保存されます。

関連トピック:

各種ドキュメント

図面の作成


レポート図面

レポート図面は、DesignSpark Electrical によって自動的に作成されます。端子台図面は、プロジェクト データベースに保存される情報と構成パラメーターに従って、自動的に生成されます。

配線図や結線図の要素は追加できません。[作図] または [修正] メニューのコマンドのみを使用して、グラフィカルな詳細を完成させることができます。グラフィック要素を追加した場合、レポートの更新後に図面を確認してください。

関連トピック:

各種ドキュメント

図面レポート


データ ファイル

DesignSpark Electrical では、各種のドキュメント タイプ、DWG/DXF、Word ファイル、Excel ファイルなどをプロジェクトに追加できます。ファイルはプロジェクトにコピーされますが、グラフィック インターフェイスでは開けません。Windows のファイル タイプに関連付けられたアプリケーションで開きます。

関連トピック:

ドキュメント タイプ

データ ファイルの追加


プロジェクト図面の管理

それぞれの図面にはマーク (番号) があります。このマークはブック内で一意であり、2 つの図面のマークを同一にすることはできません。

ドック可能パネルの [ドキュメント] タブでは、図面の表示順序をユーザーが定義できます。必要に応じて図面をドラッグ アンド ドロップして移動するか、ブックまたはフォルダーを追加することで定義できます。図面の移動、コピー、または番号の再割り当てができます。

図面を開くには、図面をダブルクリックするか、コンテキスト メニューの [開く] コマンドを使用します。セッションで図面を開くと、図面は青く表示されます。別のワークステーションで開くと、赤く表示されます。現在の図面は青い太字で表示されます。

  • 表紙の作成

  • 図面の作成

  • 図面を開く

  • 図面プロパティ

  • プレビュー

  • 図面の再構築

  • ロケーションの変更

  • ファンクションの変更

  • 図面にアクセス

  • 図面の移動

  • 図面番号の再割り当て

  • 図面のコピーと貼り付け

  • 図面の参照

  • 図面の削除


表紙の作成

メニュー: プロジェクト > 新規 > 表紙

ブックのコンテキスト メニュー: 新規 > 表紙

フォルダーのコンテキスト メニュー: 新規 > 表紙

表紙は、ブックまたはフォルダーの図面リストに自動的に追加されます。表紙がグラフィック領域で自動的に開き、タイトル ブロックが、プロジェクト、ブック、またはフォルダー プロパティに入力した情報に基づいて更新されます。

関連トピック:

プロジェクト図面の管理


図面の作成

メニュー: プロジェクト > 新規 > 配線図 (結線図 - 混合配線図)

ブックのコンテキスト メニュー: 新規 > 配線図 (結線図 - 混合配線図)

フォルダーのコンテキスト メニュー: 新規 > 配線図 (結線図 - 混合配線図)

図面のコンテキスト メニュー: 新規 > 配線図 (結線図 - 混合配線図)

作成時には、コマンドが実行された場所に応じて、図面がブックまたはフォルダーに追加されます。

図面はグラフィック ゾーンで自動的に開きます。図面のプロパティを開くと、図面の番号および関連付けられたすべてのデータを修正できます。

リストの最後の図面で、クイック アクセス ツールバーから [次へ] アイコンをクリックしても、図面を作成できます。

関連トピック:

プロジェクト図面の管理


図面プロパティ

図面のコンテキスト メニュー: プロパティ

マーク

図面マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用します。

番号: 図面に割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

階層構造

デフォルトでは、図面はロケーションとファンクションに関連付けられています。この図面に含まれるすべてのコンポーネントは、デフォルトでは、自動的にこのロケーションとファンクションに関連付けられます。図面のロケーション (またはファンクション) を変更すると、メッセージ ボックスが開き、この図面に挿入したコンポーネントのロケーション (またはファンクション) を変更できます。

ロケーション: [...] ボタンをクリックするとロケーション セレクターが開き、図面に関連付けるロケーションを選択できます。

ファンクション: [...] ボタンをクリックするとファンクション セレクターが開き、図面に関連付けるファンクションを選択できます。

情報

図面の位置: リスト ([ドキュメント] タブ) の図面の位置とプロジェクトに含まれる図面の総数を表示します。

リビジョン

現在のリビジョン: 図面に割り当てられたリビジョン インデックスを表示します。リビジョンを管理するには、[...] ボタンをクリックします。

プロパティ

図面タイプ: 図面のタイプを表示します。表紙、結線図、配線図、混合配線図、、レポートのいずれかです。混合配線図タイプに変更可能な配線図および結線図の図面を除き、この設定は変更できません。

ファイル名: ファイル名を表示します。このファイル名は変更しないで下さい。変更するとソフトウェアとのリンクが失われます。

ターゲット ファイル (ファイル ショートカットのみ): ファイル ショートカットで管理するパスとファイル名が表示されます。

タイトル ブロック: 図面で使用されるタイトル ブロック名を表示します。[...] ボタンをクリックすると、関連付けられたタイトル ブロックを変更できます。右側のアイコン (+) をクリックして、[タイトル ブロック管理] メニューにアクセスします。

説明

図面の翻訳可能なデータのうち最初のデータ。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データはプロジェクト全体で使用できます。このデータには個人用情報が保存されます。この情報は図面に表示することができます。ユーザー データには翻訳可能なユーザー データ (プロジェクト翻訳時に翻訳) と、翻訳不能なユーザー データの 2 種類があります。

[カスタマイズ...]ボタンでは、図面ユーザー データにアクセスできます。

関連トピック:

プロジェクト図面の管理


プレビュー

図面のコンテキスト メニュー: プレビュー

表示ウィンドウを開きます。

[拡大/縮小] コマンドは、DWG または DXF ファイルのメニュー バーで使用できます。図面は修正できません。

関連トピック:

プロジェクト図面の管理


図面の再構築

図面のコンテキスト メニュー: 再構築

このコマンドでは、プロジェクト データベースに保存されたデータに従って、図面を更新または再作成できます。

このコマンドを実行すると、使用可能なオプションを示すダイアログ ボックスが表示されます。

再構築: DesignSpark Electrical エンティティ (データベースで管理されているエンティティ) は削除され、データベースに保存されている情報に基づいて、図面で再生成されます。[作図] および [修正] メニューのコマンドで描画した要素 (データベースで管理されていないエンティティ) は保持されます。

削除と再構築: 図面は削除され、データベースに保存されている情報に基づいて再構築されます。[作図] および [修正] メニューのコマンドで描画した要素 (データベースで管理されていないエンティティ) は失われます。

何もしない: コマンドをキャンセルします。

関連トピック:

プロジェクト図面の管理


ロケーションの変更

図面のコンテキスト メニュー: ロケーションの変更

[ロケーションの変更] コマンドは複数の図面にわたって動作します。

図面プロパティ: ロケーション

各図面はロケーションに関連付けられています。このロケーションは、図面の作成時に定義されます。デフォルトでは、ロケーションはブックに関連付けられています。

このコマンドを選択すると、ロケーション選択ダイアログ ボックスが開き、任意のロケーションを選択できます。

最初に図面の元のロケーションに関連付けられたコンポーネントを新しいロケーションに関連付けることができます。ダイアログ ボックスが開き、任意のオプションを選択できます。

コンポーネント ロケーションの変更: 図面と同じロケーションのコンポーネントは、自動的に新しいファンクションに関連付けられます。コンポーネントが複数の図面 (シンボル) で作図された場合は、図面がファンクションの変更の影響を受けない場合でも、コンポーネントを表すすべてのシンボルが新しいファンクションに関連付けられます。

図面ロケーションのみ変更: 図面自体は新しいロケーションに関連付けられ、図面の内容は変更されません。

キャンセル: 現在のコマンドをキャンセルします。図面とその内容は変更されません。

関連トピック:

プロジェクト図面の管理

ロケーション


ファンクションの変更

図面のコンテキスト メニュー: ファンクションの変更

[ファンクションの変更] コマンドは複数の図面にわたって動作します。

図面プロパティ: ファンクション

各図面はファンクションに関連付けられています。このファンクションは、図面の作成時に定義されます。デフォルトでは、ファンクションはブックに関連付けられています。

このコマンドを選択すると、ファンクション選択ダイアログ ボックスが開き、任意のファンクションを選択できます。

最初に図面の元のファンクションに関連付けられたコンポーネントを新しいファンクションに関連付けることができます。ダイアログ ボックスが開き、任意のオプションを選択できます。

コンポーネント ファンクションの変更: 図面と同じファンクションのコンポーネントは、自動的に新しいファンクションに関連付けられます。コンポーネントが複数の図面 (シンボル) で作図された場合は、図面がファンクションの変更の影響を受けない場合でも、コンポーネントを表すすべてのシンボルが新しいファンクションに関連付けられます。

図面ファンクションのみ変更: 図面自体は新しいファンクションに関連付けられ、図面の内容は変更されません。

キャンセル: 現在のコマンドをキャンセルします。図面やその内容は変更されません。

関連トピック:

プロジェクト図面の管理

ファンクション


図面にアクセス

ドキュメントを検索

この機能では、プロジェクトのすべてのドキュメントで、ドキュメントや図面などを検索できます。

ドック可能パネル > プロジェクトのコンテキスト メニュー: 図面にアクセス

ドック可能パネル > ブックのコンテキスト メニュー: 図面にアクセス

ドック可能パネル > フォルダーのコンテキスト メニュー: 図面にアクセス

ドック可能パネル > 図面のコンテキスト メニュー: 図面にアクセス

メニュー: ツール > 検索 > ドキュメントを検索

メニュー: 表示 > ドキュメントを検索

ダイアログの左側にはプロジェクト ツリーが表示されます。右側には、プロジェクトに含まれるドキュメントのプレビューまたはリストが表示されます。

リスト モード: 図面のリスト (名前や説明など) を表示します。

サムネイル モード: 図面のサムネイル プレビューを表示します。

プレビュー: [プレビュー] ダイアログ ボックスで図面を開きます。ここで図面を変更することはできません。

構成: ダイアログ ボックスの項目の表示設定を管理します。

プロパティ: 選択した図面の [プロパティ] ダイアログ ボックスを開きます。

簡単に検索できるように、次の 4 つのフィルターを使用して結果をフィルターできます。[マーク]、[説明]、[ファイル タイプ]、[ファンクション]、[ロケーション]、[ブック] および [開かれた図面]。これによって、すべてのプロジェクト図面、またはユーザーまたは他のユーザーにより開かれた図面のみを表示できます。

図面を選択し、[開く] ボタンをクリックして開きます。


図面の移動

ドラッグ アンド ドロップ操作で移動する図面を選択し、最終的な位置まで移動します (マウスの左ボタンは押し続けます)。

あるフォルダーから別のフォルダーへ図面を移動したり、ブック レベルからフォルダーへ (あるいはその逆) 移動したりできます。この方法でフォルダー全体を移動することもできます。

関連トピック:

プロジェクト図面の管理


ドキュメントの番号再割り当て

ブックのコンテキスト メニュー: ドキュメントの番号再割り当て

フォルダーのコンテキスト メニュー: ドキュメントの番号再割り当て

メニュー: プロセス > ドキュメントの番号再割り当て

このコマンドでは、プロジェクト、フォルダー、ブック、図面のすべてのドキュメントに番号を再割り当てできます。

ダイアログ ボックスが開き、設定したパラメーターに基づいてドキュメントの番号を再割り当てできます。

選択

プロジェクト全体: プロジェクトのすべてのドキュメントの番号を再割り当てします。

現在のブック: 現在のブック (現在の配線図に関連付けられているブック) のドキュメントの番号のみを再割り当てします。

現在のフォルダー: 現在のフォルダー (現在の配線図に関連付けられているフォルダー) にあるドキュメントの番号のみを再割り当てします。

選択したドキュメント: [...] ボタンをクリックし、番号を再割り当てするドキュメントを選択します。

番号の再割り当てモード

マークの更新: 番号割り当て数式を変更した場合、ドキュメント マークを更新できます。値 ORDERNO は変更されません。

順序番号の再計算: 手動で変更した番号を除いて、すべてのドキュメント番号を再計算します。値 ORDERNO は変更されます。すべてのドキュメント マークを再計算するには、[手動マークを再計算する] ボックスをオンにする必要があります。

要素

要素: 使用可能なドキュメントのリストが表示されます。

選択: 番号を再割り当てする要素を選択できます。番号を再割り当てする要素の数も表示されます。

先頭番号: 要素に割り当てる、最初の番号を入力します。

ステップ: 増分ステップの値を入力します。たとえば、[先頭番号] が 10 で、[ステップ] が 2 の場合、要素番号は10、12、14、16 のようになります。

数式: プロジェクト構成で管理されているマーク数式が表示されます。

Fx: [...] ボタンによって数式マネージャーにアクセスし、要素の番号再割り当てに使用する数式を変更できます。数式を変更すると、プロジェクト構成の数式が置き換えられます。

マーク構成: プロジェクト構成の [マーク] タブにアクセスできます。

番号の再割り当てを確認すると、関係するブック、フォルダー、図面に番号が再割り当てされます。マーク数式は、変更された場合、プロジェクト構成で自動的に更新されます。

関連トピック:

プロジェクト図面の管理


図面のコピーと貼り付け

ブックのコンテキスト メニュー: [切り取り] - [コピー] - [貼り付け] - [形式を選択して貼り付け]

フォルダーのコンテキスト メニュー: [切り取り] - [コピー] - [貼り付け] - [形式を選択して貼り付け]

図面のコンテキスト メニュー: [切り取り] - [コピー] - [貼り付け] - [形式を選択して貼り付け]

DesignSpark Electrical には、Windows 非依存の統合クリップボード機能があります。クリップボードに貼り付けられた要素は、それ以前にクリップボード上にあった要素を自動的に上書きします。

切り取り

ブックまたはフォルダーから選択した図面のコピーを DesignSpark Electrical クリップボードに格納し、元のデータを削除します。

コピー

ブックまたはフォルダーから選択した図面のコピーを DesignSpark Electrical クリップボードに配置し、元のデータを保持します。

貼り付け

DesignSpark Electrical クリップボードの図面を貼り付けます。必要に応じて、これらの図面の図面番号とコンポーネントのコンポーネント マークは、プロジェクトに存在するマークに基づいて自動的に再計算されます。

形式を選択して貼り付け

[貼り付け] コマンドと同じです。ダイアログ ボックスが開き、 マークを管理できます。

ブックを右クリックしても、[切り取り] コマンドは使用できません。

関連トピック:

プロジェクト図面の管理


図面の参照

メニュー: 表示 > 前の図面 - 次の図面

クイック アクセス ツールバー

これらのコマンドは次のページまたは前のページにアクセスできます。プロジェクトの最終ページに到達した場合は、[次へ] ボタンをクリックすると、DesignSpark Electrical で新しい図面を作成するように指示するメッセージが表示されます。

関連トピック:

プロジェクト図面の管理


図面の削除

ブックのコンテキスト メニュー: 削除

フォルダーのコンテキスト メニュー: 削除

図面のコンテキスト メニュー: 削除

選択した図面を 1 つ以上削除します。このコマンドがブックまたはフォルダーで使用されると、そのブックまたはフォルダーのすべての図面が削除されます。

図面が削除されると、その内容も削除されます。特定の要素はデータベースに残る場合があります (ケーブル、端子など)。

図面、ブック、またはフォルダーを削除するには、オブジェクトを選択して [Del] キーを押します。

削除処理をキャンセルしたり、元に戻したりすることはできません。

関連トピック:

プロジェクト図面の管理


タイトル ブロックの管理

各図面タイプにはタイトル ブロックが関連付けられています (プロジェクト構成)。ただし、既存の図面のタイトル ブロックは修正できます。

図面に関連付けられたタイトル ブロックは、図面のプロパティでも変更できます。

図面のコンテキスト メニュー: タイトル ブロック

更新: タイトル ブロックの定義が修正された場合、このコマンドを使用して、図面のタイトル ブロックを更新します。複数の項目を選択した場合にも使用できます。

置換: 異なるタイトル ブロックをプロジェクト構成で関連付けられている図面に関連付けます。[ タイトル ブロックの選択 ] が開き、新しいタイトル ブロックを選択できます。置換後、DesignSpark Electrical では、元のタイトル ブロックを使用するすべての図面にこのタイトル ブロックを適用するかどうかが尋ねられます。また、この新しいタイトル ブロックでプロジェクト構成を更新することもできます。

削除: 図面に挿入されたタイトル ブロックを削除できます。

開く: タイトル ブロックの変更インターフェイスが開きます。タイトル ブロックが変更されていて、その変更を既存の図面に適用する場合は、[更新] コマンドを使用します。

ライブラリに追加: 図面のタイトル ブロックをライブラリに追加します。

関連トピック:

別のタイトル ブロックの選択


別のタイトル ブロックの選択

ブックのコンテキスト メニュー: タイトル ブロック > 置換

フォルダーのコンテキスト メニュー: タイトル ブロック > 置換

図面のコンテキスト メニュー: タイトル ブロック > 置換

各図面タイプにはタイトル ブロックが関連付けられています (プロジェクト構成)。このコマンドではこのデフォルトを変更できます。

図面に関連付けられたタイトル ブロックは、図面プロパティから変更できます。

タイトル ブロック セレクターによって、図面に関連付ける新しいタイトル ブロックを選択できます。

プロパティ: 選択したタイトル ブロックのプロパティ ダイアログ ボックスが開きます。

プレビュー: タイトル ブロックをプレビュー ダイアログ ボックスで開きます。このビューではブロックを変更できません。

リスト モード: タイトル ブロックのリスト (名前、説明など) を表示します。

サムネイル モード: タイトル ブロックをサムネイル プレビューとして表示します。

構成: ダイアログ ボックスの項目の表示設定を管理します。

分類

このタブには、タイトル ブロックが分類されツリー形式で表示されます。

ダイアログの左側に、タイトル ブロックが分類されて表示されます。右側には、現在選択している分類のタイトル ブロックが表示されます。

サブクラスの内容の表示: このボックスをオンにすると、選択した分類のサブクラスのすべてのタイトル ブロックが表示されます。

フィルター

このタブではタイトル ブロック リストをフィルタリングできます。すべてのフィルター条件は、タイトル ブロックのプロパティから取られます。

ダイアログ ボックスの右側には、選択した条件に対応するタイトル ブロックが表示されます。

フィルターを削除: すべてのフィルター条件を削除します。

これをすべてのプロジェクト図面または特定の図面タイプ (配線図図面など) に適用する必要がある場合は、プロジェクト構成レベルで新しいタイトル ブロックを適用することをお勧めします。ある図面でパラメーターを変更すると、この新しいタイトル ブロックを同じタイプのすべての図面に適用するかどうかを確認されます。

関連トピック:

プロジェクト図面の管理

タイトル ブロックの管理


データ ファイルの追加

DesignSpark Electrical により、任意のドキュメント タイプ (PDF や Excel ファイルなど) を管理できます。唯一の制限事項は、そのファイル タイプを開くことができるプログラムがインストールされている必要があることです。DesignSpark Electrical では Windows の関連付けが自動的に使用されてファイルが開きます。

メニュー: プロジェクト > 新規 > データ ファイル

ブックのコンテキスト メニュー: 新規 > データ ファイル

フォルダーのコンテキスト メニュー: 新規 > データ ファイル

DesignSpark Electrical では、元のファイルのコピーを作成し、プロジェクト ディレクトリに配置できます。その内容はプロジェクトをアーカイブするときに含まれます。

データ ファイルがプロジェクトに追加されたら、ダブルクリックして、関連するアプリケーションで開きます。

関連トピック:

データ ファイル

ハイパーリンク


図面/フォルダー セレクター

[図面/フォルダー選択]ダイアログ ボックスでは、コンテキストに応じた 1 つ以上の図面または 1 つのフォルダーを選択できます。また、新しいフォルダーを作成することもできます。

印刷マネージャー: 図面の選択

レポート マネージャー > レポート図面の保存先: 生成先フォルダー

ダイアログの左側にはプロジェクト ツリーが表示されます。右側には、プロジェクトに含まれるドキュメントのプレビューまたはリストが表示されます。

新しいフォルダー: フォルダーを選択する必要がある場合にこのアイコンが表示されます。新しいフォルダーを作成できます。

リスト モード: 図面のリスト (名前や説明など) を表示します。

サムネイル モード: 図面のサムネイル プレビューを表示します。

プレビュー: [プレビュー] ダイアログ ボックスで図面を開きます。ここで図面を変更することはできません。

構成: ダイアログ ボックスの項目の表示設定を管理します。

プロパティ: 選択した図面の [プロパティ] ダイアログ ボックスを開きます。

検索時に、フィルター(マーク、説明、およびファイル タイプ) に従って結果をフィルターできます。開かれた図面フィルターを使用すると、すべてのプロジェクト図面、またはユーザー自身または他のユーザーにより開かれた図面のみを表示できます。

コンテキストに応じて、1 つ以上の図面または 1 つのフォルダーを選択し、[OK] ボタンをクリックして確認します。

関連トピック:

プロジェクト図面の管理


ドキュメント セレクター

DesignSpark Electrical の機能の一部は、プロジェクト ドキュメント (図面、フォルダー、ブックなど) の選択を前提とします。ドキュメント セレクターは、選択を支援します。

印刷マネージャー: 図面の選択 > [...]

DWG ファイルのエクスポート: 図面の選択 > [...]

PDF ファイルのエクスポート: 図面の選択 > [...]

...

ダイアログ ボックスが開き、要素を選択できます。ダイアログ ボックスの内容は環境に合わせられ、選択が必要な要素 (図面、フォルダー、ブックなど) が表示されます。

プロパティ: 選択した要素の [プロパティ] ダイアログ ボックスを開きます。

プレビュー: [プレビュー] ダイアログ ボックスで図面を開きます。このビューでは変更はできません。

リスト モード: 要素 (名前、説明など) の一覧を表示します。

サムネイル モード: 要素をサムネイルによるプレビューとして表示します。

構成: ダイアログ ボックスの項目の表示設定を管理します。

ダイアログ ボックスには、要素の検索を支援するフィルター領域も含まれます。コンテキストに応じて、メニューにはその他の機能も表示されます。

選択する要素の前にチェックボックスがある場合があります。例: [印刷] コマンドでフォルダーを選択すると (ボックスをチェック)、そのフォルダーに含まれるすべての図面が選択されます。


ロケーション

メニュー: プロジェクト > ロケーション

ドック可能パネル > プロジェクトのコンテキスト メニュー: プロジェクト > ロケーション マネージャー

ロケーションとは場所のことです。一般的に、さまざまなロケーションにケーブルが接続しています。

すべての電気コンポーネント (デバイス、端子台 など) はあるロケーションに所属します。このため、ロケーション別に電気コンポーネントを含め、各ロケーションに含まれる装置に基づいて異なるリストを取得できます。

各図面はロケーションに関連付けられているため、この図面にシンボルを配置するときには、このロケーションに自動的に関連付けられます。

ダイアログ ボックスが開き、プロジェクトのロケーションを管理できます。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

新しいロケーション: 新しいロケーションを作成できます。

複数のロケーションの作成: 1 回の操作でロケーションを複数作成できます。

削除: 選択したロケーションを削除します。

プロパティ: 選択したロケーションのプロパティ ダイアログ ボックスを開きます。複数のロケーションを選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

デフォルト ロケーション: 選択したロケーションがデフォルトのロケーションとして定義されます。

ツリー表示: ロケーションをツリー表示で表示します。

リスト表示: リストの形式でデータを表示します。

ロケーション階層を管理することもできます。

上記の例では、ロケーション L3 はロケーション L1 に含まれます。ドラッグ アンド ドロップによって、L3 を L1 にスライドしてドロップするか、L3 を作成する前に L1 を選択します。

  • ロケーションの作成

  • 複数のロケーションの作成

  • ロケーション プロパティ

  • デフォルト ロケーション

  • ロケーション領域の挿入


ロケーションの作成

ロケーション マネージャー: 新しいロケーション:

ドック可能パネル > プロジェクトのコンテキスト メニュー: 新規 > ロケーション

ドック可能パネル > ロケーションのコンテキスト メニュー: 新規 > ロケーション

1. プロジェクトを選択します。

2. [新しいロケーション] アイコンをクリックします。

3. [ロケーション プロパティ] ダイアログ ボックスが開き、このロケーションに関する情報を入力できます。

ネストされたロケーション (他のロケーションに従属するロケーション) を作成するには、親ロケーションを選択してから、[新しいロケーション] アイコンをクリックします。

関連トピック:

複数のロケーションの作成

ロケーション プロパティ

デフォルト ロケーション

ロケーション領域の挿入


複数のロケーションの作成

ロケーション マネージャー: 複数のロケーションの作成

1. [複数のロケーションの作成] アイコンをクリックします。

2. ダイアログが開き、作成するロケーション数を入力できます。

確認後、ロケーションがリストに追加され、マークが自動的に計算されます。

次に、各ロケーションのプロパティを開き、必要な追加情報を適用できます。

関連トピック:

ロケーションの作成

ロケーション プロパティ

デフォルト ロケーション

ロケーション領域の挿入


ロケーション プロパティ

ロケーション マネージャー: プロパティ

ロケーション領域のコンテキスト メニュー: ロケーション プロパティ

1. ロケーションを選択します。

2. [プロパティ] アイコンをクリックして、ロケーションの [プロパティ] ダイアログを開きます。

このダイアログは、新しいロケーションの作成中に自動的に開きます。

[プロパティ] タブ

マーク

ロケーション マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

ルート: ロケーション (L) に関連づけられたルートを表示します。

番号: ロケーションに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

階層構造

マスター: 子または下位ロケーションが従属するメイン ロケーションの名前。

関連付けられたブック: ロケーションをブックに関連付けます。

説明

ロケーションの翻訳可能なデータのうち最初のデータ。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データはプロジェクト全体で使用できます。このデータには個人情報が保存されます。この情報は図面に表示することができます。ユーザー データには翻訳可能なユーザー データ (プロジェクト翻訳時に翻訳) と、翻訳不能なユーザー データの 2 種類があります。

図面に適用されるデフォルト ロケーションは、図面が作成されたブックに適用されたロケーションから取得されます。

[カスタマイズ] ボタンでは、ロケーションのユーザー データにアクセスして定義することができます。

[メーカー部品] タブ

このタブではメーカー部品をロケーションに関連付けます。

関連トピック:

ロケーションの作成

複数のロケーションの作成

デフォルト ロケーション

ロケーション領域の挿入


デフォルト ロケーション

ロケーション マネージャー: デフォルト ロケーション

DesignSpark Electrical はプロジェクト内のデフォルト ロケーションを定義します。配線図は作成時にデフォルト ロケーションに自動的に関連付けられます。これは別のロケーションが関連付けられているブックに配線図が依存している場合でも同様です。

1. リストのロケーションを選択します。

2. [デフォルト ロケーション] アイコンをクリックします。

デフォルト ロケーションは画像形式で表示されます。

また、ドック可能パネルのアイコンによっても表示されます。

関連トピック:

ロケーションの作成

複数のロケーションの挿入

ロケーション プロパティ

ロケーション領域の挿入


ロケーション領域の挿入

メニュー: 配線図 > ロケーション領域

メニュー: 結線図 > ロケーション領域

ロケーション領域では、図面での地理的なロケーションをグラフィカルに表示できます。ロケーション領域は矩形で表すか、ポリラインを使用して作成できますが、常に閉じた領域でなければなりません。

領域の作図

座標の入力: グラフィック領域で点をクリックするか座標を入力し、ロケーション領域を作図できます。矩形の領域を使用する場合、矩形の対角線を示す 2 番目の点をクリックします。ポリライン領域を使用する場合、線の 2 番目の点をクリックし、領域が完了するまでこの操作を続けます。ドック可能パネルの [閉じる] ボタンを使用すると、自動的に領域の最後の点を最初の点に接続できます。

オプション: コマンドが実行されるときには、ドック可能パネルでモードを切り替えることができます。

ロケーションの選択

ロケーション領域が閉じると、[ロケーションの選択] ダイアログ ボックスが開きます。

1. 目的のロケーションを選択します。

2. [選択] ボタンをクリックします。

ダイアログ ボックスが閉じ、選択したロケーションで自動的に図面が更新されます。

領域内に配置されたコンポーネントは、選択したロケーションに関連付けることができます。

3. 目的のオプションをクリックして、コンポーネントのロケーションを変更するか、最初に関連付けられたロケーションを保持します。

関連トピック:

ロケーションの作成

複数のロケーションの作成

ロケーション プロパティ

デフォルト ロケーション


ファンクション

メニュー: プロジェクト > ファンクション

ドック可能パネル > プロジェクトのコンテキスト メニュー: プロジェクト > ファンクション マネージャー

ファンクションを使用することによって、機器内の機能を構成する装置をグループ化できます。ファンクションをアセンブリ内の位置に関連するロケーションと混同しないように注意してください。

すべての電気コンポーネント (装置、端子台) はファンクションに属します。このため、ファンクション別に電気コンポーネントを含め、各ファンクションに含まれる装置に基づいて異なるリストを取得できます。

各図面はファンクションに関連付けられているため、この図面にシンボルを配置するときには、このファンクションに自動的に関連付けられます。

ダイアログ ボックスが開き、プロジェクトのファンクションを管理できます。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

新しいファンクション: 新しいファンクションを作成できます。

複数のファンクションの作成: 1 回の操作で複数のファンクションを作成できます。

削除: 選択したファンクションを削除します。

プロパティ: 選択したファンクションのプロパティのダイアログ ボックスを開きます。複数のファンクションを選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

デフォルト ファンクション: 選択したファンクションがデフォルトのファンクションとして定義されます。

ツリー表示: ファンクションをツリー表示で表示します。

リスト表示: リストの形式でファンクションを表示します。

ファンクションはツリーまたはリストの形式で表示できます ([ツリー表示] または [リスト表示] アイコン)。

ファンクション階層を管理することもできます。

上記の例では、F3 ファンクションは F1 ファンクションに含まれます。ドラッグ アンド ドロップによって、L3 を L1 にスライドしてドロップするか、L3 を作成する前に L1 を選択します。

  • ファンクションの作成

  • 複数のファンクションの作成

  • ファンクション プロパティ

  • デフォルト ファンクション

  • ファンクション領域の挿入


ファンクションの作成

ファンクション マネージャー: 新しいファンクション

ドック可能パネル > プロジェクトのコンテキスト メニュー: 新規 > ファンクション

ドック可能パネル > ファンクションのコンテキスト メニュー: 新規 > ファンクション

1. プロジェクトを選択します。

2. [新しいファンクション] アイコンをクリックします。

3. [ファンクション プロパティ] ダイアログ ボックスが開き、このファンクションに関連する情報を入力できます。

ネストされたファンクション (他のファンクションに従属するファンクション) を作成するには、親ファンクションを選択してから、[新しいファンクション] アイコンをクリックします。

関連トピック:

複数のファンクションの作成

ファンクション プロパティ

デフォルト ファンクション

ファンクション領域の挿入


複数のファンクションの作成

ファンクション マネージャー: 複数のファンクションの作成

1. [複数のファンクションの作成] アイコンをクリックします。

2. ダイアログが開き、作成するファンクション数を入力できます。

確認後、ファンクションがリストに追加され、マークが自動的に計算されます。

次に、各ファンクションのプロパティを開き、必要な追加情報を適用できます。

関連トピック:

ファンクションの作成

ファンクション プロパティ

デフォルト ファンクション

ファンクション領域の挿入


ファンクション プロパティ

ファンクション マネージャー: プロパティ

ファンクション領域のコンテキスト メニュー: ファンクション プロパティ

1. ファンクションを選択します。

2. [プロパティ] アイコンをクリックして、ファンクションの [プロパティ] ダイアログ ボックスを開きます。

[プロパティ] ダイアログ ボックスは、新しいファンクションの作成中にも開きます。

マーク

ファンクション マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

ルート: ファンクション (F) 関連づけられたルートを表示します。

番号: ファンクションに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

階層構造

マスター: 子またはネストされたファンクションが従属するメイン ファンクション名。

関連付けられたブック: ブックとブック内のすべての図面にファンクションを関連付けます。

説明

ファンクションの翻訳可能なデータのうち最初のデータ。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データはプロジェクト全体で使用できます。このデータには個人情報が保存されます。この情報は図面に表示することができます。ユーザー データには翻訳可能なユーザー データ (プロジェクト翻訳時に翻訳) と、翻訳不能なユーザー データの 2 種類があります。

図面に適用されるデフォルト ファンクションは、図面が作成されたブックから取得されます。

[カスタマイズ] ボタンでは、ファンクション プロパティに表示されるユーザー データ設定にアクセスできます。

関連トピック:

ファンクションの作成

複数のファンクションの作成

デフォルト ファンクション

ファンクション領域の挿入


デフォルト ファンクション

ファンクション マネージャー: デフォルト ファンクション

DesignSpark Electrical はプロジェクト内のデフォルト ファンクションを定義します。配線図は作成時にデフォルト ファンクションに自動的に関連付けられます。これは別のファンクションが関連付けられているブックに配線図が依存している場合でも同様です。

1. リストからファンクションを選択します。

2. [デフォルト ファンクション] アイコンをクリックします。

デフォルト ファンクションが変更されると、グラフィックが更新されます。

デフォルトのファンクションは、ドック可能パネルのアイコンによっても表示されます。

関連トピック:

ファンクションの作成

複数のファンクションの作成

ファンクション プロパティ

ファンクション領域の挿入


ファンクション領域の挿入

メニュー: 配線図 > ファンクション領域

メニュー: 結線図 > ファンクション領域

ファンクション領域では、図面でのファンクショナル ゾーンをグラフィカルに表示できます。ファンクション領域は矩形で表すか、ポリラインを使用して作成できますが、常に閉じた領域でなければなりません。

領域の作図

座標の入力: グラフィック領域で点をクリックするか座標を入力し、ファンクション領域を作図します。矩形の領域を使用する場合、矩形の対角線を示す 2 番目の点をクリックします。ポリライン領域を使用する場合、線の 2 番目の点をクリックし、領域が完了するまでこの操作を続けます。ドック可能パネルの [閉じる] ボタンを使用すると、自動的に領域の最後の点を最初の点に接続できます。

オプション: このコマンドを起動すると、ドック可能パネルでモードを切り替えることができるようになります。

ファンクションの選択

ファンクション領域が閉じると、[ファンクションの選択] ダイアログ ボックスが開きます。

1. 目的のファンクションを選択します。

2. [選択] ボタンをクリックします。

ダイアログ ボックスが閉じ、選択したファンクションで自動的に図面が更新されます。

領域内に配置されたコンポーネントは、選択したファンクションに関連付けることができます。

3. 目的のオプションをクリックして、コンポーネントのファンクションを変更するか、最初に関連付けられたファンクションを保持します。

関連トピック:

ファンクションの作成

複数のファンクションの作成

ファンクション プロパティ

デフォルト ファンクション


ロケーションの割り当て/ファンクション

シンボル プロパティ: シンボルの編集 > ロケーション (ファンクション)

ケーブル プロパティ: アップストリーム ロケーション (ダウンストリーム ロケーション)

コンポーネントのロケーション (ファンクション) は、コンポーネントの作成/挿入方法に基づいて、自動的に定義されます。たとえば、シンボルを配線図に挿入すると、図面のロケーションとファンクション、またはシンボルが挿入されるロケーション/ファンクション領域のロケーションとファンクションが自動的に採用されます。コンポーネントで採用するロケーション/ファンクションがない場合、プロジェクトのデフォルト ロケーション/ファンクションを使用します。

1. 目的のロケーションまたはファンクションに対応する線をクリックします。

2. ロケーション/ファンクション セレクターが開いたら、目的のロケーションまたはファンクションを選択します。

3. [選択] ボタンをクリックすると、新しいロケーションまたはファンクションが適用されます。

関連トピック:

ロケーションの管理

ファンクションの管理


コンポーネントの管理

コンポーネントは、電気機器、端子を表します。シンボルによって表され、マークがあります。コンポーネントはグラフィック表現なしでプロジェクトに存在できます (シンボルを図面に挿入する必要はありません)。

コンポーネントはドック可能パネルの特定のタブに一覧表示されます。

コンポーネントのシンボルをダブルクリックすると、このシンボルが挿入されている図面を開くことができます。

コンポーネントの表示

必要に応じて、F5 キーまたはプロジェクトのコンテキスト メニューの [更新] コマンドを使用して、コンポーネント リストを更新できます。

コンポーネント リストを表示するためのいくつかのモードが、プロジェクトのコンテキスト メニューの [表示] サブメニューで利用可能です。

ロケーション表示/ファンクション表示: このモードでは、コンポーネントをロケーション別またはファンクション別にグループ化して表示できます。

階層別の子コンポーネント/実際のロケーション (ファンクション) 内の子コンポーネント: このオプションでは、子コンポーネントをその親の下に表示できます。または、子コンポーネントのロケーション (ファンクション) がその親のロケーション (ファンクション) と異なるときに、その実際のロケーション (ファンクション) の下に子コンポーネントを表示できます。

ファンクション (ロケーション) でソート/マークでソート: マークまたはロケーション (ファンクション) でコンポーネントをソートできます。

アクセサリ端子を非表示: アクセサリ端子を非表示にできます。

新しいコンポーネントの追加

コンポーネントはコンテキスト メニューのロケーションまたは既存のコンポーネントから追加できます (あるコンポーネントが別のコンポーネントに依存する場合)。

新しいコンポーネントを作成

コンポーネント: [コンポーネント] オプションを選択した場合、1 つのマークのみが追加されます (メーカー部品を選択していない場合)。

コンポーネント プロパティのダイアログ ボックスが表示され、コンポーネントのマークの管理、および必要な場合はメーカー部品への割り当てが可能になります。

メーカー部品からの新規コンポーネントの作成

コンポーネント メーカー部品: [メーカー部品] オプションを選択すると、ダイアログ ボックスが開いてメーカー部品を選択できます。

このダイアログ ボックスの詳細については、「メーカー部品参の割り当て」セクションを参照してください。

選択した装置と、特に装置に関連付けられた分類に従って、マークが自動的に生成され、コンポーネント リストに追加されます。

作成するコンポーネントの数量も管理できます。[メーカー部品の選択] ダイアログ ボックスが閉じたら、コンポーネントの数を入力して確認します。

新規コンポーネントを作成するには、[OK (続行)] をクリックし、[メーカー部品の選択] ダイアログ ボックスを再び開いて、新規メーカー部品を検索します。

コンポーネントの削除

[削除] コマンドは、コンポーネントのコンテキスト メニューから選択できます。

図面に挿入されたコンポーネントは削除できません。

コンポーネント プロパティ

コンポーネントは、コンテキスト メニューの [プロパティ] コマンドまたはシンボルの コンポーネントのプロパティ を使用して修正できます。

これにより、[コンポーネント プロパティ] ダイアログにアクセスし、マークを変更してメーカー部品を関連付けることができます。

関連トピック:

コンポーネント プロパティ


コンポーネント プロパティ

コンポーネントのコンテキスト メニュー: プロパティ

シンボルのコンテキスト メニュー: コンポーネント プロパティ

[コンポーネント プロパティ] ダイアログ ボックスが開き、コンポーネントの情報が表示されます。

マークとデータ

マーク

コンポーネント マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

ルート: コンポーネント クラス に応じて、コンポーネントに関連付けられたルートを表示します。

番号: コンポーネントに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

階層構造

クラス: コンポーネントの分類を変更できます。これはメーカー部品を適用するときに使用されます。また、自動マーキング中に使用されるルートも定義できます。

マスター: 子またはサブ コンポーネント (PLC カードやそのラック) が依存関係にあるメイン コンポーネントの名前を表示します。

ロケーション/ファンクション: シンボルの挿入中、シンボルが中に挿入された場合、図面またはロケーション (ロケーション) 領域からロケーション (ファンクション) が自動的に取得されます。[...] ボタンをクリックし、目的のロケーション (ファンクション) を選択することで、異なるロケーション (ファンクション) を割り当てられます。

メーカー データ

このデータはメーカー部品から取得されますが、手動で修正できます。データ タイプはクラスの定義で指定します。

説明

コンポーネントの翻訳可能なデータのうち最初のフィールド。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データのフィールドには、コンポーネントに関して管理するすべての情報を入力できます。[カスタマイズ...] ボタンをクリックすると、名前を編集できます。

メーカー部品と回路

1. [メーカー部品と回路] タブをクリックすると、メーカー部品を割り当てられます。

2. 詳細については、「メーカー部品の割り当て」を参照してください。


コンポーネントの割り当て

このコマンドによって、複数のシンボルを関連付け、1 つのコンポーネントに割り当てることができます。

シンボルのコンテキスト メニュー: コンポーネントの割り当て

サイド パネルにはオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

選択内容を確認します。

選択: 選択したシンボルのリストを表示します。グラフィック領域の他のシンボルをクリックすることで、リストを完成できます。

コンポーネント: 選択したシンボルに関連付けるコンポーネントをリストで選択します。

削除: リストから選択したシンボルを削除します。

関連付けを確認する際、各タイプのシンボル (シンボルや端子) を選択すると、選択を確認するメッセージ ボックスが表示されます。

確認すると、選択したシンボルは既存コンポーネントに自動的に関連付けられます。シンボル マークは、コンポーネント マークによって更新されます。


コンポーネントの検索

ドック可能パネル: コンポーネント > コンテキスト メニュー > コンポーネントの検索

メニュー: ツール > 検索 >コンポーネントを検索

コネクターの挿入: 既存コンポーネントを選択

このコマンドでは、フィルターを使用して、プロジェクトのコンポーネントのリストからコンポーネントを検索できます。

1. 検索するコンポーネントの条件を入力します。

2. 検索は自動的に開始されます。

3. 結果はダイアログ ボックスの左側に表示されます。右側には、選択した要素のプレビューが表示されます。

条件のリスト

マーク: コンポーネント マークに基づいて検索を実行します。

説明: コンポーネントの説明に基づいて検索を実行します。

マスター: カスケードされたマークの場合に、コンポーネントの親マークに基づいて検索を実行します。

ロケーション: コンポーネントのロケーションに基づいて検索を実行します。

ファンクション: コンポーネントのファンクションに基づいて検索を実行します。

ターゲット: 選択したブックまたはフォルダーでのみ検索を実行します。

クラス: コンポーネントのクラスに基づいて検索を実行します。

メーカー部品: コンポーネントに関連付けられたメーカー部品に基づいて検索を実行します。

コンポーネント タイプ: コンポーネントのタイプに基づいて検索を実行します。

アイコンの意味

検索マネージャーを起動します。

すべてのフィルターをリセットします。

選択した要素の図面を開きます。

ドック可能パネルのコンポーネントのリストで、コンポーネントを検索できます


回路の追加

詳細配線: 仮想回路の追加

シンボル グラフィックスの編集: 複数の接続点

メーカー部品のプロパティ: 複数追加

コンポーネント プロパティ > 回路: 仮想回路の追加...

この機能により、コンポーネントに新しい回路を追加できます。

追加: 新しい回路をリストに追加できます。回路はデフォルト値で初期化されます。デフォルト値はリストで直接変更できます。

削除: 選択した回路を削除します。

メーカー部品から初期化: メーカー部品セレクターを開きます。選択したメーカー部品の回路が、回路リストに自動的に追加されます。

回路タイプを追加したら、タイプと数量を変更します。

番号: 回路の順序番号を示します。

回路タイプ: コンポーネント、シンボル、メーカー部品に対応する回路タイプをリストで選択します。

回路数: 追加する回路の数を入力します。

回路ごとの端子数: 回路の端子の数を入力します。

情報送信: 回路の送信モードを選択します。

関連トピック:

詳細配線

シンボル グラフィックスの編集


端子番号の変更

シンボル コンテキスト メニュー: シンボル端子の編集

コンポーネント プロパティ > メーカー部品と回路 > 回路のコンテキスト メニュー: 端子の編集

回路: 回路番号を示します。

インデックス: 回路の順序番号を示します。

マーク: 材料端子の番号を入力するために使用します。デフォルトでは、材料端子の番号は、コンポーネントに関連付けられたメーカー部品によって提供されます。

方向: 接続点 (具体的には端子の接続点) の方向を指定できます。

最大ワイヤ数: 材料端子に接続できるワイヤまたはケーブル コアの数を入力するために使用します。

使用: フリー テキストを入力できます。これは接続点の特定の属性で反映できます。

最大ワイヤ断面 (mm²) / 最小ワイヤ断面 (mm²): 端子装置の断面を入力するために使用します。


コンポーネント セレクター

コンポーネント セレクターはすべてのプロジェクト コンポーネントをグループ化します。このダイアログ ボックスによって、コンポーネントを選択できます。

プリント基板挿入: 既存のプリント基板を選択

形式を選択して貼り付け: コンポーネントの関連付け

コンポーネントはロケーションでグループ化されます。

1. ロケーションのアイコンをダブルクリックして、コンポーネントを表示します。

コンテキストによっては、コンポーネント リストにはコンポーネント タイプ (コネクターまたは PCB など) のみが表示されます。

2. 必要なコンポーネントを選択します。

3. [選択] ボタンをクリックして確認します。


結線図

結線図は簡易的ながらも包括的に装置のケーブルを表現した図です。結線図では、電気配線図のすべてを実現せずに、ケーブルのリストを生成できます。結線図は、各種ロケーション、端子台、および装置間の接続 (ケーブル) を表す図面から構成されます。結線図では、配線図で使用できるケーブル コアを予約できます。

関連トピック:

ケーブルの作図

結線図シンボル

パターン


ケーブルの描画

結線図または混合回線図ではケーブルを作図できます。

メニュー: 結線図 > ケーブルを作図

グラフィック領域でケーブルを作図できるようになりました。

1. ケーブルの最初の点をクリックします。

2. ケーブルの 2 番目の点をクリックします。

ドック可能パネルには使用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドは最初のケーブルを作図するために使用された後で停止します。

コマンドを終了します。

最後の操作を元に戻します。

ケーブル スタイル

プロジェクト (ケーブル スタイル マネージャー) で定義されたケーブル タイプのいずれかを選択します。

挿入後の操作

何もしない: ケーブルを作図したときにコマンドを終了します。

確認する: オプション ダイアログ ボックスが開き、[ケーブル参照の選択] または [詳細配線] ダイアログ ボックスの表示という 2 つの選択肢が表示されます。

シンボルに接続されたケーブルを作図するときには、最初の点がシンボル マーカー (デフォルトでは緑色のスナップ) に対応することに注意してください。

関連トピック:

ケーブル スタイル マネージャー

渡り配線

ケーブル予約

詳細配線

ケーブルの追加

Cable label

ケーブル マークの表示


渡り配線

メニュー: 結線図 > 渡り配線

メニュー: 回路図 > 渡り配線

渡り配線を使用すると、必要に応じて、異なる配線図または同じ図面で、ワイヤ間の連続リンクを作成できます。これは結線図のケーブルまたは回路図のワイヤとなります。

このコマンドで作成された渡り配線は手動の渡り配線と見なされます。

このコマンドを選択すると、[管理] ダイアログ ボックスが表示されます。このダイアログには 2 つの部分があり、上部には始点 (図面 1) の配線図、下部には終点 (図面 2) の図面が表示されます。マウス ホイールを使用すると図面の任意の箇所を拡大できます。この方法は関連付けるワイヤのみを確実に選択する場合に便利です。

このコマンドの実行時には、「図面 1」がグラフィック領域で有効になります。

以下のコマンドは「図面 1」および「図面 2」に対して使用できます。

前へ: プロジェクト図面リストの前の図面を表示できます。

次へ : プロジェクト図面リストの次の図面を表示できます。

選択: 図面セレクターが開き、必要な図面を選択できます。

前の図面/次の図面: このオプションでは、プロジェクト図面を 1 つずつ前後にスクロールできます。始点の図面と終点の図面の両方で前後の図面に移動します。

始点のシンボル: 始点矢印の表示に使用するシンボルを選択できます。間違ったシンボル (たとえば終点シンボル) を選択すると、その選択を阻止するメッセージが表示されます。

終点のシンボル: 終点矢印の表示に使用するシンボルを選択できます。間違ったシンボル (たとえば始点シンボル) を選択すると、その選択を阻止するメッセージが表示されます。

始点のシンボルと終点のシンボルには、ワイヤ間のクロス リファレンスが表示されます。これには、図面マーク、バンドル マーク、図面の行と列、等電位番号など、情報を反映する、固有の属性があります。

水平表示 と垂直表示では、表示モードを管理できます。

単一挿入

1 つのワイヤから別のワイヤへのリンクを管理できます。

1. [単一挿入] アイコンをクリックします。

2. 配線図のワイヤまたはケーブルの終点をクリックします。

3. 別の配線図のワイヤまたはケーブルの終点を選択します。

矢印が挿入され、自動的に相互にクロス リファレンスが挿入されます。

複数挿入

複数ワイヤのセットから別の複数ワイヤのセットへのリンクを管理できます。

1. [複数挿入] アイコンをクリックします。

2. 始点の図面上で、複数ワイヤの開始セットの最初のワイヤと最後のワイヤをクリックします。

3. 終点の図面上で、複数ワイヤの終了セットの最初のワイヤをクリックし、最後のワイヤで終了します。

削除

削除: 既存の渡り配線を削除できます。矢印を選択して削除します。

複数削除: 複数の既存の渡り配線を削除できます。複数挿入と同様に、最初のワイヤと最後のワイヤを選択し、削除を確認します。

リンクの削除中は、リンクのすべての構成要素 (始点と終点の矢印、シンボル、およびテキスト) が削除されます。

関連トピック:

ケーブルの作図 (結線図)

ワイヤの作図 (回路図)


ケーブル予約

メニュー: 結線図 > ケーブル予約

結線図ケーブルのコンテキスト メニュー: ケーブルとコアの予約

現在存在するケーブルを管理するか、[新しいケーブル] アイコンを選択して新しいケーブルを作成できます。

新しいケーブル: ケーブル カタログが開き、プロジェクトに追加する参照型番を選択できるようになります。

削除: 選択したケーブルを削除します。コアが使用中の場合は削除できません。

プロパティ: 選択したケーブルのプロパティを表示します。

複製 : 各ケーブルまたは複数のケーブルを、部品、ファンクション パスなどのすべての関連付けられたプロパティとともにコピーします。番号値は自動的に増加します。

置換: 選択したケーブルを、カタログの別のケーブルで置換します。新しいケーブルには、置換元のケーブルと同じ数以上のコアがなければなりません。

スイッチ: 各ケーブルの始点と終点を入れ替えます。

ケーブル コアの関連付けの解除: 選択したケーブル コアを切断します。

ツリー表示: ケーブル リストの表示タイプを管理します。ケーブルはファンクション別または始点/終点別にグループ化できます。

フィルター: マーク、部品参照、始点と終点のロケーションで、一覧表示されているケーブルをフィルタリングします。

予約前ケーブル: 予約済みのケーブルを除き、すべてのケーブルを自動的に非表示にします。フィルターを解除するには、このアイコンを再度クリックします。

ケーブル コアを予約するには、次のように操作します。

1. コアに対応するボックスをオンにします。

2. すべてのコアを予約するには、ケーブルの横にあるボックスをオンにします。

メニューの [ケーブル コア選択] セクションにある 2 つのアイコン（[自動] と [手動]）を自由に使用して、コアを選択できます。

3.[OK] をクリックしてダイアログ ボックスを終了し、選択内容を保存します。

警告: この操作ではケーブル コアのみが予約されます。装置は実際にはケーブル接続されません。

選択したケーブルに対応するテキストは、自動的に線上に配置されます。このテキストはプロジェクト プロパティ ([フォント] タブ) でカスタマイズできます (スタイルとコンテンツ)。

関連トピック:

ケーブル マネージャー

ケーブルの追加

詳細配線


詳細配線

メニュー: 結線図 > 詳細配線

結線図ケーブルのコンテキスト メニュー: 詳細配線

このダイアログ ボックスは 3 つの部分に分かれています。中央にはケーブルが表示され、左側と右側には始点と終点、および端子台が表示されます。

始点または終点のピンにコアをドラッグ アンド ドロップできます。接続は緑色のゾーンで表示され、始点または終点にコア番号が表示されます。

配線が完了すると、「始点」と「終点」の緑色のゾーンに接続情報が入力されます。

コンポーネントを編集します。

コンポーネントに仮想回路を追加します。

端子台に端子を追加します。

アイコン

ケーブルの追加: 新しいケーブルを追加します。

コアの予約: ケーブルとコアの予約ダイアログ ボックスを開きます。

置換: ケーブル カタログで新しいケーブルを選択し、選択したケーブルを置換します。新しいケーブルには、置換元のケーブルと同じ数以上のコアがなければなりません。

接続: 装置とコアの両方を選択したときに、ケーブル コアを接続します。

ワイヤの関連付け: 選択したケーブルがケーブルレス ワイヤと矛盾しないとき、ケーブル コアを自動的に接続します。

この終端の配線を解除: 選択したケーブル コアを切断します。

コアの切断: 選択したコアを片側で切断します。

スイッチ: ケーブル コアの始点と終点を入れ替えます。

ワイヤ スタイル: 選択したケーブル コアに関連付けられているワイヤ スタイルを表示します。

サブ コンポーネントを参照: コンポーネント カスケード マークのみを表示します。

コンポーネントのみを表示: コンポーネントのみを表示します (サブコンポーネントは非表示にします)。

プレビュー: 始点および終点を表示するウィンドウを表示または非表示にします。

予約されたコアのみ: 予約されたコアのみを表示します。

コンポーネントをリンクするケーブル コア: 現在リンクを構成するケーブル コアのみを表示します。

すべてのコア: すべてのコアを表示します。

関連トピック:

ケーブル マネージャー

ケーブルとコアの予約

配線図での配線


ケーブルの追加

ケーブル マネージャー: 新しいケーブル

メニュー: 結線図 > ケーブルの追加

結線図ケーブルのコンテキスト メニュー: ケーブルの追加

ケーブル予約: 新しいケーブル

詳細配線: ケーブルの追加

[ケーブル参照の検索] ダイアログが開き、プロジェクトに追加する必要があるケーブル参照を選択できます。

分類/フィルター

[分類] タブでは、ダイアログの左側にケーブル ファミリーの一覧が表示されます。右側には選択したファミリーのケーブルが表示されます。

[フィルター] タブでは、複数のフィルターを編集して目的の参照を検索することができます。

選択した参照を追加します。

ダイアログの下部で、選択した参照を削除できます。

数量: 追加するケーブル数を入力します。

検証後、ケーブルが自動的にプロジェクトに追加されます。各ケーブルには、プロジェクト構成で定義されたマーク式に従って自動的に計算されるマークがあります。これらのマークを修正する場合は、[ケーブル マネージャー] でマークを選択し、[プロパティ] アイコンをクリックします。

関連トピック:

ケーブル マネージャー


ケーブル マークの表示

このフィーチャーを使用すると、ケーブル マークを表示するテキストを表示または非表示にすることができます。

メニュー: 結線図 > ケーブル マークの表示

1. グラフィック領域で、マークを表示または非表示にするケーブルを選択します。

表示されていたテキストが非表示になり、非表示のテキストが表示されます。


テキスト整列

この機能では、テキスト、等電位番号、ワイヤ番号またはケーブル テキストを整列できます。

メニュー: 結線図（Line diagram）> テキスト整列（Texts alignment）

メニュー: 配線図（Schematic）>テキスト整列（Texts alignment）

1. グラフィック領域で、整列する必要がある使用可能なテキストを選択します。

2. テキストの挿入点に対応する垂直軸線または水平軸線を描画します。

3. サイド（上、下、右、または左）をクリックします。

選択したすべてのテキストが移動され、この軸に整列されます（テキスト基準位置は変わりません）。

使用できるテキストは、等電位番号、ワイヤ番号、ケーブル マーク（配線図）、ロケーションとファンクションのラベル、およびテキストを追加（Add text）コマンドで挿入されたテキストです。


結線図シンボル

装置はコンポーネントとも呼ばれ、1 つ以上のプロジェクト シンボルによって表現されます。ライブラリからのシンボルのみ、DesignSpark Electrical による管理の対象になります。

結線図には、結線図または混合回路図にのみ挿入可能な特定の装置があります。

挿入するシンボルを選択する方法は 3 つあります。

  • シンボルの挿入

  • シンボル パレット

  • ドック可能パネル


シンボルの挿入

メニュー: 結線図 > シンボルの挿入

初めて使用するときには、シンボル選択 が開き、挿入するシンボルを選択できます。このシンボルは記憶され、次回コマンドを使用するときに候補として表示されます。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドの継続性を保証します。シンボルの挿入後もコマンドが引き続き有効になります。

シンボルの配置後、コマンドは終了します。

コマンドを終了します。

挿入するシンボルの指定

その他のシンボル: シンボル セレクターが開き、その他のシンボルを選択できるようになります。

オプション

自動マーク: [シンボル] ダイアログ ボックスは開きませんが､プロジェクト設定に従って、マークは自動的に計算され、適用されます。

図面の単位に合わせてサイズを調整: 寸法単位の競合の管理を可能にします。たとえば、タイトル ブロックがヤード法の図面に IEC シンボルを挿入できます。

1. 点をクリックして、シンボルを挿入します。

関連トピック:

シンボル選択

シンボル プロパティ


シンボル選択

[シンボルの挿入] コマンド: その他のシンボル

配線図、結線図

選択内のシンボルは、シンボル ライブラリに保存されています。

プロパティ: 選択した [シンボル プロパティ] ダイアログ ボックスを開きます。

プレビュー: 選択したシンボル プレビュー ウィンドウを開きます。

リスト モード: シンボルのリスト (名前、説明、分類) を表示します。

サムネイル モード: サムネイル プレビューの形式でシンボルを表示します。

構成: ダイアログ ボックスの項目の表示設定を管理します。

1. 必要なシンボルを選択します。

2. [選択] ボタンをクリックして確認します。

選択したシンボルは、自動的に [シンボル挿入] サイド パネルに追加されます。

分類

このタブには、シンボル分類がツリー形式で表示されます。

ダイアログ ボックスの左側にはシンボル分類が表示され、右側には現在選択されている分類のシンボルが表示されます。

サブクラスの内容の表示: このボックスをオンにすると、選択した分類のサブクラスに含まれるすべてのシンボルを表示します。

フィルター

このタブでは、シンボルのリストをフィルタリングできます。シンボルのプロパティから取得したフィルタリング条件が表示されます。

このダイアログ ボックスの右側には、選択した条件に該当するシンボルが表示されます。

フィルターを除去: すべてのフィルター条件を除去します。

関連トピック:

シンボル マネージャー

結線図シンボルの挿入

配線図シンボルの挿入

ブラックボックスを挿入

端子の挿入


シンボル パレット

ドック可能パネル: シンボル

シンボル タイプに対して有効: 回路図と配線図

各図面タイプ (回路図/配線図/混合回路図) には独自のシンボル パレットがあります。これには頻繁に使用されるシンボルが含まれる他に、プロジェクト ライブラリで使用可能なすべてのシンボルにアクセスできます。

パレットは完全にカスタマイズ可能であり、シンボルのグループまたはシンボルの追加と除去ができます。

プロジェクト構成の [ライブラリとパレット] タブと [パレット構成] でシンボル パレットの使用方法を構成できます。

シンボルを挿入するには、次のように操作します。

1. シンボルをダブルクリックするか、ドラッグ&ドロップを利用します。

2. 図面の点をクリックして、シンボルを挿入します。

グループ管理

シンボルは、検索を最適化するためにカテゴリ別にグループ化されています。パレットにはこれらのグループを管理するためのコンテキスト メニューがあります。

シンボルの追加: 選択したグループにシンボルを追加します。[シンボル選択] が開き、追加するシンボルを選択できます。

このシンボルを編集: シンボルをシンボル エディターで開き、変更することができます。

このシンボルを削除: 選択したシンボルを削除します。

新しいグループ: 新しいグループを作成できます。グループ プロパティ ダイアログ ボックスが開き、名前とサムネイルを構成できます。

グループ プロパティ: グループ名の編集およびサムネイル サイズの設定ができます。

グループの削除: グループの削除ができます。グループに含まれるシンボルはライブラリから除去されません。

グループを有効にする: すべてのグループが一覧表示されたサブメニューを開きます。目的のグループを選択します。

シンボルの検索

パレットでは特定のシンボルを検索できます。この検索では、シンボル パレットだけではなく、シンボル ライブラリ全体が検索されます。

ボックスで次のように操作します。

1. 目的のテキストを入力します。

2. [検索] ボタンをクリックします。

[説明] フィールドに入力されたテキストを含むすべてのシンボルが検索結果に表示されます。

パレットへのシンボルの追加

パターンと同様に、グラフィック領域に挿入されたシンボルをパレットに追加できます。

1. シンボルを追加するパレットのグループを開きます。

2. グラフィック領域でシンボルを選択します。

3. パレットのグループにドラッグ アンド ドロップします

関連トピック:

シンボル選択

シンボル プロパティ

端子プロパティ


ドック可能パネル

ドック可能パネル: コンポーネント > コンポーネントのコンテキスト メニュー > シンボルの挿入

すべてのタイプのシンボルで有効: 回路図と結線図

このコマンドを実行すると、シンボル選択 が開き、挿入するシンボルを選択できます。

提案されるシンボル タイプは、現在の図面のタイプに従います。たとえば、結線図フォリオを開いた場合、結線図シンボルのみが表示されます。

1. シンボルを選択します。

2. [選択] ボタンをクリックします。

3. 図面の点をクリックして、シンボルを挿入します。

メーカー部品が複数の (各回路で関連付けられている) シンボルに関連付けられている場合、メッセージ ボックスが表示されます。

メーカー部品回路からのシンボルの入力: [メーカー部品回路セレクター] ダイアログ ボックスが開き、挿入するシンボルを選択できます。

キャンセル: メーカー部品に関連付けられたシンボルを挿入します。関連付けらたシンボルが存在しない場合、[シンボル セレクター] ダイアログ ボックスが開き、挿入するシンボルを選択できます。

関連トピック:

シンボル選択

シンボル プロパティ

端子プロパティ


シンボル プロパティ

このシンボル プロパティ ダイアログ ボックスは、結線図シンボルと配線図シンボルで使用されるものと同じです。

シンボルのコンテキスト メニュー: シンボル プロパティ

シンボルを挿入するたびにシンボル プロパティ ダイアログ ボックスが自動的に開きます ([自動マーキング] オプションを選択した場合を除く)。このダイアログ ボックスには、シンボルのコンテキスト メニューでシンボルの [プロパティ] コマンドを使用してアクセスすることもできます。

選択したシンボルに応じて、複数のプロパティを無効にすることができます。複数のシンボルを選択した場合は、共通プロパティのみが有効になります。

既存のマークに関連付け

シンボルを既存のマークに関連付ける場合は、リストの右側で選択するか、手動で同じマークを割り当て、[= >] ボタンを使用して関連付けを作成します。

ダイアログ ボックスの上部にあるフィルターを使用して、既存のコンポーネントの検索を容易にすることができます。

シンボルの編集

マーク

シンボル マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

ルート: シンボル クラス に応じて、シンボルに関連付けられたルートを表示します。

番号: シンボルに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

永続的コンポーネント: コンポーネントを表す最後のシンボルが削除されると、そのコンポーネントも削除されます。このボックスをクリックすると、コンポーネントは削除されません。

永続的コンポーネントを削除するには、[コンポーネント] タブ (ドック可能パネル) のコンテキスト メニューの [コンポーネントの削除] コマンドを使用します。

階層構造

クラス: シンボル分類を変更できます。これはメーカー部品を割り当てるときに使用されます。また、自動マーキング中に使用されるルートも定義できます。

マスター: 子またはサブ コンポーネント (PLC カードやそのラック) が依存関係にあるメイン コンポーネントの名前を表示します。

ロケーション/ファンクション: シンボルの挿入中、シンボルが中に挿入された場合、図面またはロケーション (ロケーション) 領域からロケーション (ファンクション) が自動的に取得されます。[...] ボタンをクリックし、目的のロケーション (ファンクション) を選択することで、異なるロケーション (ファンクション) を割り当てられます。

メーカー データ

このデータはメーカー部品から取得されますが、手動で修正できます。データ タイプはクラスの定義で指定します。

説明

コンポーネントの翻訳可能なデータのうち最初のフィールド。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データのフィールドには、コンポーネントに関して管理するすべての情報を入力できます。

シンボル データ

クロス リファレンス タイプ: 編集中のシンボルに対して、クロス リファレンス レベルを選択します。デフォルトでは、シンボルのプロパティで構成された値が表示されます。(次の章シンボル プロパティを参照してください。)


回路図

詳細回路図は、グラフィック シンボルを使用して、ネットワークのさまざまな部品、接続されているか機能的に関連する設備や装置を表現します。詳細回路図の目的は、装置の動作を説明し、取り付けの基本事項を提供するとともに、試運転と保守を支援することです。

グラフィック インターフェイスで回路図タイプの図面を開くと、ただちに、回路図作成固有のメニューに関連するコマンドが表示されます。

関連トピック:

ワイヤの作図

回路図シンボル

ブラック ボックス

端子

パターン


ワイヤの作図

ワイヤには、1 本のワイヤ (コマンド ワイヤ タイプ) と複数のワイヤ (電源タイプ) の 2 種類があります。これらの 2 種類のワイヤは、異なるコマンドを使用して作成されます。

各ワイヤにはワイヤ スタイルが必要です。ワイヤ スタイルの数は無制限であるため、必要な数のワイヤ スタイルを作成できます。これらは「ワイヤ スタイル マネージャー」で管理されます。ワイヤ スタイルはプロジェクト固有です。

ワイヤを使用すると、異なる装置に接続できます。ワイヤに番号を割り当て、ケーブル コアを表すことができます。

関連トピック:

ワイヤ スタイル マネージャー

複数のワイヤの作図

1 つのワイヤの作図

渡り配線

ワイヤ番号の割り当て


ワイヤ スタイル選択

ドック可能パネル: ワイヤの作図コマンド > [...]

ワイヤ タイプを変更するには、ワイヤ名の右側の [...] ボタンをクリックします。

[ワイヤ スタイル選択] ダイアログ ボックスが表示され、プロジェクトで使用可能なワイヤ スタイルから選択できるようになります。

新しいワイヤを作成する場合や、既存のワイヤまたはグループを修正する場合は、[マネージャー] ボタンをクリックしてワイヤ スタイル マネージャーを開きます。

関連トピック:

ワイヤ スタイル マネージャー

複数のワイヤの作図

1 つのワイヤの作図


1 つのワイヤの作図

メニュー: 回路図 > 1 つのワイヤ タイプを作図

コマンドを実行すると、ドック可能パネルが更新され、選択したワイヤ パラメーターが表示されます。その後、現在の図面で作図を開始できます。

1. グラフィック領域で、ワイヤの始点をクリックします。

2. 2 番目の点をクリックし、ワイヤを終了する場所を指定します。

ドック可能パネルには使用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

1 つのワイヤを作図するためにコマンドを初めて使用した後、コマンドを停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

最後の操作を元に戻します。

ワイヤ スタイル選択

名前: ワイヤ タイプを変更するには、ワイヤ名の右側の [...] ボタンをクリックします。[ワイヤ スタイル セレクター] ダイアログ ボックスが開き、必要なワイヤ スタイルを選択できます。

線分間のスペース: ワイヤ間の距離を変更することもできます。プロジェクト設定によって、値はミリメートルまたはインチです (プロジェクト構成設定の単位系を参照)。

行数: ワイヤが複数の (同じ) コンダクターから構成されている場合、作図する番号を指定します。

オプション

ベントを描画 (C キー): キーボードの [C] キーを押し、ベンドを挿入します。

非直交描画 (F8): キーボードの F8 キーを押し、ロックを無効にして直行軸でワイヤを挿入できるようにします。

関連トピック:

ワイヤ スタイル マネージャー

複数のワイヤの作図

渡り配線の管理


複数のワイヤの作図

メニュー: 回路図 > 複数のワイヤの作図

コマンドを実行すると、ドック可能パネルが更新され、選択したワイヤ パラメーターが表示されます。その後、現在の図面で作図を開始できます。

1. グラフィック領域で、ワイヤの始点をクリックします。

2. 2 番目の点をクリックし、ワイヤを終了する場所を指定します。

ドック可能パネルには使用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

1 つのワイヤを作図するためにコマンドを初めて使用した後、コマンドを停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

最後の操作を元に戻します。

ワイヤ スタイル選択

名前: グループ名の右側にある [...] ボタンをクリックし、ドック可能パネルで番号割り当てグループの名前を変更します。[ワイヤ スタイル選択] ダイアログ ボックスが開き、マネージャーにアクセスしてグループ名を選択できるようになります。

線分間のスペース: ワイヤ間の距離を変更します。値は、プロジェクトの設定に応じて、ミリメートル単位かインチ単位になります (プロジェクト構成設定の単位系を参照)。

使用可能なワイヤ: 現在選択しているワイヤ スタイルを構成するワイヤが一覧表示されます。作図するコンダクターのボックスをオンにします。

オプション

位相を反転 (スペース キー): キーボードの [Space] バーを押し、コンダクターを反転します。

ベントを描画 (C キー): キーボードの [C] キーを押し、ベンドを挿入します。

非直交描画 (F8): キーボードの F8 キーを押し、ロックを無効にして直行軸でワイヤを挿入できるようにします。

関連トピック:

ワイヤ スタイル マネージャー

1 つのワイヤの作図

渡り配線の管理


等電位プロパティ

ワイヤ コンテキスト メニュー: 等電位プロパティ

[等電位プロパティ] ダイアログ ボックスが開き、この等電位に属するワイヤに共通のデータを編集できます。

このデータは、ワイヤが属す ワイヤ スタイル プロパティによって生成されます。

ワイヤ スタイルのプロパティを修正すると、変更内容は自動的に等電位のプロパティに渡されるため、この等電位の各ワイヤのプロパティに渡されます。

等電位のマークやプロパティを修正した場合、コマンドが実行された等電位にのみ影響します。

マーク

等電位マークは、ワイヤ番号割り当てによって自動計算されるか、ワイヤ マーク エディター経由で手動で入力されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用します。

番号: 等電位に割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

全般

直径: ワイヤの直径を入力します。

断面またはゲージ: ワイヤの断面を入力します。

ワイヤ サイズ規格: プロジェクトで使用する規格を選択できます。

色: ワイヤの実際の色を選択できます。

ベンド半径 (x 直径): ベンド半径の計算に必要なパラメーターを入力できます (パラメーター × 直径 = ベンド半径)。

信号: ワイヤが伝達する信号を入力できます。

関連付けられたデータ

ワイヤ スタイル: 等電位に関連付けられているワイヤ スタイルが表示されます。

ワイヤの数: この等電位によって表現されるワイヤの数 (ワイヤ配線順序の配線数) が表示されます。

ファイル: 等電位が始まる図面マークが表示されます。

行: 等電位が始まる行番号が表示されます。

列: 等電位が始まる列番号が表示されます。

ユーザー データ

ユーザー データのフィールドには、等電位に関して管理するすべての情報を入力できます。

[カスタマイズ...] ボタンにより、 ユーザー データ 管理にアクセスできます。

関連トピック:

ワイヤ スタイル プロパティ

ワイヤ プロパティ


ワイヤ プロパティ

ワイヤ コンテキスト メニュー: ワイヤ プロパティ

ワイヤのプロパティ ダイアログ ボックスが開き、ワイヤ固有の情報を編集できるようになります。

このデータは、ワイヤが属す 等電位プロパティ から派生し、 ワイヤ スタイル プロパティによって生成されます。

ワイヤ スタイルまたは等電位のプロパティを修正する場合、自動的にワイヤ プロパティに渡されます。

ワイヤのマークやプロパティを変更しても、コマンドを使用したワイヤにしか影響しません。

マーク

ワイヤ マークは、ワイヤ番号割り当てによって自動的に計算されるか、あるいはワイヤ マーク エディターを使って手動で入力できます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用します。

番号: ワイヤに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

全般

直径 (mm): ワイヤの直径を入力します。

断面またはゲージ: ワイヤの断面を入力します。

ワイヤ サイズ規格: プロジェクトで使用する規格を選択できます。

色: ワイヤの実際の色を選択できます。

ベンド半径 (x 直径): ベンド半径の計算に必要なパラメーターを入力できます (パラメーター × 直径 = ベンド半径)。

信号: ワイヤが伝達する信号を入力できます。

関連付けられたデータ

ワイヤ スタイル: ワイヤ スタイルが表示されます。

等電位: このワイヤに関連付けられている等電位番号が示されます。

配線順序: ワイヤ配線順序の行番号が表示されます。

始点: ワイヤに接続しているコンポーネントのマーク (始点) が表示されます。

ターゲット: ワイヤに接続しているコンポーネントのマーク (終点) が表示されます。

ケーブル コア: ワイヤがケーブル コアに関連付けられている場合、このフィールドにはケーブル マークとケーブル コア マークが示されます。このワイヤがブリッジを表す場合、アイコンはブリッジを表すように変化します。

ユーザー データ

等電位について管理するすべての情報を入力するには、ユーザー データ フィールドを使用できます。

[カスタマイズ...] ボタンでは ユーザー データ 管理にアクセスできます。

関連トピック:

ワイヤ スタイル プロパティ

等電位プロパティ


等電位の競合の解決

ワイヤ コンテキスト メニュー: 等電位の競合の解決

回路図を設計または修正するときには、同じ等電位を持たない接続ワイヤでは、番号の競合が発生する場合があります。等電位の競合管理は、プロジェクト 構成([グラフィック] タブ) で有効になります。

このコマンドを実行すると、ダイアログ ボックスが開き、競合を手動で解決できます。

1. 回路図に使用するワイヤ番号を選択します。


ワイヤ スタイルの反映

ワイヤ コンテキスト メニュー: ワイヤ スタイル > 反映

コマンドを固定し、コマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

このコマンドを使用すると、選択したセグメントのワイヤ スタイルを接続されたセグメントに反映できます。ドック可能パネルには反映オプションが表示されます。

反映

等電位: 同じ等電位番号の接続全体に反映できます。

回路経由: ワイヤ スタイルがシンボルと同じアップストリームとダウンストリームになっている場合のみ、シンボル全体にワイヤ スタイルを反映します。


ワイヤ スタイルの置換

ワイヤ コンテキスト メニュー: ワイヤ スタイル > 置換

コマンドを固定し、コマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

このコマンドを使用すると、プロジェクトで使用されているワイヤを別のワイヤ スタイルに置換できます。ドック可能パネルにはワイヤを選択するオプションが表示されます。

置換範囲

プロジェクト全体: プロジェクトのすべてのワイヤ。

現在のブック: 現在の図面が配置されているブックのみ。

現在のフォルダー: 現在の図面が配置されているフォルダーのみ。

現在の配線図: 現在の図面のみ。

配線図を選択: 図面セレクターが開き、処理する図面を選択できるようになります。

配線図で選択した項目: 配線図で選択したワイヤのみ。

等電位に反映: 同じ等電位のワイヤ。

回路経由で反映: ワイヤ スタイルがシンボルと同じアップストリームとダウンストリームになっている場合のみ、シンボル全体でワイヤ スタイルを置換します。


配線図テキストの管理

いくつかのコマンドを使用して、等電位番号やケーブル マークなど、ソフトウェアが自動的に挿入したテキストを管理することができます。

  • テキスト整列

  • ワイヤ マークの表示

  • ケーブル マークの表示


ワイヤ マークの表示

このフィーチャーを使用すると、等電位マークまたはワイヤ マークを表示するテキストを表示または非表示にすることができます。

メニュー: 配線図 > テキストを表示 > ワイヤ マークを表示/非表示

1. テキストを表示または非表示にするワイヤを選択します。

表示されていたテキストが非表示になり、非表示のテキストが表示されます。


ケーブル マークの表示

このフィーチャーを使用すると、ケーブル マークを表示するテキストを表示または非表示にすることができます。

メニュー: 配線図 > テキストを表示 > ケーブル マークを表示/非表示

1. グラフィック領域で、マークを表示または非表示にするケーブルを選択します。

表示されていたテキストが非表示になり、非表示のテキストが表示されます。


回路図シンボル

シンボルは、電気装置の全体または一部を表現したものです。

シンボルは、独自のシンボルを入力できるライブラリ内で分類されます。また、シンボルは、ドック可能パネルに表示されるパレットでも、分類およびグループ化されます。

シンボルの挿入は、配線図または混合回路図で行います。

シンボルはさまざまな方法で挿入できます。

  • シンボルの挿入

  • シンボル パレット

  • ドック可能パネル


シンボルの挿入

メニュー: 配線図 > シンボルの挿入

このコマンドを初めて使用する場合は、[シンボル選択] ダイアログが開き、挿入するシンボルを選択できます。このシンボルは保存され、次回コマンドを使用するときに挿入できます。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定します。シンボルを挿入するために最初に使用された後も、コマンドは引き続き有効です。

シンボルを挿入するためにコマンドを初めて使用した後、コマンドを停止します。

コマンドを終了します。

挿入するシンボルの指定

最後に挿入したシンボルを表示します。シンボルが保存されていない場合は、シンボル選択が自動的に開きます。

表示されたシンボルを挿入しない場合は、[その他のシンボル] ボタンをクリックします。シンボル選択が開き、他のシンボルを選択できます。

シンボルの方向

このオプションでは、シンボルを挿入前に回転できます。マウスで右クリックして回転角度を選択することもできます。

オプション

手動マーク: このオプションが選択されている場合、[シンボル] ダイアログ ボックスが開き、自動的に手動モードでマークが表示されます。

プロパティを要求: このオプションが選択されていない場合、[シンボル] ダイアログ ボックスは開きませんが､プロジェクト設定に従って、マークは自動的に計算され、適用されます。

図面の単位に合わせてサイズを調整: 寸法単位の競合の管理を可能にします。たとえば、タイトル ブロックがヤード法の図面に IEC シンボルを挿入できます。

1. 図面の点をクリックして、シンボルを挿入します。

関連トピック:

シンボル選択

シンボル プロパティ


メーカー部品回路セレクター

コンポーネント ツリー (ドック可能パネル) からシンボルを挿入する場合、および複数のシンボルがメーカー部品に関連付けられている場合、[メーカー部品から回路を選択] ダイアログ ボックスが開きます。

ドック可能パネル: コンポーネント > コンポーネントのコンテキスト メニュー > シンボルの挿入 > メーカー部品回路からシンボルを挿入します

すべてのタイプのシンボルで有効: 回路図と結線図

ダイアログ ボックスには、メーカー部品回路が表示されます。回路を選択すると、ダイアログ ボックスの右側に、関連付けられたシンボルのプレビューが表示されます。複数の回路を 1 つのシンボルに関連付けられます。

1. [OK] をクリックしてシンボルを確認し、挿入します。


シンボル属性の編集

シンボルに関連付けられた属性を追加、削除、編集できます。このコマンドでは複数選択が可能です。

シンボル コンテキスト メニュー: 属性 > 属性の編集

端子のコンテキスト メニュー: 属性 > 属性の編集

ブラック ボックス コンテキスト メニュー: 属性 > 属性の編集

ダイアログ ボックスが開き、既存の属性の一覧が表示されます。# で始まる項目はすべて DesignSpark Electrical が管理する属性で、その他はユーザーが管理する属性です。

このダイアログ ボックスにも、各属性の設定が表示されます。

番号: 属性インデックス (変更できません)。

名前: 属性名。ユーザー属性名のみ変更可能です。

プロンプト: DesignSpark Electrical 属性でのみ利用可能な属性の説明。

値: グラフィック領域に表示されるテキスト (属性値)。

位置 X: 属性位置の X 座標。

位置 Y: 属性位置の Y 座標。

高さ: グラフィック領域に表示されるテキストの高さ。

テキスト スタイル: グラフィック領域でテキストの表示に使用されるテキスト スタイル。

非表示: テキストの表示/非表示を切り替えます。

色: グラフィック領域に表示されるテキストの色。

角度: テキストの向き。

基準位置: テキストに使用するテキスト基準位置をリストで選択します。

斜角: 斜体のテキストを作成します。

幅係数: 文字幅を圧縮します。

ユーザー属性: リストに新しい属性が追加されます。その設定を変更します。

定義済み属性: [属性管理] ダイアログ ボックスが開き、追加する属性を選択できます。選択された属性はリストに追加されます。その設定を変更します。

削除: 選択した属性を削除します。この属性は、グラフィック領域で除去されます。

シンボル: グラフィック領域で選択されたシンボルを一覧表示します。[<すべて>] を選択すると、選択したシンボルすべてに変更が加えられます。1 つのシンボルのみを変更するには、リストで選択します。

1. [OK] をクリックして確認します。

2. 追加、削除、変更された属性によって、シンボルは自動的に更新されます。


ブラック ボックス

任意のデバイスを表すことができる汎用的なシンボル。新しい一意のシンボルが必要ではない場合や、新しいシンボルを作成する時間がない場合には、この機能を使用することで作業時間を短縮できます。ブラックボックスは矩形で、編集可能なピンを関連付けることができます。

ブラック ボックスは「配線図」または「混合配線図」図面タイプに挿入されます。

ブラック ボックスの接続点

ワイヤとブラック ボックス領域間の各交差に接続点が挿入され、デバイス端子を表します。構成設定に従って基本接続点（端子番号はテキスト）または属性を含み方向が指定された接続点が得られます。

ブラック ボックスを挿入する方法は 2 つあります。

  • ブラックボックスを挿入

  • ドック可能パネル

  • ブラック ボックスの更新

  • 接続点の追加


ブラックボックスを挿入

メニュー: 配線図 > ブラック ボックスの挿入

初めて使用する場合は、シンボル選択が開き、挿入するシンボルを追加できます。このシンボルは保存され、次回以降にシンボル挿入コマンドを実行するときには、このシンボルを選択できます。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定。固定されている限り、コマンドを使用し続けることができます。

1 つのシンボルの挿入後、コマンドを停止します。

コマンドを停止します。

挿入するシンボルの指定

最後に挿入したシンボルを表示します。シンボルが保存されていない場合は、シンボル選択が自動的に開きます。

表示されたシンボルを挿入しない場合は、[その他のシンボル] ボタンをクリックします。シンボル選択が開き、他のシンボルを選択できます。

オプション

手動マーク: このオプションが選択されている場合、[シンボル] ダイアログ ボックスが開き、自動的に手動モードでマークが表示されます。

プロパティを要求: このオプションが選択されていない場合、[シンボル] ダイアログ ボックスは開きませんが､プロジェクト設定に従って、マークは自動的に計算され、適用されます。

図面の単位に合わせてサイズを調整: 寸法単位の競合を管理できます。たとえば、タイトル ブロックがヤード法の図面に IEC シンボルを挿入できます。

1. グラフィック インターフェイスで挿入点をクリックします。

2. ブラック ボックスの寸法をマークする点をクリックします。

関連トピック:

ブラック ボックスの更新

接続点の追加


ブラック ボックスの更新

ブラック ボックス コンテキスト メニュー: ブラック ボックスの更新

このコマンドでは、ブラック ボックスに接続されたワイヤを調整できます。接続はボックスの輪郭線上に配置され、自動的にピンが配置されます。

関連トピック:

ブラックボックスを挿入

接続点の追加


接続点の追加

ブラック ボックスのコンテキスト メニュー: 接続点の追加

ブラック ボックス領域に接続点を挿入します。

1. ブラック ボックス領域で、1 つ以上の点をクリックします。

構成設定に従い、特定のシンボルを挿入して、接続点またはデフォルトの接続点を表示できます。

これらの接続点は、ブラック ボックスのコンテキスト メニューのコマンド [シンボル端子の編集] によって編集できます。

関連トピック:

ブラックボックスを挿入

ブラック ボックスの更新


端子

端子は「端子台、端子」クラスに属する特定のシンボルによって表現されます。これは従来のシンボルと比べ、端子には特別なステータスが割り当てられるため、特定のプロセスを実行できます。端子は端子台に接続する必要があります。

端子シンボルの挿入は、配線図または混合配線図で行います。

端子シンボルはさまざまな方法で挿入できます。

  • 端子の挿入

  • シンボル パレット

  • ドック可能パネル


端子の挿入

メニュー: 回路図 > 端子の挿入

このコマンドを初めて使用する場合は、シンボル選択 ダイアログが開き、挿入するシンボルを選択できます。その後このシンボルは保存され、次回コマンドを使用するときに挿入できます。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定し、コマンドを初めて使用した後にそれを有効な状態に保ちます。

シンボルを挿入するためにコマンドを初めて使用した後、コマンドを停止します。

コマンドを終了します。

端子を表すシンボルを選択

デフォルトのシンボルが目的のものではない場合は、[その他のシンボル] ボタンをクリックします。

フィルタリングされた端子のリストがシンボル選択に表示され、必要な端子シンボルを選択できるようになります。

シンボルの方向

このオプションでは、シンボルを挿入前に回転できます。マウスで右クリックして回転角度を選択することもできます。

1. 図面の点をクリックして、端子を挿入します。

2. ワイヤ上に端子を挿入する場合、ケーブルの向きを定義するように指示するメッセージが表示されます。

3. [端子プロパティ] ダイアログ ボックスが表示されます。

複数端子の挿入

メニュー: 回路図 >「n」端子の挿入

4. ワイヤに垂直な線の終点に対応する 2 点をクリックします。

5. この線とワイヤ間の各交点に、端子が挿入されます。

6. 端子の方向を定義します。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定し、コマンドを初めて使用した後にそれを有効な状態に保ちます。

シンボルを挿入するためにコマンドを初めて使用した後、コマンドを停止します。

コマンドを終了します。

端子を表すシンボルを選択

デフォルトのシンボルが目的のものではない場合は、[その他のシンボル] ボタンをクリックします。

フィルタリングされた端子のリストがシンボル選択に表示され、必要な端子シンボルを選択できるようになります。

オプション

軸線を描画: 軸の描画は任意です。軸線が不要な場合は、ボックスをオフにします。

[端子プロパティ] ダイアログ ボックスが表示されます。

関連トピック:

シンボル選択

端子プロパティ


端子プロパティ

端子のコンテキスト メニュー: シンボル プロパティ

端子の版は挿入後に自動的に表示されます。

既存のマークに関連付け

端子台または端子を既存のマークに関連付ける場合は、リストの右側で選択するか、手動で同じマークを割り当て、[= >] ボタンを使用して関連付けを作成します。

ダイアログ ボックスの上部にあるフィルターを使用して、既存のコンポーネントの検索を容易にすることができます。

複数レベル端子には、リストで回路を選択することで、目的のレベルのみを関連付けることができます。

端子台

マーク

端子台マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

ルート: 端子台 クラス に応じて、端子台に関連付けられたルートを表示します。

番号: 端子台に割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

永続的コンポーネント: 端子台を表す最後のシンボルが削除されると、その端子台も削除されます。このボックスがオンの状態では、端子台は削除されません。

永続的端子台を削除するには、[コンポーネント] タブ (ドック可能パネル) のコンテキスト メニューの [コンポーネントの削除] コマンドを使用します。

階層構造

クラス: 端子台分類を変更できます。これはメーカー部品を適用するときに使用されます。また、自動マーキング中に使用されるルートも定義できます。

マスター: 子またはサブコンポーネントが従属するメイン端子台の名前を表示します。

ロケーション/ファンクション: シンボルの挿入中、シンボルが中に挿入された場合、図面またはロケーション (ロケーション) 領域からロケーション (ファンクション) が自動的に取得されます。[...] ボタンをクリックし、目的のロケーション (ファンクション) を選択することで、異なるロケーション (ファンクション) を割り当てられます。

端子

マーク

端子マークはプロジェクト設定に従って自動的に計算されます。

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用されます。

ルート: 端子 クラス に応じて、端子に関連付けられたルートを表示します。

番号: 端子に割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

永続的コンポーネント: 端子を表す最後のシンボルが削除されると、その端子も削除されます。このボックスがオンの状態では、端子は削除されません。

永続的コンポーネントを削除するには、[コンポーネント] タブ (ドック可能パネル) のコンテキスト メニューの [コンポーネントの削除] コマンドを使用します。

階層構造

クラス: 端子分類を変更できます。これはメーカー部品を適用するときに使用されます。また、自動マーキング中に使用されるルートも定義できます。

マスター: 子またはサブコンポーネントが従属するメイン コンポーネント (端子台) の名前を表示します。

ロケーション/ファンクション: シンボルの挿入中、シンボルが中に挿入された場合、図面またはロケーション (ロケーション) 領域からロケーション (ファンクション) が自動的に取得されます。[...] ボタンをクリックし、目的のロケーション (ファンクション) を選択することで、異なるロケーション (ファンクション) を割り当てられます。

メーカー データ

このデータはメーカー部品から取得されますが、手動で修正できます。データ タイプはクラスの定義で指定します。

説明

コンポーネントの翻訳可能なデータのうち最初のフィールド。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データのフィールドには、コンポーネントに関して管理するすべての情報を入力できます。


複数レベル端子の管理

複数レベル端子は特別な端子で、ユーザーはその上で複数のワイヤまたはケーブル コアを接続できます。含まれる回路が 1 つに限られる単一端子とは異なり、複数の回路が含まれます。複数レベル端子を識別するために、レベル番号を指定することで特別なマーキングを設定できます。

複数レベル端子マーク

複数レベル端子のマーキングは、プロジェクト構成で、他の要素と同様には設定されていません。各端子には独自のマーク スタイルを割り当てることができます。シンボルと同じマーク スタイルを使用するか、端子番号、区切り文字 (ドット) およびレベル番号を使用する特別なマーキング (たとえば 1.3 は端子 1、レベル 3 を表す) を使用することができます。

[コンポーネント プロパティ] ダイアログ ボックスでは、他のコンポーネントと同様に複数レベル端子を割り当てることができます。[マーク] セクションでは、[レベル マークを使用] オプションを選択すると、この以前のマーク スタイルが有効になります。他のコンポーネントと同様に複数レベル端子をマークする場合は、従来のマーキング モード（[自動] または [手動]）を使用します。

複数レベル端子の作成または編集

複数レベル端子を作成するには、まず単一端子を作成する必要があります。続いて、複数の端子をグループ化して複数レベル端子を生成する必要があります。

複数レベル端子の番号再割り当て

[次の端子台端子の番号再割り当て] ダイアログ ボックスには、複数レベル端子に固有のセクションがあります。結果をわかりやすくするため、選択したオプションに応じたグラフィックで結果が表示されます。

この機能の詳細については、「端子番号の再割り当て」の章を参照してください。


元に戻す/やり直す

プロジェクトが複数のワークステーションで開いていても、ほとんどのグラフィック機能は元に戻すことができます。

一部の機能、主にプロセス機能は、データベースへの影響が非常に重大であってキャンセルできないため、元に戻すことはできません。

メニュー: 編集 > 元に戻す

メニュー: 編集 > やり直す

[元に戻す] コマンドでは、最後に使用したコマンドがキャンセルされます。[やり直す] コマンドでは、最後に使用した [元に戻す] コマンドの結果がキャンセルされます。

[元に戻す] アイコンと [やり直す] アイコンには矢印が付き、最後に使用したコマンドが表示されます。これらのエントリのいずれかを選択すると、それ以前のすべての操作を 1 回で元に戻すかやり直すことができます。

一部のインターフェイスでは、ショートカット Ctrl+Z を使用して、最後の操作を元に戻すことができます。


パターン

パターンとは、すでに作図が終わっていて、別の図面やプロジェクトで再利用したい配線図の一部です。パターンは、ライブラリに保存されます。

  • 配線図パターン

  • パターン選択


配線図パターン

配線図パターンとは、すでに作図が終わっていて、他の図面やプロジェクトで再利用したい結線図、混合配線図の一部です。

パターンはライブラリ内でグループ化され、すべてのプロジェクトで使用できます。

ドック可能なパネルには、[パターン] タブが用意され、優先される配線図パターンを保存できます。独自のパレットを管理できます。

パレットに新しい配線図パターンを作成すると、自動的にパターン ライブラリに追加されます。

  • 配線図パターンの作成

  • 配線図パターンの挿入

関連トピック:

パレット構成


配線図パターンの作成

ドック可能パネル: パターン

パターンを作成するには、次のように操作します。

1. ライブラリに保存する要素を含む図面を開きます。

2. ドック可能パネルで、[パターン] タブを有効にします。

3. グラフィック ゾーンで、保存するエンティティを選択します。

このステップでは、いくつかの方法によってパターンを作成できます。

4. パレットのいずれかのセクションにエンティティをドラッグ アンド ドロップします。

または

4. パターン グループのコンテキスト メニューの [パターンに保存] コマンドを使用します。

または

4. [編集] メニューの [挿入点を付けてコピー] コマンドを使用します。

5. パターン グループのコンテキスト メニューの [新しいパターンとして貼り付け] コマンドを使用します。

ダイアログ ボックスが開き、パターンに関連付けられたデータを入力できます。

このパターンは自動的にパターン マネージャーに追加されるため、他のプロジェクトに挿入できます。

ドック可能パネルのドロップダウン メニューでは、特定のコマンドにアクセスできます。

既存のパターンを追加: ライブラリに保存されたマクロを選択し、パレットのパターンのリストに追加します。

選択をパターンに保存: 選択した要素をパターンに保存できます。パターンは、コマンドを起動したグループに作成されます。

新しいパターンとして貼り付け: [挿入点を付けてコピー] コマンドを使用すると、クリップボードで選択したグラフィック要素を新しいパターンとして貼り付けることができます。

このパターンの編集: グラフィカル インターフェイスで修正するパターンを開きます。パターンはプロジェクトとして表示されます。ドック可能パネルの [ドキュメント] タブに表示されます。

このパターンの削除: 選択したパターンをパレットから削除します。ライブラリからは削除されません。

新しいグループ: 新しいパターン グループを作成します。

グループ プロパティ: 選択したグループのプロパティにアクセスします。

グループの削除: 選択したグループを削除します。

グループを有効にする: コンテキスト メニューから選択したグループを有効にします。

関連トピック:

配線図パターンの挿入

パターン マネージャー

パレット構成


配線図パターンの挿入

リボン メニューからのパターン挿入

メニュー: 配線図 > パターンの挿入

メニュー: 結線図 > パターンの挿入

このコマンドを初めて使用する場合は、[パターン選択] ダイアログが開き、挿入するパターンを選択できます。このパターンは保存され、次回コマンドを使用するときに挿入に使用できます。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定します。パターンを挿入するために最初に使用された後、コマンドは引き続き有効になります。

シンボルを挿入するためにコマンドを初めて使用した後、コマンドを停止します。

コマンドを終了します。

挿入するパターンを指定

最後に挿入したパターンを表示します。シンボルが保存されていない場合は、パターン選択が自動的に開きます。

表示されたパターンを挿入しない場合は、[その他のパターン] ボタンをクリックします。パターン選択が開き、他のパターンを選択できます。

パレットからのパターン挿入

ドック可能パネル: パターン

1. パターンを挿入する図面を開きます。

2. ドック可能パネルからパターンをドラッグします。

3. グラフィック領域にドロップします。

パターンの検索

パレットではオプションで特定のパターンを検索できます。この検索では、パターン パレットだけではなく、パターン ライブラリ全体が検索されます。

このボックスでは、検索するテキストを入力し、[検索] ボタンをクリックします。[説明] フィールドに入力されたテキストを含むすべてのパターンが検索結果に表示されます。

マークの管理

パターンが挿入されるときには、マーク管理ダイアログ ボックスが開き、新しいマークを計算するか、既存のマークを保持できます。

このダイアログ ボックスの機能については、「 形式を選択して貼り付け 」の章を参照してください。

関連トピック:

配線図パターンの作成

パターン マネージャー

パレット構成


パターン選択

パターン グループのコンテキスト メニュー: 既存のパターンを追加します

シンボル プロパティ: 関連付けられたパターン

パターン選択で表示されるパターンは、パターン ライブラリに保存されているパターンです。

ダイアログ ボックスの左側にはパターンの分類が表示され、右側には選択したクラス内のパターンのリストが表示されます。

プロパティ: 選択したパターンのプロパティ ダイアログ ボックスを開きます。

表示: 選択したパターン プレビュー ウィンドウを開きます。

リスト モード: パターンのリストを表示します (名前、説明、クラス)

サムネイル モード: サムネイルの形式でパターンを表示します (プレビュー)。

構成: ダイアログ ボックスに含まれる要素の表示パラメーターを管理できます。

1. 必要なパターンを選択します。

2. [選択] ボタンをクリックして確認します。

関連トピック:

パターン マネージャー


コピー/貼り付け

[コピー] コマンドでは、選択した要素を DesignSpark Electrical クリップボードに配置できます。[貼り付け] コマンドでは、これらの要素を抽出できます。[コピー] コマンドと [貼り付け] コマンドを使用すると、既存の要素の複製や移動ができます。

[コピー] コマンドと [貼り付け] コマンドはソフトウェアの各状況で使用でき、これらのコマンドを使用できるオブジェクトのタイプは、コマンドが実行された環境によって異なります。

  • 切り取り

  • コピー

  • 挿入点を付けてコピー

  • 貼り付け

  • 特殊貼り付け


切り取り

[切り取り] コマンドでは、選択した要素を DesignSpark Electrical クリップボードに配置できます。これを使用して、いくつかのタイプの要素を移動します。これはソフトウェアのさまざまな場所で使用できます。

クリップボードの要素は、[貼り付け] コマンドまたは [形式を選択して貼り付け] コマンドによって挿入または作成できます。

グラフィック領域

メニュー: 編集 > 切り取り

グラフィック要素のコンテキスト メニュー: 切り取り

1. コマンドをクリックします。

2. グラフィック領域でエンティティを選択します。

3. 選択内容を確認します。

要素は強調表示され、[貼り付け] コマンドまたは [形式を選択して貼り付け] コマンドから、同一図面または別の図面に挿入できます。挿入時に ([貼り付け] コマンド) 元の要素は削除されます。

マネージャー

マネージャー > 切り取り

1. 切り取る要素を選択します。

2. コマンドをクリックします。

元の要素は保持され、別のクラスに貼り付けられるようになります。新しい要素の作成時に、元の要素は除去されます。

プロジェクト ドキュメント

プロジェクト、ブック、フォルダー、図面のコンテキスト メニュー: 切り取り

1. 切り取る要素を選択します。

2. コンテキスト メニューでコマンドをクリックします。

元の要素は保持され、整合性のある場所に貼り付けることができます (たとえば、ブックをフォルダーに貼り付けることはできません)。新しい要素の作成時に、元の要素は除去されます。

関連トピック:

コピー

挿入点を付けてコピー

貼り付け

特殊貼り付け


コピー

[コピー] コマンドでは、選択した要素を DesignSpark Electrical クリップボードに配置できます。これを使用して複数のタイプの要素をコピーし、ソフトウェアのさまざまな場所で使用可能にします。

クリップボードの要素は、[貼り付け] コマンドまたは [形式を選択して貼り付け] コマンドによって挿入または作成できます。

グラフィック領域

メニュー: 編集 > コピー

グラフィック要素のコンテキスト メニュー: コピー

1. コマンドをクリックします。

2. グラフィック領域でエンティティを選択します。

3. 選択内容を確認します。

要素は、[貼り付け] コマンドまたは [形式を選択して貼り付け] コマンドから、同一図面または別の図面に挿入できます。元の要素は保持されます。

マネージャー

マネージャー > コピー

1. コピーする要素を選択します。

2. コマンドをクリックします。

元の要素は保持され、同一クラスまたは別のクラスに貼り付けることができます。

プロジェクト ドキュメント

プロジェクト、ブック、フォルダー、図面のコンテキスト メニュー: コピー

1. コピーする要素を選択します。

2. コンテキスト メニューでコマンドをクリックします。

元の要素は保持され、整合性のある場所に貼り付けることができます (たとえば、ブックをフォルダーに貼り付けることはできません)。

関連トピック:

切り取り

挿入点を付けてコピー

貼り付け

特殊貼り付け


挿入点を付けてコピー

[挿入点を付けてコピー] コマンドでは、選択した要素を DesignSpark Electrical クリップボードに配置できます。これを使用して複数のタイプの要素をコピーしますが、グラフィック領域でのみ使用できます。

クリップボードの要素は、[貼り付け] コマンドまたは [形式を選択して貼り付け] コマンドによって挿入または作成できます。

メニュー: 編集 > コピー

グラフィック要素のコンテキスト メニュー: コピー

1. コマンドをクリックします。

2. グラフィック領域でエンティティを選択します。

3. 選択内容を確認します。

4. グラフィック領域で挿入点をクリックします。

挿入点が使用されるのは、[貼り付け] コマンドまたは [形式を選択して貼り付け] コマンドでエンティティを挿入するときです。

要素は、[貼り付け] コマンドまたは [形式を選択して貼り付け] コマンドから、同一図面または別の図面に挿入できます。元の要素は保持されます。

関連トピック:

切り取り

コピー

貼り付け

特殊貼り付け


貼り付け

DesignSpark Electrical クリップボードのオブジェクトを挿入するには、[貼り付け] コマンドを使用します。ソフトウェアのさまざまな状況で使用できます。挿入されるオブジェクトのタイプは、コマンドが実行された環境によって異なります。クリップボードが空の場合、貼り付けはキャンセルされます。

グラフィック領域

メニュー: 編集 > 貼り付け

グラフィック要素のコンテキスト メニュー: 貼り付け

1. コマンドをクリックします。

2. グラフィック領域で挿入点をクリックします。

DesignSpark Electrical クリップボードのオブジェクトにマーク (シンボル、ワイヤ、図面など) がある場合、[貼り付け] コマンドを使用すると、プロジェクトの既存のオブジェクトに対して相対的に、マークが自動的に再計算されます。マークを自分で管理する場合は、[ 形式を選択して貼り付け ] コマンドを使用してください。

マネージャー

マネージャー > 貼り付け

1. コマンドをクリックします。

マネージャーのオブジェクト (シンボル、ケーブル、メーカー部品など) も、コピー/貼り付けできます。新しいオブジェクトが作成され、接尾語の「+n」(n = 順序番号) が新しいオブジェクト名に追加されます。

プロジェクト ドキュメント

プロジェクト、ブック、フォルダー、図面のコンテキスト メニュー: 貼り付け

1. 切り取る要素を選択します。

2. コンテキスト メニューでコマンドをクリックします。

配線図または結線図が [コピー/貼り付け] コマンドの対象である場合、新しい図面が作成され、内容が自動的に複製されます。同一プロジェクト、あるいは別のプロジェクトに、プロジェクト (プロジェクトの内容)、ブック、フォルダー、図面をコピーできます。

関連トピック:

切り取り

コピー

挿入点を付けてコピー

特殊貼り付け


形式を選択して貼り付け

メニュー: 編集 > 形式を選択して貼り付け

グラフィック要素のコンテキスト メニュー: 特殊貼り付け

プロジェクト、ブック、フォルダー、図面のコンテキスト メニュー: 特殊貼り付け

これは、 貼り付けコマンドと同じように、DesignSpark Electrical クリップボードのオブジェクトを挿入するには、[形式を選択して貼り付け] コマンドを使用します。ソフトウェアのさまざまな状況で使用できます。挿入されるオブジェクトのタイプは、コマンドが実行された環境によって異なります。

[形式を選択して貼り付け] インターフェイスは、パターンを挿入するときにも開きます。

ダイアログ ボックスが開き、新規マークの作成、または既存のマークの保持が可能になります。

同じマークの場合、一方が自動マークで、もう一方が手動マークの場合を除き、自動的に関連付けられます。

貼り付けタブのオプション

このダイアログ ボックスには、クリップボードに含まれるすべてのオブジェクトが表示されます。各オブジェクト タイプに対して、目的の操作を選択します。

オブジェクト タイプ: クリップボードに含まれる各オブジェクトのリスト。

オブジェクト数: 見つかったオブジェクト数

動作

下にリストされているすべての動作は、デフォルトですべてのカテゴリの要素を対象とした動作です。これらは他のタブで個別に変更できます。

新しいマークを作成: 貼り付けられた要素のマークが、既存の要素に応じて自動的に再計算されます。

既存のマークを保持する: コピーされた要素と貼り付けられた要素でマークが同じになります。

番号を除去: この動作は、等電位番号に特有のものです。これによってそれらを再計算できます。

既存の番号を保持: この動作は、等電位番号に特有のものです。これによってそれらを保持できます。

リストで、目的の操作 ([新規マークの作成] または [既存のマークを保持する]) を選択します。オブジェクトによっては操作が無効になります。個々のオブジェクト設定は、他のタブで変更できます。新しいマークは計算されませんが、[終了] ボタンをクリックすると計算されます。

手動マークのリセット: 自動マークのみが、[形式を選択して貼り付け] コマンドによって使用されます。手動マークも管理する場合は、[手動マークのリセット] ボックスをオンにします。

他のタブで管理を行った後、[貼り付けのオプション] タブのオプションを変更すると、選択を確認するダイアログ ボックスが表示されます (設定結果を失う場合があります)。

[オブジェクト] タブ

このダイアログ ボックスには、コピーされたオブジェクトに関連する複数のタブが表示されます。それぞれのタブでは、オブジェクト マークを個別に管理できます。

関連付け: コピーされたオブジェクトは、既存オブジェクトに関連付けられます。セレクターが開き、既存オブジェクトを選択できます。

名前の変更: マークを変更するダイアログ ボックスが開きます。新しいマークは、手動マークとして作成されます。

新規マーク: 最初のタブで [既存のマークを保持する] を選択すると、各オブジェクトに新規マークを入力できます。

リスト表示: 要素をリスト形式で表示します。

ツリー表示: 要素をツリー表示で表示します。

これらのコマンドは、各オブジェクトのコンテキスト メニューからも実行できます。

検索機能によって、既存のマークを検索できます。マークを入力し、矢印をクリックして検索します。

カラー コードによって、マークのステータスを確認できます。

緑: 新規マーク。

オレンジ: 既存のマーク。

青: 新規および名前変更されたマーク。

[貼り付けの準備完了] タブ

最後のタブには、前のオプションに関する結果が表示されます。

1. [完了] ボタンをクリックして、コピーを実行します。

新しいマークは、既存のマークに従って自動的に計算されます。

関連トピック:

切り取り

コピー

挿入点を付けてコピー

貼り付け


多言語テキスト

多言語テキストは、プロジェクトで指定されたすべての言語で入力できるという点で、特殊なものです。多言語テキストはデータベースに保存されるので、通常のテキストと区別できます。プロジェクト言語が変更されると、多言語テキストは自動的に言語を切り替えます。このインターフェイスは、多言語テキストの挿入と編集と同じです。

メニュー: 作図 > 多言語テキスト

ドック可能パネルは変更され、テキストの位置を指定するオプションが表示されます。

コマンドを終了します。

前のインターフェイスに戻ります。

座標の入力

1. グラフィック領域をクリックし、テキストの挿入点の座標を入力します。

テキスト

2. 表示する各種言語でテキストを入力します。

書式

3. チェックボックスをクリックしてプロジェクト設定パラメーターを使用するか、テキストに固有のパラメーターを使用します。後者の場合、テキストのフォント名、高さ、スタイル、および色を選択します。

両端揃え

4. テキストの両端揃えを設定します。

回転角度

5. テキストの回転角度を入力します。


ハイパーリンク

メニュー: 作図 > ハイパーリンク

回路図、結線図、、またはレポート エンティティのコンテキスト メニュー。

ハイパーリンクでは、外部ファイルやプロジェクト図面をグラフィック要素にリンクできます。また、画像ファイルや PDF ファイルなどの項目に関連付けることもできます。

ダイアログ ボックスが開き、ハイパーリンクを作成できます。

表示するテキスト: ハイパーリンクのテキストを入力します。このテキストは、ハイパーリンクが作成されたエンティティのコンテキスト メニューに表示されます。

相対パス: 相対モードでファイル パスを表示するには、このオプションを選択します。

図面のハイパーリンク: [...] ボタンをクリックして、リンク ファイルを選択します。

絶対ファイル パス: 絶対モードでファイル パスを示します。

現在のフォルダー: 現在のプロジェクトのフォルダーを示します。

プロジェクト図面へのハイパーリンク: [...] ボタンをクリックして、現在のプロジェクトの図面を選択します。

リンクの除去: リンクを削除できます。

ターゲット: ファイルに関連付けられたアプリケーションを使用してファイルを開くことができます。ターゲットはプロジェクト図面の場合、グラフィック領域で開きます。

ハイパーリンクが設定されているエンティティのコンテキスト メニューのコマンドを使用してハイパーリンクを管理できます。

修正: ハイパーリンクを変更できます。

削除: ハイパーリンクを除去できます。

注意: ハイパーリンクに関連付けられたファイルは、プロジェクトのアーカイブ時に、アーカイブ ファイルに統合されません。これらのファイルをアーカイブの対象とする場合は、データ ファイルとしてプロジェクトに追加してください。

関連トピック:

データ ファイル


プロセス

プロセス (端子台、ケーブル、レポートの編集など) は、プロジェクト データベースに保存されている情報によって実現可能となります。このデータベースは、回路図が設計されるときに自動的に入力されます。

すべてのプロセスは固有の (プロセス) メニューでグループ化されますが、特定のコマンドは プロジェクト メニューにもあります。

  • クロス リファレンス

  • メーカー部品の割り当て

  • ワイヤ配線順序

  • ケーブルの配線

  • ワイヤ番号の割り当て

  • マーク番号の再割り当て

  • プロジェクト データの更新

  • プロジェクト テキストの翻訳

  • リビジョン

  • レポート マネージャー

  • バスケットに追加

  • 印刷マネージャー

  • 図面のエクスポート


配線図要素のコンテキスト メニュー

配線図の各項目 (シンボル、端子、ワイヤなど) にはコンテキスト メニューがあり、選択した項目に関連するさまざまなコマンドを実行できます。

多くのコマンドが複数選択として使用できます。複数選択を使用できない場合は、コマンドが淡色表示されます。

  • ワイヤのコンテキスト メニュー

  • シンボルのコンテキスト メニュー

  • ブラック ボックスのコンテキスト メニュー

  • 端子のコンテキスト メニュー


ワイヤ (コンテキスト メニュー)

ワイヤ スタイル ►

プロパティ: ワイヤ スタイル プロパティ ダイアログ ボックスを開きます。変更内容はプロジェクトのすべてのワイヤに影響します。

反映: 選択したセグメントのワイヤ スタイルを接続されたセグメントに反映するために使用されます。ドック可能パネルには反映オプションが表示されます。[等電位] オプションは、同じ等電位番号のワイヤに反映するために使用されます。[回路経由] オプションは、ワイヤ スタイルがシンボルの同じアップストリームとダウンストリームの場合にのみ、ワイヤ スタイルをシンボル全体に反映します。

置換: ワイヤ スタイルに応じて、プロジェクトで使用されるワイヤを別のワイヤ スタイルに置換します。ドック可能パネルにはワイヤ選択オプションが表示されます。

ケーブル プロパティ: ワイヤ/ケーブルを選択する場合のみ表示されます。[プロジェクト ケーブル プロパティ] ダイアログ ボックスを開き、ケーブルのプロパティを編集します。

ワイヤ プロパティ: [ ワイヤ プロパティ] ダイアログ ボックスが開き、ワイヤに関連するマーキングおよび技術データを管理できるようになります。

等電位プロパティ: この等電位に共通のワイヤの [プロパティ] ダイアログ ボックスが開きます。この等電位の等電位番号および関連する技術データを管理できます。

ワイヤ マークの編集: ワイヤに割り当てられている番号を編集します (ワイヤまたは等電位)。

テキストの配置: ワイヤ マーク テキストを配置します。テキストを選択し、ワイヤに対して垂直に軸を配置して作図します。テキストはこの軸に合わせて配置されます。

ワイヤ マークの表示/非表示: ワイヤに割り当てられたワイヤまたは等電位番号を表示または非表示にするために使用されます。このコマンドは複数選択時にも使用できます。

ケーブル コアの関連付け: ワイヤのケーブルを作成するために使用されます。

ケーブル コアの関連付けの解除: 選択したワイヤに関連付けられたケーブル コアの関連付けを解除します。

ワイヤ配線順序: ワイヤの配線順序を管理するために使用されます。

ブリッジの作成と削除: 2 つ以上のコンポーネント (または端子) 間でブリッジを作成できます。このコマンドを実行するときには、ブリッジを表すワイヤを選択して確認します。ワイヤにはプロジェクト構成で定義されたグラフィック特性が自動的に適用されます。このコマンドでもブリッジを削除できます。グラフィック インターフェイスでブリッジとして表示されているワイヤを選択し、[ブリッジを削除] オプションを使用します。

ケーブル コア テキストの表示/非表示: ワイヤが配線されるときに、ケーブル コアに関連付けられたテキストを表示または非表示にします。

移動: 選択したワイヤを移動するために使用されます。

コピー: DesignSpark Electrical クリップボードに選択したワイヤを配置します。

挿入点を付けてコピー: シンボルを DesignSpark Electrical クリップボードにコピーし、挿入点を定義します。

切り取り: [コピー] コマンドと同じですが、選択したワイヤが削除されます。

ハイパーリンク: 外部ドキュメントへのリンクを作成/編集します。

削除: 選択したワイヤを削除します。


シンボル (コンテキスト メニュー)

この章では、結線図、始点/終点シンボルなど、すべてのシンボル タイプを扱います。コンテキスト メニューの内容は、選択されるシンボルによって異なります。

シンボル プロパティ: [シンボル プロパティ] ダイアログ ボックスを開きます。

コンポーネントの割り当て: 選択したシンボルを既存のコンポーネントに割り当てます。

属性 ►

属性の編集: シンボル属性の変更を可能にします。

シンボル属性の表示を管理します。

クロス リファレンス スタイルの編集: クロス リファレンスの [ 構成 ] ダイアログ ボックスを開きます。

シンボル端子の編集: ダイアログ ボックスを開き、コンポーネントの 材料端子を編集 します。

シンボル ►

シンボルのコンテキスト メニューでは、4 つのコマンドを使用し、開いているコンテキスト メニューに関係なく、シンボルを編集できます。

更新: シンボル ライブラリの定義に応じて、挿入されたシンボルを更新できます。

置換: 挿入されたシンボルをライブラリの別のシンボルで置換します。

シンボルを開く: 修正インターフェイスでシンボルを開き、グラフィックス、属性、または接続点を変更します。

ライブラリに追加: 挿入されたシンボルをシンボル ライブラリに追加します。

コンポーネント プロパティ: コンポーネントを編集できるダイアログ ボックスを開き、マーク、ロケーション、およびファンクションの割り当て、コンポーネント固有のデータの入力、メーカー部品の割り当てができます。

コンポーネント ►

ロケーションの変更: シンボルに関連付けられたロケーションを変更します。

ファンクションの変更: シンボルに関連付けられたファンクションを変更します。

メーカー部品の割り当て: 1 つ以上のメーカー部品をシンボルに割り当てます。

メーカー部品の削除: シンボルに関連付けられたメーカー部品を削除します。

シンボルの挿入: このコンポーネントのシンボルを挿入できます。

移動 ►

ブラウザーに移動: [コンポーネント] タブで、選択したコンポーネントに関連付けられているシンボルのリストを表示します。この機能が使用されるのは、コンポーネントが非常に多くのシンボルによって定義されている場合です。

その他の項目では、クロス リファレンスを使用して、同じコンポーネントを持つ異なるシンボル間で移動できます。

ケーブル ►

ケーブルと配線順序を管理します。

ワイヤ配線順序: シンボルの配線順序アップストリームまたはダウンストリームを生成するために使用されます。

ケーブル コアの関連付け: シンボルのケーブルアップストリームまたはダウンストリームを生成するために使用されます。

方向 ►

シンボルの方向を変更します。

特定の角度 (0°/90°/180°/270°)

自由回転 (Free rotation): マウスを使用してシンボルを回転させます。

反転: シンボルのミラー イメージを作成します。

移動: シンボルを移動できます。

切り取り: DesignSpark Electrical クリップボードにシンボルをコピーします。シンボルが削除されます。

コピー: DesignSpark Electrical クリップボードにシンボルをコピーします。

挿入点を付けてコピー: シンボルを DesignSpark Electrical クリップボードにコピーし、挿入点を定義します。

ハイパーリンク: 外部ドキュメントへのリンクを作成/編集します。

削除: 図面からシンボルを削除します。


ブラック ボックス (コンテキスト メニュー)

シンボル プロパティ: [シンボル プロパティ] ダイアログ ボックスを開きます。

クロス リファレンス スタイルの編集: クロス リファレンスの [ 構成 ] ダイアログ ボックスを開きます。

コンポーネントの割り当て: 選択したシンボルを既存のコンポーネントに割り当てます。

属性 ►

シンボル属性の表示を管理します。

属性の編集: シンボル属性の変更を可能にします。

シンボル端子の編集: ダイアログ ボックスを開き、コンポーネントの 材料端子を編集 します。

シンボル ►

コンテキスト メニューには 4 つのコマンドがあり、開いているコンテキスト メニューに関係なく、シンボルを編集できます。

更新: シンボル ライブラリの定義に応じて、挿入されたシンボルを更新できます。

置換: 挿入されたシンボルをライブラリの別のシンボルで置換します。

シンボルを開く: 修正インターフェイスでシンボルを開き、グラフィック、属性、または接続点を変更します。

ライブラリに追加: 挿入されたシンボルをシンボル ライブラリに追加します。

コンポーネント プロパティ: このダイアログ ボックスを開くとコンポーネントの編集とマーク、ロケーション、およびファンクションの割り当て、コンポーネント固有のデータの入力、メーカー部品の割り当てができます。

コンポーネント ►

ロケーションの変更: シンボルに関連付けられたロケーションを変更します。

ファンクションの変更: シンボルに関連付けられたファンクションを変更します。

メーカー部品の割り当て: 1 つ以上のメーカー部品をシンボルに割り当てます。

メーカー部品の削除: シンボルに関連付けられたメーカー部品を削除します。

シンボルの挿入: このコンポーネントのシンボルを挿入します。

移動 ►

クロス リファレンスを使用して、同じ部品を持つ複数のシンボル間で移動します。

ブラック ボックスの更新: ブラックボックスを更新します。

接続点の追加: ブラック ボックスのエッジの周囲に接続点を追加します。

接続点の削除: ブラック ボックスの接続点を削除します。

ケーブル ►

ケーブルと配線順序を管理します。

ワイヤ配線順序: シンボルの配線順序アップストリームまたはダウンストリームを生成します。

ケーブル コアの関連付け: シンボルのケーブルアップストリームまたはダウンストリームを生成します。

移動: シンボルを移動します。

コピー: シンボルを DesignSpark Electrical のクリップボードにコピーします。

挿入点を付けてコピー: シンボルがDesignSpark Electrical クリップボードにコピーされ、挿入点を指定するように求められます。

切り取り: シンボルを DesignSpark Electrical のクリップボードにコピーします。シンボルが削除されます。

ハイパーリンク: 外部ドキュメントへのリンクを作成/編集します。

削除: 図面からシンボルを削除します。


端子 (コンテキスト メニュー)

シンボル プロパティ: [シンボル プロパティ] ダイアログ ボックスを開きます。

コンポーネントの割り当て: 選択したシンボルを既存のコンポーネントに割り当てます。

属性 ►

属性の編集: シンボル属性の変更を可能にします。

シンボル属性の表示を管理します。

シンボル端子の編集: ダイアログ ボックスを開き、コンポーネントの 材料端子を編集 します。

シンボル ►

シンボルのコンテキスト メニューでは、4 つのコマンドを使用し、開いているコンテキスト メニューに関係なく、シンボルを編集できます。

更新: シンボル ライブラリの定義に応じて、挿入されたシンボルを更新できます。

置換: 挿入されたシンボルをライブラリの別のシンボルで置換します。

シンボルを開く: 修正インターフェイスでシンボルを開き、グラフィック、属性、または接続点を変更します。

ライブラリに追加: 挿入されたシンボルをシンボル ライブラリに追加します。

コンポーネント プロパティ: コンポーネントを編集できるダイアログ ボックスを開き、マーク、ロケーション、およびファンクションの割り当て、コンポーネント固有のデータの入力、メーカー部品の割り当てができます。

コンポーネント ►

ファンクションの変更: シンボルに関連付けられたファンクションを変更します。

メーカー部品の割り当て: 1 つ以上のメーカー部品をシンボルに割り当てます。

メーカー部品の削除 (Remove manufacturer parts): シンボルに関連付けられたメーカー部品を削除します。

シンボルの挿入: このコンポーネントのシンボルを挿入できます。

レベルの定義: 選択した端子のレベル数を定義できます。ダイアログ ボックスが開き、レベル数を入力できます。

端子台の変更: 選択した端子を別の端子台に移動できます。

移動 ►

クロス リファレンスを使用して、同じ部品を持つ異なるシンボル間で移動できます。

端子台プロパティ: 端子がある端子台のプロパティを開きます。

ケーブル ►

ケーブルと配線順序を管理します。

ワイヤ配線順序: シンボルの配線順序アップストリームまたはダウンストリームを生成するために使用されます。

ケーブル コアの関連付け: シンボルのケーブルアップストリームまたはダウンストリームを生成するために使用されます。

方向 ►

シンボルの方向を変更します。

特定の角度 (0°/90°/180°/270°)

自由回転 (Free rotation): マウスを使用してシンボルを回転させます。

反転: シンボルのミラー イメージを作成します。

移動: シンボルを移動できます。

切り取り: DesignSpark Electrical クリップボードにシンボルをコピーします。シンボルが削除されます。

コピー: DesignSpark Electrical クリップボードにシンボルをコピーします。

挿入点を付けてコピー: シンボルを DesignSpark Electrical クリップボードにコピーし、挿入点を定義します。

ハイパーリンク: 外部ドキュメントへのリンクを作成/編集します。

削除: 図面からシンボルを削除します。


クロス リファレンス

デバイスは 1 つ以上のシンボルで表現できます。複数のシンボルで表現される場合、異なる図面に挿入できます。クロス リファレンスは、このような複数のシンボル間の関連付けを表します。

使用される標準とシンボルのタイプによって、複数のレベルのクロス リファレンスがあります。

- 「線の親」タイプ シンボル (回路ブレーカーなど)

- 「テーブルの親」タイプ シンボル (コイルなど)

- 「子」タイプ シンボル (接点など)

- 「同じレベル」タイプ シンボル (プッシュ ボタンなど)

- 「なし」クロス リファレンス (電源など)

クロス リファレンスはリアルタイムで計算されます。リンクされたシンボルに関わる操作 (移動、削除など) が行われると、その都度クロス リファレンスは更新されます。

クロス リファレンス サムネイルの自動生成は、シンボルの定義 (回路) および構成パラメーターに基づきます。

  • 回路管理

  • クロスリファレンスのレベル

  • クロス リファレンスによるナビゲーション


回路管理

デバイスの回路は、いわゆるデバイスの「極」に相当します。これらの回路は、シンボルの定義だけでなくメーカー部品の定義でも使用されます。シンボルの回路とメーカー部品の回路を比較すると、クロス リファレンスが生成され、端子が表示されます。

回路の定義

ソフトウェアは、電気コンポーネントの特性に対応する複数のタイプの回路を管理します。

たとえば、三極回路ブレーカーは、3 つの「回路ブレーカー、スイッチ」回路から構成されます。

コンポーネントの回路は、このコンポーネントを表すすべてのシンボルの回路の合計です。

上記の例は、回路の観点から、シュナイダー社の参照「LC1D09006B7」の定義を示します。これは、コイル、三極電力接点、NO および NC 接点から構成されます。

メーカー部品が割り当てられると、ソフトウェアはメーカー部品の回路と、コンポーネントを表す各種シンボルの回路を比較します。これらが一致する場合、材料端子の数が自動的にシンボル回路に反映され、配線図に表示されます。メーカー部品の回路とシンボルの回路の間で差異がある場合は、回路が統合されて追加され、予約されます。材料端子の数は配線図に表示されません。

クロス リファレンスの回路の役割

「クロス リファレンスの構成」で示されるように、一部のタイプの回路はクロス リファレンス サムネイル (グラフィック シンボル) に関連付けられています。これらのタイプは、「子」または「同じレベル」のシンボルに関連付けられた回路です (「親」シンボルはクロス リファレンス サムネイルを生成しません)。

クロス リファレンス サムネイルが生成されると、ソフトウェアはコンポーネントに関連付けられたすべての回路を一覧表示し、フィルタリングして「子」または「同じレベル」の回路のみを保持し、回路のタイプに関連付けられたクロス リファレンス サムネイルを使用してグラフィックを生成します。プロジェクトおよび図面のシンボルの位置と同様に、材料端子の番号は自動的に追加されます。

上記の例では、図面 10 の列 4 に 3 つの「NO 電力接点」タイプ回路があり、図面 04 の列 4 には 1 つの「NO 接点」があります。メーカー部品に属する NC 接点は図面では使用されません (予約に配置されます)。2 番目の NO 接点 (図面 04 の列 6) は、メーカー部品の一部ではありません。

回路とグループ

回路を関連付けるには、各回路に番号 (または名前) を入力します。回路を関連付けるには、関連付ける回路に同じ番号を付与する必要があります。

たとえば、反転コンタクターが回路グループを使用している場合は、あるコンタクターに関連付けられた 1 つのコイルと、2 番目のコンタクターに関連付けられた 2 つ目のコイルが表示されます。

メーカー部品データには、グループ番号が保存されます。シンボル コンポーネントを挿入すると、クロス リファレンスがグループ番号で自動的に更新されます。

関連トピック:

クロス リファレンス構成

クロスリファレンスのレベル

クロス リファレンスによるナビゲーション


クロスリファレンスのレベル

使用される標準とシンボルのタイプによって、複数のレベルのクロス リファレンスがあります。

- 「線の親」タイプ シンボル (回路ブレーカーなど)

- 「テーブルの親」タイプ シンボル (コイルなど)

- 「子」タイプ シンボル (接点など)

- 「同じレベル」タイプ シンボル (プッシュ ボタンなど)

- 「なし」クロス リファレンス (電源など)

- 「デフォルト表示を使用」標準 ANSI シンボル

各レベルのクロス リファレンスは、関連付けられたシンボルを異なる方法で表現します。

テーブルの親: 回路とロケーション情報 (図面/列) のグラフィック表示を含むブロックは、図面下部の「テーブルの親」タイプ シンボル配置で自動的に生成されます。

線の親: 回路とロケーション情報 (図面/列) のグラフィック表示を含むブロックは、「線の親」タイプ シンボルの付近に自動的に生成されます。

子または同じレベル: クロス リファレンス情報は、シンボルの #CROSS_REF 属性のテキスト形式で反映されます。

なし: クロス リファレンスは生成されません。

デフォルト表示: 回路とロケーション情報 (図面/列) のグラフィック表示を含むブロックは、シンボルが挿入された列の右側の「テーブルの親」タイプ シンボル配置で自動的に生成されます。

クロス リファレンスのレベルはシンボルのパラメーターで定義されます (「シンボル ライブラリ」を参照)。

関連トピック:

回路管理

クロス リファレンスによるナビゲーション


クロス リファレンスによるナビゲーション

デバイスは、異なる図面に挿入可能な複数のシンボルによって表現される場合があります。 DesignSpark Electrical は自動的にクロス リファレンス情報を生成し、配線図をわかりやすくします。これは、グラフィックス (サムネイル) 形式またはテキスト形式でシンボル マークの下に表示することができます。

このデバイスを構成するシンボル間を移動できます。

コンポーネント シンボルのコンテキスト メニューで [移動] オプションを選択します (コンテキスト メニューはクロス リファレンス サムネイルでも使用できます)。

関連トピック:

回路管理

クロス リファレンス構成

クロスリファレンスのレベル


メーカー部品と回路

シンボル プロパティ: メーカー部品と回路

端子プロパティ: メーカー部品と回路

ブラック ボックス端子プロパティ: メーカー部品と回路

ロケーション プロパティ: メーカー部品

このタブには、コンポーネントとその回路定義に割り当てられたメーカー部品が表示されます。

メーカー部品

検索: ライブラリ内のメーカー部品を検索するダイアログ ボックスを開きます。

メーカー部品を追加: 新しいメーカー部品を作成するダイアログ ボックスを開きます。

電気アセンブリを追加: 新しい電気アセンブリを作成するダイアログ ボックスを開きます。

削除: 選択したメーカー部品参照を削除します。

プロパティ: 選択したメーカー部品の [プロパティ] ダイアログ ボックスを開きます。

上に移動/下に移動: メーカー部品のリストを整理できます。

回路

回路定義は、[ロケーション プロパティ] ダイアログ ボックスでは利用できません。

部品をリストから選択すると、DesignSpark Electrical はコンポーネント (シンボル) を構成する回路と、メーカー部品に含まれる回路を比較します。

緑色はシンボル回路とメーカー部品回路が一致していることを示します。

赤色は一致していないことを示します。一部の回路シンボルはメーカー部品にありません。補助を追加するか、コンポーネントを修正して、メーカー部品内にシンボルを追加する必要があります。

青色はメーカー部品にシンボルで表現されていない回路 (予約回路) が含まれていることを示します。

黄色は、シンボルとしてもメーカー部品参照としても表示されない、手動で追加された仮想回路があることを示します。

端子の編集: 選択した回路の端子番号を編集できます。

仮想回路の追加: 新しい回路を追加できます。仮想回路は、メーカー部品内とシンボル内には存在しません。

仮想回路の削除: 選択した仮想回路を削除できます。

シンボル回路の切り替え: 回路リストで選択した 2 つの回路を切り替えることができます。

シンボル回路の関連付け解除: 緑色の回路のみを関連付け解除する必要があります。回路を関連付け解除すると、その回路は自動的に予約 (青色) に設定され、シンボルの回路は赤色に設定されます。

上へ/下へ: 仮想回路を整理できます。

これらのコマンドは、回路のコンテキスト メニューからも実行できます。

関連トピック:

メーカー部品の割り当て

メーカー部品プロパティ

回路管理


メーカー部品の割り当て

メーカー部品はカタログ内で管理され、要件に合わせて部品をカタログに追加できます。DesignSpark Electrical で管理されるすべてのコンポーネントには、1 つ以上のメーカー部品を関連付けることができます。ソフトウェアでは、要素タイプに応じて、メーカー部品に複数の用途があります。

  • コンポーネントへのメーカー部品の割り当て

  • シンボルへのメーカー部品の割り当て

  • ロケーションへのメーカー部品の割り当て

  • 端子へのメーカー部品の割り当て

  • 端子台へのメーカー部品の割り当て

  • 手動参照

メーカー部品が要素に関連付けられると、シンボルのクロス リファレンスやデバイス端子番号などの図面が自動的に更新されます。

各コンポーネント タイプの特定のタブで [検索] ボタンをクリックすると、[メーカー部品選択] ダイアログ ボックスにアクセスできます。

メーカー部品を検索するには 2 つのオプションがあります。[自動更新] ボックスをオンにすると、メーカー部品のリストが自動的に表示されます。

このボックスがオフの場合、[検索] ボタンをクリックしたときだけ、メーカー部品のリストが更新されます。

分類

このタブには、メーカー部品分類がツリー形式で表示されます。

このダイアログ ボックスの左側にはメーカー部品分類が表示されます。右側には、現在選択されている分類のメーカー部品が表示されます。

フィルター

メーカー部品リストをフィルタリングします。すべてのフィルタリング条件がメーカー部品プロパティに表示されます。

このダイアログ ボックスの右側には、選択した条件に該当するメーカー部品が表示されます。

フィルターを除去: すべてのフィルター条件を削除します。

分類: [分類] は最初の検索条件です。メーカー部品を割り当てるオブジェクトのクラス、同じベース クラスまたはすべてのクラスを使用できます。

デフォルトのクラスを変更するには、[...] ボタンをクリックし、必要なクラスまたはサブクラスを選択します。

他のすべての条件は、メーカー部品のプロパティの条件です。

追加する数量を管理します。

選択したメーカー部品を追加します。

割り当て済みのメーカー部品を、リストで選択した部品に置き換えます。

関連付けたすべてのメーカー部品を削除します。

メーカー部品の整列に使用されます。

コンポーネントへのメーカー部品の割り当て

コンポーネントとは、メーカー部品が関連付けられている電気機器です。

コンポーネントを作成すると、DesignSpark Electrical からメーカー部品を関連付けるように自動的に指示されます。

シンボルへのメーカー部品の割り当て

シンボル プロパティ: メーカー部品と回路

ダイアログ ボックスの下部には、コンポーネント (デバイスを構成するすべてのシンボル) を構成する回路の一覧が表示されます。

[検索] ボタンをクリックしてメーカー部品を検索するか、または [メーカー部品を追加] をクリックして新しいメーカー部品を作成します。

メーカー部品のコンテキスト メニューでは、プロパティを表示し、回路テストを有効/無効にできます。

テストが有効な場合、DesignSpark Electrical はコンポーネント (シンボル) を構成する回路と、メーカー部品に含まれる回路を比較します。

緑色はシンボル回路とメーカー部品回路が一致していることを示します。

赤色は一致していないことを示します。一部の回路シンボルはメーカー部品にありません。メーカー部品内で補助を追加するかシンボルを変更します。

青色はメーカー部品にシンボルで表現されていない回路 (予約回路) が含まれていることを示します。

ロケーションへのメーカー部品の割り当て

ロケーション プロパティ: メーカー部品

[メーカー部品] タブで [検索] ボタンをクリックすると、メーカー部品を検索できます。

端子へのメーカー部品の割り当て

端子プロパティ: メーカー部品と回路

メーカー部品を適用する端子を選択し、[メーカー部品] アイコンをクリックします。

端子台へのメーカー部品の割り当て

端子台プロパティ: メーカー部品と回路

[メーカー部品] タブで [検索] ボタンをクリックすると、メーカー部品を検索できます。選択したメーカー部品は、端子ではなく端子台に割り当てられます。この機能を使用すると、端子のアクセサリを選択できます (コンポーネントと混同しないようにしてください)。

手動参照

これまでのすべてのケースでは、メーカー部品はメーカーのカタログから取得されます。また、メーカー部品を手動で入力することもできます。たとえば、必要なメーカー部品がカタログになく、永続的な登録の必要もない場合などです。

プロパティ ダイアログ ボックス: メーカー部品 > 手動追加

パラメーターを入力し、[OK] ボタンをクリックしてデータを確認します。

部品とメーカー名を入力した時点でメーカー部品が既にカタログに存在する場合、 既存のメーカー部品のプロパティを取得するか、プロパティの入力を続けるかどうかを確認するメッセージが表示されます。

メーカー部品が既にカタログにある場合は、[OK] ボタンをクリックします。新しいメーカー部品のプロパティが既存の部品のプロパティと異なる場合は、メッセージが表示され、カタログを新しいデータで更新するか、単純にデータをコンポーネントに適用するかを指定するよう要求されます。

新しいメーカー部品を入力すると、そのメーカー部品をメーカー カタログに追加するかどうかを DesignSpark Electrical から確認されます。

関連トピック:

メーカー部品カタログ

クロス リファレンス


配線接続順序

等電位には次の 2 つのタイプがあります。

  • 単純な等電位。2 つのデバイスのみを接続します。

  • 複雑な等電位。3 つ以上のデバイスを接続します。

配線順序では、このようなデバイスの接続方法を定義できます。

配線順序の影響を受けるのは、複雑な等電位だけです。

ワイヤとケーブルの長さを最適化し、配線順序の向き (始点/終点) を決定しできるため、接続リストとケーブル リストで読み取りやすくなります。

配線序列には、「自動」配線順序 (DesignSpark Electrical が自動的に生成) と「手動」配線順序 (ユーザーが手動で生成) の 2 つのタイプがあります。

  • 配線順序の管理

関連トピック:

ワイヤ番号の割り当て

ケーブル


配線順序の管理

配線順序は、プロジェクト全体でグローバルに実行することも、1 つのワイヤに対して実行することもできます。

メニュー: プロジェクト > ワイヤ配線順序 (プロジェクトのすべてのワイヤを処理)

ドック可能パネル > プロジェクトのコンテキスト メニュー: プロジェクト > 配線接続順序マネージャー (プロジェクトのすべてのワイヤを処理)

ワイヤのコンテキスト メニュー: ワイヤ配線順序 (選択したワイヤのみを処理)

ダイアログの左側には、プロジェクトの複雑な等電位の一覧が表示されます。上半分には、ワイヤに接続された各種シンボルを表示します。

下半分には、ワイヤ配線順序の始点と終点が表示されます。

ワイヤ配線順序では、ケーブル コアも管理できます (「ケーブル」セクションを参照)。

等電位

ワイヤの自動追加: プロジェクトの複雑な等電位のすべてにわたって配線順序を管理します。接続されているデバイスの順序は、マークにより異なります (英数字ソート) 。この操作により生成される配線順序は「自動配線順序」と呼ばれます。

ワイヤの削除: プロジェクト全体のワイヤ配線順序を削除できます。

選択対象のワイヤを自動追加: ワイヤの自動追加機能と同じ動作ですが、動作の対象は、選択されている等電位に限られます。

選択対象のワイヤを削除: ワイヤの削除機能と同じ動作ですが、動作の対象は、選択されている等電位に限られます。

ワイヤのコンテキスト メニューからこのコマンドを実行した場合は、選択された等電位のみが一覧に表示されます。[プロジェクト] メニューから実行した場合は、左側の一覧から調整する等電位を選択します。

等電位に接続されたコンポーネント

次のコマンドで生成される配線順序は、「手動配線順序」と呼ばれます。

点からワイヤを追加: 一覧でマークを選択し、[点からワイヤを追加] ボタンをクリックします。マークが自動的に [始点] 列に追加されます。

始点を置換: 始点を変更します。

点へワイヤを追加: 一覧でマークを選択し、[点へワイヤを追加] ボタンをクリックします。マークが自動的に [終点] 列に追加されます。

終点を置換: 終点を変更します。

[移動] コマンドは、コンポーネントのコンテキスト メニューにあって、シンボルが挿入される図面を開きます。また、コンポーネントをダブルクリックすることもできます。

始点と終点間でマークをドラッグ アンド ドロップしたり、任意の接続上で、左上から始点または終点にドラッグ アンド ドロップしたりできます。

等電位ワイヤ

[ワイヤの自動追加] ボタンを使用すると、複雑なワイヤ上でワイヤ配線順序を自動的に生成できます。

[ワイヤの削除] ボタンでは、選択した接続線を削除できます。

[始点と終点の切り替え] ボタンでは、始点のコンポーネント マークと終点のコンポーネント マークを逆にできます。

[ケーブル コアの関連付け] および [ケーブル コアの関連付けの解除] ボタンはケーブルを対象としています。


ケーブルの配線

プロジェクトで使用されるケーブルは、ケーブル マネージャー内でグループ化されます。

自由に使用可能なケーブルのカタログには多数の参照が含まれていますが、独自の参照を作成することもできます。

設置の配線は、結線図、配線図などの複数のレベルで実現できます。

結線図ではケーブルを予約することができます。このケーブルは配線図で使用できます。

  • ケーブル マネージャー

  • 配線図での配線

  • 詳細配線


ケーブル マネージャー

ケーブル マネージャーは、プロジェクトで使用されるすべてのケーブルをグループ化します。

メニュー: プロジェクト > ケーブル

ドック可能パネル > プロジェクトのコンテキスト メニュー: プロジェクト > ケーブル マネージャー

ケーブルがリストに表示され、必要に応じてフィルタリングできます。ケーブルのソースとターゲットの情報を整理し、結線図で予約することができます。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

新しいケーブル: ケーブル カタログが開き、プロジェクトに追加する参照型番を選択できます。

削除: 選択したケーブルを削除できます。コアが既に使用中の場合は削除できません。

プロパティ: 選択したケーブルのプロパティを表示します。複数のケーブルを選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

複製 : 参照やパスなど、関連するすべてのプロパティを含む、個別または複数のケーブルをコピーします。マークは自動的にインクリメントされます。

置換: 選択したケーブルを、カタログの他のケーブルで置換できます。新しいケーブルには、置換元のケーブルと同じ数以上のコアがなければなりません。

スイッチ: 選択したケーブルの始点と終点を切り替えることができます。

ケーブル コアの関連付けの解除: 選択したケーブル コアを解放 (切断) できます。

ツリー モード: ケーブル リストの表示タイプを管理します。ケーブルはファンクションまたは始点/終点別にグループ化できます。

一部のフィルターでは、名前、部品番号または始点/終点の場所でフィルターされたケーブルを表示できます。

予約前ケーブル: 予約済みのケーブルを除き、すべてのケーブルを自動的に非表示にします。もう一度このアイコンを選択すると、フィルタリングが解除されます。

関連トピック:

ケーブル参照 マネージャー

ケーブルの追加

ケーブル プロパティ


プロジェクト ケーブル プロパティ

ケーブル マネージャー: プロパティ

ワイヤのコンテキスト メニュー (配線図): ケーブル プロパティ

ケーブルのコンテキスト メニュー (結線図):ケーブル プロパティ

[ケーブル プロパティ] ダイアログ ボックスではケーブル マークを修正できます。ケーブル マークはケーブルがプロジェクトに追加されたときに自動的に作成されます。マークは構成パラメーターに従って計算されます。

マーク

モード: [自動] モードを選ぶと、構成設定に従って、マークは自動的に計算されます。[手動] モードを選ぶ場合は、[マーク] 設定にマークを手動で入力する必要があります。

マーク: 自動マークを表示するか、手動マークの入力に使用します。

ルート: ケーブルに関連付けられたルートを表示します。

番号: ケーブルに割り当てられた順番を表示します。この番号は変更可能ですが、既存の番号は使用できません。

階層構造

アップストリーム ロケーション: ケーブルの「始点」のロケーション。

ダウンストリーム ロケーション: ケーブルの「終点」のロケーション。

ファンクション: ケーブルのファンクション。

ケーブル参照

ケーブル参照プロパティ: [...] ボタンをクリックして、ケーブル参照のプロパティ ダイアログ ボックスを開きます (データは変更できません)。

このセクションのその他のパラメーターは、ケーブル参照から取得されるデータに対応します。

特性

3D ルーティング ソフトウェアのデータ。

計算

ケーブルの電圧低下を計算するためのデータ。

説明

最初の翻訳可能なデータ フィールドはケーブル用です。プロジェクトで管理されているすべての言語の説明を入力できます。

ユーザー データ/翻訳可能なデータ

ユーザー データはプロジェクト全体に存在します。このデータには個人用情報が保存されます。この情報は図面に表示することができます。ユーザー データには翻訳可能なユーザー データ (プロジェクト翻訳時に翻訳) と、翻訳不能なユーザー データの 2 種類があります。

[カスタマイズ] ボタンを使用すると、ケーブルのユーザー データにアクセスできます。

関連トピック:

ケーブル マネージャー


配線図での配線

配線図に配置されたすべてのワイヤは、シンボルまたは端子に接続されている場合、配線できます。ケーブル コマンドはワイヤのコンテキスト メニューから使用できます。

ワイヤのコンテキスト メニュー: ケーブル コアの関連付け

ケーブル コマンドは複数のワイヤを選択するときに有効にできます。

このインターフェイスはケーブル マネージャーと類似していますが、ケーブル コアの配線を管理できます。

ケーブル コアの関連付け: ダイアログ ボックスの上半分で使用するコアを選択し、その後配線するワイヤを下半分で選択します。

ケーブル コアは表示順に関連付けられます。リストの最初のコアがリストの最初のワイヤに割り当てられ、次のコアが次のワイヤに割り当てられます。その後も同様です。コアのリストに従って、ワイヤのリストを並び替えることをお勧めします。

青色のケーブル コア (太字)ワイヤに関連付けられます。

緑色のケーブル コア (太字)選択したワイヤのいずれかに割り当てられます。

「太字」とは、当該のケーブル コアが配線図にあることを表します。太字でない青色のケーブル コアは結線図にしかありません。

ケーブル コアの関連付けの解除: 選択したコアの配線を削除します。

変更を確認した後、配線図が自動的に更新されます。ケーブルに対応するテキストは、自動的に線上に配置されます。このテキストはプロジェクト プロパティ ([フォント] タブ) でカスタマイズできます (スタイルとコンテンツ)。

関連トピック:

ケーブル マネージャー

結線図での配線


ワイヤ番号の割り当て

配線図で作図するすべてのワイヤには番号の割り当てを適用できます。マークは番号に適用され、設置の配線を管理して最適化できます。この番号の割り当ては任意であり、特定のワイヤ タイプにのみ番号を割り当てるようにすることができます。

さらに、番号の割り当てモードには、等電位番号の割り当てモード (同じ電位ですべてのワイヤが接続) とワイヤ番号の割り当てモード (物理ワイヤがデバイスを接続) の 2 種類があります。

ワイヤ番号の割り当てにはシンプルなルールがあり、番号の割り当ては最初の図面で開始し、ドック可能パネルに表示される順序に基づいて、すべての図面で継続します。図面では、ワイヤの実際の位置も考慮されます。番号の割り当ては左上から開始し、右下に向かって増加します。

番号の割り当てパラメーターはワイヤ タイプ マネージャーおよびプロジェクト構成で定義されます。プロジェクトの開発中は、いつでもワイヤ番号の割り当てを開始できます。また、ワイヤの番号割り当てを手動で適用したり、番号が以前割り当てられたワイヤを修正したりできます。

  • 新しいワイヤの番号割り当て

  • ワイヤ番号の再割り当て

  • ワイヤ マークの編集

関連トピック:

番号の割り当て設定


新しいワイヤの番号割り当て

メニュー: プロセス > 新しいワイヤの番号割り当て

このコマンドは、番号が割り当てられていないワイヤにのみ影響します。番号が割り当てられているワイヤはこのコマンドの影響を受けません。

ワイヤ番号を割り当てるときは、ワイヤがシンボルまたは端子に接続していなければなりません。接続していないワイヤには番号が割り当てられません。

関連トピック:

番号の割り当て設定

ワイヤ番号の再割り当て

ワイヤ マークの編集


ワイヤ番号の再割り当て

メニュー: プロセス > ワイヤ番号の再割り当て

このコマンドは、ユーザー定義オプションに応じてプロジェクトのすべてのワイヤに適用できます。

選択

プロジェクト全体: プロジェクトのすべてのワイヤの番号を再割り当てします。

現在のブック: 現在のブック (現在の配線図に関連付けられているブック) のワイヤの番号のみを再割り当てします。

現在のフォルダー: 現在のフォルダー (現在の配線図に関連付けられているフォルダー) にあるワイヤの番号のみを再割り当てします。

現在の配線図: 現在の配線図にあるワイヤの番号のみを再割り当てします。

配線図で選択したワイヤ: 配線図で選択したワイヤの番号のみを再割り当てします。

配線図を選択: 配線図セレクターが開き、処理する配線図を選択できます。これらの配線図内のワイヤの番号のみが再割り当てされます。

ワイヤ番号の割り当て

ワイヤ番号の削除: 既存のワイヤ番号を削除します。もう一度番号を表示するには、新しい番号割り当て操作を実行します。すべての番号付けを再計算するには、[手動番号の再計算] ボックスをオンにする必要があります。

新しいワイヤ番号を割り当て、既存のワイヤ マークを再計算: 番号割り当てパラメーターが変更された場合などに、新しいワイヤに番号を割り当てたり、番号が設定済みのワイヤに番号を再割り当てします。カウンター値に影響させることを目的に式が変更されない限り、この番号の再割り当てはカウンター値に影響しません。

ワイヤ番号の再計算: 手動で変更された番号以外のすべてのワイヤ番号を再計算します。すべての番号付けを再計算するには、[手動番号の再計算] ボックスをオンにする必要があります。

ワイヤ スタイル マネージャー: このボタンにより、[ワイヤ スタイル マネージャー] を開いてワイヤ スタイルを編集できます。

関連トピック:

番号の割り当て設定

新しいワイヤの番号割り当て

ワイヤ マークの編集


ワイヤ マークの編集

ワイヤのコンテキスト メニュー: ワイヤ マークの編集

このオプションは、個別のワイヤまたは複数のワイヤで実行できます。

コマンドによってダイアログ ボックスが開き、ワイヤ番号を変更できるようになります。

このダイアログは、番号が自動的に生成されたか、手動で生成されたかを示します。ダイアログ ボックスの左側には等電位番号が表示され、右側にはワイヤ番号が表示されます。

1. [新規] 列のテキストを編集し、番号を変更します。

入力された番号が既にプロジェクトに存在する場合、警告メッセージが表示されます。

関連トピック:

番号の割り当て設定

新しいワイヤの番号割り当て

ワイヤ番号の再割り当て


マーク番号の再割り当て

プロジェクト構成のマーク設定が修正された場合、プロジェクトの既存の要素のマークを更新する必要があります (コンポーネント、ロケーションなど)。

メニュー: プロセス > マーク番号の再割り当て

選択

プロジェクト全体: すべてのプロジェクト要素を処理します。

現在のブック: 現在のブック (現在の配線図に関連付けられているブック) に含まれている要素のみを処理します。

番号の再割り当てモード

マークの更新: マーク数式を変更した後に、[要素] セクションのリストで選択された要素の番号を再割り当てできます。順序の番号は保持され、手動マークも保持されます。

順序番号の再計算: [要素] セクションのリストで選択した要素の番号を再割り当てできます。順序の番号は図面内の位置と相対して再計算され、[手動マークを再計算する] を選択した場合は、手動マークも再割り当てされます。

要素

番号の再割り当てコマンドで処理する要素のボックスを選択します。

マークの設定にアクセスするには、[マーク構成...] ボタンをクリックします。

関連トピック:

マークの設定


接続オブジェクトにデータを反映

データを接続オブジェクト全体に反映します。たとえば、PLC のチャネル アドレスを、このチャネルに接続されているワイヤの番号に割り当てる場合に、この機能を使用できます。最初のステップで、データのソースを選択します。たとえば、プロジェクトの全体か一部、または図面で選択したオブジェクトになります。次のステップでは反映ルールを作成し、最後のステップでは更新するオブジェクトを選択します。

メニュー: プロセス > 接続オブジェクトにデータを反映

選択

プロジェクト全体: プロジェクトのすべてのオブジェクトにデータを反映します。

現在のブック: 現在のブック (現在の配線図に関連付けられているブック) のオブジェクトのみにデータを反映します。

現在のフォルダー: 現在のフォルダー (現在の配線図に関連付けられているフォルダー) のオブジェクトのみにデータを反映します。

現在の配線図: 現在の配線図のオブジェクトのみにデータを反映します。

配線図で選択されたオブジェクト: 現在の配線図で選択したオブジェクトのみにデータを反映します。

配線図を選択: 配線図セレクターが開き、処理する配線図を選択できます。これらの配線図内のオブジェクトのみが処理されます。

反映する情報

反映の追加: 新しい反映ルールを作成できます。

削除: 選択した反映ルールを削除します。

新しい反映ルールを作成すると、新しい行がテーブルに追加されます。各列の値を選択し、ルールを作成します。ルールの順序を変更するには、[上へ] アイコンと [下へ] アイコンを使用して、ルールを処理する順序を管理します。チェック ボックスでは、反映ルールの有効と無効を切り替えることができます。

オブジェクトからコピー: データの反映に使用するオブジェクトをリストから選択します。

反映するデータ: 反映するデータ型をリストから選択します。このデータは、選択したオブジェクトに固有になります。

終点のオブジェクト: すでに選択したデータを反映するオブジェクトをリストから選択します。

終点のデータ: 反映したデータをコピーするデータ型をリストから選択します。

オブジェクト プロパティの更新

オブジェクトが反映データで自動的に更新されても、[更新] チェック ボックスをオンにして、式を使用してデータを反映する必要があります。


データの更新

DesignSpark Electrical データ (シンボル、メーカー部品など) に変更が加えられた場合、最後の変更結果が反映されるように、プロジェクト データの更新が必要な場合があります。

メニュー: プロセス > データの更新

このコマンドを実行すると、プロジェクト データの更新ウィザードが自動的に表示されます。

ステップ 1.プロジェクト データの更新

DesignSpark Electrical の他のウィザードとは異なり、データを更新するコマンドには、構成ファイルを保存または読み込むためのオプションがありません。デフォルトではすべてのデータが処理されます。すべての管理対象プロジェクト データを自動的に更新するには、[完了] ボタンをクリックします。

選択したプロジェクト データを更新するには、[次へ] ボタンを選択します。

ステップ 2.選択

ウィザードの 2 番目の画面には、更新の対象となるデータのリストが表示されます。

更新するデータ タイプが選択され、何も要求されていない場合は、アラートが表示されます。

ステップ 3.メーカー部品

状態: [状態] 列は選択した参照の有効状態を示します。[状態] フィールドをダブルクリックすると、ポップアップ ダイアログが開き、参照の置換が無効な理由が表示されます。

[状態] フィールドは参照専用です。すべての参照はデータの有効性に関係なく置換されます。

メーカー: プロジェクト内のメーカー名を表示します。

参照: プロジェクトのメーカー部品を表示します。

既存のインスタンス: プロジェクト全体のインスタンス数を表示します。

異なるインスタンス: 更新するインスタンス数を表示します。

選択: データ更新の対象となる部品のボックスをオンにします。

ステップ 4.ケーブル参照

状態: [状態] 列は選択した参照の有効状態を示します。[状態] フィールドをダブルクリックすると、ポップアップ ダイアログが開き、参照の置換が無効な理由が表示されます。

[状態] フィールドは参照専用です。すべての参照はデータの有効性に関係なく置換されます。

メーカー: プロジェクト内のメーカー名を表示します。

参照: プロジェクト参照を表示します。

既存のインスタンス: プロジェクト全体のインスタンス数を表示します。

異なるインスタンス: 更新するインスタンス数を表示します。

選択: データ更新の対象となる参照のボックスをオンにします。

ステップ 5.シンボル

状態: [状態] 列は選択したシンボルの有効状態を示します。[状態] フィールドをダブルクリックすると、ポップアップ ダイアログが開き、シンボルの置換が無効な理由が表示されます。

[状態] フィールドは参照専用です。すべてのシンボルはデータの有効性に関係なく置換されます。

名前: プロジェクト内のメーカー名を表示します。

既存のインスタンス: プロジェクト全体のインスタンス数を表示します。

異なるインスタンス: 更新するインスタンス数を表示します。

選択: データ更新の対象となるシンボルのボックスをオンにします。

ダイアログの右側のプレビューには、現在のシンボル、既存のシンボル、および更新するシンボルが表示されます。

ステップ 6.タイトル ブロック

状態: [状態] 列は選択したタイトル ブロックの有効状態を示します。[状態] フィールドをダブルクリックすると、ポップアップ ダイアログが開き、タイトル ブロックの置換が無効な理由が表示されます。

[状態] フィールドは参照専用です。すべてのタイトル ブロックはデータの有効性に関係なく置換されます。

名前: プロジェクト内のタイトル ブロック名を表示します。

既存のインスタンス: プロジェクト全体のインスタンス数を表示します。

異なるインスタンス: 更新するインスタンス数を表示します。

選択: データ更新の対象となるタイトル ブロックのボックスをオンにします。

ダイアログの右側のプレビューには、現在のタイトル ブロック、既存のタイトル ブロック、および置換するタイトル ブロックが表示されます。

ステップ 7.プロジェクト データの更新

[完了] ボタンを選択すると、更新するように選択した項目を使用してプロジェクト図面とデータベースが更新されます。

注意: このコマンドは元に戻すことができません。更新する要素について確実ではない場合は、コマンドを実行する前にプロジェクトをアーカイブすることをお勧めします。

関連トピック:

メーカー部品カタログ

ケーブル カタログ

シンボルの管理

タイトル ブロックの管理


プロジェクト テキストの翻訳

DesignSpark Electrical では、複数の言語によるデータ入力が可能です。これらの翻訳はすべて同じインターフェイスで確認できます。

メニュー: プロセス > 翻訳

ドック可能パネル > プロジェクトのコンテキスト メニュー: 翻訳

ダイアログ ボックスが開き、プロジェクト内の各コンポーネント プロパティの翻訳や多言語テキストを入力または修正できます。

翻訳を編集するには、対応するテキストをクリックします。

エクスポート/インポート: 別のアプリケーション (Excel、Access、SQLite 形式) での翻訳を管理します。テキストの 1 例のみがエクスポートされます。

[言語セレクター] ダイアログ ボックスでは、翻訳のためのベース言語を選択します。ファイルを開くかどうかを確認するメッセージ ボックスが表示されます。

ファイル構造は変更しないでください。変更すると、翻訳をインポートできなくなります。

言語の追加または削除: プロジェクトで使用し、翻訳する言語を選択できます。[言語セレクター] ダイアログ ボックスが開いたら、言語に対応するボックスをチェックします。プロジェクトに存在しない言語のみが表示されます。既存の言語を削除すると、選択を確認するメッセージ ボックスが表示されます。

翻訳の削除: 選択したテキストに対して、プロジェクト プロパティで使用されているメイン言語を除く、すべての翻訳を削除します。

検索/置換: テキストの検索および 置換が可能になります。

フィルター ゾーンにテキストを入力できます。そうすると、リストには、入力した文字列を含むテキストのみが表示されます。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

空のテキストを非表示: メイン言語の空のテキストを非表示にします。

翻訳済みテキストを非表示: すでに翻訳されているすべての言語のテキストを非表示にします。

関連トピック:

言語構成

ユーザー データ


テキストの検索/置換

プロジェクト翻訳: 検索/置換

このコマンドでは、プロジェクトで翻訳可能なテキストを検索して、置換できます。

言語: 検索を実行する言語を選択します。

検索対象: 検索するテキストを入力し、[次を検索] ボタンをクリックします。テキストが見つかった行が選択されます。[次を検索] ボタンをもう一度クリックすると、DesignSpark Electrical はリストの残りを検索し、次のテキストを見つけます。

置換: 見つかったテキストの場所に挿入するテキストを入力します。[置換] ボタンをクリックすると、見つかった最初のテキストが置換されます。見つかったテキストをすべて置換する場合は、[すべて置換] ボタンをクリックします。

大文字と小文字を一致: このオプションでは、大文字と小文字を区別して検索を実行します。

次で始まる: このオプションでは、入力した文字から始まるテキストを検索します。

単語全体: このオプションでは、入力した単語が存在し、入力した単語の前後にスペースが存在するテキストを検索します。

次を検索: リストを検索し、次の検索対象のテキストを見つけます。

置換: 入力した既存のテキストと一致する最初のテキストを置換します。

すべて置換: 入力した既存のテキストと一致するすべてのテキストを置換します。


言語セレクター

[言語 セレクター] ダイアログ ボックスには複数の用途があります。マネージャーで使用して [説明] フィールドの言語を選択したり、プロジェクトの翻訳で使用してさまざまな機能の言語を選択できます。

シンボル マネージャー > シンボル プロパティ: 説明

タイトル ブロック マネージャー > タイトル ブロック プロパティ: 説明

ケーブル参照マネージャー > ケーブル プロパティ: 説明

メーカー部品マネージャー > メーカー部品プロパティ: 説明

マネージャーでは、[言語セレクター] ダイアログ ボックスによって、要素の説明で管理する言語を選択できます。選択された言語は、自動的に要素のプロパティに追加されます。

[翻訳] ダイアログ ボックス: 追加

[翻訳] ダイアログ ボックスの [言語セレクター] ダイアログ ボックスには、1 つまたは複数の言語の選択が必要な場合のチェック ボックスありと、1 言語しか選択できないためチェック ボックスなしの 2 つの外観があります。


リビジョン

ブック、表紙、および図面にのみ、リビジョン番号が割り当てられます。リビジョン番号は、プロジェクト レベルではなく、個別に管理されます。リビジョン番号は、プロジェクト構成パラメーターに従って、書式設定されます。

リビジョン インデックスは図面作成中に設定できます。

ブックのコンテキスト メニュー: リビジョン

図面のコンテキスト メニュー: リビジョン

リビジョン インデックスは、3 つのステップで管理されます。最初はインデックスを作成し、2番目のステップではインデックスが確認され、次にインデックスが検証されます。

リビジョン インデックスがブックで管理されるときは、このインデックスをブック内のすべての図面に反映できます。

新しいリビジョン: 新しいリビジョン インデックスを作成します。新しいリビジョンを作成する前に、最初に現在のリビジョンを確認する必要があります。

確認: 最後のリビジョン インデックスに「確認済み」ステータスを入力します。これにより、リビジョンを確認した日付とユーザー名が記録されます。

検証: 最後のリビジョン インデックスに「検証済み」ステータスを入力します。これにより、リビジョンを検証した日付とユーザー名が記録されます。

検証を除去: 最後のリビジョン インデックスの最終ステータスを除去します。

削除: 最後のリビジョン インデックスを削除します。

プロパティ: 編集: リビジョン プロパティ ダイアログ ボックスが開き、リビジョン インデックスに関連付けられているデータを編集できるようになります。

[カスタマイズ] ボタンでは、リビジョン インデックスに特に関連するユーザー データ パラメーターにアクセスできます。

新しいリビジョン インデックスの作成後、別のダイアログ ボックスが開き、ブックのドキュメントを印刷したり、ブックのドキュメントを PDF ファイルにエクスポートしたり、スナップショットを作成したりすることができます。


リビジョン プロパティ

ブックのコンテキスト メニュー: リビジョン > プロパティ

図面のコンテキスト メニュー: リビジョン > プロパティ

ダイアログ ボックスに、リビジョン インデックスのプロパティがリストされます。

変更できるのは、ユーザー名およびユーザー データだけです。


レポート マネージャーと設計ルール マネージャー

レポート

レポートは、生産または製造に役立つ一覧表 (装置、ケーブルの一覧など) です。

メニュー: プロジェクト（Project）> レポート（Reports）

ドック可能パネル > プロジェクトのコンテキスト メニュー: プロジェクト > レポート マネージャー

レポートはプロジェクト データベースに保存されているデータを取得します。データは図面の形式で生成するか、Excel やテキスト ファイルなどの各ファイル形式にエクスポートし、DesignSpark Electrical 外で使用できるようにします。

レポートはレイアウトとデータの書式化を提供するレポート構成に基づいています。

レポート マネージャーでは、プロジェクトで使用するレポートを管理できます。ダイアログ ボックスの左側には、プロジェクトで使用されているレポート構成のリストが表示されます。右側には、選択したレポートの結果が表示されます。

追加: プロジェクトに新しいレポートを追加できます。

削除: 選択したレポートを削除します。

スケジュール: レポートを生成する順序を管理できます。

更新: ソフトウェアをクライアント/サーバー モードで使用しているときに、レポートのデータを更新します (データは別のユーザーが変更できます)。

図面の生成: レポート図面を生成または更新します。

Excel エクスポート: レポート構成を使用して、プロジェクト データを Microsoft Excel ファイルにエクスポートします。

テキスト エクスポート: レポート構成を使用して、プロジェクト データをテキスト ファイルにエクスポートします。

XML エクスポート: レポート構成を使用して、プロジェクト データを XML ファイルにエクスポートします。

リンクの使用

レポートのプレビューにリンクを含めると、シンボル、ロケーション プロパティ、メーカー部品など、プロジェクト要素に移動できます。リンクは、下線付きの青いテキストとして表示されます。リンクを使用するには、テキスト (デフォルト リンク) をクリックするか、コンテキスト メニューを使用して要素を選択します (オブジェクトに複数のオブジェクトが関連付けられている場合)。

レポートにリンクを作成するには、レポート構成の [移動] 設定を使用します。

リンクをクリックしたときに実行される操作は、リンクされているオブジェクトによって決まります。

オブジェクト | 操作
ドキュメント | 図面に移動します。
コンポーネント | ドック可能パネル (コンポーネント タブ) にコンポーネントが表示されます。 2D フットプリントも含めて、コンポーネントに関連付けられているすべてのシンボルが表示されます (図面のシンボルに移動)。
回路 | 回路に関連付けられているシンボルが表示されます。
シンボル | 図面のシンボルに移動し、その周りをズームします。
ケーブル | ケーブルが予約されている結線図が表示されます (ケーブルに接続されている、最初のコンポーネントに移動します)。 配線図のケーブル コアが表示されます (ケーブル コアに接続されている、最初のコンポーネントに移動します)。
等電位 | 配線図の等電位が表示されます。
ワイヤ/ケーブル コア | 配線図のワイヤが表示されます (ワイヤに接続されている、最初のコンポーネントに移動します)。
メーカー部品 | この参照に関連付けられているシンボルが表示され、このシンボル (2D フットプリント、ワイヤ ラベル、3D コンポーネント) に移動します。
ロケーション | ロケーション プロパティ ダイアログ ボックスが開きます。
ファンクション | ファンクション プロパティ ダイアログ ボックスが開きます。


レポートの追加

レポート マネージャー: 追加

プロジェクトのレポート構成を追加または除去します。

ダイアログ ボックスの上部には複数のフィルターが表示されます。これにより、レポート構成を簡単に検索できます。

使用するレポート構成に対応するボックスをオンにし、[OK] ボタンをクリックします。

レポート マネージャー で抽出データが更新され、プレビューが表示されます。

関連トピック:

レポート マネージャー

レポートのスケジュール

レポート図面の生成

Excel エクスポート

テキスト エクスポート

XML エクスポート


レポートのスケジュール

レポート マネージャー: スケジュール

レポートの起動順序を管理します。

[下へ] アイコンと [上へ] アイコンを使用し、レポートの起動順序を管理します。

レポートは一覧に表示されている順序で生成されます。

関連トピック:

レポート マネージャー

レポートの追加

レポート図面の生成

Excel エクスポート

テキスト エクスポート

XML エクスポート


レポート図面の生成

このコマンドでは、レポート図面の生成や更新ができます。

レポート マネージャー: 図面の生成

レポートはブック レベルで生成されます。プロジェクトにフォルダーが含まれる場合は、レポートの右側の [...] ボタンをクリックして、指定した出力先フォルダーを選択します（複数選択が可能です）。

生成するレポートの横のボックスを選択し、[OK] を選択すると、レポートが生成されます。

ブックまたはフォルダーのコンテキスト メニュー: ここにレポートを描画

構成を選択...: どのレポートを図面として生成するかを管理するダイアログが開きます。

プロジェクトのすべてのレポート : プロジェクトのすべてのレポートを図面として生成します。

選択したレポートの更新: ブックまたはフォルダーに既にレポートが含まれる場合、このオプションが有効です。このオプションを使用すると、これらの図面が更新されます。

関連トピック:

レポート マネージャー

レポートの追加

レポートのスケジュール

Excel エクスポート

テキスト エクスポート

XML エクスポート


Excel エクスポート

レポート マネージャー: Excel エクスポート

レポート構成を使用して、プロジェクト データを Excel ファイルにエクスポートします。

まず、ウィザードで、エクスポートするレポートの選択を求められます。

ステップ 1.Excel エクスポート

すべてのレポートをエクスポートする: すべてのプロジェクト レポートをエクスポートするには、これを選択します。その他の場合はリストを使用し、エクスポートするレポートを選択します。

ステップ 2

シートの区切りに改ページする: レポートで定義された改ページごとに 1 つの図面を作成します。

作成したファイルをプロジェクトに追加するこのオプションが有効な場合、XLS ファイルがプロジェクトの保存ディレクトリに作成され、データ ファイルとしてプロジェクトに追加されるか、すでに存在する場合は更新されます。このオプションが有効でない場合は、定義されたディレクトリにテキスト ファイルが生成されます。

ターゲット フォルダー: ファイルの保存先ディレクトリを入力します。[...] ボタンをクリックします。[作成したファイルをプロジェクトに追加する] オプションを有効にした場合、プロジェクトのフォルダーまたはブックを選択する必要があります。このオプションを有効にしていない場合は、ディレクトリの選択を求められます。

ファイルを開く: XLS ファイルに関連付けられたアプリケーションで生成したファイルを開きます。

ステップ 3.完了

[完了] をクリックすると、Excel ファイルの生成処理が始まります。

印刷、PDF ファイルへのエクスポート、新規リビジョンの作成など、いくつかのコマンドを実行すると、エクスポートした XLS ファイルは、プロジェクト ドキュメント内にある場合、自動的に更新されます。コンテキスト メニューの [エクスポートしたレポートを更新] を使用して更新することもできます。

関連トピック:

レポート マネージャー

レポートの追加

レポートのスケジュール

レポート図面の生成

テキスト エクスポート

XML エクスポート


テキスト エクスポート

レポート マネージャー: テキスト エクスポート

データをテキスト ファイル形式で生成します。

作成したファイルをプロジェクトに追加する: プロジェクトのストレージ ディレクトリにテキスト ファイルを作成し、そのファイルをデータ ファイルとしてプロジェクトに追加します (すでに存在する場合は更新)。このオプションが有効ではない場合、ユーザーが定義したディレクトリにテキスト ファイルが作成されます。

ターゲット フォルダー: ファイルのターゲット フォルダーを入力します。[...] ボタンをクリックします。[作成したファイルをプロジェクトに追加する] オプションを有効にした場合、プロジェクトのフォルダーまたはブックを選択する必要があります。このオプションを有効にしていない場合、ディスクのディレクトリを選択するように指示されます。

すべてのレポートをエクスポートする: すべてのプロジェクト レポートをエクスポートするには、これを選択します。また、エクスポートするレポートをリストで選択することもできます。

最初の行に列ヘッダーを含める: ファイルの最初の行にデータベース フィールド名を生成します。

[テキスト ID]、[テキスト区切り文字]、および [ファイル タイプ] はテキストの書式設定パラメーターです。これらは、ファイルがインポートされるソフトウェアの要件に従って、選択する必要があります。

作成後に生成したファイルを開く場合は、[ファイルを開く] ボックスを選択します。

印刷、PDF ファイルへのエクスポート、新規リビジョンの作成など、一部のコマンドを実行すると、エクスポートした TXT ファイルは、プロジェクト ドキュメント内にある場合、自動的に更新されます。コンテキスト メニューの [エクスポートしたレポートを更新] を使用して更新することもできます。

関連トピック:

レポート マネージャー

レポートの追加

レポートのスケジュール

レポート図面の生成

Excel エクスポート

XML エクスポート


XML エクスポート

レポート マネージャー: XML エクスポート

XML エクスポートでは、テキスト ファイルの形式でデータを生成できます。

作成したファイルをプロジェクトに追加する: プロジェクトのストレージ ディレクトリに XML ファイルを作成し、そのファイルをデータ ファイルとしてプロジェクトに追加します (すでに存在する場合は更新)。このオプションが有効ではない場合、ユーザーが定義したディレクトリに XML ファイルが作成されます。

ターゲット フォルダー: ファイルのターゲット フォルダーを入力します。[...] ボタンをクリックします。[作成したファイルをプロジェクトに追加する] オプションを有効にした場合、プロジェクトのフォルダーまたはブックを選択する必要があります。このオプションを有効にしていない場合、ディスクのディレクトリを選択するように指示されます。

すべてのレポートをエクスポートする: すべてのプロジェクト レポートをエクスポートするには、これを選択します。また、エクスポートするレポートをリストで選択することもできます。

ファイルを開く: 生成したファイルを XML ファイルに関連付けられたアプリケーションで開きます。

印刷、PDF ファイルへのエクスポート、新規リビジョンの作成など、いくつかのコマンドを実行すると、エクスポートした XML ファイルは、プロジェクト ドキュメント内にある場合、自動的に更新されます。コンテキスト メニューの [エクスポートしたレポートを更新] を使用して更新することもできます。

関連トピック:

レポート マネージャー

レポートの追加

レポートのスケジュール

レポート図面の生成

Excel エクスポート


バスケットに追加

材料見積もりの管理を支援するため、固有のレポート構成により、材料リストを Excel、TXT、XML ファイルにエクスポートできます。

メニュー: プロセス > バスケットに追加

各ロケーションまたは各プロジェクトの材料リストをエクスポートできます。材料リストをエクスポートするロケーションを選択します。

すべて選択: すべてのプロジェクト ロケーションを選択します。

Excel エクスポート: Excel ファイルにリストをエクスポートします。

テキスト エクスポート: TXT ファイルにリストをエクスポートします。

XML エクスポート: XML ファイルにリストをエクスポートします。

製品詳細の更新: メーカー部品の [価格] 列と [在庫状況] 列を Web サービスから更新します。

[バスケットに追加] コマンドは、レポート機能を使用して、データを Excel、TXT、XML ファイルにエクスポートします (詳細についてはこれらの各章を参照)。


プロジェクトを検証

DesignSpark Electrical を使用する際に、存在しないフォルダーに割り当てられた図面や、削除されたロケーションに割り当てられたコンポーネントなど、ソフトウェアで誤ったデータが生成される可能性があります。プロジェクトを検証機能では、電気図面設計でのエラーをチェックしません。

プロジェクトを検証機能はデータベースのエラー修正に使用できます。

メニュー: ツール > プロジェクトを検証

この機能を使用する前に、プロジェクトをアーカイブすることをお勧めします。

図面に対して、整合性のないエンティティが訂正または除去されます。図面ファイル上のエラーは自動的に修正されます。

プロセスの終了時には、ダイアログ ボックスで訂正処理の結果が表示されます。訂正をチェックし、必要に応じてプロジェクトを適応することをお勧めします (移動された図面、削除されたワイヤやコンポーネントなど)。


印刷マネージャー

メニュー: プロジェクト > 印刷

ドック可能パネル > プロジェクトのコンテキスト メニュー: 印刷

ドック可能パネル > ブックのコンテキスト メニュー: 印刷

ブックのコンテキスト メニューからこのコマンドを実行すると、そのブックの図面のみが印刷目的で選択されます。

印刷設定は構成ファイルに保存し、将来使用することができます。必要に応じて、任意の数の構成ファイルを作成できます。

印刷プレビュー: 選択した図面の印刷プレビュー ウィンドウが開きます。

選択項目から除去: 選択した図面を選択項目から除去します。

複数構成の印刷: さまざまな構成を使用して図面を印刷します。

リスト モード: 図面のリストを表示します。

サムネイル モード: 図面のサムネイル プレビューを表示します。

構成: ダイアログ ボックスの項目の表示設定を管理します。

印刷構成

以前作成した印刷構成ファイルを選択し、目的の印刷設定を読み込むことができます。印刷構成ファイル マネージャーにアクセスするには、[...] ボタンをクリックします。

ページ設定

プリンターとページ サイズを定義します。[プロパティ] ボタンでは、プリンター設定にアクセスできます。

PDF ファイルのエクスポート

このボックスを選択すると、選択した図面を PDF 形式で生成します。

方向

ページの向きを定義します。

図面

印刷する図面を選択するダイアログ ボックスにアクセスします。

コピー

印刷するコピーの数とアセンブリ モードを定義します。

スケール

目的の倍率を選択できます ([形式に合わせる] オプションが推奨されます)。

スタイルを使用してプロット

プロット スタイルを選択できます。DesignSpark Electrical で使用されるすべての色には、印刷色と線幅を含めることができます。これにより、プロット スタイルを使用して、印刷中に使用する色と線幅を設定できます。スタイルを変更しない場合、プログラムで使用された色と同じ色が使用されます。グレースケール スタイルはモノクロで印刷されます。

プロジェクト図面の印刷用の構成がいくつかある場合は、構成ファイルをリストから選択します。次に、この構成を使用して印刷する図面を選択します。必要に応じて、この操作をその他の構成ファイルで繰り返します。[複数構成の印刷] アイコンをクリックし、印刷に使用する構成を確認します。

関連トピック:

印刷構成ファイルの管理

PDF エクスポート


印刷構成ファイルの管理

印刷マネージャー: 構成を印刷 > [...]

印刷構成ファイルを管理します。これらのファイルには印刷パラメーターと図面選択セットが含まれます。

右側のボタンを使用して、構成ファイルの作成、コピー、または削除を行います。

関連トピック:

印刷マネージャー


図面のエクスポート

図面は DWG または PDF 形式 に公開することができます。

エクスポートされたすべての図面が、図面としてではなく、データ ファイルとして DesignSpark Electrical に復元されるわけではありません。

  • DWG ファイルのエクスポート

  • PDF ファイルのエクスポート


DWG ファイルのエクスポート

DesignSpark Electrical で作成される図面はすべて EWG 形式で保存されます。図面をさまざまなバージョンの DWG/DXF にエクスポートすることで、たとえば DesignSpark Electrical を所有していない他社との間でもデータを共有できます。

EWG の名前は DesignSpark Electrical により自動生成されます。この名前はプロジェクトの図面の名前とは関係ありません。プロジェクト ディレクトリ内の EWG ファイルの名前は変更しないでください。この操作を行うと、DesignSpark Electrical ファイルの整合性が失われます。

メニュー: インポート/エクスポート > DWG ファイルのエクスポート

ダイアログ ボックスが開き、DWG ファイルのディレクトリを選択できるようになります。

図面は、ドック可能パネルに表示されるプロジェクトの構造と同様のツリー構造にエクスポートされます。

フォルダーとファイル

ベース フォルダーのパス: エクスポートするフォルダー/ディレクトリ図面を選択できます。

フォルダー名の数式: 数式マネージャーを使用してメインのフォルダー/ディレクトリの名前をフォーマットします。

ファイル名の数式: 数式マネージャーを使用して生成されたファイルの名前をフォーマットします。

エクスポート後にフォルダーを開く: このオプションを選択すると、エクスポート処理の最後に、定義されたベース フォルダー/ディレクトリでファイル エクスプローラーが開きます。

すべての図面を 1 つのファイルにエクスポート: エクスポート対象として選択したすべての図面を 1 つのファイルにグループ化します。各図面は DWG プレゼンテーション モード (「用紙」スペース) に配置されます。

形式とバージョン

生成されるファイルの形式 (DXF または DWG) とファイル バージョンを選択します。

エクスポートする図面

エクスポートする図面を選択します。[...] ボタンをクリックすると、図面セレクターが開き、[すべて] オプションではプロジェクトのすべての図面が選択されます。

図面スタイル: [図面スタイル] ボタンを使用すると、テキストおよび色オブジェクトの設定を変更できます。プロジェクトに図面スタイル構成ファイルを割り当てていない場合は、メッセージにより通知されます。

関連トピック:

PDF エクスポート

データ ファイル


PDF ファイルのエクスポート

Acrobat (PDF) 形式でプロジェクトの図面を生成します。

メニュー: インポート/エクスポート > PDF ファイルのエクスポート

ドック可能パネル > プロジェクトのコンテキスト メニュー: PDF ファイルのエクスポート

ドック可能パネル > ブックのコンテキスト メニュー: PDF ファイルのエクスポート

ブックのコンテキスト メニューからこのコマンドを実行すると、このブックに属する図面のみがエクスポート目的で選択されます。

PDF 形式でのエクスポートは内部プログラムを使用し、PDF Creator や他の PDF プリンターとして PDF プリンターをインストールする必要はありません。

PDF エクスポート機能では印刷マネージャーを使用します。

最初に、PDF ファイルの保存先となるディレクトリを選択します。このダイアログ ボックスの使用方法については、「印刷マネージャー」の章を参照してください。

ブックマークとハイパーリンクを作成: PDF ファイル内の各ページにナビゲーション リンクを作成します。また、ドック可能パネルの [ドキュメント] および [コンポーネント] タブの内容を使用すると、ブックマークのリストも作成できます。また、レポートは、リンクがレポート構成で管理されている場合、それらのリンクを統合することもできます。

ブック別に 1 つの PDF ファイルをエクスポートする: プロジェクトに複数のブックがあり、このオプションを選択した場合、エクスポートの終了時に、ファイル エクスプローラーでファイルを作成したディレクトリが開きます。プロジェクトに 1 つのブックしかない場合、エクスポートの終了時に、PDF ファイルが開きます。

関連トピック:

印刷マネージャー


データの管理

DesignSpark Electrical は常にデータベースに接続されています。特定のデータは現在のプロジェクト固有ですが、メーカー カタログやライブラリ マネージャーのようにアプリケーション固有のデータもあります。

配線図の作成中とさまざまなプロセスの使用中は、プロジェクト データは自動的に更新されます。

アプリケーション データ (ライブラリ、カタログなど) は、配線図設計を作成するために使用されます。またプロジェクト データを追加するためにも使用されます。

各種のデータベース編集ソフトウェアを使用し、DesignSpark Electrical 外部でこれらのデータを変更することは推奨しません。 DesignSpark Electrical には、情報をデータベースに追加するツールが用意されています (データのインポート、シンボル作成など)。新しいバージョンの DesignSpark Electrical ごとに、自動的に既存のデータに追加された新しいデータが含まれる場合があります。

  • 検索マネージャー

  • データ インストール

  • ライブラリ マネージャー

  • グラフィカル データ

  • カタログ


検索マネージャー

メニュー: ツール > 検索

このコマンドでは、コンポーネントや図面などの特定のプロジェクト要素を検索できます。

このコマンドを実行すると、ダイアログ ボックスが開きます。

検索するオブジェクト タイプ: 検索する要素に対応するボックスをオンにします。

マーク: 検索する要素のマークを入力します。

説明: 検索する要素の説明を入力します。

1. [検索] ボタンをクリックして、検索を実行します。

入力した検索条件に合致するマークのリストが、ダイアログ ボックスの中央に表示されます。

ダイアログ ボックスの右側には、選択した要素のプレビュー領域が表示されます。

選択した要素の図面を開きます。

ドック可能パネルのコンポーネントのリストで、コンポーネントを検索できます

選択した要素の [プロパティ] ダイアログ ボックスを開きます。

要素のコンテキスト メニューでは、コンポーネント ツリーで要素を表示するか、要素が見つかった図面を開くことができます。


データ インストール

完全インストールまたは再インストールを実行すると、UPDATE という一時ディレクトリが作成され、すべてのライブラリ、メーカー カタログ、レポート構成などの構成ファイルなどが配置されます。次に、ユーザーはデータの更新方法を選択できます。

DesignSpark Electrical の起動時には、一時 UPDATE フォルダーが存在する限り、表示されるウィザードを使用してデータ更新処理を管理することができます。

更新をキャンセルすると、次回 DesignSpark Electrical を起動するときに、自動的にオプションが表示されます。

データ タイプ選択

ウィザードの 2 番目の画面では、更新するデータのタイプを選択できます。

更新処理に含めるデータ タイプを選択します。

最初にはすべてのデータ タイプを選択することを強くお勧めします。

[次へ] をクリックして続行するか、更新処理から除外するデータ タイプの選択を解除します。

更新ウィザードは、最新のインストール データに対して現在のデータを比較します。

各データ タイプに対して実行される操作を選択します。

操作の定義

Shift / Ctrl / Ctrl+A などのキーを使用して、データのリスト項目を複数選択できます。

追加: このデータは現在のインストールに存在せず、追加されます。

置換: 既存のデータが最新のバージョンで上書きされます。

何もしない: 新しいデータはインストールされず、既存の情報が保持されます。

両方を保持: 既存の情報が保持され、新しい情報は別の新しい名前でインストールされます。

更新: このオプションはメーカー カタログ (ケーブルおよび材料) にのみ関連付けられています。カタログ参照は自動的に更新されます。

既定のアクション タイプが提示されます。これは次のルールに基づいて定義されています。

- 新しいデータは追加されます。

- 既存のデータが修正された場合は、自動的に [何もしない] に設定されます。

- データが存在し、ユーザーによって変更されずに、新しいファイルがソフトウェアの発行元によって更新済みに設定された場合、置換 に設定されます。

- ケーブルおよび装置のカタログは必ず 更新 に設定されます。

データ タイプ

シンボル - タイトル ブロック: アシスタントには、要素名、説明、変更日、および現在の要素を作成または変更したユーザーの名前が表示されます。既存の要素を保持し、同じ要素の最新バージョンをインストールする場合は、異なる名前が新しい要素に割り当てられます。

ケーブルとメーカー カタログ: カタログは全体 (すべてのメーカー カタログ参照) で管理されます。参照が存在しない場合、自動的に追加されます。参照が存在し、ユーザーによって修正された場合、新しい参照はインストールされません。参照が存在し、ユーザーによって修正されずに、ソフトウェアの発行元によって更新された場合、新しい参照が自動的にインストールされ、既存の参照を上書きします。

プロジェクト テンプレート: 新しいモデルとソフトウェアの発行元によって修正されたモデル (異なる変更日) のみがインストールされます。ユーザーが作成したモデルは保持されます。

構成ファイル: 新しい構成ファイルと発行元によって修正された構成ファイル (異なる変更日) のみがインストールされます。ユーザーが作成した構成ファイルは保持されます。

パレット: 新しいパレットとソフトウェアの発行元によって修正されたパレット (異なる変更日) のみがインストールされます。ユーザーが作成したパレットは保持されます。

データ インストールの実行

ウィザードの最後のタブには、管理するデータ タイプの概要が表示されます。

[完了] ボタンをクリックして、インストールを実行します。処理するデータ量によっては、この処理に時間がかかる場合があります。

セットアップ処理が完了すると、UPDATE ディレクトリは自動的に削除されます。

関連トピック:

インストール


ライブラリ プロパティ

ライブラリ マネージャー

メニュー: ライブラリ > ライブラリ マネージャー

ライブラリ マネージャーでは、すべてのアプリケーションのライブラリを管理できます。現在のプロジェクト固有ではありません。

新規: 新しいライブラリを作成できます。

削除: リストで削除するライブラリを選択し、[削除] アイコンをクリックします。ライブラリのみが削除されます。内容 (シンボル、タイトル ブロック、参照など) は削除されません。

プロパティ: ライブラリの特性、名前、説明、および含まれるオブジェクトのタイプを編集できます。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

関連トピック:

ライブラリ プロパティ

ライブラリ

ライブラリ構成


ライブラリ プロパティ

ライブラリ マネージャー: プロパティ

ライブラリ マネージャー: 新規

選択したライブラリの [プロパティ] ダイアログ ボックスを開き、ライブラリの命名、説明の適用、ライブラリ タイプへの割り当てを行います。

ライブラリ名と説明を入力し、このライブラリが含むオブジェクトのタイプに対応するオプションを選択します。

関連トピック:

ライブラリ マネージャー


グラフィック データ

グラフィック データは、マネージャーでグループ化されたライブラリに保存されます。グラフィック データ マネージャー (シンボル マネージャーなど) では、既存の要素を編集し、新しいデータを追加できます。

これらのマネージャーには、DWG ファイルのインポートや、ファイルのアーカイブ/解凍など、共通の機能があります。

  • グラフィック コマンド

  • 複数の属性

  • マネージャー構成

  • クラス選択

  • DWG ファイルのインポート

  • アーカイブと解凍

  • タイトル ブロック マネージャー

  • シンボル マネージャー

  • パターン マネージャー


グラフィック コマンド

コマンドには次の 5 つのグループがあります。

  • ファイルを管理するコマンド

  • グラフィック エンティティを作成するコマンド

  • 寸法のコマンド

  • グラフィック エンティティを編集するコマンド

  • 管理機能

関連トピック:

タイトル ブロック

シンボル

2D フットプリント


ファイル管理コマンド

ファイル管理コマンドを使用して外部ファイルと DesignSpark Electrical ファイルを管理できます。

  • 新規

  • 開く

  • 名前を付けて保存

  • 閉じる

  • 印刷

  • ページ設定

  • 印刷プレビュー

  • 終了

  • 保存


新規

メニュー: ファイル > 新規

新しい DWG ファイルを作成し、グラフィック領域の新しいタブで開きます。


開く

メニュー: ファイル > 開く

既存の DWG ファイルを選択するダイアログボックスが開きます。

開いたファイルは、グラフィック領域の新しいタブに表示されます。


ページ設定

メニュー: ファイル > ページ設定

[印刷セットアップ] ダイアログ ボックスが開き、アクティブな DWG ファイルまたは DesignSpark Electrical ファイルの印刷パラメーターを設定できます。

プリンター

名前: 使用するプリンターを選択します。Windows のプリンター パラメーターにアクセスするには、[プロパティ] ボタンをクリックします。

状態: 選択したプリンターの状態を表示します。

タイプ: プリンターのタイプを表示します (この情報はプリンターのパラメーターから取得します)。

配置: プリンターの接続ポートを表示します。

コメント: プリンターに関するコメントを表示します (この情報はプリンターのパラメーターから取得します)。

用紙

サイズ: プリンターによって管理される事前定義された用紙の書式をリストから選択します。

ソース: リストから、使用する用紙トレイを選択します。

インチ/ミリメートル: ファイルの印刷管理に使用する単位を選択します。

印刷領域: 選択した単位で印刷領域の寸法を表示します。

オフセットをプロット

中央プロット: 印刷ページの中心に配置する場合に、このボックスをオンにします。

X: 横方向のオフセット値を入力します。

Y: 縦方向のオフセット値を入力します。

ページの向き

縦/横: ページの向きを選択します。

垂直対称でプロット: グラフィック エンティティを対称に印刷する場合に、このボックスをオンにします。

プロット スケール

事前定義されたスケール率をリストから選択するか、特定の率を入力します (印刷で使用する単位 = ファイルの単位)。[形式を調整] に設定すると、グラフィック エンティティは選択した用紙サイズに合うようにスケール調整されます。

プロット領域

次のいずれかのオプションを選択します。

表示: エンティティは画面に表示されるとおり印刷されます。

エクステント: すべてのファイル エンティティは、用紙セクションで定義したページに印刷されます。

限界: ファイル限界内に含まれるすべてのエンティティが印刷されます。

プロット スタイル テーブル

グラフィック エンティティで使用される各画面の色が、用紙上の色と線幅に対応します。プロット スタイル テーブルを使用しない場合、画面の色と線幅が用紙上と同じになります。

プロット スタイル テーブルを使用することで、個別に色の対応を定義できます。

使用するプロット スタイル テーブルをリストから選択します。

選択したプロット スタイル テーブルは、[プロット スタイル テーブル ファイルを変更] をクリックすると編集できます。ダイアログ ボックスが開き、画面の色と印刷される色と線幅を関連付けることができます。

プロット スタイル テーブル リストで [なし] を選択すると、[線幅でプロット] ボックスをオンにできます。これにより、色と線幅は画面上と用紙上で同じになります。

ネットワーク: ネットワーク プリンターへのアクセスを可能にします。

プレビュー: ページ上に印刷された状態のグラフィック エンティティを表示します。


印刷プレビュー

メニュー: ファイル > 印刷プレビュー

ページ設定のオプション設定を使用して、アクティブな DWG ファイルまたは DesignSpark Electrical ファイルのイメージを表示します。

[印刷プレビュー] は、DWG ファイルまたは DesignSpark Electrical 図面で使用できます。

印刷: 現在のファイルを印刷します。

ページ: まだ実装されていません。

拡大/縮小: ページ表示の拡大/縮小を選択します。

ページ数: 1 ページまたは複数ページを表示します。

パラメーター: ページ設定を開き、印刷パラメーターを変更できます。

プレビューを閉じる: ファイルを印刷せずにプレビュー ウィンドウを閉じます。


印刷

メニュー: ファイル > 印刷

アクティブな DWG ファイルまたは DesignSpark Electrical ファイルを印刷します。

印刷セットアップ ダイアログ ボックスが開き、印刷パラメーターを調整できます。

[OK] をクリックすると、ファイルがプリンターに送信されます。


保存

メニュー: ファイル > 保存

アクティブなドキュメントを保存します。

現在アクティブなファイルが DWG ファイルで、一度も保存していない場合は、アクティブなドキュメントを新しい名前、新しいファイル形式、または新しいフォルダー内に保存するためのダイアログ ボックスが開きます。

アクティブなファイルが DesignSpark Electrical 図面の場合は、[保存] コマンドを使用する必要はありません。ファイルを閉じると自動保存されます。


名前を付けて保存

メニュー: ファイル > 名前を付けて保存

アクティブなドキュメントを、新しい名前、新しいファイル形式で保存するか、新しいフォルダーに保存します。

[名前を付けて保存]（ファイル メニュー）は DesignSpark Electrical図面に使用しないでください。


閉じる

メニュー: ファイル > 閉じる

アクティブなドキュメントを閉じます。

注記: [ファイル] メニューの右上隅またはグラフィック領域の [閉じる] をクリックしてください。

DWG ファイルを開いて変更し、[閉じる] をクリックすると、[...への変更を保存] ダイアログ ボックスが開き、各ファイルを保存してから閉じるかどうかを確認するメッセージが表示されます。

DesignSpark Electrical 図面を閉じる場合は、閉じる前にドキュメントが自動的に保存されます。


終了

メニュー: ファイル > 終了

ソフトウェアを終了します。

DWG ファイルを開いて変更し、[終了] をクリックすると、[名前を付けて保存...] ダイアログ ボックスが開き、開いている各ファイルを保存してから終了するかどうかを確認するメッセージが表示されます。

DesignSpark Electrical 図面を開いて変更し、[終了] をクリックすると、ドキュメントが自動的に保存されて終了します。


図面パラメーター

[図面パラメーター] ダイアログ ボックスで、現行ファイルに固有のすべての設定をグループ化します。DWG ファイルまたは配線図でグループ化できます。

メニュー: 表示 > 図面オプション

ステータス バーを右クリック

オブジェクト スナップ モード

各グラフィック エンティティには特定の点があり、その点を使用して他のエンティティを編集したり、配置できます。たとえば、線には 2 つの終点と 1 つの中点があり、円には中心点と 4 つの四分円点があります。

緑色のアイコンは、各モードのマーカー形式を表します。

リストで使用するモードを選択します。

オブジェクト スナップオンを有効にする: 特定の点の使用を有効または無効にします。ステータス バーの [OSNAP] をクリックするか、F11 キーを押す方法もあります。

図面

ステータス バーでパラメーターをクリックするか、キーボード ショートカットを使用すると、直交、グリッドなどのパラメーターのオンとオフを切り替えることができます。

スナップ オン (F9): スナップはカーソル スナップを指定された場所に作成し、グリッド設定とは異なります。

グリッド オン (F7): 図面のグリッドを表示または非表示にします。

Ortho オン (F8): 直交トラップのオンとオフを切り替えます。ポインターの動きが X 軸か Y 軸に固定されます。

線幅有効 (F10): 線幅のオンとオフを切り替えます。さまざまな線の太さが表示または非表示になります。

ワイプアウト フレームを表示: ワイプアウト領域を表示または非表示にします。

スナップ間隔: 2 つの仮想スナップ点間の間隔を定義します。

グリッド間隔: 2 つのグリッド点間の間隔を定義します。

線種スケール: 現行ファイルで使用している単位に基づいて線の要素を変更できます。複雑な線種 (軸、不連続など) のみがこのパラメーターによって影響を受けます。複雑な線種には倍率を使用して間隔と線を拡大または縮小します。

測定系: 測定用の単位系を定義します。

グリッド ゾーン: グリッドを表示するゾーンの座標を定義します。ボタンをクリックして、このゾーンをグラフィックに定義することもできます。


作図コマンド

[作図] メニューの[作成]グループのコマンドを使用して 2D グラフィック エンティティを作成できます。

これらのコマンドで配置されたグラフィックは、グラフィック表示専用です。これらはプロジェクト データベースでは管理されないため、データ処理コマンドはこれらに影響しません。

これらは、タイトル ブロック、シンボル、2D フットプリントなどの作成に使用できます。ただし、作図コマンドは電気配線図の生成には使用しないでください。

  • 線

  • ポリライン

  • 弧

  • 円

  • 楕円

  • 楕円弧

  • 矩形

  • クラウド

  • ハッチ

  • ワイプアウト

  • 画像を添付

  • 画像の挿入

  • テキストを追加

  • 複数行テキスト

  • ハイパーリンク

  • 属性

  • ブロックの作成

  • ブロックの挿入


線

メニュー: 作図 > 線

現在アクティブなドキュメント内に一連の線セグメントを作成します。

線セグメントはプロジェクト データベースでは管理されないため、電気配線図の生成には線または一連の線を使用しないでください。

各線セグメントには、2 つの移動可能な端点があります。1 本の線を作成する場合、次のようにこれらの端点を定義します。

* ドキュメントをクリックして動的に指定するか、

* 手動で端点の座標を指定します。

一連の線を作成した後、各線セグメントを個別に編集または移動します。線を編集または移動する場合、線と線の端点は動的にのみ位置を変更できます。

ドキュメントに新しい線エンティティが示されると、ドック可能パネルには利用可能なオプションが表示されます。

コマンドを終了します。

最後の操作を元に戻します。

キーボード入力: 以下を入力できます。カンマで区切られた X および Y 座標 (例: 150,125)、"<" で区切られた距離と角度 (例: 150<45)、前の点からの相対座標 (例: @10,150)。

閉じる: 最後のセグメントの最後の点は、最初のセグメントの最初の点に対応して、閉じた領域を作成します。


ポリライン

メニュー: 作図 > ポリライン

ポリラインを定義するには、連続した線セグメントまたは弧を作図します。線または弧の集合全体が 1 つのエンティティを形成します。ポリラインでは厚さを指定できます。2 番目のエンティティの 1 番目の点は、1 番目のエンティティの 2 番目の点に対応します。

ドキュメントに新しいポリラインが表示されると、ドック可能パネルには利用可能なオプションが表示されます。

コマンドを終了します。

最後の操作を元に戻します。

キーボード入力: 以下を入力できます。カンマで区切られた X および Y 座標 (例: 150,125)、"<" で区切られた距離と角度 (例: 150<45)、前の点からの相対座標 (例: @10,150)。

線: 作図した最後のエンティティの最後の点に基づいて線セグメントを作図できます。

弧: 作図した最後のエンティティの最後の点に基づいて弧を作図できます。パネル下部で円弧配置オプションを選択します。

幅: 次のエンティティに特定の厚さを設定できます。この厚さは、次のすべてのエンティティで使用されます。

閉じる: 最後のエンティティの最後の点は、最初のエンティティの最初の点に対応して、閉じた領域を作成します。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


弧

メニュー: 作図 > 弧

弧を作図できます。

新しい弧を作図する場合、3 つの点を指定して位置を定義します。

コマンドを終了します。

キーボード入力: 以下を入力できます。カンマで区切られた X および Y 座標 (例: 150,125)、"<" で区切られた距離と角度 (例: 150<45)、前の点からの相対座標 (例: 10,150)。

オプション: パネル下部で円弧配置オプションを選択します。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


円

メニュー: 作図 > 円

円を作図します。円を配置するには、円の中心点と円周上の点を定義します。

ドキュメントに新しい円を表示すると、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

座標の入力: X 座標と Y 座標の値を入力します。これらの座標値はカンマで区切ります (例: 150,125)。

半径: 円の半径の長さを入力するか、グラフィック領域で 2 番目の点をクリックします。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


楕円

メニュー: 作図 > 楕円

楕円を作図します。アクティブなドキュメントに楕円を配置するには、中心点と、エンティティの 2 つの軸を定義します。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

座標の入力: X 座標と Y 座標の値を入力します。これらの座標値はカンマで区切ります (例: 150,125)。

距離: 楕円の最初と 2 番目の軸の長さを入力します。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


楕円弧

メニュー: 作図 > 楕円弧

アクティブなドキュメント上に楕円弧を配置するには、中心点、楕円の両軸、円弧の 2 つの端点を定義します。

ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

座標の入力: X 座標と Y 座標の値を入力します。これらの 2 つの座標値はカンマで区切ります (例: 150,125)。

距離: 楕円の最初と 2 番目の軸の長さを入力します。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


矩形

メニュー: 作図 > 矩形

矩形を作図します。

アクティブなドキュメントに矩形を配置するには、対角寸法の長さを定義するか、ドック可能パネルでその長さと幅を指定します。

コマンドを終了します。

座標の入力: X 座標と Y 座標の値を入力します。これらの 2 つの座標値はカンマで区切ります (例: 150,125)。

寸法: 長さと幅に対応する値を入力します。

回転: 角度に対応する値を入力します。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


クラウド

メニュー: 作図 > クラウド

連続する円弧から構成される固有の形状を作図します。たとえば、リビジョン ステップ中にグラフィック表示に注目を集めるために使用されます。多言語テキストを使用して、リビジョン クラウドにコメントを入力します。

矩形、楕円形、またはフリーハンドの 3 つの形状を使用してクラウドを表現できます。これらの形状はリボンで直接選択するか、挿入中にドック可能パネルで選択できます。

コマンドを終了します。

最後の操作を元に戻します。

形状: 使用する形状を選択します。コマンド オプションは、選択した形状によって異なります。

座標の入力: X 座標と Y 座標の値を入力します。これらの 2 つの座標値はカンマで区切ります (例: 150,125)。

クラウド半径: 連続する円弧セグメントの半径を指定します。

矩形モード固有のオプション

寸法: 長さと幅に対応する値を入力します (矩形モードのみ)。

回転: 角度に対応する値を度単位で入力します (矩形モードのみ)。

楕円形モード固有のオプション

距離: 楕円の最初と 2 番目の軸の長さを入力します (楕円形モードのみ)。

フリーハンド モード固有のオプション

円弧/線: 作図するエンティティ タイプを選択します。円弧モードでは、その他の配置オプションがドック可能パネルの下部に表示されます。

幅: 線/円弧の幅を入力します。

閉じる: 形状を閉じます。終点の座標は始点の座標と同じです。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


ハッチ

メニュー: 作図 > ハッチ

選択したハッチ パターンで、図面エンティティ間または図面エンティティ内の領域を塗りつぶすオプションを表示する [ハッチ] ダイアログ ボックスを開きます。

ハッチ領域を定義するドキュメントのエンティティを選択してから、ハッチ をクリックします。または、[ハッチ] ダイアログ ボックスの [オブジェクトの選択] をクリックしてから、エンティティを選択します。

オブジェクトの選択: ハッチする領域を具現化するオブジェクトを選択できます。

タイプ: [事前定義] パターンまたは [ユーザー定義] を選択します。

パターン: このオプションは、[事前定義] を選択している場合のみ使用できます。パターン タイプを選択します｡

色: パターンの色を選択します。

角度: パターンの角度を選択します。

スケール: このオプションは、[事前定義] を選択している場合のみ使用できます。パターンのスケールを選択します。

間隔: このオプションは、[ユーザー定義] を選択している場合のみ使用できます。2 本の線間の距離を入力します。

両面: このオプションは、[ユーザー定義] を選択している場合のみ使用できます。垂直ハッチを追加する場合は、このボックスを選択します。

[OK] ボタンをクリックすると、ハッチが自動的に生成されます。

このエンティティ タイプを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


ワイプアウト

メニュー: 作図 > ワイプアウト

他のエンティティを隠すまたは非表示にする多面領域を定義します。

ワイプアウトを配置するには、形状の始点を定義してから後続の各点を定義します。

コマンドを終了します。

前のインターフェイスに戻ります。

最後の操作を元に戻します。

グラフィック領域のゾーン頂点をクリックするか、座標を入力します。このゾーンの後ろに配置されたグラフィック要素は非表示になります (削除されるわけではありません)。[修正] メニューの [順序] コマンドを使用して、ワイプアウトに対するエンティティの位置を管理します。

座標の入力: X 座標と Y 座標の値を入力します。これらの座標値はカンマで区切ります (例: 150,125)。


画像を添付

メニュー: 作図 > 画像を添付

ワークステーションに保存されている画像をアクティブなドキュメントにリンクさせる、一連のダイアログ ボックスの最初のダイアログ ボックスを開きます。画像を添付すると、リンクした画像のプレビューがドキュメントに表示されます。

ダイアログ ボックスが開き、添付画像を管理できます。

添付: 画像ファイルを添付できます。ファイルを選択すると、ダイアログ ボックスが開き、挿入パラメーターを定義できます。

削除: リストから選択した画像ファイル参照を削除し、アクティブなドキュメントからプレビュー画像を除去します。

添付画像を含むプロジェクトをアーカイブするには、データ ファイルのコマンドを使用してプロジェクトに添付画像ファイルを追加します。


画像の挿入

メニュー: 作図 > 画像の挿入

ワークステーションに保存されている画像をドキュメントに挿入する、一連のダイアログ ボックスの最初のダイアログ ボックスを開きます。挿入した画像はドキュメント ファイルの一部になります。

挿入点: 挿入点の座標を設定します。[後で指定] を選択すると、グラフィック領域で画像を挿入する際に、挿入点を設定できます。

スケール: 倍率を設定します。[後で指定] を選択すると、グラフィック領域で画像を挿入する際に、倍率を設定できます。

回転: 回転角度を設定します。[後で指定] を選択すると、グラフィック領域で画像を挿入する際に、回転角度を設定できます。


テキストを追加

メニュー: 作図 > テキストを追加

ドキュメントに 1 行テキストを挿入するための [テキストの作成] ダイアログ ボックスを開きます。

テキスト: 現行ファイルに挿入するテキスト文字列を入力します。テキストを空にすることはできません。

テキスト オプション

両端揃え: テキストの両端揃えを定義します。

テキスト スタイル: テキスト スタイルを定義します。[テキスト スタイル マネージャー] をクリックすると、テキスト スタイル定義にアクセスできます。

回転: 回転角度を設定します。[後で指定] を選択すると、グラフィック領域でテキストを挿入する際に、回転角度を設定できます。

高さ: テキスト高さを設定します。[後で指定] を選択すると、グラフィック領域でテキストを挿入する際に、テキスト高さを設定できます。

斜角: 斜めのテキストの角度値を度で定義します。

幅係数: テキストを拡大する場合にテキスト高さを維持します。

上下反転: 垂直ミラーでテキストを挿入します。

戻る: 水平ミラーでテキストを挿入します。

挿入点

テキストの座標を設定します。[後で指定] を選択すると、グラフィック領域でテキストを挿入する際に、挿入点を設定できます。

注記: [多言語テキスト] 挿入コマンドでドキュメントに追加したテキストとは異なり、[テキストを追加] ([作図] メニュー) で追加したテキストはプロジェクト データベースに表示されません。


複数行テキスト

メニュー: 作図 > 複数行テキスト

複数行ブロックのテキストを挿入するダイアログ ボックスを開きます。

ツール メニューのテキスト スタイル マネージャーで現在選択しているテキスト スタイルで、複数行テキストの表示を制御します。

テキストを入力するためのダイアログ ボックスが開きます。

注記: 多言語テキスト挿入コマンドでドキュメントに追加したテキストとは異なり、複数行テキスト (作図 メニュー) で追加したテキストはプロジェクト データベースに表示されません。


属性

メニュー: 作図 > 属性

属性を作成するダイアログ ボックスを開きます。一般的には、ブロックを挿入するたびに、属性によって別のテキストを追加できます。

ダイアログ ボックスでは属性を作成できます。

属性

名前: 属性名です。属性名はブロック定義内で一意でなければなりません。

プロンプト: 属性を含めるブロックを挿入する際に、プロンプト メッセージを表示します。

値: 属性のデフォルト値が含まれます。

モード

非表示: ブロックを挿入する際に、属性値を非表示にします。

固定: ブロックを挿入する際に、属性の固定値を適用します。

確認: ブロックを挿入する際に、値を確認します。

定義済み: ブロックを挿入する際に、デフォルト値に戻します。

テキスト オプション

両端揃え: 属性の両端揃えを定義します。

テキスト スタイル: テキスト スタイルを定義します。[テキスト スタイル マネージャー] ではテキスト スタイル定義にアクセスできます。

回転: 回転角度を設定します。[後で指定] を選択すると、グラフィック領域で属性を挿入する際に、回転角度を設定します。

高さ: 属性の高さを設定します。[後で指定] を選択すると、グラフィック領域で属性を挿入する際に、属性の高さを設定します。

斜角: 斜めのテキストの角度値を度で定義します。

幅係数: 高さを変更しないでテキストを拡大できます。

上下反転: 垂直ミラーで属性を挿入します。

戻る: 水平ミラーで属性を挿入します。

挿入点

属性の座標を設定します。[後で指定] を選択すると、グラフィック領域で属性を挿入する際に、挿入点を設定します。


ブロックの作成

メニュー: 作図 > ブロックの作成

アクティブなドキュメントから、ドキュメントに複数回再挿入できる、エンティティの名前付きブロックまたはグループを作成します。

名前付きブロックはアクティブなドキュメントのみのブロック定義テーブルに表示されます。そのため、現行ファイルで定義されたブロックのみ使用できます。

コマンドを終了します。

前のインターフェイスに戻ります。

ブロック エンティティを選択すると、ダイアログ ボックスが開き、ブロックのパラメーターを入力できます。

名前: ブロック名です。この名前は DWG ファイル内で一意でなければなりません。

選択したオブジェクト

別個のエンティティとして維持: 選択したエンティティは別個に維持されます。エンティティはブロックに変換されません。

ブロックに変換: 選択したエンティティをブロックに変換します。

削除: 選択したエンティティを削除します。[ブロックの挿入] コマンドで再挿入できます。

基本点

挿入点の座標を入力するか、[画面上で指定] オプションを選択します (ダイアログ ボックスを閉じたら、グラフィック領域で挿入点をクリックする必要があります)。


ブロックの挿入

メニュー: 作図 > ブロックの挿入

ドキュメントにエンティティの名前付きブロックまたはグループを挿入します。

現在のブロック定義テーブルで指定したブロックを追加したり、ドキュメントに外部 DWG ファイルのブロック コンテンツを挿入できるダイアログ ボックス シーケンスが起動します。

ブロックに属性が含まれている場合、アクティブなドキュメントにブロックを挿入する際に属性を編集できます。

参照: ワークステーションに保存されている DWG ファイルを選択できます。このファイルに含まれているすべてのエンティティが挿入されます。

ブロック名: このオプションが有効な場合、挿入するブロックの名前を選択する必要があります。

分解: 挿入したブロックを分解します。ブロックを構成するすべてのエンティティが別々に挿入されます。

挿入点

挿入点の座標を設定します。[後で指定] を選択すると、グラフィック領域でブロックを挿入する際に、挿入点を設定できます。

スケール

倍率を設定します。[後で指定] を選択すると、グラフィック領域でブロックを挿入する際に、倍率を設定できます。[分解] を選択した場合、この設定は使用できません。

回転

回転角度を設定します。[後で指定] を選択すると、グラフィック領域でブロックを挿入する際に、回転角度を設定できます。

ブロックの挿入コマンドを使用して電気配線図を作成しないでください。このコマンドで配置したグラフィック エンティティはプロジェクト データベースでは管理されません。


寸法コマンド

[作図] メニューの [寸法] グループにあるコマンドを使用して 2D レイアウト図面に寸法を追加できます。

これらの寸法コマンドは、寸法スタイル マネージャー で管理する寸法スタイル設定を使用します。

  • 長さ寸法

  • 配置された寸法

  • 直径寸法

  • 半径寸法

  • 座標寸法

  • 角度寸法


長さ寸法

メニュー: 作図 > 長さ寸法

平行線上で X-Y 軸の寸法を作成します。

コマンドを終了します。

最初の延長線の始点に対応する最初の点をクリックするか、その座標を入力します。

2 番目の延長線の始点に対応する 2 番目の点をクリックするか、その座標を入力します。

寸法線の位置をクリックします。

座標の入力: X 座標と Y 座標の値を入力します。これらの 2 つの座標値はカンマで区切ります (例: 150,125)。


配置された寸法

メニュー: 作図 > 配置された寸法

2 つの選択された始点を接続する線に平行な寸法を作成します。

コマンドを終了します。

最初の延長線の始点に対応する最初の点をクリックするか、その座標を入力します。

2 番目の延長線の始点に対応する 2 番目の点をクリックするか、その座標を入力します。

寸法線の位置をクリックします。

座標の入力: X 座標と Y 座標の値を入力します。これらの 2 つの座標値はカンマで区切ります (例: 150,125)。


直径寸法

メニュー: 作図 > 直径寸法

弧または円の直径の寸法を作成します。

コマンドを終了します。

選択内容を確認します。

円または弧をグラフィック領域で選択し、寸法の位置を指定します。


半径寸法

メニュー: 作図 > 半径寸法

弧または円の半径の寸法を作成します。

コマンドを終了します。

選択内容を確認します。

円または弧をグラフィック領域で選択し、寸法線の位置を指定します。


座標寸法

メニュー: 作図 > 座標寸法

2 点間の水平方向または垂直方向の距離を測定する寸法を作成します。

コマンドを終了します。

測定する 2 点を定義し、寸法線の位置を指定します。

座標の入力: X 座標と Y 座標の値を入力します。これらの 2 つの座標値はカンマで区切ります (例: 150,125)。


角度寸法

メニュー: 作図 > 角度寸法

角度寸法を作成します。

コマンドを終了します。

選択内容を確認します。

角度の 2 本の線を選択し、寸法線の位置を指定します。


修正のコマンド

[修正] メニューの [編集] および [修正] グループのコマンドを使用して、さまざまな既存のエンティティを操作できます。

注記: [修正] コマンドを使って、電気エンティティを変更できます。こうした変更によって、プロジェクト データベースのエンティティ レコードは自動的に更新され、配線図の設計ルールと整合性がなくなることに注意してください。このため、電気エンティティを変更する場合は、すべての [修正] コマンドは使用しないでください。

  • プロパティ

  • ブラシ

  • 配列

  • 消去

  • 移動

  • 複数コピー

  • オフセット

  • 回転

  • スケール

  • ミラー

  • フィレット

  • 伸縮

  • トリム

  • 延長

  • ブロックの配置

  • 距離

  • 消去

  • 分解

  • レイヤー

  • 複数の属性

  • 属性の編集

  • テキストの編集

  • ハッチを編集

  • 寸法を更新

  • 順序 - フォアグラウンドを設定

  • 順序 - バックグラウンドを設定

  • 順序 - エンティティの下に移動

  • 順序 - エンティティの上に移動


ブラシ

メニュー: 修正 > ブラシ

あるエンティティのプロパティを別のエンティティにコピーします。

個別エンティティまたは複数のエンティティのブラシ プロパティを変更する際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

基準エンティティを選択してから、コピーしたプロパティを適用するエンティティを選択します。

電気配線図のエンティティに ブラシ コマンドを使用しないでください。


消去

メニュー: 修正 > 消去

選択したエンティティを削除します。

エンティティを削除する場合、ドック可能パネルには利用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

削除するエンティティを選択して確認します。エンティティを選択して Del キーを押しても削除できます。

注記: シンボルやワイヤなどの電気配線図のエンティティにこのコマンドを使用すると、プロジェクト データベースが自動更新されます。


移動

メニュー: 修正 > 移動

選択したエンティティを、指定した距離と方向に移動します。

コマンドを終了します。

選択内容を確認します。

移動するエンティティを選択してから、基点の座標 (始点) と終点の座標 (終点) を指定します。

座標の入力: X 座標と Y 座標の値を入力します。これらの 2 つの座標値はカンマで区切ります (例: 150,125)。

距離: 移動の長さを入力できます。構文 (線の長さ<角度) を使用します。例: 100<45 は、選択したエンティティを 45°の角度で 100 単位の長さまで移動します。

電気エンティティ (シンボル、ワイヤなど) でこのコマンドを使用すると、プロジェクト データベースが自動的に更新されます。


複数コピー

メニュー: 修正 > 複数コピー

選択したエンティティの複数コピーを作成します。

アクティブなドキュメントに複数コピーを挿入する際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

コピーする項目を選択してから、基点 (始点) と終点 (終点) を指定します。

座標の入力: X 座標と Y 座標の値を入力します。これらの座標値はカンマで区切ります。例: 150,125

距離: コピーの長さを入力できます。この構文 (線の長さ<角度) を使用します。例:100<45。

この例は、選択したエンティティを 100 単位の長さと 45° の角度でコピーします。

注記: シンボルやワイヤなどの電気配線図のエンティティにこのコマンドを使用すると、プロジェクト データベースが自動更新されます。


配列

メニュー: 修正 > 配列

選択したエンティティの複数のコピーを、垂直および水平パターンで作成します。

配列を追加する際、ドック可能パネルに利用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

行: 必要な行数 (垂直方向のコピー数) を入力します。

列: 必要な列数 (水平方向のコピー数) を入力します。

オブジェクト選択: このボタンをクリックして、コピーするエンティティを選択します。

行オフセット: コピーされた各エンティティ間の距離を入力するか、ボタンをクリックして距離をグラフィックで定義します。

列オフセット: コピーされた各エンティティ間の距離を入力するか、ボタンをクリックして距離をグラフィックで定義します。

注記: シンボルやワイヤなどの電気配線図のエンティティにこのコマンドを使用すると、プロジェクト データベースが自動更新されます。


回転

メニュー: 修正 > 回転

基点を中心としたエンティティの方向を修正します。

コマンドを終了します。

選択内容を確認します。

処理するエンティティを選択し、グラフィック領域で点をクリックするか値を入力して、回転の基点と角度を指定します。

回転角度を指定: 角度値を入力します。

電気エンティティ (シンボル、ワイヤなど) でこのコマンドを使用すると、プロジェクト データベースが自動的に更新されます。


スケール

メニュー: 修正 > スケール

X 方向と Y 方向の比率を変えずに、選択したエンティティのサイズを変更します。

選択したエンティティのサイズを変更する際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

エンティティを選択します。

座標の入力: グラフィックス領域でクリックするか、またはその座標で基点を指定します。

属性: ブロックの属性に倍率を適用する場合は、[同じサイズを保持] オプションを選択します。

軸倍率を入力: 必要なモード ([縮小] または [拡大]) を選択し、グラフィック領域でクリックして 2 番目の点を指定するか、倍率の値を入力します。

スケールを使用して、電気配線図のエンティティのプロパティを変更しないでください。


ミラー

メニュー: 修正 > ミラー

指定した対称軸を使って、選択したエンティティの反転コピーを作成します。

選択したエンティティのミラー イメージを追加する際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

処理するエンティティを選択し、対称軸の 2 つの終点を指定してから、ソース オブジェクトを消去するかどうかを選択します。

座標の入力: X 座標と Y 座標の値を入力します。これらの座標値はカンマで区切ります (例: 150,125)。

距離: 線の長さを入力します。この構文 (線の長さ<角度) を使用します。例:100<45 は、長さが 100 単位で角度が 45° の線を作図します。

ソース オブジェクトを削除: 元のエンティティを削除します。

注記: シンボルやワイヤなどの電気配線図のエンティティにこのコマンドを使用すると、プロジェクト データベースが自動更新されます。


フィレット

メニュー: 作図 > フィレット

2 本の交差する線を、指定した半径の弧で結合します。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

調整/調整しない: 弧の端点で線を切り取る (切り取らない) ことができます。

半径の変更: 弧の半径を入力できます。

フィレットを追加する 2 本の線を選択します。


オフセット

メニュー: 修正 > オフセット

同心円、平行線、平行曲線を作成します。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

既存のエンティティまたは所定の点から指定した距離に、新しいエンティティを作成します。

オフセット定義

経由点: 元のエンティティとコピー間の距離に対応する 2 点をクリックします。

距離: 元のエンティティとコピー間の距離を入力します。

コピーするエンティティを選択し、そのエンティティをコピーするサイドのコピー先を示す点をクリックします。

電気エンティティ (シンボル、ワイヤなど) でこのコマンドを使用すると、プロジェクト データベースが自動的に更新されます。


伸縮

メニュー: 修正 > 伸縮

エンティティの選択した点を移動します。

エンティティの一部の点のみを選択した場合、選択していない点は現在の位置にとどまります。そのため、選択した点を移動すると、エンティティが伸縮します。

エンティティのすべての点を選択すると、エンティティ全体が移動します。

コマンドを終了します。

選択内容を確認します。

伸縮コマンドでは、選択ウィンドウに含まれる点のみが移動します。選択ウィンドウ外の点は変更されません。選択ウィンドウ内のすべてのオブジェクトが移動されます。伸縮する点を選択してから、基点と終点を指定します。

距離: 距離の長さを入力します。この構文 (線<角度) を使用します。例: 100<45 は、長さが 100 単位で角度が 45° の線を作図します。


トリム

メニュー: 修正 > トリム

アクティブなドキュメントで他のエンティティと交差または重複するエンティティをトリムします。

コマンドを停止できます。

選択内容を確認します。

トリムの境界となるエンティティを選択し、トリムするエンティティを選択します。


延長

メニュー: 修正 > 延長

エンティティを、別のエンティティに達するか交差するまで延長します。

エンティティを延長する際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

延長を制限するエンティティを選択してから、延長するエンティティを選択します。


ブロックの配置

メニュー: 修正 > ブロックの配置

参照ブロックから、選択したブロックを配置します。

最初のステップで、参照ブロックを選択します。ドック可能パネルに使用可能なオプションが表示されます。

コマンドを終了します。

選択内容を確認します。

オプション

最も近い: 選択したブロックは、その挿入点の場所に応じて、垂直または水平に移動します。その場所に最も近い軸が使用されます。

水平: 選択したブロックの挿入点は、水平な軸から配置されます。

垂直: 選択したブロックの挿入点は、垂直な軸から配置されます。

これらのオプションのいずれかを選択してから、参照ブロックから配置するブロックを選択します。

配置は、参照ブロックの挿入点から行われます。


距離

メニュー: 修正 > 距離

2 点間の距離を測定します。

2 点間の距離を測定する場合、ドック可能パネルには利用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

グラフィック領域で 2 点をクリックします。

メッセージには、距離、角度、およびデルタ X とデルタ Y の値が表示されます。


消去

メニュー: 修正 > 消去

ドキュメントの定義テーブル内の使用されていない行ブロック、テキスト スタイル、線種などの要素を削除できます。DWG ファイルを消去すると、ファイル サイズが縮小または最適化されます。

ダイアログ ボックスには、「消去可能」要素と「消去不可能」要素が表示されます。

DWG ファイルで使用されていない場合、要素を消去できます。

ダイアログ ボックスで、消去する要素を選択します。複数選択キー (Ctrl、Shift) を使用できます。

DWG ファイルを消去する際に、[消去] ダイアログ ボックスに使用可能なオプションが表示されます。

各要素の削除を確認: 選択すると、削除ごとにメッセージ ボックスが開きます。それぞれの削除内容を確認する必要があります。

ネストした要素を消去: 選択すると、ネストした要素 (他の要素に依存する要素) がすべて削除されます。

選択項目を消去: 選択した要素を消去します。

すべて消去: 選択内容に関係なくすべての要素を消去します。

電気配線図を含むドキュメントで [消去] ([修正] メニュー) を使用しないでください。


分解

メニュー: 修正 > 分解

ブロックを構成エンティティに分解できます。

コマンドを終了します。

選択内容を確認します。

分解するブロックを選択します｡このブロックに属性が含まれる場合は、属性値は失われます。

電気配線図のエンティティに対して、分解 (修正 メニュー) を使用しないでください。


レイヤー

メニュー: 修正 > レイヤー

現行の DWG ファイルのレイヤーを管理できるダイアログ ボックスを開きます。各 DWG ファイルのレイヤー数は無制限です。

DWG ファイルのレイヤーを管理する際に、[レイヤー マネージャー] ダイアログ ボックスに使用可能なオプションが表示されます。

レイヤーの追加: レイヤーを新規作成します。[名前] 列でレイヤーの名前を変更できます。

選択項目を削除: 選択したレイヤーを削除します。エンティティを含んでいるレイヤーは削除できません。

選択したレイヤーを現在のレイヤーに設定: リストでレイヤーを選択して、「現在のレイヤー」に割り当てます。描画しているレイヤーが現在のレイヤーです。リストでは特定のアイコンで識別されます。

各レイヤーはデフォルトで色、線種、線幅に関連付けられます。このレイヤーで描画したエンティティには、デフォルトでこれらのパラメーターが設定されます。レイヤーに対応するセルをクリックすると、これらの項目を選択できます。

表示および印刷時にレイヤーを非表示にできます。

有効/無効: レイヤーに配置したエンティティは非表示になり、印刷できません。

フリーズ/フリーズ解除: グラフィックについては、このコマンドは「有効/無効」コマンドと同様です。

大きいファイルでは、「有効/無効」コマンドの使用をお勧めします。すべてのエンティティの表示が高速になります。

印刷: レイヤーを印刷できるようにするかどうかを定義します (非表示レイヤーは印刷されません)。

電気配線図を含むドキュメントで レイヤー (修正 メニュー) を使用しないでください。


属性の編集

メニュー: 修正（Modify）> 属性の編集（Edit attributes）

ブロックが含まれているドキュメントの場合、選択したブロックの属性プロパティを編集できるダイアログ ボックスが表示されます。

ブロックの属性を編集する際に、ドック可能パネルにダイアログ ボックスを起動するための要件が表示されます。

コマンドを終了します。

選択内容を確認します。

ブロックを選択します｡ダイアログ ボックスにブロックの属性のリストが表示されます。

ブロック名: ブロック名を表示します。

属性の追加: 新しい属性を追加できます。リストの最後に新しい行が追加されます。新しい属性の特性を変更できます。

属性の削除: 選択した属性を削除します。

属性に関連付けられたすべてのパラメーターを変更できます。

ダイアログ ボックスを閉じると、ブロックの属性が自動的に更新されます。

電気配線図のエンティティに [属性の編集] コマンドを使用しないでください。


ハッチを編集

メニュー: 修正 > ハッチを編集

ハッチングされた領域を含むドキュメントに対して、選択したハッチング領域のオプションを変更できます。

コマンドを停止できます。

選択内容を確認します。

ハッチング オプションのあるダイアログ ボックスが開き、特性を修正できます。

タイプ: [事前定義] パターンまたは [ユーザー定義] を選択します。

パターン: このオプションは、[事前定義] オプションを選択している場合のみ使用できます。パターン タイプを選択します｡

色: パターンの色を選択します。

角度: パターンの角度を選択します。

スケール: このオプションは、[事前定義] オプションを選択している場合のみ使用できます。パターンのスケールを選択します。

間隔: このオプションは、[ユーザー定義] オプションを選択している場合のみ使用できます。2 本の線間の距離を入力します。

両面: このオプションは、[ユーザー定義] オプションを選択している場合のみ使用できます。垂直ハッチを追加する場合は、このボックスをオンにします。

ダイアログ ボックスを閉じると、ハッチは自動的に更新されます。


寸法を更新

メニュー: 修正 > 寸法を更新

選択した寸法を現在の寸法スタイルに更新します。新しいデフォルト寸法を選択しないでこのコマンドを使用すると、更新は行われません。

寸法スタイルを更新する際に、ドック可能パネルに現在のデフォルト寸法スタイルが表示されます。

コマンドを終了します。

寸法には現在のスタイルで定義されているパラメーターが使用されます。

更新する寸法を選択します｡


順序 - フォアグラウンドを設定

メニュー: 修正 > 順序 > フォアグラウンドを設定

選択したエンティティを他のエンティティのフォアグラウンドに引き出します。

エンティティをフォアグラウンドに引き出す際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

フォアグラウンドに設定するエンティティを選択します。


順序 - バックグラウンドを設定

メニュー: 修正 > 順序 > バックグラウンドを設定

選択したエンティティをアクティブなドキュメントの他のすべてのエンティティのバックグラウンドに押し出します。

エンティティをバックグラウンドに押し出す際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

バックグラウンドに設定するエンティティを選択します。


順序 - エンティティの下に移動

メニュー: 修正 > 順序 > エンティティの下に移動

最初に選択したエンティティ セットを 2 番目に選択したエンティティ セットの後ろに押し出します。

最初のエンティティ セットを 2 番目のセットの後ろに押し出す際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

最初に、フォアグラウンドに描画されたエンティティを選択してから、バックグラウンドに描画されたエンティティを選択します。


順序 - エンティティの上に移動

メニュー: 修正 > 順序 > エンティティの上に移動

最初に選択したエンティティ セットを 2 番目に選択したエンティティ セットの前に引き出します。

最初のエンティティ セットを 2 番目のセットの前に引き出す際に、ドック可能パネルに使用可能なオプションが表示されます。

コマンドを固定し、初めて使用した後にコマンドを有効な状態に保ちます。

コマンドを初回使用後に停止します。

コマンドを終了します。

前のインターフェイスに戻ります。

最初に、バックグラウンドに描画されたエンティティを選択してから、フォアグラウンドに描画されたエンティティを選択します。


グラフィック形式マネージャー

すべての DWG ファイルおよび DesignSpark Electrical 図面には、線、テキスト、寸法を含めることができます。線種、テキスト スタイル、寸法スタイルに対して、保存済みの定義でこれらの要素の外観を設定できます。また、新しいカスタム定義を設定したり、既存の定義を編集したりできます。

[ツール] メニューのグラフィック形式グループのコマンドを使用して、さまざまなエンティティの形式を管理できます。

  • 線種マネージャー

  • テキスト タイプ マネージャー

  • 寸法タイプ マネージャー


線種マネージャー

メニュー: ツール/線種

[線種マネージャー] ダイアログ ボックスが開き、DWG ファイルや電気配線図で現在使用できる線種を一覧表示します。

現在使用できる線種がリストに表示されます。使用できる線種の数は各ドキュメントで個別に設定するため、このリストはファイルによって異なる場合があります。

アクティブなドキュメントの線種は、次のオプションを使用して管理します。

読み込み: このボタンはファイルで使用できるすべての線種のリストを開きます。線種は [開く] ボタンをクリックして選択できる XLIN ファイルに保存されます。このリストで、現行ファイルにインポートする線種を選択します。

選択項目を削除: 選択されている線種を削除します。DWG ファイル（または電気配線図）で使用されている線種は削除できません。

選択内容を現在の項目に設定: 選択した線種を DWG ファイル (または電気配線図) 内の現在の項目に設定します。


線種を読み込む

メニュー: ツール > 線種 > 読み込む

本ソフトウェアは、各 DWG ファイルまたは電気配線図に、選択した線種のみを読み込みます。このため、使用できる線種のリストは、ドキュメントに応じて異なります。

アクティブなドキュメントで使用できない定義済み線種を使用する場合は、デフォルトの XLIN ファイルにリストされる線種を読み込む、またはカスタムの XLIN ファイルから線種をインポートしてください。

開く: XLIN ファイルを開きます。

選択内容を読み込んで閉じる: マネージャーでインポートする線種を選択します。ダイアログ ボックスが閉じると、マネージャー リストに線種が自動的に追加されます。

すべて読み込んで閉じる: すべての線種がマネージャーにインポートされます。線種は、ダイアログ ボックスが閉じるとき、マネージャー リストに自動的に追加されます。


テキスト スタイル マネージャー

メニュー: ツール > テキスト スタイル

DWG ファイルまたは電気配線図で使用できる、現在使用可能なテキスト スタイルを一覧表示する [テキスト スタイル マネージャー] ダイアログ ボックスを開きます。新しい現在のテキスト スタイルを選択すると、アクティブなドキュメントにテキストを追加するすべてのコマンドで、定義したスタイルが使用されます。ドキュメントごとにテキスト スタイルを定義する必要があるため、使用可能なスタイルのリストはファイルやプロジェクトで異なる可能性があります。

アクティブなドキュメントの現在のテキスト スタイルを選択するオプションや、使用可能なスタイル リストのテキスト スタイルを表示、追加、編集、削除するオプションは以下のとおりです。

テキスト スタイルの追加: 新しいテキスト スタイルを追加します。リストの最後に新しい行が追加されます。名前とパラメーターを変更できます。

選択項目を削除: 選択したテキスト スタイルを削除します。DWG ファイル（または電気配線図）で使用されているテキスト スタイルは削除できません。

選択したスタイルを現在のスタイルに設定: 選択したテキスト スタイルを DWG ファイル (または電気配線図) の現在のスタイルとして定義します。


寸法スタイル マネージャー

メニュー: ツール > 寸法スタイル

DWG ファイルまたは電気配線図で使用できる、寸法スタイルを一覧表示する [寸法スタイル マネージャー] ダイアログ ボックスを開きます。

新しい現行寸法スタイルを選択すると、アクティブなドキュメントに寸法を追加するすべてのコマンドで、定義したスタイルが使用されます。また、[寸法を更新] ([修正] メニュー) で更新した寸法は新しい現行寸法スタイルに変更されます。ドキュメントごとに寸法スタイルを定義する必要があるため、使用可能なスタイルのリストはファイルやプロジェクトで異なる可能性があります。

現行寸法スタイルを選択する方法や、使用可能なスタイル リストの寸法スタイルを表示、追加、編集、削除する場合は、次のいずれかのオプションを使用します。

現在の項目として設定: 選択した寸法スタイルを DWG ファイル (または電気配線図) の現在のスタイルとして定義します。

新規: 新しい寸法スタイルを追加できます。ダイアログ ボックスでは、寸法スタイルに名前を付けたり、基本の既存スタイルを選択できます。

修正: 選択した寸法スタイルのパラメーターを変更できます。すべての寸法スタイル設定を表示するダイアログ ボックスが開きます。

比較: 2 つの寸法スタイルを比較します。

削除: 選択した寸法スタイルを削除します。DWG ファイル (または電気配線図) で使用されている寸法スタイルを削除することはできません。


新しい寸法スタイル

メニュー: ツール > 寸法スタイル > 新規

新しい寸法スタイルを作成するダイアログ ボックス シーケンスを起動します。

新しいスタイル: 新しい寸法スタイルの名前を定義します。この名前は DWG ファイル（または電気配線図）内で一意でなければなりません。

コピー: 既存の寸法ファイルを選択します。既存のこの寸法スタイルのすべての設定が新しい寸法スタイルにコピーされます。

作成ダイアログ ボックスを閉じると、寸法スタイルの編集ダイアログ ボックスが開き、寸法スタイルのパラメーターを変更できます。


寸法スタイルの変更

メニュー: ツール > 寸法スタイル > 変更

既存の寸法スタイルを編集、プレビューする [寸法スタイルの変更] ダイアログ ボックスを開きます。また、このダイアログ ボックスで新しい寸法スタイルのパラメーターを設定します。

ダイアログ ボックスの右側に、選択した寸法スタイルのプレビューが表示されます。

線と矢印

寸法線: 寸法線の色と幅を定義します。ベースライン間隔パラメーターはまだ実装されていません。

延長線: 延長線の色と幅を定義します。また、延長戦の位置と長さを管理できます。

矢じり: 矢印のサイズを定義します。

テキスト

テキスト表示: 寸法値を具現化するテキストの色、スタイル、高さを定義します。

テキスト配置: 寸法値を具現化するテキストの位置を定義します。

テキスト整列: 寸法値を具現化するテキストの整列を定義します。

調整

調整オプション: 寸法の配置を最適化します。

調整: 小さい寸法を定義します。

寸法オブジェクト スケール: 寸法オブジェクトに割り当てる倍率を定義します。

主要単位

長さ寸法: 長さ寸法の精度と区切り文字を定義します。

測定スケール: すべての寸法の倍率を定義します (実数値 x 倍率 = 表示される値)。

角度寸法: 角度寸法の測定モードと精度を定義します。


寸法スタイルの比較

メニュー: ツール > 寸法スタイル > 比較

選択した 2 つの寸法スタイルの違いを表示する [寸法スタイルの比較] ダイアログ ボックスを開きます。

比較する 2 つの寸法スタイルを選択します。

一致しない項目がダイアログ ボックスに表示されます。


マネージャー構成

どのマネージャーを開いても、内容は相違しますが、すべてのマネージャーで共通して次の全機能を利用できます。

構成

シンボル マネージャー: 構成

タイトル ブロック マネージャー: 構成

パターン マネージャー: 構成

ダイアログ ボックスが開き、マネージャー画面の各種構成パラメーターを入力できます。

リスト モード

ダイアログ ボックスの左側では、「リスト」モードで表示される列を選択できます。

サムネイル モード

サムネイル サイズ: サムネイルの寸法を入力します。

2 つのサムネイル間のスペース: サムネイルを区切る距離を幅と高さで入力します。サムネイルに表示される記号または名前はこの領域に表示されます。サムネイルの 2 つの線間には必ず十分な距離を確保してください。

サムネイルの下のテキスト: 表示されるテキストのタイプを選択します。

サムネイルの表示: プロパティ (データの反映に使用) を表示しない場合は、ボックスを選択します。

サムネイル モード/リスト モード

シンボル マネージャー: リスト モード/サムネイル モード

タイトル ブロック マネージャー: リスト モード/サムネイル モード

2D フットプリント マネージャー: リスト モード/サムネイル モード

パターン マネージャー: リスト モード/サムネイル モード

リスト モード: リスト形式でデータを表示します。列見出しを右クリックすると、表示する列を選択できます。列見出しの左クリックで、この列を並び替えることができます。

サムネイル モード: グラフィック形式でデータを表示します。

いずれのモードでも、コンテキスト メニューを使用して、要素に使用できる各種機能にアクセスできます。

サブクラスの内容の表示

ライブラリに生成される要素には、分類に使用できる条件があります (左側の領域にあるツリー構造形式のリストを参照)。ツリー構造リストで分類が選択されると、右側のリストが簡易表示となり、選択したクラスに対応する要素のみが表示されます。

[サブクラスの内容を表示します] ボックスをオンにすると、ダイアログ ボックスではクラスのサブレベルに含まれる要素も表示されます。

シンボル/タイトル ブロック/パターンの編集時にマネージャーを終了

要素 (シンボル、タイトル ブロック) を編集してグラフィックスを修正するときには、[マネージャー] ダイアログ ボックスを開いたままにするか閉じることができます。

関連トピック:

タイトル ブロック マネージャー

シンボル マネージャー

パターン マネージャー


クラス選択

シンボル マネージャー > プロパティ: クラス名

タイトル ブロック マネージャー > プロパティ: クラス名

パターン マネージャー > プロパティ: クラス

メーカー部品セレクター: クラス

シンボル、パターン、タイトル ブロックを編集する場合、クラス セレクターによって、その要素に関連付けられたクラスを選択できます。

クラス選択の内容は、要素タイプに応じて自動的に変わります。

[メーカー部品セレクター] ダイアログ ボックスで、検索条件としてクラスを使用します。


アーカイブと解凍

どのマネージャーを開いても、内容は相違しますが、すべてのマネージャーで共通して次の全機能を利用できます。

この機能をプロジェクトのアーカイブと解凍と混同しないようにしてください。この機能では、1 つ以上の要素 (シンボル、タイトル ブロック) を TEWXIP ファイルにアーカイブし、別のワークステーションで解凍します。TEWXIP ファイルに含まれる要素は解凍時に自動的にライブラリに配置されます。この機能は、たとえば 2 社間でシンボルをやり取りする間に使用します。

シンボル マネージャー: アーカイブ (解凍)

タイトル ブロック マネージャー: アーカイブ (解凍)

パターン マネージャー: アーカイブ (解凍)

アーカイブ

1. アーカイブする要素を選択します。

2. [アーカイブ] アイコンをクリックします。

ダイアログ ボックスが開き、アーカイブ ファイルを保存できます。

解凍

ダイアログ ボックスが開き、解凍する TEWZIP ファイルを選択できます。データ更新ウィザードが自動的に開きます。詳細については、「アーカイブと解凍」の章を参照してください。

関連トピック:

タイトル ブロック マネージャー

シンボル マネージャー

パターン マネージャー

アーカイブと解凍


DWG ファイルのインポート

どのマネージャーを開いても、内容は相違しますが、すべてのマネージャーで共通して次の全機能を利用できます。以下の章では、シンボルのインポート方法を説明します。機能は、タイトル ブロックのインポートの場合と同じです。

ライブラリ (シンボル、タイトル ブロックなど) を入力する場合、DWG 形式のファイルをインポートできます。

シンボル マネージャー: DWG ファイルのインポート

タイトル ブロック マネージャー: DWG ファイルのインポート

インポート アシスタントの表示は、インポートする要素によって異なる可能性があります。

ステップ 1.シンボル (タイトル ブロック) インポート ウィザード

ファイルの追加: [ファイル選択] ダイアログ ボックスが開きます。シンボル、タイトル ブロックを含む DWG ファイルまたはアーカイブ ファイル (ZIP) を選択できます。

フォルダーの追加: [ディレクトリ選択] ダイアログ ボックスが開きます。このフォルダー/ディレクトリに含まれるすべての DWG ファイルがインポート アシスタントに追加されます。

削除: 選択した要素をリストから削除します。

次のステップに移動するには、[次へ] をクリックします。

ステップ 2.シンボル (タイトル ブロック) の始点

構成をインポート: インポート パラメーターを含む構成を選択できます。

情報

インポートする要素が表示されるリストが作成されます。

ステップ 3.新しいシンボル (タイトル ブロック) のインポート

インポート アシスタントにはインポートする要素のリストが表示されます。

すべて選択: リストに表示される、すべてのシンボルを選択できます。

プロパティ: 選択したシンボル (タイトル ブロック) のプロパティ ダイアログ ボックスが開きます。複数のシンボル (タイトル ブロック) を選択すると、共通プロパティのみがダイアログ ボックスに表示されます。シンボル (タイトル ブロック) のプロパティは、ダブルクリックすると編集可能になります。

操作: シンボル (タイトル ブロック) に割り当てるアクションをリストから選択します。

名前: シンボル (タイトル ブロック) 名が表示されます。

説明: プロパティを編集して説明を追加できます。

単位系: シンボル (タイトル ブロック) を描画した単位系をリストから選択します。

クラス: 選択した要素にクラスを関連付けることができます。

ライブラリ: 要素を保存するライブラリを選択します。

変更日: インポートした日付を表示します。

ステップ 4.属性の変換

次の手順では、ソフトウェアで管理される属性と、インポートされた要素で表示される可能性のある属性とを関連付けます。

置換: [...] ボタンをクリックして、新しい属性を選択します。

操作: 目的のオプション ([置換]/[削除]/[何もしない]) を選択します。

ステップ 5.設定の保存

アシスタントの最後の手順では、インポートに使用した各種設定を保存できます。これらのパラメーターは新しいインポートで再利用できます。

インポート構成の保存

構成ファイルを使用した場合は、それを更新できます。構成ファイルを使用しなかった場合は、新しい構成ファイルに設定を保存できます。

[完了] をクリックして要素をインポートするか、[キャンセル] をクリックしてインポートをキャンセルします。これはインポートをキャンセルできる最後のダイアログです。

関連トピック:

タイトル ブロック マネージャー

シンボル マネージャー

パターン マネージャー


グラフィック マネージャー

シンボル、2D フットプリント、タイトル ブロックは、マネージャーという名前の特定のライブラリに保存されます。.これらのマネージャーでは、独自の要素を作成できます。

その要素は、グラフィック インターフェイスで開いて、そのグラフィック表示を変更できます。また、属性を追加して、プロジェクト データベースに保存された情報に反映させることができます。

  • タイトル ブロック マネージャー

  • シンボル マネージャー

  • パターン マネージャー

  • 属性管理


属性管理

シンボル、およびタイトル ブロック属性は、データベースに格納されている情報を反映します。 DesignSpark Electrical 属性の管理に役立つツールが用意されています。

  • 属性の挿入

  • 複数の属性

  • 属性プロパティ

  • 属性の置換

  • 属性管理のためのツール

  • リビジョン属性の管理


属性の挿入

シンボル、2D フットプリントおよびタイトル ブロック属性は、データベースに格納されている情報を反映します。特定のインターフェイスにより、これらを選択してグラフィック領域に挿入できます。

メニュー: シンボルの編集（Edit symbol）>属性の挿入（Insert attribute）

メニュー: タイトル ブロックの編集（Edit title block）>属性の挿入（Insert attribute）

コマンドを起動すると、ダイアログ ボックスに使用可能な属性が一覧表示されます。

シンボルまたはタイトル ブロックに既に存在する属性は青で表示されます。

1. 一覧の属性の横にあるチェック ボックスをオンにすると、その属性をシンボルまたはタイトル ブロックに挿入できるようになります。

2. [OK] をクリックするとダイアログ ボックスが閉じ、属性挿入ドック可能パネルが表示されます。

このパネルでは、配置前に属性に適用された設定 (フォントや高さなど) を変更できます。

プロパティ

属性を (横並びまたは縦並びに) 配置できます。また、フォント設定、両端揃え、高さなどの属性のプロパティや、各属性間の間隔を指定できます。

属性リスト

新しい属性を追加します。

選択した属性を削除します。

属性の順序を変更します。

3. グラフィック領域で、属性グループの挿入点をクリックします。

関連トピック:

属性プロパティ


複数の属性

属性は、シンボル、タイトル ブロック、および 2D フットプリント (ブロック) にある特殊なテキスト文字列です。属性には「ラベル」(名前)、「プロンプト」(説明)、および「値」(表示するテキスト) があります。

属性は、プロジェクト情報やソフトウェア データベースを反映するために使用します。場合によっては、このデータが長いテキストで表示され、配線図の設計が妨害されることがあります。

[複数の属性] コマンドでは、既存の属性 (単一の属性) に基づいて複数の属性を作成できます。値はテキストの数行に表示されます。

メニュー: 修正 > 複数の属性

メニュー: シンボルの編集 > 複数の属性

メニュー: タイトル ブロックの編集 > 複数の属性

グラフィカル インターフェイスで、複数の属性に変換する 1 つの属性を選択します。

ドック可能パネルが変わり、作成のオプションが表示されます。

複数属性として設定

属性数: データを反映する行数を入力します。

属性間の距離: 2 つの属性間の距離を入力し、線の間のスペースを指定します。

画面上の位置の指定: [属性数] パラメーターを 2 より大きくした場合は、このボックスをオフにして、属性を自動的に上下に配置します。それ以外の場合は、各属性の挿入点をクリックするように指示されます。

属性名が修正されます。接尾語 {n} は末尾に配置されます。「n」は複数の属性の順序番号と等しくなります。

複数の属性の次の行に反映される情報を入力するときには、「|」文字を行区切り文字として使用してください。例: Circuit breaker | Tetrapolar | 4P 3D


属性プロパティ

属性プロパティでは、その属性の名前とテキスト定義を修正できます。

属性のコンテキスト メニュー: プロパティ

属性プロパティは、[プロパティ] ドック可能パネルに表示されます。

全般

属性名およびその説明を入力します。

属性名は重要です。 DesignSpark Electrical は属性名を使用して、挿入した属性にプロジェクト データを反映します。ソフトウェアが名前を認識しない場合、情報は表示されません。

形状

このセクションでは、テキスト設定を入力します。これは、属性の挿入時に使用されます。


属性の置換

この機能では、選択した属性を別の属性に置換できます。

属性のコンテキスト メニュー: 属性の置換

メニュー: シンボルの編集 > 属性の置換

メニュー: タイトル ブロックの編集 > 属性の置換

1. 置換する属性をグラフィック領域で選択します。

2. [属性セレクター] ダイアログ ボックスで新しい属性を選択します。

この機能を使用できるのは、属性を選択したときのみです。


属性管理のためのツール

属性の表示

メニュー: シンボルの編集 > 属性の表示

メニュー: タイトル ブロックの編集 > 属性の表示

この機能では位置やテキスト サイズなどの属性を管理しやすくするため、さまざまなスタイルの属性をグラフィック領域に表示できます。グラフィックに関してのみ変更され、名前は変更されません。

属性の表示: 属性名を表示します。属性が非表示の場合は、属性を表示できます。

サンプル値の表示: 属性が受けることのできる値のサンプルで属性を置き換えます。このモードでは、属性のプロパティを編集できません。

属性の説明を表示: 属性をその説明で置き換えます。このモードでは、属性のプロパティを編集できません。

属性を非表示: 属性を非表示にします。

属性の手動変更

ソフトウェアで使用できる複数の属性は、言語、インデックスまたはデータ インデックスを示す特定の文字で形成されています。

#AIO_0_TZ_1_L1: 属性タイプ (この例では入出力)。

#AIO_0_TZ_1_L: 属性タイプの順序番号 (この例では最初の I/O)。

#AIO_0_TZ_1_L1: 前の値に関連付けられている翻訳可能なユーザー データ 1 (この例では最初の I/O の最初の翻訳可能なデータ)。

#AIO_0_TZ_1_L1: 前の値の言語 (この例では最初の I/O の最初の翻訳可能なデータの言語)。

インデックス: インデックス文字は、前のコードにより定義される属性タイプの順序番号です。0 が最初で、1 が 2 番目、と続きます。

データ インデックス: データ インデックス文字は、データ タイプ (TX: ユーザー データおよび TZ: 翻訳可能なユーザー データ) を識別するコードに従います。0 は最初のユーザー データ (または翻訳可能なユーザー データ) の値を反映し、1 は 2 番目のユーザー データ (または翻訳可能なユーザー データ) の値を反映する、と続きます。

言語: L1 はプロジェクトのメイン言語のテキストを反映し、L2 は 2 番目の言語、と続きます。これらの文字を言語コード (EN - FR - ES...) に置き換えることで、ある言語を強制的に適用できます。たとえば、プロジェクトの言語に関係なくテキストを常に英語で表示したい場合は、文字を EN に置き換えます。

これらのコードを管理できるコマンドもあります。これらのコマンドは、選択した属性のタイプに応じて表示されます。

インデックスを変更: 属性タイプの順序番号を変更できます。ダイアログ ボックスで、新しいインデックスを導入します。

TX/TZ データ インデックスを変更: ユーザー データまたは翻訳可能なデータの番号を変更できます。ダイアログ ボックスで、新しいデータ インデックスを導入します。

言語コードを変更: ユーザー データまたは翻訳可能なデータの言語を変更できます。リストで、プロジェクトで使用されているいずれかの言語、または別の言語 (プロジェクト構成で設定されていなくても可) を選択します。

リビジョン インデックスを変更: リビジョンのインデックス コードを変更できます。ダイアログ ボックスに新しいバージョン インデックスを入力します（タイトル ブロックでのみ使用可能）。

属性リスト

すべてのシンボルおよびタイトル ブロック属性が含まれる Excel ファイルを生成するには、ewExportUsedAttributes コマンド（コマンド ラインでのみ使用可能）を使用します。


リビジョン属性の管理

リビジョン属性はタイトル ブロックの変更グリッドに表示され、タイトル ブロック エディターで管理されます。

メニュー: タイトル ブロックの編集 > リビジョン インデックスを変更

リビジョン属性のコンテキスト メニュー: リビジョン インデックスを変更

各リビジョン属性には、正 (絶対モード) または負 (相対モード) にすることができるインデックス番号があります。

マーキング モード

相対: インデックス番号は現在のリビジョンから計算されます。インデックス番号 "-0" を指定すると、現在のリビジョン インデックスが表示されます。"-1" を指定すると、前のリビジョン インデックスが表示されます。

たとえば 0AB モードでは、現在のリビジョンが "E = sixth index" である場合、"-2" インデックス番号を指定すると、リビジョン インデックス "C = fourth index" (6-2=4) が反映されます。

構成設定では、リビジョン インデックスの位置を選択できます:

- 図面の変更グリッドの底部

- リビジョン属性の位置に対応

絶対: インデックス番号はリビジョン インデックスに対応します。インデックス番号 "0" は最初のリビジョン インデックスに対応し、インデックス番号 "1" は 2 番目のリビジョン インデックスに対応します.図面でリビジョン インデックスを表示するには、それに対応する属性を、タイトル ブロックの変更グリッドに挿入しておく必要があります。

インデックス: 絶対モードでは負の値のみを表示します。相対モードでは正の値を表示します。選択したモードに応じて、値は目的のインデックス番号に対応します。


挿入点管理

シンボルの挿入点は、配線図への挿入で使用される仮想の点に対応します。一般的に、これはワイヤとの接続点に対応します。

ブロックの挿入点はタイトル ブロックの左下端に対応します。一般的に、データの整合性 (クロス リファレンスの位置および始点と終点の極性) を保証するために、タイトル ブロックの挿入点を座標位置 (0,0) にすることをお勧めします。

メニュー: シンボルの編集 > 挿入点 (シンボル)

メニュー: タイトル ブロックの編集 > 挿入点 (タイトル ブロック)

グラフィカル インターフェイスの挿入点に対応する点をクリックします。赤い斜めの十字はこの点を表します。


タイトル ブロック マネージャー

タイトル ブロック マネージャーは、回路図を設計するために使用可能なすべてのタイトル ブロックをまとめてグループ化します。タイトル ブロックのフィルタリング条件を使用すると、分類が可能です。

メニュー: ライブラリ > タイトル ブロック マネージャー

[タイトル ブロック マネージャー] ダイアログ ボックスが開きます。タイトル ブロックの追加、編集、または削除ができます。

マネージャーの左側には 2 つのタブがあります。

分類

このタブには、タイトル ブロックの分類がツリー形式で表示されます。

ダイアログの左側に、タイトル ブロックが分類されて表示されます。右側には、現在選択している分類のタイトル ブロックが表示されます。

フィルター

このタブでは、タイトル ブロックのリストをフィルタリングできます。すべてのフィルター条件は、タイトル ブロック プロパティに存在するものと同じです。

ダイアログ ボックスの右側には、選択した条件に対応するタイトル ブロックが表示されます。

フィルターを除去: すべてのフィルター条件を除去する場合は、このボタンをクリックします。

マネージャーの右側には、左側で入力した選択項目または検索条件に対応するタイトル ブロックが表示されます。

タイトル ブロックは、リスト ([リスト モード] アイコン) またはサムネイル ([サムネイル モード] アイコン) で表示されます。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

新規: 新しいタイトル ブロックをライブラリに追加できます。

開く: 選択したタイトル ブロックがグラフィカル インターフェイスまたは DraftSight で開き、変更できるようになります。

DWG ファイルのインポート: DWG ファイルをタイトル ブロックとしてインポートできます。

削除: 選択したタイトル ブロックを削除します。

プロパティ: 選択したタイトル ブロックの [プロパティ] ダイアログ ボックスを開きます。複数のタイトル ブロックを選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

プレビュー: タイトル ブロックをプレビュー ダイアログ ボックスで開きます。このインターフェイスでは変更はできません。

切り取り: 選択したタイトル ブロックのコピーを DesignSpark Electrical クリップボードに配置して、元のタイトル ブロックを削除します。

次のショートカットも使用できます: Ctrl + X

コピー: 選択したタイトル ブロックのコピーを DesignSpark Electrical クリップボードに配置して、元のタイトル ブロックを保持します。[コピー] コマンドを使用して、選択した要素リストを Excel などの別のアプリケーションにコピーすることもできます (リスト モードのみ)。

次のショートカットも使用できます: Ctrl + C

貼り付け: DesignSpark Electrical クリップボードのタイトル ブロックを貼り付けます。新しいタイトル ブロックが作成されます。

次のショートカットも使用できます: Ctrl + V

すべて選択: マネージャーの右側に表示されるすべてのタイトル ブロックを選択できます。

リスト モード: リスト (名前、説明、分類) の形式でタイトル ブロックを表示します。このモードでは、選択した要素のリストを Excel などの別のアプリケーションにコピーできます。

サムネイル モード: サムネイル プレビューの形式でタイトル ブロックを表示します。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

アーカイブ: アーカイブする要素を選択し、[アーカイブ] アイコンをクリックします。

ダイアログ ボックスが開き、アーカイブ ファイルを保存できます。

解凍: ダイアログ ボックスが開き、解凍する TEWZIP ファイルを選択できるようになります。データ更新ウィザードが自動的に開きます。詳細については、「アーカイブと解凍」の章を参照してください。

サブクラスの内容の表示: このボックスをオンにすると、選択した分類のサブクラスに含まれるすべてのオブジェクトが表示されます。

ダイアログを開いたままにします: このオプションが選択されている場合は、オブジェクトを開いてもダイアログ ボックスは閉じません。

  • 新しいタイトル ブロックの追加

  • タイトル ブロック プロパティ

  • タイトル ブロック グラフィックスの編集


新しいタイトル ブロックの追加

タイトル ブロック マネージャー: 新規

タイトル ブロックの [プロパティ] ダイアログ ボックスが開き、特性が表示されます。

この段階では、特性のみが作成されます。グラフィックを作成するには、エディターでタイトル ブロックを開く必要があります。

既存のタイトル ブロックに近いタイトル ブロックを新規作成するには、[コピー] および [貼り付け] コマンドを使用してから、コピーした内容を修正します。

関連トピック:

タイトル ブロック プロパティ

タイトル ブロック グラフィックスの編集


タイトル ブロック プロパティ

タイトル ブロック マネージャー: 新規

タイトル ブロック マネージャー: プロパティ

タイトル ブロックと関連付けられているデータを修正するための [プロパティ] ダイアログ ボックスを開きます。

タイトル ブロックが既に存在する場合、ダイアログ ボックスの左側に、属性とともに「編集」モードのプレビューが表示されます。

複数のタイトル ブロックを選択した場合は、共通プロパティのみが表示されます。

全般

名前: タイトル ブロック名を定義します。この名前は一意でなければなりません。

説明: ソフトウェアで管理されているすべての言語によるテキストの説明を定義します。詳細図の下に表示されます。説明は、固有のアイコンをクリックすることで、すべての言語で利用可能になります。[言語セレクター] が開き、目的の言語を選択できます。

クラス: タイトル ブロックを保存するクラスを定義します。

単位系: タイトル ブロックのモードを定義します。この選択は重要です。このタイトル ブロックから作成する図面のタイトル ブロックと配線図では、同じ単位系を使用する必要があります。新しいシンボルを作成するとき、DesignSpark Electrical では、選択した単位系に対応するテンプレート ファイルが使用されます。

ライブラリ: タイトル ブロックを保存するライブラリを定義します。

システム

このセクションは読み取り専用です。作成/修正日や作成者の名前などの情報を表示します。

行

行あり: タイトル ブロックで行管理を有効にします。

最初の行のマーク: 最初の行をマークできます。後続の行は自動的にマークされます。

最初の行の位置: 最初の行の Y 座標を入力できます。

行の高さ: 行の高さを定義します。最初の行がタイトル ブロックの上部にあり、最後の行がタイトル ブロックの下部にある場合は、値の前に記号「-」を付けます。すべての行は同じ高さにする必要があります。

行数: タイトル ブロックの行の数を定義します。

行番号割り当て: タイトル ブロックに複数の列がある場合、使用するモードを選択します。

列

列あり: タイトル ブロックで列管理を有効にします。

最初の列のマーク: 最初の行をマークできます。後続の列は自動的にマークされます。

最初の列の位置: 最初の行の X 座標を入力できます。

列の幅: 列の幅を定義します。すべての列は同じ幅にする必要があります。

列数: タイトル ブロックの列の数を定義します。

オプション

クロス リファレンス オフセット: 「テーブルの親」タイプのシンボルのクロス リファレンス サムネイル挿入の高さを定義します。

関連トピック:

新しいタイトル ブロックの追加

タイトル ブロック グラフィックスの編集


タイトル ブロック グラフィックスの編集

ライブラリのタイトル ブロックは、データベースに保存されているグラフィック表現と一連のパラメーターから構成されています。タイトル ブロックは、タイトル ブロック マネージャーを使用して挿入することが必要で、そうしなければソフトウェアで管理できません。

タイトル ブロックには属性があり、データベースに保存されているプロジェクト構造のデータが反映されるようになっています。

タイトル ブロック マネージャー: 開く

[ドキュメント] タブ > 図面のコンテキスト メニュー > タイトル ブロック: 開く

選択したタイトル ブロックがグラフィック インターフェイスで開きます。[ダイアログを開いたままにします] オプションを有効にしなければ、マネージャー ダイアログ ボックスは閉じます。それ以外の場合は、手動で閉じるか、サイズを変更できます。

エディターが開くと、リボン メニューが変わります。[タイトル ブロックの編集] セクションが表示されます。

ドック可能パネルに、タイトル ブロックのプロパティが表示されます。

DesignSpark Electrical でシンボルを管理するには、次の手順を実行します。

  • 挿入点管理

  • 属性管理

ファイルを閉じると、ファイルを保存するかどうかを確認するメッセージが表示されます。

ファイルを DraftSight で開いて、グラフィックを編集できます。

関連トピック:

グラフィック コマンド

新しいタイトル ブロックの追加

タイトル ブロック プロパティ

ユーザー データ


シンボル マネージャー

シンボル マネージャーは、回路図を設計するために使用可能なすべてのシンボルをまとめてグループ化します。シンボルのフィルタリング条件を使用すると、分類が可能です。

メニュー: ライブラリ > シンボル マネージャー

[シンボル マネージャー] ダイアログ ボックスが開きます。シンボルの追加、編集、または削除ができます。

マネージャーの左側には次の 2 つのタブがあります。

分類

このタブには、シンボル分類がツリー形式で表示されます。

このダイアログ ボックスの左側にはシンボル分類が表示されます。右側には、現在選択している分類のシンボルが表示されます。

サブクラスの内容の表示: このボックスをオンにすると、選択した分類のサブクラスに含まれるすべてのシンボルが表示されます。

フィルター

このタブでは、シンボルのリストをフィルタリングできます。すべてのフィルター条件は、シンボル プロパティに存在するものと同じです。

ダイアログ ボックスの右側には、選択した条件に対応するシンボルが表示されます。

フィルターを除去: すべてのフィルター条件を除去する場合は、このボタンをクリックします。

マネージャーの右側には、左側で入力した選択項目または検索条件に対応するシンボルが表示されます。

シンボルは、リスト (リスト モード アイコン) またはサムネイル (サムネイル モード アイコン) で表示されます。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

新規: 新しいシンボルをライブラリに追加できます。

開く: 選択したシンボルがグラフィック インターフェイスまたは DraftSight で開き、変更することができます。

DWG ファイルのインポート: DWG ファイルをシンボルとしてインポートできます。

削除: 選択したシンボルを削除します。

プロパティ: 選択したシンボルの [プロパティ] ダイアログ ボックスを開きます。複数のシンボルを選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

プレビュー: シンボルをプレビュー ダイアログ ボックスで開きます。このインターフェイスでは変更はできません。

切り取り: 選択したシンボルのコピーを DesignSpark Electrical クリップボードに配置して、元のシンボルを削除します。

次のショートカットも使用できます: Ctrl + X

コピー: 選択したシンボルのコピーを DesignSpark Electrical クリップボードに配置して、元のシンボルを保持します。[コピー] コマンドを使用して、選択した要素リストを Excel などの別のアプリケーションにコピーすることもできます (リスト モードのみ)。

次のショートカットも使用できます: Ctrl + C

貼り付け: DesignSpark Electrical クリップボードのシンボルを貼り付けます。新しいシンボルが作成されます。

次のショートカットも使用できます: Ctrl + V

すべて選択: マネージャーの右側に表示されるすべてのシンボルを選択できます。

リスト モード: リスト (名前、説明、分類) の形式でシンボルを表示します。このモードでは、選択した要素のリストを Excel などの別のアプリケーションにコピーできます。

サムネイル モード: サムネイル プレビューの形式でシンボルを表示します。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

アーカイブ: アーカイブする要素を選択し、[アーカイブ] アイコンをクリックします。

ダイアログ ボックスが開き、アーカイブしたファイルを保存できます。

解凍: ファイルの選択ダイアログ ボックスが開き、解凍する TEWZIP ファイルを選択できます。データ更新ウィザードが自動的に開きます。詳細については、「アーカイブと解凍」の章を参照してください。

サブクラスの内容の表示: このボックスをオンにすると、選択した分類のサブクラスに含まれるすべてのオブジェクトが表示されます。

ダイアログを開いたままにします: このオプションが選択されている場合は、オブジェクトを開いてもダイアログ ボックスは閉じません。

  • 新しいシンボルの追加

  • シンボル プロパティ

  • シンボル グラフィックスの編集


新しいシンボルの追加

シンボル マネージャー: 新規

シンボルの [プロパティ] ダイアログ ボックスが開き、特性が表示されます。

この段階では、特性のみが作成されます。グラフィックを作成するには、エディターでシンボルを開く必要があります。

既存のシンボルに近いシンボルを新規作成するには、[コピー] および [貼り付け] コマンドを使用してから、コピーした内容を修正します。

関連トピック:

シンボル プロパティ

シンボル グラフィックスの編集


シンボル プロパティ

シンボル マネージャー: 新規

シンボル マネージャー: プロパティ

シンボルと関連付けられているデータを修正するために、シンボルの [プロパティ] ダイアログ ボックスを開きます。

シンボルが既に存在する場合、ダイアログ ボックスの左側に、属性と接続点とともに「編集」モードのプレビューが表示されます。

選択したシンボルに応じて、複数のプロパティを無効にすることができます。複数のシンボルを選択した場合は、共通プロパティのみが有効になります。

全般

名前: シンボルが作成されると、名前が自動的に追加されます。この名前は一意でなければなりません。また、必要に応じて名前を変更できます。

説明: シンボルを説明します。ライブラリで「サムネイル モード」を選択した場合、サムネイルの下に説明テキストが表示されます。シンボルは説明のアルファベット順に配置されます。説明は、固有のアイコンをクリックすることで、すべての言語で利用可能になります。[言語セレクター] が開き、目的の言語を選択できます。

クラス: シンボルを保存するクラスを定義します。

シンボル タイプ: シンボルのタイプを定義します。

複数ワイヤシンボル は配線図に挿入可能なシンボルをグループ化します。

結線図シンボルは結線図に挿入可能なシンボルをグループ化します。

ブラック ボックス シンボルは、ブラック ボックスで使用可能なシンボルをグループ化します。

端子シンボルは、端子を表すシンボルをグループ化します。

リダイレクト シンボルは、渡り配線管理で使用するシンボルをグループ化します。

クロス リファレンスのシンボルはクロス リファレンスを表すシンボルをグループ化します。

ケーブル ラベルはケーブル ラベルを表すシンボルをグループ化します。

接続ラベルは接続ラベルを表すシンボルをグループ化します。

ワイヤ ラベルはワイヤ ラベルを配置するためのシンボルをグループ化します。

等電位ラベルは等電位ラベルを配置するためのシンボルをグループ化します。

ロケーション ラベルはロケーション ラベルを配置するためのシンボルをグループ化します。

パッシブ シンボルはパッシブ シンボル (マークのないシンボル) をグループ化します。これらはプロジェクトのデータベースに保存されますが、処理やレポートでは考慮されません。

単位系: シンボルが作図された単位モードを定義します。新しいシンボルを作成するとき、DesignSpark Electrical では、選択した単位系に対応するテンプレート ファイルが使用されます。

ライブラリ: シンボルが分類されているライブラリを定義します。

メーカー部品

メーカー: メーカーの名前を定義します。このパラメーターと [参照] パラメーターとの関連付けは解除できません。

参照: シンボルと メーカー部品を関連付けます。このメーカー部品は、挿入時に自動的にコンポーネントに関連付けられます。[...] をクリックしてメーカー部品を割り当てます。

システム

このセクションは読み取り専用です。作成/修正日と作成者が表示されます。

特性

マーク ルート: シンボルの挿入時に使用するマーク ルートを表示します。値を入力しない場合は、クラスに関連付けられているルートが使用されます。

関連付けられたマクロ: パターンをシンボルに関連付けます。シンボルを挿入するときは、ドック可能パネルで [関連付けられたパターンの挿入] を選択するか、コンポーネントのコンテキスト メニューで [コンポーネント] タブを選択します。

規格: シンボルで使用する規格を定義します。

クロス リファレンス タイプ: シンボルのデフォルトのクロス リファレンス レベルを定義します。これはシンボルの挿入時に変更できます。

オプション

接続点の表示: 回路図の接続点を表示します。

属性の方向を維持します: 選択すると、属性はシンボルとともに回転しません。

関連トピック:

新しいシンボルの追加

シンボル グラフィックスの編集


シンボル グラフィックスの編集

シンボルは、ライブラリにあるとき、データベースに保存されているグラフィカル表現と一連の技術特性から構成されています。シンボル マネージャーで挿入されていないシンボルは、ソフトウェアによって生成されません。そのシンボルにはマークが付いておらず、メーカー部品に関連付けることができません。

シンボルには回路が含まれており、回路には接続点を配置できます。これらの接続点によって、ワイヤの切り取りが可能になります。また、接続点を使用して、メーカー部品で指定された材料端子数を反映できます。

シンボルには属性 (テキスト) もあり、データベースに保存されている特定の情報を配線図全体に反映できます (マーク、クロス リファレンス テキストなど)。

シンボル マネージャー: 開く

シンボルのコンテキスト メニュー: シンボル > シンボルを開く

選択したシンボルがグラフィック インターフェイスで開きます。[ダイアログを開いたままにします] オプションを有効にしなければ、マネージャー ダイアログ ボックスは閉じます。それ以外の場合は、手動で閉じるか、サイズを変更できます。

エディターが開くと、リボン メニューが変わります。[シンボルの編集] セクションが表示されます。

ドック可能パネルが変化して、シンボル プロパティと回路定義が表示されます。

DesignSpark Electrical でシンボルを管理するには、次の手順を実行します。

  • 挿入点管理

  • 回路管理

  • 接続点の管理

  • 属性管理

ファイルを閉じると、ファイルを保存するかどうかを確認するメッセージが表示されます。

ファイルを DraftSight で開いて、グラフィックを編集できます。

関連トピック:

グラフィック コマンド

新しいシンボルの追加

シンボル プロパティ

ユーザー データ

メーカー部品

回路の管理


回路管理

シンボル回路を管理するには、ドック可能パネルの [シンボル構造] セクションを使用します。

回路番号は 0 ～ n です。一般的に、シンボルの挿入点に対して相対的に左から右 (または上から下) に割り当てられます。ソフトウェアは、電気コンポーネントのタイプに対応する複数のタイプの回路を管理します。

シンボル回路はメーカー部品の回路と一致し、このシンボルに関連付けられなければなりません。

メニュー: シンボルの編集 > 新しい回路

ダイアログ ボックスが開き、回路の特性を選択できるようになります。

番号: 追加する回路の数を入力します。

回路タイプ: 回路のタイプを選択します。リストはシンボルのクラスによって異なります。回路リスト全体にアクセスするには、[その他の回路タイプ] を選択します。

情報送信: 位相や等電位番号など、回路が特定の情報を送信できるようにするかどうかを定義します。

切断可能: （位相番号のみを送信できます）。

大多数の配線図シンボルで使用されます。受信接続点と送信接続点間の等電位番号は異なります。

通過: (シンボルを通過する等電位)

通過回路とは、2 つの接続点間で等電位が継続される回路ですが、回路の各点については個別のワイヤ配線順序があります。

ハイパー通過: (シンボルを通過する等電位)

ハイパー通過回路は、リンクされていて同一の回路および接続点データを持つコンポーネントを使用している 2 つ以上の異なる回路に、同じ等電位ワイヤ番号を設定する場合に使用されます（たとえば、バスバー分散ブロックは複数のセグメントに分割されます。ワイヤは回路を通過しません）。

ハイパー ハイパー通過: （シンボルを通過する等電位およびワイヤ）

ハイパー ハイパー通過回路は、同じ接続点の詳細を持つ 2 つ以上のシンボルを接続します（たとえば画面などで、これらのポイント間で等電位を継続します）。ただし接続点は、2 つのエンド コンポーネント間でワイヤが直接接続されているかのように透過的であるため、接続レポートでは詳細に説明されません。標準的なケースは、渡り配線です。

ドック可能パネルの下部には、回路のプロパティが表示されます。


接続点の管理

シンボルがワイヤに挿入されると、ワイヤは自動的にシンボルの右側で切断されます。同様に、ワイヤがシンボル上に配置されると、自動的に切断されます。これは、シンボルに接続点がある場合にのみ可能です。

接続点は、シンボルの挿入時にワイヤ上で重なるように配置されます。接続点には属性があり、メーカー部品材料端子の番号を反映できます。

メニュー: シンボルの編集（Edit symbol）> 接続点（Connection point）

接続点には 3 種類あります。

接続点 (デフォルト): 極性の始点/終点以外のすべてのシンボルに使用する接続点。

受信/送信接続点: これらの接続点には方向があり（受信/送信）、極性の始点/終点で使用されるシンボル専用に予約されています。

接続点を挿入するときには、[スナップ] オプションが有効で、分解能ピッチがシンボルの回路間を分ける距離と 2 本のワイヤ (例: 2 相電源ワイヤ) を分ける距離に対応していることを確認してください。

接続点は、シンボルがワイヤを切断する必要がある場所に配置されます。

接続点を挿入するには:

1. ドック可能パネルで、接続点が属する回路を選択します。

2. メニューでコマンドを選択します。

3. 接続点を正しい方向に回します (キーボードのスペース キーを押すと、接続点がワイヤの角度に従って回転します)。

4. グラフィック領域で、接続点の挿入点をクリックします。

接続点が挿入されたことを通知するメッセージが表示されます (N:0-C:0)。「C」の後ろの数字は回路番号です。「N」の後ろの数字は回路の順序番号です。

「N」に割り当てられた値は重要ではありません。回路に 2 つの接続点しかない場合でも、「N:6」となる場合があります。指定された回路の「N」に対するすべての値が比較される必要があります。プログラムは「N」の値に従って、回路のすべての接続点を分類します。

回路「C1」の場合、「N:1」と「N:4」になります。N:1 は回路の最初の接続点であり、N:4 は次の接続点です。メーカー部品が割り当てられる場合、材料端子に番号を割り当てるときと同じ原則が使用されます。最初の材料端子番号は、回路の最初の接続点に割り当てられます。2 番目の材料端子番号は、回路の 2 番目の接続点に割り当てられます。このように、すべてのコンポーネント回路に割り当てられます。

端子タイプをシンボルの接続点に関連付けることができますが、このシンボルにメーカー部品を割り当てた場合は、メーカー部品の端子タイプが適用されます。

コンテキスト メニューでは、既存の接続点を編集することができます。

複数の接続点

メニュー: シンボルの編集（Edit symbol）> 複数の接続点（Multiple connection points）

このコマンドは接続点コマンドと類似しています。ただし、回路を同時に作成でき、定義後にすべての接続点の配置を支援するという点が異なります。

ダイアログ ボックスにより、シンボルに属する回路を追加できます。

回路を追加します。

選択した回路を削除します。

回路定義でメーカー部品を選択します。このメーカー部品はシンボルと関連付けることができます。

回路タイプを追加し、回路数（Number of circuits）フィールドに数量を指定します。コンポーネントと各回路の端子数を入力します。メーカー部品を選択した場合、このデータは自動的に入力されます。[OK] をクリックして確認し、ダイアログ ボックスを終了します。

接続点はカーソルに接続されます。接続点は、ドック可能パネルの指示に従い、次々に配置されます。


パターン マネージャー

DesignSpark Electrical にはライブラリがあり、「パターン」と呼ばれる配線図の一部を保存できます。

パターンはパターン マネージャー内でグループ化され、すべてのプロジェクトで使用できます。パターンのフィルタリング条件を使用すると、分類が可能です。

メニュー: ライブラリ > パターン マネージャー

[パターン マネージャー] ダイアログ ボックスが開きます。パターンの追加、編集、または削除ができます。

マネージャーの左側には 2 つのタブがあります。

分類

このタブには、パターンの分類がツリー形式で表示されます。

ダイアログ ボックスの左側にはパターンの分類が表示され、右側には現在選択されている分類のパターンが表示されます。

サブクラスの内容の表示: このボックスをオンにすると、選択した分類のサブクラスに含まれるすべてのパターンが表示されます。

フィルター

このタブでは、パターンのリストをフィルタリングできます。すべてのフィルター条件は、パターン プロパティに存在するものと同じです。

ダイアログ ボックスの右側には、選択した条件に対応するパターンが表示されます。

フィルターを除去: すべてのフィルター条件を除去する場合は、このボタンをクリックします。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

開く: パターンはプロジェクトとして表示されます。[開く] アイコンをクリックすると、パターンは [ドキュメント] タブのドック可能パネルに自動的に追加されます。先頭にはアスタリスクが付き、プロジェクトと区別できるようになっています。図面をダブルクリックするとパターンが表示され、グラフィカル インターフェイスで開くことができます。

削除: 選択したパターンを削除します。

プロパティ: パターン プロパティのダイアログ ボックスを開きます。複数のパターンを選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

表示: パターンをプレビュー ダイアログ ボックスで開きます。このインターフェイスでは変更はできません。

切り取り: 選択したパターンのコピーを DesignSpark Electrical クリップボードに格納して、元のパターンを削除します。

次のショートカットも使用できます: Ctrl + X

コピー: 選択したパターンのコピーを DesignSpark Electrical クリップボードに格納して、元のパターンを保持します。[コピー] コマンドを使用して、選択した要素リストを Excel などの別のアプリケーションにコピーすることもできます (リスト モードのみ)。

次のショートカットも使用できます: Ctrl + C

貼り付け: DesignSpark Electrical クリップボードのパターンを貼り付けます。新しいパターンが作成されます。

次のショートカットも使用できます: Ctrl + V

すべて選択: マネージャーの右側に表示されるすべてのパターンを選択できます。

リスト モード: リスト (名前、説明、分類) の形式でパターンを表示します。このモードでは、選択した要素のリストを Excel などの別のアプリケーションにコピーできます。

サムネイル モード: サムネイル プレビューの形式でパターンを表示します。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

アーカイブ: アーカイブする要素を選択し、[アーカイブ] アイコンをクリックします。ファイルを保存するためのダイアログ ボックスが開き、アーカイブしたファイルを保存できます。

解凍: ファイルの選択ダイアログ ボックスが開き、解凍する TEWZIP ファイルを選択できます。データ更新ウィザードが自動的に開きます。詳細については、「アーカイブと解凍」の章を参照してください。

サブクラスの内容の表示: このボックスをオンにすると、選択した分類のサブクラスに含まれるすべてのオブジェクトが表示されます。

ダイアログを開いたままにします: このオプションが選択されている場合は、オブジェクトを開いてもダイアログ ボックスは閉じません。

パターンを追加するには、「パターンの作成」の章を参照してください。

関連トピック:

パターンのプロパティ

パターンの管理

グラフィック コマンド


パターンのプロパティ

パターン作成

パターン マネージャー: プロパティ

パターンと関連付けられているデータを修正するために、パターンの [プロパティ] ダイアログ ボックスを開きます。

複数のパターンを選択した場合は、共通プロパティのみが表示されます。

名前: パターンには自動的に名前が付けられます。名前の変更は可能ですが、一意でなければなりません。

階層構造

クラス名: [...] ボタンをクリックし、クラス セレクター を開き、パターンが格納されるクラスを選択します。

ライブラリ: パターン ライブラリを開きます。パターン ライブラリとは、パターンの挿入が可能な環境です。このタイプを変更すると、パターンの挿入時に、不具合が生じる可能性があります。

システム

このセクションでは、パターンの作成および変更についての情報が表示されます。

情報

このセクションでは、リストで使用可能な値を使用してマクロ タイプを変更できます。

マクロのバージョンについての情報も表示されます。

説明

説明は、ソフトウェアで管理されているすべての言語を使って入力できます。

ユーザー データ

パターンに関連付けられたユーザー データを管理できます。

翻訳可能データ

パターンに関連付けられた翻訳可能なデータを管理できます。


メーカーのカタログ

DesignSpark Electrical には、電気のメーカー部品とケーブル参照が含まれます。ただし、独自の参照を入力することができます。

参照データを処理する管理機能には、メーカー部品用機能とケーブル参照用機能の 2 つがあります。

  • ケーブル参照 マネージャー

  • メーカー部品マネージャー


列構成

メニュー: ライブラリ > ケーブル参照マネージャー > 構成

メニュー: ライブラリ > メーカー部品マネージャー > 構成

メニュー: ファイル > プロジェクト マネージャー > 構成

メニュー: プロジェクト > レポート(設計ルール チェック) > プロパティ > 列タブ > 構成

このコマンドでは、マネージャーまたはレポート テンプレートの列を表示または非表示にできます。内容はマネージャーまたはレポート テンプレートのタイプによって異なります。

表示する情報に対応するボックスをオンにします。


カタログの解凍

メニュー: ライブラリ > ケーブル参照マネージャー > 解凍

メニュー: ライブラリ > メーカー部品マネージャー > 解凍

ケーブル カタログおよびメーカー部品の解凍コマンドでは、2 つのオプションを利用できます。

解凍ウィザード: 解凍ウィザードを使用してカタログを解凍できます。更新するカタログを選択できます。

デフォルトのオプションで復元: 解凍ウィザードを使用せずにカタログを解凍できます。既存の参照が、解凍された参照で体系的に更新されます。


ケーブル参照 マネージャー

すべてのケーブル参照は 1 つのデータベースに保存されます。これらは分類され、複数の条件を使用して簡単に検索できます。

メニュー: ライブラリ（Library）> ケーブル参照マネージャー（Cable references manager）

コマンドを実行すると、ケーブル参照管理ダイアログ ボックスが開きます。

ダイアログ ボックスの左側の [分類] タブには、参照の分類の最初の条件であるクラスのリストが表示されます。フィルター（Filters）タブでは、参照を検索し、プロパティなどの修正ができます。

ダイアログ ボックスの右側には、選択したクラスに含まれる参照のリストまたはフィルター条件に適合するケーブルのリストが表示されます。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

新しい参照: 新しいケーブル参照を追加するには、マネージャーの左側でクラスを選択し、[新しい参照] アイコンをクリックします。新しい参照を作成するときには、ケーブル参照を選択することもできます (マネージャーの右側)。この参照は、選択した参照の特性を自動的に引き継ぎます。

参照の [プロパティ] ダイアログ ボックスが開き、参照を修正できます。

複数挿入: このコマンドは [新しい参照（New reference）] コマンドと類似していますが、確認時にプロパティ ダイアログ ボックスが閉じず、別の新しい参照を作成するかどうかを確認するメッセージが表示される点が異なります。

インポート: このコマンドでは参照のカスタム リストをインポートし、カタログに統合できます。

削除: 選択した参照を削除できます。

プロパティ: 選択したケーブル参照の [プロパティ] ダイアログ ボックスを開きます。複数のケーブル参照を選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

切り取り: 選択した参照のコピーを DesignSpark Electrical クリップボードに配置して、元の参照を削除します。

次のショートカットも使用できます: Ctrl + X

コピー: 選択した参照のコピーを DesignSpark Electrical クリップボードに配置して、元の参照を保持します。[コピー] コマンドを使用して、選択した要素リストを Excel などの別のアプリケーションにコピーすることもできます (リスト モードのみ)。

次のショートカットも使用できます: Ctrl + C

貼り付け: DesignSpark Electrical クリップボードの参照を貼り付けます。新しい参照が作成されます。

次のショートカットを使用することもできます。Ctrl + V

すべて選択: マネージャーの右側に表示されるすべての参照を選択できます。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

アーカイブ: アーカイブする参照を選択し、[アーカイブ] アイコンをクリックします。

ダイアログ ボックスが開き、アーカイブ ファイルを保存できます。

解凍: ファイル選択用のダイアログ ボックスが開き、解凍する TEWZIP ファイルを選択できます。データ更新ウィザードが自動的に開きます。詳細については、「アーカイブと解凍」の章を参照してください。

: インターネットから部品参照アーカイブ ファイルのダウンロードにアクセスするために使用されます。これらのファイルには、最新の部品更新が含まれます。

寸法の単位: ケーブルの寸法に使用する単位系をリストから選択します。

カタログの追加

ケーブル参照は、カタログ内にメーカー別にメーカー名でグループ化されます。カタログに含まれていないケーブル参照もあります。必要に応じて、電気コンテンツ ポータル（Electrical Content Portal）からダウンロードできます。

オンライン コンテンツ: インターネットからアーカイブ ファイルのダウンロードにアクセスするために使用されます。これらのファイルには、最新の参照更新が含まれます。

関連トピック:

ケーブル プロパティ

アーカイブと解凍


ケーブル プロパティ

ケーブル参照マネージャー: プロパティ

ケーブル参照マネージャー: 新しい参照

ケーブル参照マネージャー: 複数挿入

プロパティ

全般

参照: 参照を識別するコード。

メーカー: ケーブルのブランド名またはメーカー名。

クラス: ケーブルが属するクラスです。ケーブルが属するクラスを変更するには、クラス ボックスをクリックします。次に、ダイアログ ボックスでクラスを選択します。

項目番号: ユーザーが管理する内部情報。

外部 ID: 外部 ID は、要素と外部アプリケーションの対応する要素をリンクするときに使用されます。

ライブラリ: ケーブル参照があるライブラリを選択します。

ファミリー: ケーブル参照を分類する新しいファミリーを選択または作成できます。

規格: ケーブル規格です。

シリーズ: 多くの場合、ケーブル参照はシリーズ別にグループ化されます。

説明: ケーブルの説明。

サプライヤ

サプライヤ名: サプライヤ名を入力します。

ストック番号: サプライヤにストック番号を入力します。

情報

作成者: 参照の作成者 (ユーザーまたはシステム) の名前。

作成日: シンボルが作成された日付。この日付は自動生成されます。

変更日: シンボルが最後に変更された日付。この日付は自動生成されます。

特性

色、直径、断面、ベンド半径などのケーブルに関連する情報です。作成済みのケーブルには、その長さを入力できます。

ERP データ

このセクションは ERP 接続が有効な場合合に使用できます。ユーザー データ フィールドに特定の値を入力できます。この情報を使用して個人のデータベースを更新できます。

ケーブル コア

このタブでは、ケーブルを構成するコアの定義を管理できます。

追加: リストの最後にコアを追加できます。

挿入: 選択した要素の上にコアを追加します。

削除: 選択したコアを削除します。

上へ/下へ: コアの順序を変更します。

グループ化/グループ解除: 選択したケーブル コア (ペア) をグループ化またはグループ解除します。

関連トピック:

ケーブル カタログ

ケーブル参照 マネージャー


メーカー部品マネージャー

すべてのメーカー部品は独自のデータベースに保存されます。これらは分類され、複数の検索条件を持ちます。

メニュー: ライブラリ（Library）> メーカー部品マネージャー（Manufacturer parts manager）

コマンドを実行すると、[メーカー部品マネージャー] ダイアログ ボックスが開きます。

ダイアログ ボックスの左側の [分類] タブには、さまざまなクラスのリストが表示されます。分類の最初の条件は参照です。たとえば、フィルター（Filters）タブでは、メーカー部品を検索して、プロパティなどを変更できます。

ダイアログ ボックスの右側には、選択したクラスに含まれる部品のリストが表示されます。

メーカー部品を表示するには 2 つのオプションがあります。自動更新（Automatic refresh）ボックスをオンにすると、メーカー部品の一覧が自動的に表示されます。

自動更新（Automatic refresh）ボックスがオフの場合は、更新（Refresh）ボタンをクリックしたときにのみ部品の一覧が更新されます。

[削除] や [プロパティ] など、これらの機能の一部では複数選択を使用できます。

メーカー部品を追加: 事前に選択した既存のメーカー部品をコピーして新しいメーカー部品が作成されます。追加する部品によく合致する部品を選択することで最適な結果を得られます。選択したら、メーカー部品の追加（Add manufacturer part）ボタンをクリックします。

複数挿入: このコマンドはメーカー部品の追加（Add manufacturer part）コマンドと類似していますが、確認時にプロパティ ダイアログ ボックスが閉じず、別のメーカー部品を作成するかどうかを確認するメッセージが表示される点が異なります。

インポート: このコマンドでは参照のカスタム リストをインポートし、カタログに統合できます。

削除: 選択したメーカー部品を削除できます。

プロパティ: メーカー部品プロパティのダイアログ ボックスを開きます。複数のメーカー部品を選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

切り取り: 選択したメーカー部品のコピーを DesignSpark Electrical クリップボードに配置して、元のメーカー部品を削除します。

次のショートカットも使用できます: Ctrl + X

コピー: 選択したメーカー部品のコピーを DesignSpark Electrical クリップボードに配置して、元のメーカー部品を維持します。[コピー] コマンドを使用して、選択した要素リストを Excel などの別のアプリケーションにコピーすることもできます (リスト モードのみ)。

次のショートカットも使用できます: Ctrl + C

貼り付け: DesignSpark Electrical クリップボードのメーカー部品を貼り付けます。新しいメーカー部品が作成されます。

次のショートカットも使用できます: Ctrl + V

すべて選択: マネージャーの右側に表示されるすべてのメーカー部品を選択できます。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

アーカイブ: アーカイブするメーカー部品を選択し、[アーカイブ] アイコンをクリックします。

ファイルを保存するためのダイアログ ボックスが開き、アーカイブしたファイルを保存できます。

解凍: ファイルの選択ダイアログ ボックスが開き、解凍する TEWZIP ファイルを選択できます。データ更新ウィザードが自動的に開きます。詳細については、「アーカイブと解凍」の章を参照してください。

回路の管理

メーカー部品をいくつかインポートすると、回路はインポートされず、インポートしたメーカー部品ごとに回路を追加する必要があります。これには、メーカー部品のコンテキスト メニューで、回路に固有のコピーと貼り付けを使用できます。

回路をコピー: 選択したメーカー部品の回路をクリップボードにコピーします。

回路を貼り付け: クリップボードに存在する回路を、選択したメーカー部品に貼り付けます。

回路を取り外す: 選択したメーカー部品の回路を削除します。

その他のコンテンツを取得

メーカー部品は、カタログ内にメーカー別にメーカー名でグループ化されます。カタログに含まれていないメーカー部品もあります。必要に応じて、電気コンテンツ ポータル（Electrical Content Portal）からダウンロードできます。

オンライン コンテンツ: インターネットからアーカイブ ファイルのダウンロードにアクセスするために使用されます。これらのファイルには、最新のメーカー部品更新が含まれます。

製品詳細の取得

DesignSpark Electrical Web サービスから、メーカー部品の価格と在庫に関する情報を取得できます。

製品価格を取得: 選択したメーカー部品の [価格] 列を更新します。

在庫状況を更新: 選択したメーカー部品の [在庫状況] 列を更新します。

価格は、通貨コード (ユーロの場合は €) を使用して消費税課税前の金額で表示されます。

在庫状況には在庫数が表示されるか、在庫なしかどうかが表示され、わかる場合は入荷日が表示されます。

関連トピック:

メーカー部品プロパティ

電気アセンブリ

メーカー部品のインポート

アーカイブと解凍

CAD ファイル ダウンローダー


メーカー部品プロパティ

メーカー部品マネージャー: プロパティ

メーカー部品マネージャー: メーカー部品を追加

メーカー部品マネージャー: 複数挿入

メーカー部品の技術データが複数のタブに保存されています。

  • プロパティ

  • ユーザー データ

  • 回路と端子

複数のメーカー部品を選択した場合、または同時に複数の参照を作成した場合は、[次へ] をクリックして次のメーカー部品のプロパティに移動します。

[前へ] をクリックすると前の部品に戻ります。


メーカー部品プロパティ

メーカー部品マネージャー: プロパティ > [プロパティ] タブ

これらのすべての値は、メーカー部品の検索時に利用できます。

全般

参照: メーカー部品を識別するコード。

メーカー: 装置のメーカーまたはブランドの名前。

クラス名: 装置が属すクラス。メーカー部品が属すクラスを修正するには、[...] ボタンをクリックし、クラスを選択します。

ライブラリ: メーカー部品が分類されているライブラリを選択します。

タイプ: 次のタイプがあります。

ベース メーカー部品タイプ (デバイス ピン番号が表示される図面でグラフィック表現される要素。例: 回路ブレーカー)。

補助メーカー部品タイプ (図面でグラフィック表現されて、「ベース」の子である要素。例: 接点)。

アクセサリ メーカー部品タイプ (グラフィック表現がなく、「ベース」または「補助」の子である要素。例: ラベル)。

固有デバイスのその他のタイプ。

項目番号: ユーザーが管理する内部情報。

外部 ID: 外部 ID は、要素と外部アプリケーションの対応する要素をリンクするために使用されます。

シリーズ: メーカー部品は、Schneider 社のカタログの TESYS などのように、シリーズごとにグループ化されます。

データ シート: メーカー部品にリンクを割り当てることができます。このリンクは、「使用説明書」や「技術仕様書」などのファイル、またはインターネット リンクにすることができます。リンクを作成するには、[...] ボタンをクリックし、ファイルを選択するか、Web アドレスを入力します。[開く] ボタンをクリックすると、リンクを開くことができます。

マーク ルート: コンポーネントの作成時にルート マークを使用できるようにします。値を入力しない場合は、クラスに関連付けられているルートが使用されます。

説明: ソフトウェアがサポートするすべての言語で説明を入力できます。固有アイコンによって、言語セレクターを開くことができます。

メーカー型番: メーカーの型番。内部参照型番またはデバイス範囲などを使用できます。ソフトウェアがサポートするすべての言語で値を入力します。固有アイコンによって、言語セレクターを開くことができます。

サプライヤ

サプライヤ名: サプライヤ名を入力します。

ストック番号: サプライヤのストック番号を入力します。

価格: メーカー部品の価格を表示します。

在庫状況: メーカー部品の在庫がないかどうかを示します。

情報

このセクションは読み取り専用です。作成/修正日と作成者が表示されます。回路数およびデバイス端子数も表示されます。

説明図

メーカー部品にシンボルを関連付けることができます。[...] をクリックすると、シンボル セレクターが開き、必要なシンボルを選択できます。

シンボル/回路の関連付けを使って、複数シンボルを 1 つのメーカー部品に関連付けられます。この機能によって、1 つのシンボルを 1 つ以上の回路に関連付けられます。

サイズ

このセクションではメーカー部品の寸法を入力できます。

使用/制御/値

メーカー部品の電気データを入力します。これらの値は、メーカー部品を検索する基準として使用されます。

メーカー データ

このセクションに表示されるメーカー データは、[全般] セクションで選択したクラスに応じて異なります。これらのデータに各値を入力します。


ユーザー データ

メーカー部品マネージャー: プロパティ > ユーザー データ タブ

すべてのユーザー データと翻訳可能なデータが表示されます。[カスタマイズ] ボタンを使用すると、これらのデータを管理できます。


メーカー部品プロパティ/回路、端子

メーカー部品マネージャー: プロパティ > 回路、端子タブ

このタブでは、回路に関してメーカー部品の定義を管理でき、デバイス端子の数も管理できます。

上記の例は、4 ピン回路ブレーカーの定義です。「回路ブレーカー、スイッチ」タイプの 4 つの回路が必要です。一覧の最初の回路は、グラフィックの左側にある要素に対応します (垂直挿入使用時)。

デバイス端子番号の場合は、1 つの回路につき 2 つの端子があります。最初の番号は、回路の上部の端子に対応します (垂直挿入使用時)。次の番号は下部の端子に対応します。

回路

複線追加: [回路追加] ダイアログ ボックスが開き、複数の回路を追加できるようになります。

追加: リストの最後に 1 つの回路を追加します。

挿入: 選択した回路の上に新しい回路を追加します。

新しい回路リストから必要な回路を選択します。

削除: 選択した回路を削除します。

上へ/下へ: 回路の順序を変更します。

番号: 回路番号を表示します。

タイプ: 回路タイプを定義します｡

端子マーク: 「端子」セクションに入力された装置端子マークを表示します。

グループ化: グループ番号 (複数の回路のグループ化に使用) を表示します。

シンボル: 回路に関連付けられたシンボルの名前を表示します。

端子

回路を選択し、端子マークにアクセスします。

追加: リストの最後に 1 つの端子を追加します。

挿入: 選択した端子の上に新しい端子を追加します。

削除: 選択した端子を削除します。

上へ/下へ: 端子の順序を変更します。

回路: 回路番号を表示します。

インデックス: 回路での端子の順序を表示します。

マーク: 材料端子の番号を定義します。

端子タイプ: リストで、端子に関連付けられる端子タイプを選択します。

最大ワイヤ数: 材料端子に接続できるワイヤまたはケーブル コアの数を定義します。

ニーモニック: チャネル ニーモニック (PLC) または個人用テキストを挿入できます。

最大ワイヤ 断面 (mm²) / 最大ワイヤ ゲージ (AWG): この端子に接続されているワイヤの最大断面に対応するデバイス端子の断面を入力できます。

最小ワイヤ断面 (mm²) / 最小ワイヤ ゲージ (AWG): この端子に接続されているワイヤの最小断面に対応するデバイス端子の断面を入力できます。

別のメーカー部品による回路の管理

類似したメーカー部品を作成するときは、メーカー部品の回路定義を使用して、新しいメーカー部品にコピーできます。メーカー部品マネージャーのメーカー部品のコンテキスト メニューには、回路を管理するための特定のコマンドがあります。

回路をコピー: 選択したメーカー部品の回路を DesignSpark Electrical クリップボードにコピーできます。

回路を取り外す: 選択したメーカー部品の回路を削除します。

回路を貼り付け: DesignSpark Electrical クリップボードから、選択したメーカー部品に回路を貼り付けることができます。


CAD ファイル ダウンローダー

CAD ファイル ダウンローダーへの初回アクセスには、電気コンテンツ ポータル (ECP) アカウントのログインとパスワードを入力する必要があります。

[CAD ファイル ダウンロード] ダイアログ ボックスには、メーカー部品カタログからダウンロードした 2D フットプリントまたは 3D 部品が表示されます。

メニュー: ライブラリ > メーカー部品マネージャー > 2D フットプリント

メーカー部品マネージャー: メーカー部品コンテキスト メニュー > 2D フットプリント

[メーカー部品マネージャー] ダイアログ ボックスで、メーカー部品を選択し、コマンドをクリックしてダウンロードを開始します。既存のファイルがすでにメーカー部品に関連付けられている場合、上書きするかどうかを確認するメッセージが表示されます。

ダウンロードされた 2D フットプリントは、メーカー部品と同じクラスの 2D フットプリントに自動的に保存されます。

中止: 選択した 2D フットプリントのダウンロードを中止します。

再試行: 中止した 2D フットプリントを再度開始します。

開く: 選択した 2D フットプリントを開きます。この機能には 3 つのオプションがあります。フットプリントはグラフィック インターフェイス ([開く] をクリック)、プレビュー ウィンドウ。

削除: 選択した 2D フットプリントを削除します。

メーカー部品マネージャー: [メーカー部品マネージャー] ダイアログ ボックスを開きます。

プロパティ: 選択した 2D フットプリントのプロパティを開きます。

ログ アウト: ECP セッションを閉じます。

関連トピック:

2D フットプリント マネージャー


端子タイプ マネージャー

端子タイプは、ケーブル コアまたはワイヤがコンポーネントに接続される方法を定義するために使用します。それらは、特定のマネージャーでグループ化されており、このマネージャーで主に使用される端子を見つけることができます。独自の端子を追加または編集できます。

端子タイプはコンポーネント (シンボルの接続点) およびメーカー部品 (端子) で管理され、そのデータを反映する特定の属性があります。専用のレポートで、プロジェクトで使用されているすべての端子タイプを合成できます。

メニュー: ライブラリ > 端子タイプ マネージャー

マネージャーのダイアログ ボックスが開きます。端子タイプの追加、編集、または削除ができます。

新規: 新しい端子タイプをライブラリに追加できます。

削除: 選択されている端子タイプを削除します。

プロパティ: 選択した端子タイプの [プロパティ] ダイアログ ボックスを開きます。複数の端子タイプを選択した場合、[プロパティ] ダイアログ ボックスでは共通プロパティのみが表示されます。

リスト モード: リスト (コード、説明、日付、およびシンボル名) の形式で端子タイプを表示します。

サムネイル モード: サムネイル プレビューの形式で端子タイプを表示します。

構成: ダイアログ ボックスの項目の表示設定を管理できます。

アーカイブ: アーカイブする要素を選択し、[アーカイブ] アイコンをクリックします。

ダイアログ ボックスが開き、アーカイブしたファイルを保存できます。

解凍: ファイルの選択ダイアログ ボックスが開き、解凍する TEWZIP ファイルを選択できます。データ更新ウィザードが自動的に開きます。詳細については、「アーカイブと解凍」の章を参照してください。

  • 端子タイプ プロパティ


端子タイプ プロパティ

端子タイプ マネージャー: 新規

端子タイプ: プロパティ

端子タイプのプロパティ ダイアログ ボックスを開き、関連付けられたデータを変更します。

端子タイプが既に存在する場合、ダイアログ ボックスの左側に、属性とともに編集モードのプレビューが表示されます。

複数の端子タイプを選択した場合は、共通プロパティのみが有効になります。

全般

名前: 端子タイプを識別する端子タイプの名前。この名前は端子タイプ マネージャー内で一意でなければなりません。

説明: 端子タイプについて説明します。マネージャーで [サムネイル モード] を選択した場合、サムネイルの下に説明テキストが表示されます。端子タイプは説明のアルファベット順に配置されます。説明は、固有のアイコンをクリックすることで、すべての言語で利用可能になります。[言語セレクター] が開き、目的の言語を選択できます。

シンボル: 端子に関連付けるシンボルを選択できます。特定のアイコンを使用すると、シンボル マネージャーでシンボルを選択できます。

システム

このセクションは読み取り専用です。作成/修正日と作成者が表示されます。


端子タイプ セレクター

シンボルの接続点のプロパティ (編集モード): 端子タイプ

メーカー部品の端子のプロパティ: 端子タイプ

コンポーネントの端子の編集: 端子タイプ

端子タイプ セレクターでは、コンポーネントの端子に関連付ける端子タイプを選択できます。

リスト モード: シンボルのリスト (名前、説明、分類) を表示します。

サムネイル モード: サムネイル プレビューの形式でシンボルを表示します。

構成: ダイアログ ボックスの項目の表示設定を管理します。

1. 必要なシンボルを選択します。

2. [選択] ボタンをクリックして確認します。


アーカイブと解凍

データのアーカイブでは、システム バックアップ、ワークステーション間のデータ転送、または他社への送信を実行するために、データを特定のファイルに保存します。

解凍を実行すると、アーカイブされたファイルが開きます。また、管理ツールを使用できるようになり、既存のデータに対するアーカイブ データの影響を処理できます。

  • アーカイブ

  • 解凍


アーカイブ

データのアーカイブでは、システム バックアップ、ワークステーション間のデータ転送、または他社への送信を実行するために、データを特定のファイルに保存します。

アーカイブするデータのタイプによって、ソフトウェアのさまざまな場所からデータ アーカイブを実行できます。各アーカイブ機能は特定のファイルを作成します。

アーカイブされたファイルのデータ タイプは、ファイル拡張子によって識別できます。

  • 環境アーカイブ: .TEWZIP

  • プロジェクト アーカイブ ファイル: .PROJ.TEWZIP

  • シンボル アーカイブ ファイル: .SYMB.TEWZIP

  • タイトル ブロック アーカイブ ファイル: .TITLE.TEWZIP

  • パターン アーカイブ ファイル: .MACRO.TEWZIP

  • メーカー部品アーカイブ ファイル: .PARTS.TEWZIP

  • ケーブル参照 アーカイブ ファイル: .CABLE.TEWZIP

  • テンプレート アーカイブ ファイル: .CONFIG.TEWZIP

一部のアーカイブ タイプには設計依存データが含まれます。たとえば、プロジェクト アーカイブには、シンボル、タイトル ブロック、構成などが含まれます。パターン アーカイブには部品とシンボルが含まれることがあります。解凍処理中に、設計依存データの統合を管理できます。

  • 環境のアーカイブ

  • プロジェクトのアーカイブ

  • シンボルのアーカイブ

  • タイトル ブロックのアーカイブ

  • メーカー部品のアーカイブ

  • ケーブル参照のアーカイブ

  • パターンのアーカイブ

  • 構成のアーカイブ

環境のアーカイブ

DesignSpark Electrical によって管理されたすべてのデータの抽出が必要になる場合があります。たとえば、配線図 (タイトル ブロック、シンボル、レポート、構成) がカスタマイズされている場合など。環境アーカイブでは、すべてのデータを 1 つのファイルに保存できます。このデータは同じ環境設定で作業する請負業者などのユーザーに渡すことができます。環境アーカイブにより、プロジェクト マネージャーでもプロジェクトが使用可能になります。

メニュー: ファイル > 環境のアーカイブ

ウィザードが表示されます。ダイアログ ボックスの左側にアーカイブ オプションが表示されます。

[カスタム]: アーカイブに統合する要素をカスタマイズします。[選択] タブでは、アーカイブ処理の対象とするデータ タイプを選択できます。他のタブでは、各データ タイプをより正確に管理できます。

[すべてのプロジェクト]: プロジェクト マネージャーに表示されるプロジェクト、および分類などの必須項目のみが含まれます。

[すべてのオブジェクト]: 各要素を個別に選択するかわりに、すべての要素を選択します。

選択したライブラリからのオブジェクト: 次のステップで選択するライブラリに含まれる要素だけを選択できます。

[ユーザーが変更したオブジェクト]: 変更された要素のみをアーカイブ ファイルに追加します。

[これ以降にユーザーが変更したオブジェクト]: 2 つの日付（カスタムの日付と最終アーカイブの日付）の間に変更した要素だけを含めます。

この日数後に定期アーカイブを実行することを通知: 定期アーカイブを実行するよう通知します。有効にするオプションを選択し、2 つのアーカイブ間の日数を入力します。

オプションを選択した後、さまざまなタブの間を移動して、アーカイブ ファイルに含める要素を指定できます。[完了] をクリックして、アーカイブ ファイルを作成します。

アーカイブ ファイルのサイズは、選択したデータの量によって異なります。

コマンドを有効にすると、ファイル名の入力を求められます。

環境アーカイブのファイル拡張子は「.TEWZIP」です。

プロジェクトのアーカイブ

プロジェクトをアーカイブすると、そのプロジェクトに含まれるすべてのドキュメントとデータ、および設計作業に必要な項目 (シンボル、タイトル ブロック、設定など) もバックアップされます。プロジェクト アーカイブ コマンドはプロジェクト マネージャーから実行できます。

プロジェクト マネージャー: アーカイブ

プロジェクトを選択し、[アーカイブ] アイコンをクリックします。

プロジェクトは、ユーザーのワークステーションのみで開いている場合を除き、アーカイブする前に閉じる必要があります。プロジェクトが他のワークステーションで開かれている場合は、ロックされます。

プロジェクトのアーカイブ時に、他のすべてのユーザーに対してプロジェクトはロックされます。

複数のプロジェクトを選択した場合、プロジェクトはすべて 1 つのアーカイブ ファイルにまとめられます。

ファイル名の入力を求められます。プロジェクト アーカイブ ファイルのファイル拡張子は「PROJ.TEWZIP」です。プロジェクトがアーカイブされると、プロジェクト マネージャーに保持されます。

シンボルのアーカイブ

シンボルをアーカイブすると、すべてのシンボル データ (グラフィック、回路、接続点) を含むアーカイブ ファイルが作成されます。シンボル アーカイブはシンボル マネージャーから実行できます。

シンボル マネージャー: アーカイブ

対象のシンボルを選択し、[アーカイブ] アイコンをクリックします。

シンボル アーカイブ ファイルのファイル拡張子は「SYMB.TEWZIP」です。

タイトル ブロックのアーカイブ

タイトル ブロックをアーカイブすると、すべてのタイトル ブロック データ (グラフィック、属性設定など) を含むアーカイブ ファイルが作成されます。このコマンドはタイトル ブロック マネージャーから実行できます。

タイトル ブロック マネージャー: アーカイブ

対象のタイトル ブロックを選択し、[アーカイブ] アイコンをクリックします。

タイトル ブロック アーカイブ ファイルのファイル拡張子は「TITLE.TEWZIP」です。

メーカー部品のアーカイブ

メーカー参照アーカイブの主な用途は、複数のワークステーションや企業間でのメーカー部品の共有や受け渡しです。アーカイブ コマンドはメーカー部品マネージャーから実行できます。

メーカー部品: アーカイブ

対象のメーカー部品を選択し、[アーカイブ] アイコンをクリックします。

メーカー部品アーカイブ ファイルの拡張子は「PARTS.TEWZIP」です。

ケーブル参照のアーカイブ

ケーブル参照アーカイブの主な用途は、異なるワークステーションや企業間での参照の共有や受け渡しです。このコマンドはケーブル参照マネージャーから実行できます。

ケーブル参照マネージャー: アーカイブ

対象の参照を選択し、[アーカイブ] アイコンをクリックします。

ケーブル参照アーカイブ ファイルの拡張子は「CABLE.TEWZIP」です。

パターンのアーカイブ

パターン アーカイブ ファイルには、パターン設計で使用されるすべてのデータが含まれます。アーカイブ コマンドはパターン マネージャーから実行できます。

パターン マネージャー: アーカイブ

対象のパターンを選択し、[アーカイブ] アイコンをクリックします。

パターン アーカイブ ファイルの拡張子は「MACRO.TEWZIP」です。

構成のアーカイブ

このコマンドを使用すると、すべての構成 (プロジェクト構成ファイルとワイヤ構成ファイル以外) をアーカイブできます。端子や自動構成などの一部の構成アーカイブには依存関係が含まれます。

構成管理: アーカイブ

アーカイブ時には各種構成 (端子ブロック、PLC など) の間に違いはありません。ファイル拡張子はどのタイプでも同じです。そのため、アーカイブ ファイルのタイプを後で識別できるようにアーカイブ ファイルに付けられた名前を記録しておく必要があります。対応しないマネージャーでは構成ファイルを解凍できません。たとえば、自動構成マネージャーでは端子構成を解凍できません。

構成アーカイブ ファイルの拡張子は「CONFIG.TEWZIP」です。

関連トピック:

解凍


解凍

解凍を実行すると、アーカイブ ファイルのデータが開き、抽出されます。このデータは既存のデータと比較されます。

アーカイブ ファイルは拡張子によって識別できます。

  • .TEWZIP: 環境アーカイブ ファイル

  • .PROJ.TEWZIP: プロジェクト アーカイブ ファイル

  • .SYMB.TEWZIP: シンボル アーカイブ ファイル

  • .TITLE.TEWZIP: タイトル ブロック アーカイブ ファイル

  • .MACRO.TEWZIP: パターン アーカイブ ファイル

  • .PARTS.TEWZIP: メーカー部品アーカイブ ファイル

  • .CABLE.TEWZIP: ケーブル参照アーカイブ ファイル

  • .CONIG.TEWZIP: テンプレート/構成アーカイブ ファイル

ファイルは関連するマネージャーから解凍する必要があります。(「アーカイブ」セクションを参照。)

この章で説明する内容は、プロジェクトを除く、すべてのアーカイブ ファイルに当てはまります。詳細については、「プロジェクトの解凍」を参照してください。

[解凍] を選択すると解凍ウィザードが開き、解凍するデータを管理できるようになります。このウィザードはデータ更新ウィザードと同様です。

[選択] タブで、インポートするデータを選択します。

解凍ウィザードは解凍するデータを既存のデータと比較します。その後、データ タイプごとに選択できます。

動作

複数の項目に同じ操作タイプを適用する場合は、Shift / Ctrl / Ctrl+A キーを使用します。

行を右クリックすると、メニューが開き、要素のプロパティが表示されます。

追加: データが現在のインストールに存在しないため、このデータを追加します。

置換: 既存のデータを最新のバージョンで上書きします。

何もしない: 既存の情報を保持します。新しいデータは追加されません。

両方を保持: 既存の情報を保持し、新しい情報は新しい名前で追加します。

更新: カタログ参照を更新します。このオプションはメーカー カタログ (ケーブルおよび材料) の場合のみ有効です。

デフォルトのアクション タイプが次のルールに基づいて提示されます:

- 新しいデータは [追加] とマークされます。

- ユーザーが作成した既存のデータをそのユーザーが変更した場合、[置換] とマークされます。

- ソフトウェア エディターが作成した既存のデータをユーザーが変更した場合、[何もしない] とマークされます。

- データが存在し、ユーザーがそのデータを変更していないが、新しいファイルがソフトウェア エディターによって更新済みにマークされると、このデータは [置換] とマークされます。

- ケーブルおよび装置のカタログは [更新] とマークされます。

データ タイプ

シンボル - タイトル ブロック: ウィザードには、要素名、説明、変更日、および現在の要素を作成または変更したユーザーの名前が表示されます。既存の要素を保持し、同じ要素の最新バージョンをインストールする場合は、新しい要素に別の名前を割り当てます。

ケーブルとメーカー カタログ: カタログは、すべての参照を含めて、全体で管理されます。参照が存在しない場合、自動的に追加されます。参照が存在し、ユーザーが修正した場合、新しい参照はインストールされません。参照が存在し、ユーザーが修正していないが、ソフトウェアの発行元によって更新された場合、新しい参照が自動的にインストールされ、既存の参照を上書きします。

プロジェクト テンプレート: 新規または修正済み (異なる変更日) のモデルのみがインストールされます。ユーザーが作成したモデルは保持されます。

レポート構成: ユーザーが作成または修正したレポート構成は保持されます。ソフトウェアの発行元が作成または修正した構成は自動的にインストールされます。

構成ファイル: 新規または修正済み (異なる変更日) の構成ファイルのみがインストールされます。ユーザーが作成した構成ファイルは保持されます。

パレット: 新規または修正済み (異なる変更日) のパレットのみがインストールされます。ユーザーが作成したパレットは保持されます。

関連トピック:

アーカイブ

データ インストール


ロック プロジェクト

このメッセージ ボックスが表示されるのは、別のユーザー。